Делаем руль и педали к компьютеру

Делаем руль и педали Чтобы изготоаить руль и педали, достаточно купить несколько деталей, прочитать инструкции и советы и немного поработать руками. Как же все это работает. Большинство персональных компьютеров, используемых для игр, имеет звуковую карту. На этой карте есть геймпорт, в который можно подключать джойстики, геймпады, рули и прочее. Все эти устройства используют возможности игрового порта одинаково - разница лишь в конструкции устройства, а человек выбирает такое, какое является наиболее подходящим и удобным для той игры, в которую он играет. Геймпорт персонального компьютера поддерживает 4 переменных сопротивления (потенциометра) и 4 мгновенных кнопки-выключателя (которые включены, пока нажаты). Получается, что можно в один порт подключить 2 джойстика: по 2 сопротивления (одно - влево/вправо, другое - вверх/вниз) и по 2 кнопки на каждый.

Делаем руль и педали Если посмотреть на звуковую карту, то можно без труда разглядеть геймпорт, как на этом рисунке. Синим цветом указано, каким иголкам в порту соответствуют функции джойстика: например j1 Х означает "джойстик 1 ось Х" или btn 1 - "кнопка 1". Номера иголок показаны черным цветом, считать надо справа налево, сверху вниз. при использовании геймпорта на звуковой плате нужно избегать подключений к иголкам 12 и 15. Саундкарта использует эти выходы для midi на передачу и прием соответственно. В стандартном джойстике потенциометр оси Х отвечает за движение рукоятки влево/вправо, а сопротивление оси Y - вперед/назад. Применительно к рулю и педалям, ось Х становится управлением, а ось Y соответственно дросселем и тормозом. Ось Y должна быть разделена и подключена так, чтобы 2 отдельных сопротивления (для педалей газа и тормоза) действовали как одно сопротивление, как в стандартном джойстике. Как только станет ясна идея геймпорта, можно начинать проектировать любую механику вокруг основных двух сопротивлений и четыех выключателей: рулевые колеса, рукоятки мотоцикла, контроль тяги самолета... насколько позволяет воображение.

Рулевой модуль. В этом разделе будет рассказано, как сделать основной модуль руля: настольный кожух, содержащий почти все механические и электрические компоненты руля. электрическая схема будет пояснена в разделе "проводка", здесь же будут охвачены механические детали колеса.

Делаем руль и педали Делаем руль и педали

На рисунках: 1 - рулевое колесо; 2 - ступица колеса; 3 - вал (болт 12мм x 180мм); 4 - винт (держит подшипник на валу); 5 - 12мм подшипник в опорном кожухе; 6 - центрирующий механизм; 7 - болт-ограничитель; 8 - шестерни; 9 - 100к линейный потенциометр; 10 - фанерная основа; 11 - ограничитель вращения; 12 - скоба; 13 - резиновый шнур; 14 - угловой кронштейн; 15 - механизм переключения передач.

На рисунках вверху показаны общие планы модуля (без механизма переключения передач) сбоку и в виде сверху. Для придания прочности всей конструкции модуля используется короб со скошенными углами из 12мм фанеры, к которому спереди прикреплен 25мм выступ для крепления к столу. Рулевой вал сделан из обычного крепежного болта длиной 180мм и диаметром 12мм. Болт имеет два 5мм отверстия - одно для болта-ограничителя (7), ограничивающего вращение колеса, и одно для стального пальца механизма центрирования, описанного ниже. Используемые подшипники имеют 12мм внутренний диаметр и прикручены к валу двумя винтами (4). Центрирующий механизм - механизм, который возвращает руль в центральное положение. Он должен работать точно, эффективно, быть простым и компактным. Есть несколько вариантов, здесь будет описан один из них.

Делаем руль и педали Механизм (рис. слева) состоит из двух алюминиевых пластин (2), толщиной 2мм, через которые проходит рулевой вал (5). Эти пластины разделены четырьмя 13мм вкладышами (3). В рулевом валу просверлено 5мм отверстие, в которое вставлен стальной стержень (4). 22мм болты (1) проходят через пластины, вкладыши и отверстия, просверленные в концах стержня, фиксируя все это вместе. Резиновый шнур накручивается между вкладышами на одной стороне, затем по вершине рулевого вала, и, наконец, между вкладышами с другой стороны. натяжение шнура можно менять, чтобы регулировать сопротивление колеса. Чтобы избежать повреждений потенциометра, необходимо сделать ограничитель вращения колеса. Практически все промышленные рули имеют диапазон вращения 270 градусов. Однако здесь будет описан механизм поворота на 350 градусов, уменьшить который будет не проблема. Стальной г-образный кронштейн, длиной 300мм (14) прикрепляется болтами к основе модуля. этот кронштейн служит для нескольких целей:
- является местом крепления резинового шнура центрирующего механизма (два болта m6 по 20мм в каждом конце);
- обеспечивает надежную точку останова вращения колеса;
- усиливает всю конструкцию в момент натяжения шнура.

Болт-ограничитель (7) м5 длиной 25мм вкручивается в вертикальное отверстие в рулевом валу. Непосредственно под валом в кронштейн вкручивается болт 20мм m6 (11). Для уменьшения звука при ударе на болты можно одеть резиновые трубочки. Если нужен меньший угол поворота, тогда в кронштейн надо вкрутить два болта на необходимом расстоянии. Потенциометр крепится к основанию через простой уголок и соединяется с валом. Максимальный угол вращения большинства потенциометров составляет 270 градусов, и если руль разработан для вращения в 350 градусов, то необходим редуктор. Пара шестерен с поломанного принтера подойдут идеально. Нужно только правильно выбрать количество зубов на шестернях, например 26 и 35. В этом случае передаточное число будет 0.75:1 или вращение на 350 градусов руля даст 262 градуса на потенциометре. Если руль будет крутиться в диапазоне 270 градусов, то вал соединяется с потенциометром напрямую.

Педали. Основа модуля делается аналогично модулю руля из 12мм фанеры с поперечиной из твердой древесины (3) для крепления пружины возврата. Пологая форма основы служит подставкой для ног. Стойка педали (8) сделана из 12мм стальной трубки, к верхнему концу которой крепится болтами педаль. Через нижний конец стойки проходит 5мм стержень, который держит педаль в монтажных кронштейнах (6), прикрученных к основанию и сделанных из стального уголка. Поперечина (3) проходит через всю ширину педального модуля и надежно (должна выдерживать полное растяжение пружин) приклеивается и привинчивается к основанию (2). Пружина возврата (5) крепится к стальному винту с ушком (4), который проходит через поперечину прямо под педалью. Такая конструкция крепления позволяет легко регулировать натяжение пружины. Другой конец пружины цепляется к стойке педали (8). Педальный потенциометр установлен на простом L-кронштейне (14) в задней части модуля. Тяга (11) крепится к приводу (12) на втулках (9, 13), позволяя сопротивлению вращаться в диапазоне 90 градусов.

Делаем руль и педали

Ручка переключения передач. Рычаг коробки передач представляет собой алюминиевую конструкцию, как на рисунке слева. Стальной стержень (2) с нарезанной резьбой крепится к рычагу через втулку (1) и проходит через отверстие, просверленное в Г-образном кронштейне на основании модуля руля. С обеих сторон отверстия в кронштейне на стержень установлены две пружины (1) и затянуты гайками так, чтобы создавалось усилие при движении рычага. Две большие шайбы (4, 2) располагаются между двумя микровыключателями (3), которые прикручены один на другом к основанию. Все это хорошо видно на рисунках слева и снизу.

Делаем руль и педали

Делаем руль и педали Справа на рисунке показан альтернативный механизм переключения передач - на руле, как в болидах формулы 1. Здесь используется два маленьких шарнира (4), которые установлены на ступицу колеса. Рычаги (1) крепятся к шарнирам таким способом, чтобы они могли двигаться только в одном направлении, т. е. к колесу. В отверстия в рычагах вставляются два маленьких выключателя (3), так, чтобы при нажатии они упирались в резиновые подушечки (2), приклеенные к колесу и срабатывали. Если выключатель имеет недостаточно жесткое давление, то возврат рычагов можно обеспечить пружинами (5), установленными на шарнир.

Делаем руль и педали Проводка. Немного о том, как работает потенциометр. Если снять с него крышку, то можно увидеть, что он состоит из изогнутой токопроводящей дорожки с контактами А и С на концах и бегунка, соединенного с центральным контактом В (рис 11). Когда вал вращается против часовой стрелки, то сопротивление между А и В увеличится на то же самое количество, на какое уменьшается между С и В. Подключается вся система по схеме стандартного джойстика, имеющего 2 оси и две кнопки. Красный провод всегда идет на средний контакт сопротивления, а вот фиолетовый (3) может быть подключен на любой из боковых, в зависимости от того, как установлено сопротивление.

С педалями не так все просто. Поворот руля эквивалентен движению джойстика влево/вправо, а нажатие педалей газ/тормоз соответственно - вверх/вниз. И если сразу нажать на обе педали, то они взаимно исключат друг друга, и ни какого действия не последует. Это одно-осевая система подключения, которую поддерживает большинство игр. Но многие современные симуляторы, типа GP3, F1-2000, TOCA 2 и т.д., используют двух-осевую систему газ/тормоз, позволяя применять на практике методы управления, связанные с одновременным использованием газа и тормоза. Ниже показаны обе схемы.

Делаем руль и педали Делаем руль и педали

Схема подключения одно-осевого устройства. Схема подключения двух-осевого устройства

Делаем руль и педали Так как много игр не поддерживают двойную ось, то будет разумно собрать коммутатор (рис. справа), который позволит переключаться между одно- и двух-осевой системой переключателем, установленным в педальном модуле или в "приборной панели".

Деталей в описываемом устройстве не много, и самые главные из них - потенциометры. Во-первых, они должны быть линейными, сопротивлением в 100к, и ни в коем случае не логарифмическими (их иногда называют аудио), потому что те предназначены для аудио-устройств, типа регуляторов громкости, и имеют нелинейную трассу сопротивления. Во-вторых, дешевые потенциометры используют графитовую трассу, которая износится весьма быстро. В более дорогих используются металлокерамика и токопроводящий пластик. Такие проработают намного дольше (примерно - 100,000 циклов). Выключатели - любые какие есть, но, как было написано выше, они должны иметь мгновенный (то есть незапирающий) тип. Такие можно достать из старой мыши. Стандартный разъем джойстика D-типа с 15 иголками продается в любом магазине, где торгуют радиодеталями. Провода любые, главное, чтобы их можно было легко припаять к разъему.

Подключение и калибровка. Все тесты должны проводиться на отключенном от компьютера утройстве. Сначала надо визуально проверить паяные соединения: нигде не должно быть посторонних перемычек и плохих контактов. Затем надо откалибровать рулевой потенциометр. Так как используется сопротивление 100к, то можно измерить прибором сопротивление между двумя соседними контактами и настроить на 50к. Однако, для более точной установки, нужно замерить сопротивление потенциометра, повернув руль до упора влево, затем до упора вправо. Определить диапазон, затем разделить на 2 и прибавить нижний результат измерений. Полученное число и надо выставить, используя прибор. За неимением измерительных приборов, нужно выставить потенциометр в центральное положение, насколько это возможно. Потенциометры педалей при установке должны быть слегка включены. Если применяется одно-осевая система, то сопротивление педали газа должно быть установлено в центр (50к на приборе), а сопротивление тормоза быть выключено (0к). Если все сделано правильно, то сопротивление всего педального модуля, измеренное между иголками 6 и 9, должно уменьшиться, если нажать на газ, и увеличится - если на тормоз. Если это не случится, тогда надо поменять местами внешние контакты сопротивлении. Если применяется схема двух-осевого подключения, то оба потенциометра могут быть установлены на ноль. Если есть переключатель, то проверяется схема одно-осевой системы.

Перед соединением с компьютером, необходимо проверить электрическую цепь, чтобы не возникло короткого замыкания. Здесь потребуется измерительный прибор. Проверяем, что нет контакта с питанием +5v (иголки 1, 8, 9 и 15) и землей (4, 5 и 12). затем проверяем, чтобы был контакт между 4 и 2, если нажать кнопку 1. Тоже самое между 4 и 7, для кнопки 2. Далее проверяем руль: сопротивление между 1 и 3 уменьшается, если повернуть колесо влево, и увеличивается, если вправо. В одно-осевой системе сопротивление между иголками 9 и 6 уменьшится, когда нажата педаль газа, и увеличивается, когда нажат тормоз.

Последний этап - подключение к компьютеру. Подключив штекер к саундкарте, включаем компьютер. Заходим в "Панель управления - Игровые устройства" выбираем "добавить - особый". Ставим тип - "джойстик", осей - 2, кнопок 2, пишем имя типа "LXA4 Super F1 Driving System" и давим OK 2 раза. Если все было сделано правильно и руки растут от куда надо, то поле "состояние" должно измениться на "ОК". Щелкаем "свойства", "настройка" и следуем инструкциям на экране. Остается запустить любимую игрушку, выбрать в списке свое устройство, если потребуется, дополнительно его настроить, и все, в добрый путь!

1999-2006. Сайт ПАЯЛЬНИК (cxem.net). При использовании материалов с данного сайта, обязательна ссылка на сайт ПАЯЛЬНИК и первоисточник!


Руль для компьютера

Еще с тех пор, когда я первый раз гонял в ралли (NeedForSpeed 1), я подумал: "А почему бы мне не сделать руль?". И действительно, ведь это совсем несложно! Долго не доходили до этого руки - играть все равно некогда - других дел хватает, но вот моему сыну - страстному фанату автомобилей в свои четыре с небольшим года управлять клавишами не очень удобно. То ли дело руль. Вот для этого юного автогонщика я в первую очередь и старался. Сама идея очень проста. В принципе руль - это тот же джойстик. Только немного другая механика и форма. Самое сложное - сам руль. Лучше всего взять готовый от детского автомобиля или даже от настоящего (хотя это наверное и круто, но он все же великоват). Я просто выпилил из фанеры и обмотал кожзаменителем. Затем надо придумать крепление (в зависимости от конструкции вашего руля). Руль должен свободно вращаться и на его оси необходимо установить переменный резистор на 100 кОм. Обязательно надо сделать ограничители (и по прочнее), не то на первом же повороте свернете резистору голову. К столу я креплю руль маленькими тисочками - очень удобно и надежно. Теперь педали - газ и тормоз. Можно сделать действительно педали и давить на них ногами (внутрь например поставить микрики), но я поступил проще - поставил переключатель на три положения (газ-нейтралка-тормоз) и закрепил возле руля, так как мой сынуля, сидя за компьютером, ногами до пола все равно не достает по причине своего малого возраста.

Руль для компьютера

Распайка порта MIDI звуковой карточки:

N кон.   Назначение         N кон.   Назначение
1        +5v для XY1        9        +5v для XY2
2        кнопка 1           10       кнопка 3
3        X1                 11       X2
4        Ground             12       Ground
5        Ground             13       Y2
6        Y1                 14       Кнопка 4
7        Кнопка 2           15       N.C.
8        N.C.

Кнопки для газа и тормоза. Сопротивление переменного резистора от 100 до 220 кОм - обязательно с линейной характеристикой типа "А" У меня стоит 100 кОм. RY - можно тоже использовать для управления газ-тормоз, хотя он нужен в любом случае при калибровке. В "Настройках" в "Панели управления" в "Игровых устройствах" в Windows'е добавить устройство "Джойстик 2 оси и 2 кнопки". Там же можно провести калибровку. В игрушке выбираешь пункт управление джойстиком. В любом случае в каждой игрушке есть калибровка джойстика (в частности в NeedForSpeed 1 она есть). Единственная проблема которая у меня возникла - это когда включаешь управление в игрушке на джойстик - переключение по пунктам тоже осуществляется этим джойстиком, поэтому стоит чуть-чуть повернуть руль от среднего положения и курсор сразу начинает летать по всем пунктам. И вообще при калибровке заметны колебания курсора, которые впрочем во время игры абсолютно ни на что не влияют. Причем я так думаю, что проблема именно в моей звуковой карточке, так как она сама по себе очень сильно шумит (самая дешевая, что поделаешь). Думаю, что при хорошей карточке таких проблем не будет вообще.

Купил я наконец-то себе новую звуковую карточку SB Live. Как я и ожидал - все проблемы с дрожанием курсора исчезли. Перестал летать курсор по меню и вообще работает все отлично. Я доволен. Как я говорил руль у меня выпилен из фанеры - я туго обмотал его толстым поролоном и уже поверх черным кожзаменителем. Получилось очень эстетично и просто классно. Вот думаю переделать крепление руля (поставить на подшипники что ли, чтоб не болтался). Купил небольшую аккуратную струбцину, чтобы крепить к столу. Осталось резистор RY закрепить где-нибудь, чтоб не висел на проводах и получится очень даже приличная конструкция. И играть приятно и другим показать не стыдно. Моему сыну уже пять и он гоняет как заправский гонщик.

Поставил себе NeedForSpeed III. Все очень здорово! Он сам обнаружил джойстик (т.е. руль) и встал на него. Я не глядя в настройки весь в нетерпении запускаю, ревут двигатели, переключаю тумблер на "газ". "3, 2, 1 GO!" все рванули вперед, а я поехал назад. Нормально. Захожу в настройки - все правильно: "вперед-назад" задано управление самим джойстиком (т.е. резистором RY), а у меня он не используется (но подключен! просто висит на проводах). Ставлю в настройках управление кнопками джойстика. Запускаю, газ на полную, поехали. Начало меня мотать по дороге как новичка-водителя упившегося в "зюзю". Очнь большая чувствительность руля - чуть повернул руль и уже скоблишь стены. Что-то не то. Начал разбираться, вошел в настройки джойстика. Есть там режим "мертвой зоны" центрального положения - уменьшил почти до нуля, стало гораздо лучше. Потом заметил, что у меня руль имеет небольшой люфт (болтается говоря по-русски), затянул потуже. И самое главное поворот руля у меня был градусов 120 (я так поставил ограничители), раньше это не мешало, а теперь пришлось их переставить - угол увеличился почти до 270 градусов. Больше резистор не позволит (хотя больше по-моему и не надо).

Машина перестала "рыскать" и больше не мотает со стороны в сторону. Небольшой поворот руля и машина делает плавный поворот по трассе, красиво, аж душа поет. Вот теперь ехать одно удовольствие и я теперь твердо знаю, что рулить курсорными клавишами с клавиатуры - это большое извращение. Единственный недостаток сейчас в моей конструкции - нет плавной регулировки скорости - резистор болтается на проводах - надо закрепить и рычажок приделать, чтоб цивильно было "газ" регулировать (или все же педали сделать), но это как время выберу.

А теперь вот подумываю, может еще и штурвал сделать. Я тут запустил Descent III. Он джойстик (т.е. мой руль) определил, я даже порулил немного вправо-влево и отдельным резистором RY вверх-вниз, а вперед-назад надо нажимать на клавиатуре, что очень неудобно, вот если бы было четыре кнопки, тогда вперед-назад можно перевести на них. Попробую как-нибудь задействовать кнопки от другого джойстика (выводы на разъеме МИДИ-порта 10, 14) может получится.


Джойстик своими руками

В этой небольшой статье я постараюсь изложить информацию, необходимую для понимания принципа работы обычного аналогового джойстика, подключаемого к игровому порту компьютера. Стандартный игровой порт, расположенный на звуковой карте, обслуживает аналоговые сигналы X1, Y1, X2, Y2 и дискретные B1, B2, B3, B4. С помощью аналоговых сигналов передаются данные об отклонении рукоятки джойстика, с помощью дискретных - данные о нажатии кнопок джойстика. Таким образом изначально игровой порт был расчитан на подключение двух двухкнопочных джойстиков. Но как правило подключается один джойстик и дополнительные устройства. В таком случае аналоговые оси распределяются так:

X1 - перемещение рукоятки вперед-назад (тангаж)
Y1 - перемещение рукоятки влево-вправо (крен)
X2 - перемещение педалей
Y2 - перемещение рукоятки управления двигателем - РУДа (тяга)

Положении рукоятки, РУДа и педалей определяется с помощью стоомных потенциометров: минимальное сопротивление - крайнее левое (верхнее) положение, максимальное - крайнее правое (нижнее) положение. В принципе можно использовать и другие потенциометры, но тогда джойстик прийдется достаточно точно откалибровать. Кнопки замыкаются на землю. Вместо передачи данных о положении РУДа, сигнал X2 может использоваться для передачи данных о положении хата - переключателя вида. Это что касается аналоговых устройств. Так называемые цифровые игровые устройства передают данные о положении рукоятки, РУДа, педалей, хата и кнопок с помощью цифровых протоколов, используя для этого дискретные сигналы игрового порта. Наиболее распространенные расширения функций игрового порта и реализации цифровых интерфейсов будут описаны отдельно.

Разъем DB15 мама, вид со стороны контактов
Контакт | Сигнал | Контакт | Сигнал
1 2 3 4 5 6 7 8 | +5V B1 X1 GND GND Y1 B2 +5V | 9 10 11 12 13 14 15 | +5V B3 X2 GND Y2 B4 +5V

Для подключения игровых устройств служит разъем типа DB15 - "мама" на звуковой карте и "папа" на кабеле, идущем к игровым устройствам. Выше дана его распиновка (разъем DB15 "мама", вид со стороны контактов). Поскольку разъем игрового порта часто совмещают с разъемом MIDI, контакты 8, 12 и 15 могут иметь другое предназначение. Поэтому лучше брать питание и землю с 1, 9 и 4, 5 контактов разъема. Ниже приводится схема простейшего аналогового игрового устройства, состоящего из четырехкнопочного джойстика, РУДА и педалей. Вместо переменных резисторов могут использоваться оптопары - светодиод и фоторезистор. Такой джойстик называется оптическим и большинство игроков отдают предпочтение именно оптическим джойстикам.

Владимир Климус


Cоединение 2-х компьютеров на лазерных указках

Оптосоединение 2-х компьютеров на лазерных указках

Питается устройство от COM-поpта. Фототpанзистор - любой из отечественных, например, типа ФТ-2, pезистор R1 - в пpеделах 5-10 кОм. Диоды - Д522. Конденсатор 10мкФ х 10В. По-хоpошему надо бы ещё pеализовать ноpмальную схему огpаничения для лазеpного диода. Поскольку схема не пpоизводит пpеобpазования RS232 в SIR, то дальность получается поpядка сотни метpов (ну или чуть больше). Если использовать SIR/FIR для модуляции в нынешних наплатных SuperIO-чипах и ноpмальный PIN-диод с усилителем - будет и 230 Кбод, и 460 Кбод. Однако там необходимо учесть огpаничение на наличие питания только в +5 вольт.

Александр Коносевич


Система связи двух компьютеров на лазеpных указках

Цифровая часть приемопередатчика. После долгих экспериментов я пришел к выводу, что простой и надежный приемник для RS232 сделать трудно. Для RS232 надо мастерить что-то вроде схемы "привязки к уровню черного (или белого?)" - как в телевидении. Простыми средствами мне это сделать не удалось. Поэтому было принято решение перейти к импульсно-кодовому представлению сигналов RS232 и передаче информации импульсами. Такая система давно разработана и называется IRDA. Однако по условию задачи связь должна быть через ком-порт. Где-то в и-нете я видел микросхемы (буржуйские, разумеется) которые подключаются прямо к ком-порту, а на выходе у них импульсная последовательность или даже просто оптический сигнал. И приемник встроен в ту же микросхему. Мне эта штука не понравилась по двум причинам: относительная дороговизна и жесткая привязка к фиксированной скорости ком-порта. Т.е. если вы (или какая-то умная программа) решили перенастроить порт на другую скорость - вам надо менять тактовую частоту на входе микросхемы. По всем эти причинам я решил смастерить что-то похожее на IRDA, но более простое и независимое от скорости работы порта. Вот что получилось.

Стандарт FIRDA. Каждый фронт в сигнале RS232 кодируется коротким однополярным импульсом, который передается по оптическому каналу. Hа приемнике эти импульсы поступают на вход триггера, работающего в счетном режиме. Hа выходе триггера получаем (в идеале) сигнал RS232. В принципе, это все. У это чудесного по своей простоте алгоритма есть только один существенный недостаток, который заключается в том, что при пропуске хотя бы одного импульса, на выходе триггера начинает появляться инверсия сигнала RS232. Конечно, можно сказать, что при потере стартового фронта в RS232 (или первого импульса в пачке IRDA) тоже произойдет сбой синхронизации, который при плотном потоке информации может быть ликвидирован не скоро. Однако, в предлагаемой системе потеря любого (а не только первого) импульса приводит к неприятностям. Грубо говоря, помехоустойчивость FIRDA раз в 8-10 хуже IRDA или RS232. В принципе, это было бы не так страшно (считаем, что ошибки появляются достаточно редко), если бы с течением времени FIRDA выходил на нормальный режим работы, как это происходит с его именитыми прототипами. Однако, если не предусмотреть специальных мер, FIRDA так и будет гнать инвертированный поток, пока не произойдет еще одного сбоя ;)) Именно длительная инверсная работа мне казалась главным недостатком FIRDA и я дополнил его маленькой добавкой, которая в последствии меня самого удивила своей эффективностью и практически решила все проблемы. Добавка очень простая: если в течении некоторого времени (ну например 0.1 сек) на выходе триггера присутствует "1", то следует принудительно перевести его в нулевое состояние (считаем, что в паузах передачи на выходе RS232 - ноль). Теперь для полного счастья надо дергать готовность ком-порта передатчика один раз в 10 сек, прерывая передачу на 0.1 сек, с тем чтобы триггер приемника установился в исходное состояние. Очевидно, в данном примере потери в скорости передачи - 1процент. Вот теперь, действительно все. Как показала практика, дергать готовность ком-порта передатчика не надо. Многочисленные эксперименты показали, что при реальной работе через ком возникает множество естественных пауз различной длительности. (были проверены несколько сетевых игрушек, сеть между двумя Вин98, терминалки с разными протоколами. Действительно плотный поток оказался только у терминалок, работающих через Z-модем). В моей версии линка время принудительной установки триггера выбрано около 5 миллисекунд. Такие паузы встречаются очень часто. Правда, это ограничивает снизу используемые скорости передачи (в моем случае - не меньше 2400). Зато никаких проблем ни с каким софтом я не имел во всем диапазоне скоростей 2400..115200.

Система связи двух компьютеров

Описание принципиальной схемы. Сигнал Тх с выхода ком-порта через ограничивающий резистор R1 поступает на схему выделения фронтов, собранную на элементаж DD1.1, DD1.2. Hа выводе 4 элемента DD1.2 присутствуют импульсы длительностью около 1 микросекунды. ВременнЫе параметры этих импульсов не достаточно стабильны, поэтому в схему включен генератор нормированных по длительности импульсов, собранный на триггере Т2. Он формирует импульсы длительностью около 3-4 микросекунд. При необходимости длительность подстраивается резистором R3. Для тех, кому важна стабильность/надежность/дальность работы линка и допустима максимальная скорость работы 57600, я бы посоветовал удвоить номинал С2 и тем самым увеличить длительность нормированного импульса до 8 миллисекунд. Можно использовать специальный переключатель максимальных скоростей 115200-57600. подключающий дополнительную емкость С2. (длина проводников до переключателя должна быть минимальна.) Схема цифровой части приемника содержит триггер Т1 с элементами R4,R5,C3,V2, задающими максимальную длительность единицы на выходе триггера. При указанных на схеме номиналах, она равна примерно 5 миллисекундам. Если кто-то собирается работать только с большими скоростями, имеет смысл уменьшить это время путем уменьшения С3. Hа элементах DD1.3, DD1.4 собран выходной усилитель, сигнал с которого поступает на вход Rx ком-порта. Это на всякий случай. У меня все прекрасно работало на перепутанном мотке проводов длинной 20 метров, когда я брал неусиленный сигнал (через резистор 1К) прямо с вывода 1 триггера Т1. Теперь несколько слов о настройке схемы. К счастью, цифровая часть приемопередатчика является совершенно самостоятельной и самодостаточной схемой, допускающей полную настройку и отладку без всяких лазеров и аналоговой части. Порядок настройки. Создайте файл килобайт на 300, содержащий один символ (мне понравился Y). Создайте батник, который засылает этот файл в ком-порт, а потом вызывает сам себя ;-) Запустите его. Проконтролируйте длительности и формы импульсов в передатчике.(лучше это делать на максимальной скорости, поскольку импульсы короткие). Закройте батник. Замкните выход передачика на вход приемника, а выход приемника подайте на вход Rx того же самого ком-порта. Войдите в любую терминальную программу ( я пользовался DN-ской терминалкой) Попробуйте понажимать на клавиши. Вы должны увидеть нажимаемые символы на экране. Если этого не происходит, попробуйте просто замкнуть Rx и Tx и добиться описанного эффекта настройкой терминальной программы, после чего снова попытайтесь сделать то же самое через приемопередатчик. И наконец, последнее, самое важное испытание. Тут потребуется уже два компьютера. Соедините их ком-порты тремя проводами по классической схеме. Запустите какой-нибудь софт,использующий этот линк. Убедитесь, что все работает. Теперь попробуйте в разрыв одного сигнального провода вставить цифровой приемопередатчик. Попробуйте поработать с этим же софтом через эту железку и убедитесь, что FIRDA вас вполне устраивает ;-))), поимитируйте помехи в передаче доступными вам способами. После этого можно переходить к постройке аналоговой части линка.

Система связи двух компьютеров

Передатчик. Особых пояснений, как мне кажется, он не требует. Лазерный диод является коллекторной нагрузкой первого транзистора. Резистор в его эмиттерной цепи ограничивает ток через этот транзистор и создает условия для работы второго транзистора, который является фактически (совместно с R1) управляемым делителем входного напряжения. Второй транзистор управляется фототоком диода, встроенного в лазер для организации схемы ограничения температурного дрейфа его параметров. С увеличением светового потока увеличивается базовый ток второго транзистора, и он шунтирует входной сигнал на уровне, безопасном для лазера. Подстроечный резистор R3 предназначен для регулировки допустимого уровня излучения лазера.Hоминалы схемы подобраны так, что при комнатной температуре можно уменьшить его сопротивление до нуля и это не приводит к фатальным последствиям для лазерного диода (по крайней мере у меня проблем не было). Hастройка передатчика сводится к измерению амплитуды сигнала на резисторе R2 (при подключенной и работающей цифровой части) и установление подстроечным резистором амплитуды импульсов, соответствующей импульсному току 30-35 ма (при комнатной температуре).(Речь идет о 5-и милливаттных указках). Для надежности можно уточнить эти цифры для конкретной указки путем измерения тока через нее при свежезаряженных аккумуляторах (до разборки). Эту величину можно в дальнейшем принять за номинальный импульсный ток через указку. Если в схеме используется R4 (у меня его нет), и часть тока всегда течет через этот резистор, на соответствующую величину надо уменьшить выставляемый ток через R2, так что бы суммарный импульсный ток оказался в указанных выше пределах. При изменении тепературы параметры излучения, конечно, будут плавать, но разброс значений будет существенно снижен за счет отрицательной обратной связи по световому потоку через фотодиод и второй транзистор. Резистором R4 можно выставить начальный уровень тока через лазер в отсутствие сигнала. Считается, что это повышает живучесть лазерного диода. С1 с этой же целью сглаживает переходные процессы при включении/выключении лазера. К питанию особых требований нет, можно взять +5В из компьютера. В заключение пару слов о разборке указки и ее цоколевке. Могу рассказать только о своей паре указок. Hасколько это типично - не знаю. Сначала я делал надпил корпуса надфилем по периметру указки на уровне кнопки включения указки. Часть с батарейками отламывается. Становится видна маленькая печатная платка, на которой крепится кнопка. Платка припаяна прямо к выводам лазерного диода. Иголкой измерил глубину до втулки, в которую запресован собственно лазер. Сделал второй надрез, стараясь попасть на уровень втулки, в результате чего получил обрубок указки с полностью сохраненной оптической частью, а с другой (обрубленной )стороны торчали три вывода с платкой, которую я отпаял. Итак, остались три вывода, торчащие из обрезанной части указки. Они расположены треугольником. Один из них соединен с корпусом лазерного диода. Это общий вывод лазерного диода и фотодиода. Предположим, что этот вывод соответствует верхнему углу треугольника. Тогда справа внизу будет расположен вывод фотодиода, а слева внизу - вывод лазерного диода. Перед разборкой полезно провести исследование расходимости луча лазера без оптической системы. Это вам понадобится при оценке чувствительности вашего приемника и дальности работы вашего линка. Для этого надо осторожно вывернуть оптическую систему из передней части указки и замерить диаметр пятна, который получается на расстоянии от указки в интервале 5-25 см. Теперь можно переходить к построению самой важной части линка - аналоговой части приемника.

Система связи двух компьютеров

Приемник. Аналоговая часть. Этот блок требует наибольшей аккуратности и, я бы сказал схемотехнической культуры при построении и наладке. Питание лучше брать не из компьютера, а от отдельного стабилизированного блока питания. Длина проводников должна быть минимальна. Фильтрующие питание конденсаторы C1,C2.C4,C5 д.б. расположены максимально близко к выводам операционного усилителя. Особенно важно близкое расположение к ОУ элементов входной цепи С3,VD1,R4. Желательно компактное расположение и экранирование всей конструкции. При грамотной схемотехнике у вас не должно быть никаких проблем с настройкой. У меня на столе не было выполнено ни одно из перечисленных выше требований и тем не менее все успешно работает. Так что есть надежда, что если сделать все правильно,то у вас тоже будет работать ;-))) Пару слов о самой схеме. Она предельно проста. Cоблюдайте полярность фотодиода! Резистор R4 влияет на амплитуду сигнала с фододиода и на его форму/частотные характеристики. Чем меньше номинал резистора, тем меньше сигнал с фотодиода и тем лучше его форма. У меня получались вполне приличные результаты при увеличении резистора до 4.7 К. Однако спешить с его увеличением я бы не советовал. И вообще, первое, что вы должны добится - это работа приемника на какой-нибудь умеренной скорости, ну например 57600. Это лучше делать в следующем порядке. Итак, после десятой проверки монтажа выводим сопротивление подстроечника R1 в ноль и включаем питание. Подключаем к ком-порту собранный передатчик (цифровую и аналоговую части), запускаем батник (предварительно установив скорость работы порта 57600), позволяющий наблюдать непрерывную картинку передачи одного байта (о нем шла речь в первой части трилогии), располагаем лазер со снятой оптической системой в двух-трех сантиметрах от фотодиода, подключаем лограф к выходу приемника и начинаем медленно увеличивать сопротивление R1. Через некоторое время транзистор Т1 начнет приоткрываться, и на выходе приемника появится гребенка импульсов. Оптимальное значение сопротивления R1 определяется в ходе экспериментов визуально по форме и амплитуде импульсов на выходе приемника. При выключении передатчика амплитуда шумов на выходе приемника не должна превышать 1-2 вольта. Транзистор Т1 должен быть лишь слегка приоткрыт. Типичное значение напряжения на его коллекторной нагрузке- 1-2 вольта. После достижения успеха на этом первом этапе можно двигаться дальше - постепенно раздвигать приемник и передатчик, находить их наилучшее взаимное положение и, подстраивая R1, получать гребенку импульсов амплитудой почти равной амплитуде питания +12В. Форма у них может быть не совсем прямоугольной, но амплитуда должна быть хорошей. При максимально возможной раздвижке передатчика и приемника надо определить диаметр расфокусированного пятна лазера. Этот диаметр даст вам представление о максимальной дальности, на которой будет работать ваш линк. У меня этот диаметр равнялся примерно 20 см, что примерно соответствует динамическому диапазону в 33 дБ. Как мне кажется, этого вполне должно хватить для уверенной связи на расстоянии 100 метров без применения входных линз или на расстоянии 200 метров, если использовать сведотдиод типа ФД320 в виде красной пластмассовой линзочки диаметром около сантиметра на прямоугольном основании. А при наличии входной оптики... Впрочем, при больших дальностях уже другие проблемы... Вернемся к настройке приемника. Теперь полезно попробовать настройку для разных скоростей ком-порта. И, наконец, можно подключить цифровую часть приемника и повторить опыты, описанные в первой части данной трилогии. Я специально ничего не говорил о конструктивном оформлении приемника. Да, наверно полезно иметь какие-нибудь бленды на входных светодиодах. Вообще-то приемник весьма устойчив к засветкам разного рода. Обычная засветка лампочкой 60 ватт с расстояния 70 см под углом в 30 градусов никак не влияла на работу схемы. Конденсатор C3 очень хорошо "режет" все низкочастотные помехи.

skov@gaap.spb.ru


Удлинитель COM порта на 200 метров

Кабель используется типа UTP2. Схема размещается в корпусе переходника 9-9pin. Прием-передача выполнены по балансной схеме и являются помехозащищенными. Питание берется с Com портов, т.е. уровни входных напряжений сигнала согласованы. Дальность достигается за счет того, что входные токи ОУ порядка 10 nA а выходные порядка 2 mA за счёт чего достигается высокая чувствительность. Сопротивления выбраны такие для того чтобы схема работала и в случае возникновения наводок ограничить входные токи. Все элементы дешевые. К тому же защищается Com порт, высокое напряжение в линии сожжет ОУ, а не порт. Проверить правильность сборки можно подключив преобразователь к Com порту, на стороне линии соединить прием с передачей (соблюдая полярность сигнала) запустить терминальную программу и нажимая клавиатуру на экране должны отражаться нужные символы (при включённом "локальном эхе" дублироваться).


Соединение компьтеров через COM порты по двум проводам

Схема соединения компьтеров

От Борисенко А.А.: У меня реально работает на 80м и 1,2км. Транзисторы, показанные на схеме, сильно греются; поэтому лучше заменить Q1 КТ315 на КТ626, а Q2 КТ361 на КТ646. Резистор R3, чтобы вдруг ничего не cгорело, ставьте 0,5 Вт. Микросхему никакой другой заменять не стоит: УД1 и УД2В не подходят вообще, а у УД2А характеристики хуже, её я ставить не пробовал, но, предполагаю, что она может сгореть.

От Коряжкина Максима: пробовал-работает, теоретически схема может обеспечивать работу на несколько километров (у меня на 2,5 км работала месяц). Операционник вычитает собственный сигнал из общего и получает удаленный. Схему можно оптимизировать подбором резисторов исходя из длинны (сопротивления линии). Изучавший в школе закон ома сам поймет, ламер всеравно порты на компе попалит, так что объяснять не буду. И учтите - гальванической развязки тут нет!


Передатчик ТТЛ сигнала

Передатчик ТТЛ сигнала

Передатчик разрабатывался для передачи цифровых сигналов в безпроводных компьютерных сетях, также может быть использован для ситем оповещения дистанционных включателей и тому подобных приборов. Использование передатчика для передачи цифровых сигналов наложило высокие требования к качеству изходящего от него сигнала, схема получилась весма недорогой при повторении, примерно 1.5 доллара. Передатчик использует 100% АМ модуляцию для передачи данных , частота ключевания может достигать 0..500КГц и может быть поднята уменьшением емкости конденсатора С10. Рабочая частота 104МГц обусловлена только отсутствием приемной аппаратуры на другие диапазоны и легко может быть изменена без потерь в качестве сигнала или его мощности. Питание 9 Вольт, напряжение питания должно быть хорошо отфильтрованно и стабилизированно. Токи потребления генератор - 5мА, первый каскад усилителя примерно 2мА , выходной каскад 7мА, все вместе 14мА.Максимальная мощность, при хорошо настроенных контурах, примерно 100мВт. Если описывать мощность передатчика на практических примерах, то можно привести такой факт, что на 50% от максимально возможного излучения устойчивый прием был через 7 этажей панельного здания или такой излучение платы (антенны нет) нормально принимается через пару бетонных перегородок и расстояние 10м , опытов на открытой местности пока не проводил. Хочу так же напомнить, что излучаемая мощность при плохой настройке передатчика может составлять десятки процентов от максимально возможного.При настройке приемника на частоту передатчика слышен только "белый" шум приемника на максимально возможной громкости приемника .

Передатчик ТТЛ сигнала

Передатчик ТТЛ сигнала

Передатчик ТТЛ сигнала

Плата с обратной стороны имеет слой фольги - подложку, ее необходимо в двух трех местах припаять к общему проводу. Передатчик мной проверялся только на этом варианте платы. Катушки намотаны на оправке из центрального изолятора диаметром 5мм антенного кабеля 75Ом , количество витков - 5, диаметр провода - 0.5мм. C3, показанный на схеме, отсутствует на фото и в случае необходимости подбирается и ставится на предназначенное для него на плате место. Транзисторы можно заменить на КТ368АМ, при этом частота будет несколько выше, хотя для замены подойдут любые универсальные транзисторы с частотой более 300 МГц и мощностью более 200мВт, таких вариантов несчесть.

Резонансный контур выходного каскада L3 C12 рекомендую заменить длинной линией в виде катушки, при этом мощность излучения поднимается в два раза .Данные для катушки, провод длинной 0.1 длинны волны, каркас из центрального изолятора антенного кабеля 75Ом, намотка сплошная. Оптимальной нагрузкой выходного каскада передатчика является длинная линия в виде катушки .Длинна провода в катушке определяется частотой передатчика и должна состовлять 0.1 длинны волны для данного передатчика на частоте 104 МГц длинна провода составила 80см .Такая нагрузка не является резонансной, по этому она не преобразует импульсный сигнал в синусоидальный и может работать в усилителях класса С только в качестве выходной нагрузки но не будет работать в промежуточных каскадах класса С. Резисторы R5 R7 рекомендую заменить на катушки с длинной провода 0.15 .. 0.25 длинны волны .Реактивные элементы не рассеивают мощность на тепло и по этому КПД и мощность передатчика увеличиваются. также на место этих катушек подойдут дроссели на ферритовых сердечниках, мной проверенны дроссели марок ДПМ3, ДПМ0.2, ДПМ0.1, ДМ0.1 индуктивностью 20 .. 200 мкГн, самопальный 20 витков провода диаметром 0.23мм на торроидальном сердечнике с внешним диаметром 8мм , внутренним диаметром 5мм высотой 2мм , марка феррита неизвестна и неиграет значительной роли .


Тестер для витой пары

С помощью этого тестера можно проверить на обрыв сетевой кабель 10/100 мегабит.
Резистор подбирается под нормальное свечение светодиодов, примерно 1 кОм.

Тестер для витой пары

1999-2006. Сайт ПАЯЛЬНИК (cxem.net). При использовании материалов с данного сайта, обязательна ссылка на сайт ПАЯЛЬНИК и первоисточник!


Регулятор скорости вентилятора

Предлагаемая ниже схема обеспечивает простую регулировку оборотов вентилятора без контроля оборотов. В устройстве использованы отечественные транзисторы КТ361 и КТ814. Конструктивно плата размещается непосредственно в блоке питания, на одном из радиаторов и имеет дополнительные посадочные места для подключения второго датчика (внешнего) и возможность добавить стабилитрон, ограничивающий минимальное напряжение, подаваемое на вентилятор.

Регулятор скорости вентилятора

Рис.1 Принципиальная схема регулятора.

Регулятор скорости вентилятора - фото Регулятор скорости вентилятора - плата

Рис.2 Внешний вид и топология печатной платы.


Регулятор скорости вентилятора

Как известно, вентилятор в блоках питания компьютеров формата AT вращается с неизменной частотой независимо от температуры корпусов высоковольтных транзисторов. Однако блок питания не всегда отдает в нагрузку максимальную мощность. Пик потребляемой мощности приходится на момент включения компьютера, а следующие максимумы - на время интенсивного дискового обмена. Если же учесть еще и тот факт, что мощность блока питания обычно выбирается с запасом даже для максимума энергопотребления, нетрудно придти к выводу, что большую часть времени он недогружен и принудительное охлаждение теплоотвода высоковольтных транзисторов чрезмерно. Иными словами, вентилятор впустую перекачивает кубометры воздуха, создавая при этом довольно сильный шум и засасывая пыль внутрь корпуса.

Уменьшить износ вентилятора и снизить общий уровень шума, создаваемого компьютером, можно, применив автоматический регулятор частоты вращения вентилятора, схема которого показана на рисунке. Датчиком температуры служат германиевые диоды VD1-VD4, включенные в обратном направлении в цепь базы составного транзистора VT1VT2. Выбор в качестве датчика диодов обусловлен тем, что зависимость обратного тока от температуры имеет более выраженный характер, чем аналогичная зависимость сопротивления терморезисторов. Кроме того, стеклянный корпус указанных диодов позволяет обойтись без каких-либо диэлектрических прокладок при установке на теплоотводе транзисторов блока питания.

Регулятор скорости вентилятора с датчиком температуры

Резистор R1 исключает возможность выхода из строя транзисторов VT1, VT2 в случае теплового пробоя диодов (например, при заклинивании электродвигателя вентилятора). Его сопротивление выбирают, исходя из предельно допустимого значения тока базы VT1. Резистор R2 определяет порог срабатывания регулятора.

Следует отметить, что число диодов датчика температуры зависит от статического коэффициента передачи тока составного транзистора VT1, VT2. Если при указанном на схеме сопротивлении резистора R2, комнатной температуре и включенном питании крыльчатка вентилятора неподвижна, число диодов следует увеличить. Необходимо добиться того, чтобы после подачи напряжения питания она уверенно начинала вращаться с небольшой частотой. Естественно, если при четырех диодах датчика частота вращения окажется значительно больше требуемой, число диодов следует уменьшить.

Устройство монтируют в корпусе блока питания. Одноименные выводы диодов VD1-VD4 спаивают вместе, расположив их корпусы в одной плоскости вплотную друг к другу. Полученный блок приклеивают клеем БФ-2 (или любым другим термостойким, например, эпок-сидным) к теплоотводу высоковольтных транзисторов с обратной стороны. Транзистор VT2 с припаянными к его выводам резисторами R1, R2 и транзистором VT1 (рис. 2) устанавливают выводом эмиттера в отверстие "-cooler" платы блока питания.

Налаживание устройства сводится к подбору резистора R2. Временно заменив его переменным (100-150 кОм), подбирают такое сопротивление введенной части, чтобы при номинальной нагрузке (теплоотводы транзисторов блока питания теплые наощупь) вентилятор вращался с небольшой частотой. Во избежание поражения электрическим током (теплоотводы находятся под высоким напряжением!) "измерять" температуру наощупь можно, только выключив компьютер. При правильно отлаженном устройстве вентилятор должен запускаться не сразу после включения компьютера, а спустя 2.. .3 мин после прогрева транзисторов блока питания.

Б. ПОРТУНОВ
г. Брянск
Радио №7, 2000


Регулятор скорости вентилятора

В отличии от схемы, которая замедляет обороты вентилятора после старта (для уверенного запуска вентилятора), данная схема позволит увеличить эффективность работы вентилятора путем увеличения оборотов при повышении температуры датчика. Схема также позволяет уменьшить шум вентилятора и продлить его срок службы.

Hастpойка пpоизводится до закpепления теpмодатчика на pадиатоpе. Вpащая R1 добиваемся чтобы вентилятоp остановился и затем вpащая в обpатную стоpону заставляем его гаpантиpованно запускаться пpи зажимании теpмоpезистоpа между пальцами (36 гpадусов) Если ваш вентилятоp иногда не запускается даже пpи сильном нагpеве (паяльник поднести) то нужно добавить цепочку С1, R2. Тогда R1 выставляем так, чтобы вентилятоp гаpантиpованно запускался пpи подаче напpяжения на холодный блок питания, а потом, чеpез несколько секунд после заpяда конденсатора, обоpоты падали, но полностью вентилятоp не останавливался. Тепеpь закpепляем датчик и пpовеpяем как все это будет кpутится пpи pеальной pаботе.

Rt - любой теpмоpезистоp с отpицательным ТКЕ, напpимер, ММТ1 номиналом 10 - 30 кОм. Теpмоpезистоp кpепится (пpиклеивается) чеpез тонкую изолиpующую пpокладку (лучше слюдяную) к pадиатоpу высоковольтных тpанзистоpов (или к одному из них).


Регулятор скорости вентилятора

Предлагаемое устройство позволяет автоматически регулировать скорость вращения вентилятора в зависимости от температуры охлаждаемого объекта, что в свою очередь снижает производимый вентилятором шум, а также продлевает срок его службы.

Схема устройства регулировки скорости вентилятора

Благодаря простоте предлагаемой схемы, монтаж можно осуществить в навесном варианте. При этом транзистор крепится на радиатор с помощью винта, через изолирующую прокладку, остальные детали приклеиваются токонепроводящим клеем. Так как в качестве термоэлементов используются диоды, необходимо обеспечить их тепловой контакт с радиатором (термопастой или клеем). Составной транзистор КТ973 можно заменить парой транзисторов КТ814 и КТ361. Подбором резистора R1 регулируют температуру включения вентилятора. Устройство особенно эффективно при работе вместе с программными кулерами. Схема взята из журнала "Радио" и переработана инженером ЦЭС№8 Вовненко А.С.


Сигнализатор неисправности кулера

Устройство предназначено для подачи звукового сигнала при остановке вентилятора, охлаждающего центральный процессор ПК (т.е. кулера). Сигнализатор включается в разрыв кабеля питания кулера, размеры печатной платы 40x32.5 мм (умещается в спичечном коробке). Принципиальная схема сигнализатора изображена на рис.1.

Форма тока через кулер

Работа устройства основана на особенности формы потребляемого кулером тока (риc.2). С резистора R1 снимается напряжение, пропорциональное току через кулер, с амплитудой импульсов около 2В. Фильтр C1R2 подавляет постоянную составляющую сигнала, чтобы в отсутствие импульсов транзистор VT1 был полностью закрыт. Каждый импульс тока (один оборот кулера) на короткое время открывает транзистор VT1, разряжая конденсатор C2. После окончания импульса транзистор закрывается, конденсатор C2 начинает постепенно заряжаться через R4, но при нормальной работе кулера к моменту прихода следующего импульса он успевает зарядиться незначительно, на входе 9 DD1 постоянно присутствует низкий уровень. При обрыве, заклинивании или замыкании кулера импульсы тока прекращают поступать на вход сигнализатора, транзистор VT1 постоянно закрыт, и конденсатор C2 заряжается (сопротивление резистора R4 подбирается так, чтобы установившееся напряжение на C2 уверенно распознавалось микросхемой как высокий уровень). Высокий уровень на входе 9 DD1 разрешает работу генератора, собранного на вентилях DD1.1-DD1.4 и формирующего прерывистый звуковой сигнал. Частота звука зависит от C4 и R6 (приведенные на схеме номиналы соответствуют приблизительно 2 кГц), частота прерывания звука - с помощью C3 и R5 (по схеме 9-10 Гц). В качестве излучателя звука можно использовать пьезоэлектрический капсюль (подобный используемым в электронных будильниках и телефонных аппаратах). Вариант печатной платы сигнализатора и монтажная схема приведены на рис.3 и 4 соответственно.

Настройка сигнализатора выполняется в два этапа. Сначала подбором R1 и C1 необходимо добиться устойчивого открывания транзистора VT1 положительными импульсами тока кулера. Затем подбором R4 и C2 устанавливается допустимый интервал между испульсами, по истечении которого включается сигнализация. (Желательно контролировать форму напряжения на конденсаторе C2 с помощью осциллографа.)

А.Яновский


Промежуточный усилитель звуковой карты для устранения недостатков

in english
по-русски
Поиск электронных компонентов на складах
Smileys Celebrity News Xbox Mod Chip Locuri de munca Swimsuit Photography

Промежуточный усилитель звуковой карты

Необходимой частью современного компьютера является Sound Blaster. Он позволяет получить звуковое сопровождение программ. В мире в последнее время большинство звуковых карт (плат) для компьютеров семейства IBM выпускаются без мощного оконечного усилителя и рассчитаны на подключение активных колонок или любого усилительного комплекса. Это позволяет получить более высокое качество звука и исключает перегрузку внутреннего источника питания компьютера.

Имея небольшой опыт работы на персональном компьютере, несложно приобрести и установить звуковую плату в любое свободное гнездо соответствующего разъема на материнской плате (внутри корпуса компьютера). В магазинах большой выбор звуковых карт — от укомплектованных в наборе, включающем колонки, до отдельных узлов. Покупать набор получается значительно дороже, чем то же самое по отдельности. Да и не всех комплектация набора способна удовлетворить качеством компонентов, например входящих колонок. Но приобретя все компоненты по отдельности, есть риск столкнуться с неполной совместимостью узлов. Так, купив хорошую звуковую карту фирмы "Creative" и отлично звучащие колонки SP-690 (50 Вт) фирмы "Advance", при их соединении вместе обнаружились два недостатка. Во-первых сигнал со звуковой карты недостаточен по уровню, чтобы получить от колонок максимальную мощность. Вторым недостатком явился сильный щелчок в динамиках при включении питания компьютера.

Промежуточный усилитель звуковой карты

Согласовать уровень сигнала и убрать щелчки позволяет схема, приведенная на рис. 1. Узлы усилителей УС1 и УС2 идентичны. Каждый канал обеспечивает усиление в 7,5 раз в полосе частот 20...100000 Гц. Конденсатор С4 в цепи базы транзистора VT3 дает плавное нарастание напряжения питания на усилителях — это устраняет прохождение импульсного броска от переходных процессов. Питаться промежуточный усилитель может от блока питания компьютера, для чего потребуется на задней стенке корпуса установить миниатюрный разъем ХЗ, соединенный с цепью +12 В источника питания. Ток потребления схемы не более 4, 6 мА.

Промежуточный усилитель звуковой карты

В схеме использованы детали: конденсаторы С1...С4 типа К53-1Б, резисторы любого типа. Штекер Х1 должен подходить к разъему звуковой карты, гнездо Х2 типа ОНП-ВГ-68-8/16, 5х14-Р или аналогичное, для подключения штекера активных колонок, ХЗ — любой малогабаритный. Топология печатной платы и расположение на ней элементов показаны на рис. 2. Настройка схемы заключается в получении одинакового усиления в каналах, подбором номинала резистора 1R6 (2R6) в пределах 200...1500 Ом (регулируется величина отрицательной обратной связи).


Сопряжение звуковой карты с музыкальным инструментом

Сопряжение звуковой карты с музыкальным инструментом

R1    - 4.3 кОм;
R2,R3 - 200 Ом;
R4    - 470 Ом (подстраивается под конкретную звуковую карту)
VT1   - КТ312,КТ315,КТ3102 и т.п.
U1    - АОД101

Если Вы увлекаетесь MIDI музыкой, тогда вам обязательно должна пригодиться указанная ниже схема сопряжения звуковой карты компьютера с клавишным музыкальным инструментом. Устройство испытано на соединении инструмента YAMAHA PSR-510 с звуковой картой ESS1698.


Коммутатор двух устройств для LPT порта

При помощи этой схемы можно подключить к одному порту для принтера 2 устройства. Это может быть полезно, например, при соединени 2-х компьютеров через LPT порт для принтера, когда в этот порт ещё должен подключаться принтер.

Комутатор для LPT порта


Универсальный паралельный адаптер

Универсальный параллельный адаптер предназначен для подключению к компьютеру различных устройств с цифровыми входами. Например, он может использоваться для записи информации в ПЗУ, прямого управления шаговыми двигателями, для налаживания различных электронных схем в качестве эмулятора и т.д.. При наличии соответствующего программного обеспечения многие из перечисленных задач можно выполнить используя только порт компьютера, но при этом возникает вполне реальный риск выхода порта из строя, так как его выходы не имеют защиты и рассчитаны на подключение только одного вывода, а для ремонта может потребоваться замена материнской платы. Кроме того для подключения к параллельному порту чего либо необходимо предварительно выключить компьютер. Адаптер устраняет эти проблемы и позволяет думать в первую очередь о разрабатываемой схеме, а не о том как бы в процессе ее создания не спалить компьютер.

Универсальный паралельный адаптер

Идея использовать параллельный порт для выдачи и приема цифровых сигналов с ТТЛ уровнями не нова, например в [1] приводится подобная схема. Предлагаемый здесь адаптер отличается простотой, при возможностях достаточных для большого количества применений. К тому же если Вам через какое то время понадобится увеличить количество входов-выходов можно просто собрать такую же схему и подключить ее по приведенной ниже таблице. Хотя если предполагается что выводов одной схемы сразу будет недостаточно лучше использовать более мощный вариант. Схема состоит из трех регистров и одного мультиплексора. Все регистры включены по одинаковой схеме, за исключением третьего, его выходы могут быть переведены в высокоомное состояние, поэтому к нему так же подведен управляющий сигнал разрешения включения выходов ОЕ. Информационные входы всех регистров объединены и подключены к соответствующим выходам параллельного порта компьютера, так как используется ТТЛШ серия, то допустимо нагружать один выход порта на несколько входов микросхем. Для стробирования используются управляющие линии порта, подключенные ко входам С регистров. Для увеличения количества входов используется мультиплексор D4.

Схема подключается к параллельному порту, так же необходимо подвести питание +5В к микросхемам, лучше всего для этого использовать блок питания компьютера. В моем варианте собранная схема находится внутри компьютера, подключается к внутреннему разъему LPT порта на системной плате, для питания использует 4 контрактный разъем, а рабочие выходы выведены на 32 контактный разъем вмонтированный в заглушку от отсека 5,25 на передней панели. На этот же разъем выведены напряжения питания +5, +12 вольт. При необходимости увеличить количество выводов можно собрать второй такой же блок и подключить его в соответствии с приведенной ниже таблицей к первому, подключенному к компьютеру. При этом появятся дополнительно несколько входов и выходов, но время доступа увеличится. Для подключения к внешнему устройству используются цепи О1...О24, из них О1...О16 являются обычными выходами, а О17-О24 могут использоваться как входы или выходы. Цепь О16 параллельно используется для внутренних нужд.

Подключение к параллельному порту

Вывод порта | Тип | Название вывода | Цепь адаптера
2 | O | D0 | IN1
3 | O | D1 | IN2
4 | O | D2 | IN3
5 | O | D3 | IN4
6 | O | D4 | IN5
7 | O | D5 | IN6
8 | O | D6 | IN7
9 | O | D7 | IN8
1 | O | -STROBE | IN9
14 | O | -AUTO FD | IN10
16 | O | -INIT | IN11
17 | O | -SLCT IN | IN12
10 | I | -ACK | IN13
11 | I | BUSY | IN14
12 | I | PE | IN15
13 | I | SLCT | IN16
18...25 | - | GND | общ.

Подключение второго адаптера для увеличения количества выводов

Первый | Второй | Первый | Второй
O1 | I1 | O9 | I9
O2 | I2 | O10 | I10
O3 | I3 | O11 | I11
O4 | I4 | O12 | I12
O5 | I5 | O17 | I13
O6 | I6 | O18 | I14
O7 | I7 | O19 | I15
O8 | I8 | O20 | I16

Программа должна писаться для каждого конкретного случая использования устройства отдельно, поэтому я не привожу здесь никаких вариантов, а только рассматриваю основные принципы программного управления схемой. Практически любой язык программирования имеет функции позволяющие записать число по заданному адресу в порт ввода-вывода. Управление схемой осуществляется через вызовы таких функций. Для записи 8 битного числа в буферный регистр схемы, необходимо записать его в регистр данных параллельного порта, затем записать в в регистр управления любое число имеющее в соответствующем разряде единицу (соответствующем выводу С выбранного буферного регистра) и затем в него же ноль. Для чтения 4х бит данных достаточно просто прочитать регистр состояния порта, для чтения остальных бит предварительно измените состояние линии О16. Необходимо учитывать то что некоторые входные и выходные линии порта проинвертированы. Адреса регистров для LPT1 приведены в таблице и верны для большинства компьютеров, но для корректного определенья адресов следует использовать данные BIOS.

Регистр данных | 378h
Регистр состояния | 379h
Регистр управления | 37Ah


Устройства чтения СИМ карт (3 варианта)

Устройства чтения СИМ карт - схема

Устройства чтения СИМ карт - схема

Устройства чтения SIM карт - схема


Востановление читаемости CD

Насчет полировки компашек, могу сказать следующее: кучу компашек с разными типами царапин я легко, примерно за 20 минут, "воскресил" при помощи старых джинсовых штанов, сделав из них перчатку. Причем не использовал пасты -они только царапали. Поверхность получается как у новой компашки. Так что попробуй этот способ.

http://www.recom.newmail.ru

Восстановил абсолютно нечитаемый (зелёный) CD-R диск следующим образом: Берётся металлический предмет с нешероховатыми краями (я использовал обычную чайную ложку). Затем в местах царапин очень аккуратно "снимается верхний слой" (если это можно так назвать) банальным трением. После этого куском войлока полируется место обработки. Вот и всё.

Сайт ”Город Мастеров”

Устранить царапины на CD, мешающие его чтению, можно с помощью обычной пасты ГОИ или чего-либо подобного. Опасности - можно невзначай повредить информационный слой (когда прижимаешь диск, или кладёшь его на не совсем чистую поверхность) . Если на просвет не видно "дырок" в алюминии, нет трещин, то есть достаточно большие шансы. Методика: Запастись достаточным количеством тряпок - желательно хлопчатобумажных (шерсть пластик царапает, убедился ещё в армии при шлифовке оргстекла шинелью) , очень хорошо идёт старое постельное бельё. Приготовить ровную и чистую поверхность - кусок стекла, например. Намазать тряпку пастой ГОИ (не сильно, лучше с соляркой или керосином, но можно и так) . Расстелить тряпку на рабочей поверхности (намазанным кверху) и зафиксировать её. Обычно один конец подкладывается под стекло, а второй удерживается внатяжку свободной рукой. Диск кладется на всю эту грязь зелёную и лёгкими круговыми движениями... Форма и направление движений подробно описана в руководствах по столярному делу (полировка мебели :-). Время от времени поглядывая на поверхность, видим, что мелкие царапины исчезают, а крупные становятся "прозрачными". Можно и так попробовать. Но "прозрачные" царапины преломляют лазерный луч неизвестно как, и соответственно неизвестно, что мы получим на выходе. Поэтому меняем тряпки. Если есть выбор паст ГОИ, выбираем более тонкую. Если нет, то продолжаем просто на чистой тряпке с добавлением керосина или соляра. Под конец всё на чистой тряпке надо промыть, протереть, привести в божеский вид. В общем, дело долгое и нудное, но если нет другого выхода - помогает. Пробовал выравнивать глубокие царапины "шкуркой" ускоряет процесс, главное, не перестараться. И ещё - при полировке не переусердствовать и не перегреть диск - даже при небольшом, казалось бы, прижиме, поверхность нагревается ощутимо.

Автор не известен

Наверно, вы заметили, что цветные компакт-диски обычно читаются надёжнее, чем белые. Это основано на свойстве лазерного луча, а на этом же основан и метод маскировки царапин. Вся информация на диске дублируется. Поэтому задача сводится к тому, чтобы предотвратить перескакивания луча с читаемого трека на другой. Вам понадобятся острая палочка (можно заточить спичку), увеличительное стекло и зелёнка (она в аптеке продаётся). Всё остальное просто. Макаете палочку в зелёнку и закрашиваете царапину. В результате луч не будет отражаться от краев царапины и пойдёт дальше по тому же треку. 100% гарантии нет, но, если царапина не от гвоздя, то часто помогает и затраты минимальные.

С. Нелюбов


CD-ROM в роли проигрывателя Audio-CD

На стендах магазинов и салонов сейчас большой выбор всевозможной аудиоаппаратуры, в том числе с проигрывателями компакт-дисков. Многие компьютеры теперь также оснащены блоком привода CD-ROM, позволяющим на компьютере не только считывать файловую информацию, но и прослушивать музыкальные компакт-диски.

Конечно, не всем необходимо покупать, скажем, магнитолу с проигрывателем компакт-дисков или музыкальный центр, уже имея неплохой усилитель или другую воспроизводящую аппаратуру. Для тех, кто хочет обзавестись таким проигрывателем с минимальными материальными затратами, рекомендую приобрести приводы CD-ROM, которые, как уже отмечалось, пригодны для воспроизведения музыкальных компакт-дисков. Выбирая такой блок, следует учитывать, что высокоскоростные приводы, хотя и стоят дороже, не обладают какими-либо преимуществами при воспроизведении обычных звуковых компакт-дисков.

В последнее время продаются приводы CD-ROM, на которых имеются две кнопки - "Play" и кнопка для выдвижения лотка. Причем они выполняют дополнительные функции: очередное нажатие на кнопку "Play" во время воспроизведения компакт-диска позволяет перейти на прослушивание следующей музыкальной композиции, а кнопка для выдвижения лотка при воспроизведении выполняет функцию "Пауза". Если же на блоке привода только одна кнопка - для выдвижения лотка, то после загрузки компакт-диска автоматически включается режим воспроизведения. Есть также приводы CD-ROM с пультом дистанционного управления, но они относительно дороги.

CD-ROM в роли проигрывателя Audio-CD

Пример размещения разъемов на задней панели одного из таких устройств приведен на рисунке. Все, что необходимо сделать, используя проигрыватель компакт-дисков, это подключить питание и соединить его с усилителем. Блок питания должен иметь два стабилизированных выходных напряжения: +12 В и +5 В. Ток, потребляемый приводом, обычно указан в паспорте, либо на корпусе. На передней панели - гнездо для подключения стереотелефонов, на задней имеется разъем аналогового выхода (ANALOG AUDIO) с амплитудой выходного сигнала до 1 В. К нему подключают двухпроводный экранированный кабель с соответствующим разъемом для соединения с усилителем.

О.Люпаев
г. Новочебоксарск
Радио №2, 1999


Метод очистки оптики в CD проигрывателях

Луч лазера, отражается от призмы проходит сквозь фокусирующую линзу и падает на диск. Отразившись от диска, луч возвращается, проходит сквозь призму и падает на считывающий фотодетектор. Как видите, загрязнение линзы или призмы вдвойне ухудшают прохождение луча, так как два раза оказываются на его пути. Попадание грязи на оптику лазера является наиболее распространенной причиной прекращения нормальной работы CD-проигрывателя: аппарат "заикается", не "распознает" или не раскручивает диски.

Метод очистки оптики Загрязнение линзы объектива самая частая и простая неисправность. Пыль лучше всего сдуть с поверхности линзы при помощи аэрозольного баллончика. От головки баллончика отходит тонкая пластиковая трубочка, позволяющая направить воздух в нужное место. Для очистки лазера направьте трубочку на линзу и "подуйте" на лазер в течение 1-2 секунд. Поверхность линзы можно очистить и ватной гигиенической палочкой. Если загрязнение сильное, то можно воспользоваться этиловым спиртом. Не нажимайте сильно - этим вы сотрете специальный просветляющий слой на поверхности линзы. Да и механизм подвески линзы очень деликатный, нажатием его можно повредить. ВНИМАНИЕ: ни в коем случае не используйте ацетон - линза сделана из пластмассы и вы безнадежно испортите ее.

Если очистка поверхности линзы не помогла, то, вероятно, пыль попала внутрь лазера, на поверхность призмы. Это более сложное загрязнение, но и с ним можно справиться. Но для этого придется разобрать лазер. Отжав защипы, снимите предохранительную крышечку и вы увидите следующее: Сложное сооружение около линзы - специальная электромагнитная подвеска. Она является частью системы автоматической фокусировки луча. При воспроизведении, электромагнит непрерывно корректирует положение линзы, поддерживая постоянным расстояние между линзой и диском. Это необходимо, поскольку при вращении диск совершает значительные колебания в вертикальной плоскости, и без системы автоматической фокусировки нормальная работа проигрывателя CD была бы просто невозможна.

Первый способ очистки призмы: простой. Подведите трубочку к зазору между линзой и корпусом и несколько раз, короткими "очередями" продуйте призму. Долго дуть нельзя, так как сжатый воздух, выходя из баллона, охлаждается и, тем самым, также охлаждается и призма. При этом, возможна конденсация влаги из воздуха комнатной температуры на поверхности призмы. После высыхания капелек воды, образуются разводы грязи, отмыть которые будет очень сложно. Такой способ позволяет очистить пыль, осевшую на призме, но при более серьезных загрязнениях воспользуйтесь вторым способом.

Второй способ: требующий аккуратности. Так же, как и в первом способе, снимите пластмассовую крышку. Под ней можно увидеть два маленьких винтика. Нанесите тонкие риски на металлическую рамку, сквозь которую проходят винты и на металлическое основание на корпусе лазера. Это позволит при обратной сборке правильно установить линзу на место. А это очень важно, иначе будет нарушена оптическая ось. Отвинтите винты, и снимите фокусирующую линзу. Возможно, рядом с винтами будут нанесены капельки клея - аккуратно срежьте их острым скальпелем. В шахте под линзой и стоит призма. Надо аккуратно протереть ее поверхность. Здесь есть небольшая сложность. Призма, как вы помните, расположена под наклоном 45 градусов, и обычная ватная палочка оказывается слишком толстой. Ей можно очистить лишь центр призмы. Чтобы удалить пыль с углов призмы необходим более тонкий инструмент. Фирма Aiwa поставляет в сервис-центры специальные, более миниатюрные палочки. В домашних условиях можно взять спичку, остругать её и намотать на кончик немного ваты. Главное - не поцарапать поверхность призмы и проследить за тем, чтобы внутри лазера не осталось ваты. Несколькими движениями протрите призму. Соберите лазер обратно, точно совместив нанесенные ранее риски. ВНИМАНИЕ: избегайте резких движений. Соединительный шлейф, между электромагнитами линзы и лазером можно оборвать неосторожным движением. Если после проведения указанных операций CD-проигрыватель не начнет работать, то можно слегка добавить ток лазера при помощи соответствующего подстроечника, расположенного обычно на видном месте. Если и в этот раз ничего не помогло, то скорее всего либо лазер уже не подлежит восстановлению, либо неисправность заключается в другом.


Ремонт и обслуживание приводов CD-ROM

В статье рассматриваются основные дефекты приводов (дисководов) CD-ROM и способы их устранения. Опыт эксплуатации персональных компьютеров показывает, что в общем потоке отказов эти устройства занимают четвертое место (вслед за мониторами, "винчестерами" и накопителями на гибких дисках). При рассмотрении неисправностей предполагается, что дисковод CD-ROM корректно установлен в операционной системе компьютера и правильно сопряжен с соответствующими платами и блоком питания. Наиболее часто встречаются следующие неисправности приводов CD-ROM.

1. УСТРОЙСТВО НЕДОСТУПНО ОПЕРАЦИОННОЙ СИСТЕМЕ

При этом диск загружается нормально - транспортный механизм исправен. Прежде всего проверяют подсоединение к дисководу CD-ROM внешних разъемов для исключения влияния плохих контактов. Затем, если возможно, меняют его подключение, т. е. меняют порт на системной плате (IDE0 или IDE1). Можно также попробовать подключить устройство к специальному разъему IDE на звуковой карте. Наконец проверяют правильность установки переключателя MASTER-SLAVE. В случае, если устройство имеет SCSI интерфейс, следует сменить его адрес.

емонт и обслуживание приводов CD-ROM Если все это не привело к положительному результату, вскрывают устройство и убеждаются в надежности паяных соединений информационного разъема, соединителя питания и переключателя активности (адреса) устройства. Затем проверяют, вращается ли вал приводного электродвигателя вместе с диском. Если он не вращается, проверяют исправность двигателя. Отсоединив оба его провода от печатной платы, подают на них от внешнего источника постоянное напряжение 5 В в соответствии с расцветкой проводов ("+" - красный, "-" - черный). Вращение вала двигателя свидетельствует о том, что неисправность следует искать в цепях управления им. Какая из микросхем (на печатной плате их всего две или три) управляет электродвигателем, определяют по идущим к ней печатным проводникам, к которым припаяны провода от двигателя. Кроме того, несколько выводов этой микросхемы (чаще всего два-три средних) соединены с шиной общего провода (фото 1).

Далее измеряют напряжение на выводах питания микросхемы управления, а также температуру ее корпуса (она должна быть не выше 35...40° С). Потемнение печатной платы под микросхемой и элементами, расположенными рядом с ней, указывает на высокую рабочую температуру этих деталей, что требует их проверки. Если выявить неисправный элемент не удалось, следует в первую очередь заменить микросхему. В корпусе приводного электродвигателя может быть размещен стабилизатор частоты вращения (к двигателю подведено четыре и более проводов). В данном случае прежде всего заменяют микросхему стабилизатора. Если же это невозможно (нет доступа, залита компаундом), следует заменить узел двигателя целиком.

2. ПРИ НАЖАТИИ НА КНОПКУ ИЗВЛЕЧЕНИЯ ДИСКА НЕ РАБОТАЕТ ТРАНСПОРТНЫЙ МЕХАНИЗМ

При такой неисправности необходимо убедиться, поступает ли напряжение с входного соединителя привода CD-ROM к его электронным элементам. Затем в соответствии с приведенным выше алгоритмом проверяют исправность кнопки, электродвигателя транспортного механизма и микросхемы управления им. В некоторых устройствах нужно также убедиться в целостности резинового пассика, передающего вращение от электродвигателя к рабочему зубчатому колесу транспортного механизма (на фото 2).

3. ПРИВОД CD-ROM РАБОТАЕТ НЕУСТОЙЧИВО, А ИНФОРМАЦИЯ ЧИТАЕТСЯ С БОЛЬШИМ ЧИСЛОМ ОШИБОК

В подобном случае на вскрытом устройстве вначале проверяют, появляется ли свечение лазера (красного цвета) на 2...10 с при установке транспортного механизма в рабочее положение. Свечение можно заметить только под определенным углом зрения в затемненном помещении (ни в коем случае нельзя заглядывать в его объектив - это опасно для глаз!). Каретка с лазером в этот момент должна переместиться вперед-назад, а приводной электродвигатель - включиться на короткое время. Убедившись, что все работает нормально, приподнимают верхний фиксатор диска и вручную выводят транспортный механизм в положение установки CD-ROM, открывая тем самым доступ к линзе лазера (фото 3). Мягкой кисточкой осторожно очищают линзу от пыли. Делать это надо с большой аккуратностью, чтобы не повредить подвеску лазера.

емонт и обслуживание приводов CD-ROM

Далее передвижением транспортного механизма или его разборкой освобождают посадочное место лазерного диска на приводном двигателе (приводном зубчатом колесе). После этого спиртом очищают от пыли вначале посадочный диск (резиновое кольцо - фото 2), а затем - верхнее прижимное кольцо (если, конечно, оно есть). В завершение очищают от пыли всю остальную механическую часть устройства, проверяют движение каретки лазера и при необходимости смазывают техническим вазелином ее направляющую.

4. ПРИ ВРАЩЕНИИ CD-ROM ЗАДЕВАЕТ ЭЛЕМЕНТЫ ДИСКОВОДА

Проверяют крепление приводного электродвигателя или посадочного диска. Если оно ослабло или имеет большой люфт (крен), дефект следует устранить.

Вот, пожалуй, и все, что может сделать специалист, имеющий среднюю подготовку. Впрочем, это не так уж и мало. По статистике неисправности электродвигателей, микросхем управления ими, а также загрязнение привода диска и линзы лазера составляют более 50 % всех отказов устройств CD-ROM. Следует отметить, что рекомендации по устранению неисправностей, приведенные в п. 1-3, справедливы и для записывающих устройств CD-ROM. Алгоритмы поиска и устранения неисправностей лазера, приводного механизма его каретки, устройства управления и узла сопряжения с внешним интерфейсом здесь не рассматриваются, так как требуют специальных навыков в каждом конкретном случае. Повышенный шум или гудение, издаваемые приводом при работе с отдельными лазерными дисками (характерно для устройств с высокими скоростями чтения), не являются неисправностью, для некоторых типов устройств CD-ROM это - штатный режим. В заключение - несколько полезных советов. Чтобы привод CDROM служил долго и надежно, необходимо придерживаться некоторых правил:
- по-возможности приобретайте лицензионные CD-ROM. Если же куплен "пиратский" диск, обязательно проверьте его на коробление, отсутствие зазубрин по периметру и т. д.;
- не реже одного раза в год очищайте устройство от пыли, как описано выше;
- не допускайте запыления и загрязнения лазерных дисков и при необходимости очищайте их батистовой тканью, смоченной спиртом;
- не применяйте так называемые чистящие диски для устройств CD-ROM.

Радио №12, 1999
А. Родин
г. Москва


Как сделать из монитора телевизор

У многих, кто начинал свое знакомство с компьютерами из семейства ZX-SPECTRUM, БК-001 и др., имеется цветной монитор типа 32ВТЦ-202 (МС 6113.02) или аналогичный. Если этот монитор уже не используется по своему прямому назначению, то предлагаемая доработка схемы позволяет превратить его в современный телевизор с дистанционным управлением на ИК-лучах. Для этого потребуется к уже имеющимся в мониторе блокам установить часть недостающих узлов: модуль цветности, радиоканал и блок управления. Их лучше приобрести уже готовые. Узлы эти унифицированны и легко устанавливаются внутри корпуса на металлическом каркасе (калитке). Это не потребует больших материальных затрат и много времени. Имеющуюся в мониторе плату видеоканала и блок управления необходимо удалить (они в дальнейшем не используются). А для удобства крепления новых плат фильтр блока питания и сам блок питания перемещаются глубже внутрь основания корпуса. Блок-схема электрических соединений узлов показана на первом рисунке. На ней новые блоки, которые устанавливаются в корпусе, показаны пунктиром. На рисунке изображены только выполняемые соединения между блоками, в дополнение к уже имеющемуся монтажу.

При доработке схемы монитора применены новые узлы:
блок радиоканала БРК-3-32 (от телевизора Ц-415);
модуль цветности МЦ-31 (подойдет любой модификации);
модуль управления МСН-405 с блоком БПД-45, а также пульт ДУ на ИК-лучах;
динамик типа 0.5ГД-36 (для него имеются уже установочные отверстия на передней панели монитора).

Шасси Расположение блоков на каркасе внутри корпуса показано на втором рисунке (вид сзади). Блок радиоканала устанавливается в нижней части левой калитки. В верхней части той же калитки закрепляется модуль цветности. Блок питания располагается вертикально на своем родном кронштейне, выходным разъемом вверх. В данном случае в качестве блока управления используется модуль МСН- 405 совместно с блоком дежурного режима БПД-45. Модуль МСН-405 устанавливают на месте снятого блока управления, используя металлический кронштейн. На месте его установки с лицевой стороны в корпусе телевизора прорезается отверстие под индикатор и органы управления. Блок дежурного режима и ПФП устанавливаются на основании внизу корпуса телевизора на освободившемся после перемещения БП месте. Динамик крепится справа внизу корпуса на имеющееся посадочное место с помощью саморезов. Соединение блоков и модулей проводится жгутом, прокладку которого лучше начинать от источника питания до требуемых мест.

Для нормальной работы телевизора на плате МГСР, расположенной на модуле строчной развертки, потребуется выполнить доработку. Она заключается в установке транзистора КТ315 в разрыв цепи от разъема ХР1/13 (место для размещения указанных элементов на плате имеется). Это обеспечивает инвертирование сигнала, что необходимо для нормальной синхронизации генератора внутри микросхемы. Потребуется также на плате блока разверток установить дополнительные резисторы R1 и R2 (первый рисунок). Они используются в дальнейшем для регулировки напряжения.

При настройке телевизора потребуется его комплексная регулировка. Для этого необходимо представлять себе принцип работы входящих в него узлов и иметь электрические схемы всех блоков. Объем книги не позволяет описывать этот процесс подробно. Например, можно порекомендовать познакомиться с книгой "Регулировка и ремонт цветных телевизоров", автор С. А. Ельяшкевич, или аналогичной. В частности, в процессе регулировки выполняются операции в следующей последовательности: Проверить наличие номинальных напряжений на выходе источника питания. Установить напряжение примерно 30 В на модуляторе кинескопа (на блоке разверток резистор R1, см. первый рисунок). Настроить при помощи блока МСН телевизор на любой принимаемый телевизионный сигнал-в соответствии с инструкцией по эксплуатации телевизора "Горизонт 51CTV-441". Для нормальной регулировки звука потребуется в модуле МСН-405 заменить резистор R34 на номинал 1 кОм, а подбором резистора R7 (из блока радиоканала БРК-3-32) настраивается минимальный уровень громкости. Максимальную громкость устанавливаем подстройкой резистором R28 на блоке радиоканала. После получения на экране изображения настраивается модуль цветности (МЦ-31). Комплексная регулировка телевизора проводится в соответствии с рекомендациями, изложенными в литературе. Следует лишь иметь в виду, что выходной каскад будет питаться пониженным напряжением (180 В). Последним этапом настройки является устранение геометрических искажений и центровка растра с помощью соответствующих регуляторов на платах блока разверток. При неустойчивой синхронизации она регулируется штатными элементами на МКР и МГСР соответственно. В указанной литературе методика настройки описана более подробно, но при этом необходимо учитывать состав данного телевизора.


Применение компьютерных блоков питания

Обращая внимание на дешевизну компьютерных (PC/AT) блоков питания (результат огромных «тиражей»), их очень просто приспособить и для других радиолюбительских нужд. В типовой схеме (рис.1) сетевое напряжение сразу выпрямляется в постоянное 320 В, половина которого прилагается к первичной обмотке трансформатора Т1 через ключевые Q1/Q2 (действуют попеременно). Вторичные обмотки Т1 имеют общую заземленную точку, а напряжения формируются двухполупериодными двухдиодными (D1D2 для +12 В и D3D4 для +5 В) выпрямителями с LC-сглаживающими фильтрами. Четыре оставшихся необозначен-ных на схеме диода используются для формирования напряжений отрицательной полярности. Управление ключевыми транзисторами осуществляется через второй трансформатор Т2, первичная обмотка которого подключена к выходу специализированной ИМС TL494. Это интегральный ШИМ-регулятор с несущей около 30 кГц (задается цепочкой C1R1 на выводах 5 и 6), длительность коммутирующих импульсов на выходе которого зависит от результата сравнения напряжений на выходах +5 В и +12 В с внутренним опорным напряжением. Если выходные напряжения блока питания меньше, чем надо, то длительность импульсов увеличивается и наоборот; таким образом обеспечивается эффективная стабилизация выходных напряжений.

Применение компьютерных блоков питания

Типовая спецификация стандартного блока питания: +5 В/ 3...22А, +12 В/0,5...8 А, -12 В/0,5 А, -5 В/0,5 А. Рассмотренная схемотехника задает следующие требования к возможным модификациям: общая мощность всех нагрузок не должна превышать 200 Вт (это ограничения Q1, Q2, Т1); ток через любую из 12-вольтовых обмоток не должен превышать 4 А, а 5-вольтовых -10 А (ограничения катушек L1a/b и диодов D1-D4); каждая из половинок вторичной обмотки Т1 должна нагружаться симметрично, т.е. обязательно двухполупериодное выпрямление; соотношение напряжений пяти и 12-вольтовых выходов изменить невозможно ввиду фиксированного соотношения числа витков вторичных обмоток Т1 - абсолютные значения напряжений можно изменять на ±30%, или 3,5...6,5 В и 9...15 В, но их соотношение всегда будет равно 5:12. Пример 1: 6 В/16 А. Напряжение 6 В укладывается в 30%-ный коридор для 5-вольтового выхода, а 16 А соответствует (2х)8 А от каждого плеча выпрямителя, т.е. требования выполнимы.

Применение компьютерных блоков питания

Схема для такого варианта показана на рис.2; здесь выходы +12/-12/-5 В с обрамлением устранены за ненадобностью. Выходное напряжение определяется резисторами R4 и R5. TL494 регулирует выход так, чтобы напряжения на ее выводах 1 и 2 (опорное 5 В) были равными, т.е. напряжение на R5 равно 5 В. Очевидно, что при этом напряжение на R4 равно 6-5=1 В и его сопротивление R4=R5(6B-5B)/5B. Если R5=4,7 кОм, то подходящее R4=1 кОм. Пример 2: 24 В/ 4 А. 24 В не укладывается в 30% коридор ни одного из стандартных напряжений, поэтому применим модификацию включения вторичных обмоток - рис.3. Здесь добавлены D5 и D6, формирующие напряжение -12 В. Перемаркируем -12 В в «общий», тогда +12 В станет +24 В (такой «фокус» возможен из-за гальванической развязки схемы от сети и нагрузки). Сопротивление R3=R5(12 В - 5 В)/5 В, т.е. если R5=3,3 кОм, то R3 = 4,7 кОм.

Применение компьютерных блоков питания

D. Begebeger
Elektor Electronics №6, 2003, с.46-50


Переделка старых блоков питания компьютера АТ в АТХ

АТ в АТХ

У многих имеются старые блоки питания конструктива АТ. Предлагаемая несложная доработка блока питания вашего компьютера позволит вам получить блок конструктива АТХ. Аналогичные схемы переделки уже публиковались и это одна из таких схем. После переделки блок АТ будет содержать главную функцию - возможность отключения по окончании работы вашего компьютера и включении его, как в блоке конструктива АТХ. Вся переделка блока питания конструктива АТ хорошо видна на рисунке. Все дополнительные элементы устанавливаются в блоке питания вашего компьютера, а дополнительные соединительные провода припаиваются и выводятся из блока питания на АТХ разъем питания на материнской плате вашего компьютера.

А. Манойленко (UN9LK)


Разводка разъемов питания AT и ATX

AT ATX

P8
PIN | DESCRIPTION
1 | Power Good, +5 VDC when all voltages has stabilized.
2 | +5 VDC (or n/c)
3 | +12 VDC
4 | -12 VDC
5 | Ground
6 | Ground

P9
PIN | DESCRIPTION
1 | Ground
2 | Ground
3 | -5 VDC
4 | +5 VDC
5 | +5 VDC
6 | +5 VDC

PIN | DESCRIPTION
1 | +3.3 VDC
2 | +3.3 VDC
3 | Ground
4 | +5 VDC
5 | Ground
6 | +5 VDC
7 | Ground
8 | Power Ok (+5V & +3.3V is ok)
9 | +5 VDC Standby Voltage (max 10mA)
10 | +12 VDC
11 | +3.3 VDC
12 | -12 VDC
13 | Ground
14 | Power Supply On (active low)
15 | Ground
16 | Ground
17 | Ground
18 | -5 VDC
19 | +5 VDC
20 | +5 VDC


БП для трансивера из компьютерного БП AT/ATX

Весной 2001 года UA3DJG опубликовал статью в журнале "Радиохобби" о применении БП от компьютера. Переделка занимает около часа, включая сборку-разборку. Хочу поделиться своим опытом изготовления такого БП и "дополнить" статью автора.

БП для трансивера из компьютерного БП AT/ATX
Рис.1 Принципиальная схема переделок.
Красным цветом отображены новые детали.

Я использовал БП, на котором было написано 230W PEAK LOAD. Оказалось, что он для быстрой переделки не подходит. Ниже приведена пошаговая инструкция переделки:

  1. Отпаять все провода, идущие с выходов других источников (-5 В, -12 В, +5 В), кроме общего (GND) и +12 В.
  2. Оставшиеся провода сложить в пучки. Желтым пучком (+12 В) сделать несколько витков на ферритовом кольце (2000НМ, диаметром 25 мм), а затем вместе с черным (GND) подключить соответственно к клеммам «+12 В» и «-12 В», установленным на месте розетки для подключения монитора. Параллельно этим клеммам подключить конденсатор 33 мкФ х 25 В.
  3. Отверстие в корпусе, через которое выходили наружу провода питания, использовались для установки клавишного выключателя (-220 В) с подсветкой (предварительно напильником придать отверстию нужную форму).
  4. Заменить выпрямительные диоды источника +12 В (сборка из двух диодов на радиаторе - показана красным цветом на рис.1) на КД2999 (2 шт.) с любой буквой, установив их на уголке (TNX RV4HV) и его уже закрепить на радиаторе, припаяв удлинительные провода к выводам диодов (рис.2). Еще лучше применить здесь сборку из диодов с барьером Шоттки 25 А х 100 В - меньше падение напряжения и, соответственно, нагрев.
  5. Емкости 220 х 200V заменить на 330 х 350V. Так как конденсаторы отличаются от установленых, то их распаивают на ножках из провода.
  6. Емкость на "выходе" + 12В заменить на 4000,0 х 16В. Для снижение напряжения на вентиляторе необходимо включить диоды в цепь питания. Диоды в цепи +5В, располагаются снизу печатной платы.
  7. Для повышения выходного напряжения с 12-ти до 13-ти вольт необходимо разорвать печатный проводник, идущий от средней точки выпрямительной сборки +5 В, и включить в эту цепь любой кремниевый диод на 1..2 А в прямом включении, как показано на рис.1 (D*). Автор применил КД226. После этого трансивер стал отдавать в антенну свои «родные» 100 Вт (при 12 В -80...90 Вт). По указанной цепи подается напряжение обратной связи для каскада стабилизации выходных напряжений; уменьшение этого напряжения с помощью прямосмещенного диода примерно на 0,6 В привело к увеличению выходных напряжений, в т.ч. и источника +12 В до +13 В; вместо диода можно применить и резистор, подобрав его сопротивление для получения +13...+13,5 В.

БП для трансивера из компьютерного БП AT/ATX

Рис. 2

БП для трансивера из компьютерного БП AT/ATX

Рис.3

Получился БП с такими параметрами: Uвых - 14,2В при токе нагрузки 20А, легкий (вес около 700 г), маленький (80x100x150 мм), надежный источник питания с защитой от к.з. на выходе (раз 10 «коротил» выход отрезком провода - он просто отключался). Выходное напряжение изменяется не более чем на 30...40 мВ при изменении напряжения сети от 180 до 280 В. Паразитная модуляция сигнала при передаче отсутствует. На холостом ходу потребляет от сети около 7 Вт. КПД при изменении тока нагрузки от 5 до 20 А в пределах 80...85%. Блок в эксплуатации с мая этого года на даче. Напряжение сети в течении дня может меняется от 195 до 235В, но на качестве работы FT-840 не сказывается При сравнении с БП собранном по обычной схеме, отличий не замечено.

Николай Шадрин
RZ4HX
 rz4hx@infopac.ru


БП для трансивера из компьютерного источника питания AT/ATX

Пошаговая инструкция для переделки компьютерного блока питания для использования с трансивером.
1. Необходимо удалить все детали для -12, -5 и +5 вольт. Я удалил диоды, конденсаторы, обмотки дросселя и нагрузочные резисторы для этих напряжении. Все это занимает много места.
2. Перемотать намоточные узлы для +12 вольт более толстым проводом. Дроссель для +12 вольт я намотал проводом 1.3. На 1 вольт 1.5 витка, то есть 20-21 витка. Можно мотать и в два провода, проводом 0.6. Обмотка должна сильно прилагать к сердечнику. С трансформатором дела обстоят посложнее, его очень сложно разобрать (Залит чем-то китайским, Hi!). Если разберете, попытайтесь намотать его более толстым проводом. Посчитайте витки и намотайте столько же +8-10 витков (У нас иногда в сети бывает 190 вольт).
3. Заменить выпрямительные диоды для +12 вольт на сборку из диодов с барьером Шоттки 30А 45В. Я применил сборку 30CPQ045. (Может быть у других производителей данная сборка называется по другому). Использование отечественных диодов дало неудовлетворительные результаты. - большое падение напряжения. Диоды КД 2998 дали при нагрузке падение около 1.1 вольта.
4. Разорвать на плате дорожку, которая шла на первую ножку TL494. Через резисторный делитель подать напряжение на эту первую ножку микросхемы. ( Огромное спасибо А.Ю.Сидельникову 4L1AW ). Этим мы заставляем микросхему отсчитывать нужное нам напряжение +12 вольт. В исходном варианте она отсчитывает суммарное напряжение, где доминирующим является +5 вольт.
5. Подбором номиналов резисторов делителя выставил нужное напряжение на выходе +14 вольт.

БП для трансивера из компьютерного источника питания AT/ATX БП для трансивера из компьютерного источника питания AT/ATX

Все что я сделал показано на принципиальной схеме ниже на рис.1. Фотография получившегося блока питания приведена на рис.2. Источник был испытан в самом жестком режиме. Падение напряжения при 18А составило 0.3В. Как не странно БП работает. Я думаю все легко и просто. А после переделки у вас в наличии окажется легкий и небольшой БП. Если есть предложения или замечания пожалуйста, пишите на мой E-mail.

Давид Девдариани
4L1DA
4l1da@rambler.ru


Ремонтируем блока питания компьютера

После разборки БП прозвонить на короткое замыкание ключевые транзисторы (типично BUT11A), резисторы на 1..3 ом в базе их на обрыв, мост на короткое/обрыв, пред-выходные транзисторы на кз/обрыв, диоды во вторичных цепях на пробой. В качестве пред-выходных при замене можно ставить наши КТ315, выходные или наши КТ872, КТ8114 (но тогда для самозапуска возможно потребуется снижение номинала резисторов между базой и коллектором их до 200к...150к), или импортные типа этих: 2SC3447, 2SC3451, 2SC3457, 2SC3460(61), 2SC3866, 2SC4706, 2SC4744, BUT11A, BUT12A, BUT18A, BUV46, MJE13005 После смены неисправных деталей проверить исправность микросхемы ШИМ типа tl494 или ее аналога, если определено что она неисправна - сменить. Желательно для профилактики убрать переключатель 220/120в. При включении в сеть для проверки, необходимо вместо предохранителя включить лампу накаливания типа 100вт 220в, а в выходную цепь +5в резистор 2...5ом 20вт

  Пpовеpка микpосхемы TL494 и ее аналогов (М1114ЕУ4, mPC494C, IR3M02). В состав этой ИС входит: задающий генератор пилообразного напряжения А1, частота генератора задается внешним резистором R1
конденсатором C1 и может быть приближенно определена по формуле f=1/(C1*R1). R1 включается между выводами 6 и 7, а C1 между выводами 5 и 7. Амплитуда пилы не зависит от номиналов R1 и C1 и приблизительно равна 4В; усилитель цепи обратной связи DA2; широтно-импульсный модулятор, выполненый на компараторе DA4; усилитель защиты преобразователя от перегрузки по току или короткого замыкания на нагрузке DA1; делитель частоты на два, выполненный на счетном тигере DD2; каскады совпадения на элементах DD1, DD5, DD6; каскад на компараторе DA3, позволяющий построить:
- схему исключения перенапряжения на выходе преобразователя в переходных режимах;
- схему ограничения диапазона изменения коэффициента заполнения в необходимых пределах;
- схему обеспечения плавного выхода преобразователя на режим;
- логические элементы DD3, DD4 предназначенные для задания режима управления либо однотактными либо двухтактными преобразователями;
- выходные транзисторы Q1 и Q2;
- встроенный непрерывный стабилизатор напряжения DA5 и реле напряжения (пороговое устойство) DA6;
- развязывающие диоды D1, D2 для обеспечения функции "ИЛИ" для выходных сигналов микросхем DA1, DA2.

Микросхема управления работает следующим образом. Непрерывный стабилизатор напряжения обеспечивает питанием все функциональные узлы ИС и задает опороне напряжение +5В (вывод 14) относительно общего вывода 7. Реле напряжения DA6 разрешает прохождение сигналов управления на базы транзисторов Q1 и Q2 только в том случае, если DA5 вышла на режим. Пилообразное напряжение (вывод 5), вырабатываемое генератором А1, поступает на вход компараторов DA3, DA4. На другой вход ШИМ-компаратора DA4, через развязывающий диод D2 поступает сигнал рассогласования с усилителя ошибки DA2. На один из входов DA2, непосредственно или через делитель, подключается источник опорного напряжения с вывода 14, а на другой вход поступает напряжение цепи обратной связи, т.е. выходное какого-либо канала (обычно с канала +5В). Между выводами 3 и 3, как правило, включается корректирующая RC-цепь для обеспечения устойчивой работы стабилизирующего преобразователя. С выхода ШИМ - компаратора прямоугольные импульсы поступают на один вход схемы совпадения DD1, с ее выхода импульсы проходят на счетный тригер DD2 и на схемы совпадения DD5, DD6.

Если на управляющий вход элементов DD3, DD4 (вывод 13) подана логическая единица, то микросхема обеспечивает управление двухтактными преобразователями с паузами на нуле, а если на вывод 13 подан логический ноль (вывод 13 сеодинен с выводом 7), то DD2 не оказывает воздействие на работу ключей DD3, DD4 и в этом случае микросхема может быть использована для ШИМ или ЧИМ управления однотактными проебразователями. Для построения защиты по току, как отмечалось ранее, может быть использован DA1, при этом на один из его входов подается опорное напряжение, определяющее уровень срабатывания токовой защиты, а на второй вход подается сигнал с датчика тока. Узлы с использованием схем DA1 и DA3 могут быть самыми разнообразными. Некоторые примеры рассмотрены при описании нижеследующих схем блоков питания. Для увеличения выходной мощности микросхемы при управлении однотактниками транзисторы Q1 и Q2 могут быть запараллелены, поскольку в этом режиме они работают синхронно и синфазно. Выводы М1114ЕУ4 полностью соответствуют выше перечисленным зарубежным аналогам, а соответствие между выводами М1114ЕУ3 и М1114ЕУ4 представлено ниже.

М1114ЕУ4 -- 1 2 3 4 5 6  7  8  9 10 11 12 13 14 15 16
М1114ЕУ3 -- 4 5 6 7 8 9 15 10 11 12 13 14 16  1  2  3
Основные параметры М1114ЕУ3, М1114ЕУ4
Uпит.микросхемы(вывод 12) - Uпит.min=9В; Uпит.max=40В
Допустимое напряжение на входе DA1, DA2 не более Uпит/2
Допустимые параметры выходных транзисторов Q1, Q2:
Uнас менее 1.3В;
Uкэ менее 40В;
Iк.max менее 250мА
Остаточное напряжение коллектор-эммитер выходных транзисторов не более 1.3В.
I потребляемый микросхемой - 10-12мА
Допустимая мощность рассеивания:
0.8Вт при температуре окр.среды +25С;
0.3Вт при температуре окр.среды +70С.
Частота встроенного опорного генератора не более 100кГц.

Алгоритм поиска неисправностей М1114ЕУ3, М1114ЕУ4 Проверка работоспособности микросхемы производится при отключенном БП и при питании ИС от внешнего ИВЭП напряжением +9В...+15В поданного на 12-й вывод относительно 7-го. Все измерения проводятся тоже относительно 7-го вывода. Кроме того подключение к ИС лучше осуществлять подпайкой проводов, а не с помощью "крокодилов", это обеспечит повышенную надежность контакта и исключит возможность ложных соприкосновений.

  1. При подаче внешнего напряжения осциллографируем напряжение на 14-ом выводе, оно должно быть +5В(+/-5%) и оставаться стабильным при изменении напряжения на 12-ом выводе от +9В до +15В. Если этого не происходит, то значит вышел из строя внутренний стабилизатор напряжения DA5
  2. С помощью осциллографа наблюдаем наличие пилообразного напряжения на выводе 5 (см.рис.1.1а UвхDA4) если оно отсутствует или имеет искаженную форму, то необходимо проверить исправность времязадающих элементов C1 и R1 подключаемых соответственно к 5-му и 6-му выводам, если эти элементы исправны, то неисправен встроенный генератор и необходима замена ИС.
  3. Проверяем наличие прямоугольных импульсов на выводах 8 и 11. Они должны соответствовать диаграмме 5 и 5' на рис.1.1а. Если импульсы отсутствуют, то ИС неисправна, а если присутствуют, то проверяем работоспособность других узлов ИС.
  4. Соединив проводником 4-й вывод с 7-м, мы должны увидеть, что ширина импульсов на 8-м и 11-м выводах увеличилась; соединив 4-й вывод с 14-м импульсы должны исчезнуть, если этого не наблюдается, то надо менять ИС. Снизив напряжение внешнего до 5В, мы должны увидеть, что импульсы исчезли (это говорит, что сработало реле напряжения DA6), а подняв напряжение до +9В...+15В импульсы должны снова появиться, если этого не произошло и импульсы (которые могут быть произвольными) присутствуют на 8 и 11, то значит в ИС неисправно реле напряжения и необходима замена микросхемы.
  5. Проверка работоспособности DA2. Снимаем ранее установленную перемычку между 4-м и 7-м выводом, подаем на 12-й вывод напряжение питания в пределах +9В...+15В и соединив 1-й вывод с 14-м мы должны увидеть, что на 8-м и 11-м выводах ширина импульсом стала равгой нулю, если этого не происходит, то DA2 неисправна и надо менять ИС.
  6. В БП на рис.2, рис.3, рис3.4, DA1 используется в узлах токовой защиты и если предыдущие тесты показали, что все другие узлы ИС функционируют нормально, то проверка исправности DA1 осуществляется следующим образом: подаем на 12-й вывод +9В...+15В и наблюдаем на 8 и 11 примоугольные импульсы. От другого источника питания подаем отрицательное напряжение на 15 вывод (относительно 7-го) при этом импульсы на 8 и 11 должны исчезнуть. Если этого не происходит, то значит не работает узел защиты на DA1.


Подсветка клавиатуры

Смотрится этот модинг достаточно стильно и он удобнее многих вариантов которые мне приходилось видеть. Вобщем, не буду много писать, а просто выложу фотки и всё сразу станет понятно. Секрет в том, что к монитору приклеены 2 синих SMD светодиода. Сами диоды не видно, видно только свет и даже не сразу понтно откуда свет. Диоды я крепил самым простым способом - припаял их на кусочек макетной платы и плату скотчем приклеил к монитору. Провода также приклеены скотчем и уходят под стол, а там к компьютеру. В компьютер провод попадает через вентиляционные отверстия в задней стенке и подключается к разъему питания (+5V) через резистор 130 Ом.

После нескольких часов испытаний были обнаружены следующие недостатки:
1. мало света в центре, нужно поставить по центру ещё один диод;
2. синий свет не очень хорошо воспринимается, лучше поставить белые диоды - это будет не так красиво, но зато и света больше станет;
3. плохо видно подсветку дополнительной клавы.


Модинг флопи диска, CD-привода

Я видел несколько заметок на тему замены светодиода в флопике. Все просто меняют зеленый диод на красный или синий, получаетя конечно неплохо, но слишком просто. Я же решил немного усложнить этот модинг и добавить в него оригинальности. Вот что у меня вышло в итоге: я поставил два SMD светодиода по бокам от щели для дискет. К светодиодом как обычно подпаял тоненькие проводки. Сначала я просто подключил их к +5V на разъеме питания флопика, но потом подумал, что это не интересно и слишком просто. Я выпаял индикатор активности и впаял на его место свои светодиоды. Теперь при обращении к флопику из дисковода идет мягкий голубой свет. Получилось и красиво и функционально. Свет виден и при закрытой крышке и при вставленой дискете.

Модинг флопи диска


Печатаем струйным принтером на CD и DVD

Приспособить струйный принтер для печати на CD и DVD не очень сложно. Для этого вам необходим сам принтер, Epson и Canon. Принтеры марки НР не подходят для данной цели, потому как идет изгиб носителя печати. Остановимся на принтерах марки Epson. Основное требование, проход носителя (диска) должно быть прямоточным, т.е. без изгибов. Сам диск сложно протащить через принтер с точным позиционированием, для этих целей требуется изготовить подложку, которая будет "держать" диск и ровно позиционировать в нужном положении.

Этап 1. Снимите механизм затяжки бумаги (не путайте с валами и роликами протяжки), можно и не снимать некоторые модели принтеров позволяют изменить конструкцию так что даже останется возможность печати на бумаге. Этап 2. Удалите все пластиковые запчасти, которые стоят до механизма протяжки бумаги. Для того чтобы подложка с диском свободно могла пройти к валу протяжки. Важный момент: флажок датчика бумаги должен попадать в область протягивания подложки. Также, если останутся левый и правый выступ в блоке затяжки, не удаляйте их, они буду точно позиционировать подложку, да и сама подложка будет ровно входить между ними. Этап 3. Выпилите окно в задней части корпуса принтера высотой порядка 2-3 см. Этап 4. Самый важный этап (важна точность) - изготовление подложки.

На верхнем рисунке - вид в разрезе (серым цветом обозначен картон, желтым - ламинирующая пленка). "D" - диаметр диска. Место, куда ложится диск. "В" - ширина подложки. Ширину вы можете подобрать сами, по расстоянию между выступами в блоке затяжки, которые и будут направлять подложку и не дадут ей сместится (люфт). "А" - расстояние между началом подложки и выступом, который будет определять начало "бумаги", для каждой модели принтера может быть различным. "А" - определяется примерно следующим образом, это расстояние между флажком датчик начала бумаги и край листа бумаги который лежит в лотке +1,5-2 см. для надежности.

Технология изготовления подложки: после того как удалили все мешающие объекты и выступы для продвижения подложки, нужно взять картон толщиной 1-1,5 мм. Обрезать с краев, до ширины прохождения подложки между выступами. Вырезать слева срез "А", который будет означать начало "носителя". Вставить подложку вплотную к протяжному валу и распечатываете окружность по диаметру диска. Переднюю кромку картона чуть заострите, как указано на рисунке, можно подрезать или "заточить" наждачкой. Проламинируйте верхнюю часть подложки (сдвинуть пленку вперед начала подложки, чтобы она выступала на 2-3 мм.). Вырежте с помощью циркуля с насаженным лезвием отверстие. Туда будет ложиться диск при печати. Далее проламинируйте нижнюю часть подложки (также сдвинуть вперед подложки на 2-3 мм. пленку, чтобы верхняя и нижняя образовали заострение).

Подложка готова, нижняя пленка будет поддерживать диск, ну и сам диск будет лежать плотненько в вырезанном отверстии. Для того чтобы диск не болтался при печати по середине паза на пленку можно наклеить двухсторонний скотч, он будет держать диск при печати. Головку желательно поднять иначе она будет задевать диск. Возможно сразу расстояние "А" не получится подобрать, и принтер будет прогонять подложку. Для этого, укорачивая подложку с передней кромки, т.е. уменьшая расстояние "А", подберите оптимальное расстояние "А". Как достигнете нужного результата, опять сделайте из ламинатной пленки заострение. И подложка готова для работы.

Фомин Дмитрий


Инфракрасный порт и работа с ним

Для чего нужен ИК-порт? Такое устройство позволяет без применения проводов создать устойчивое соединение между компьютером и другими устройствами (оборудованными ИК-портами). Например, это может быть сканер или принтер. Хотя сейчас большинство пользователей приобретает такое устройство для связи настольного компьютера с карманным компьютером или, что бывает значительно чаще, сотовым телефоном. Последние два устройства имеют достаточно примитивную систему ввода и, безусловно, ее расширение увеличивает комфорт работы с информацией. Мобильный телефон стал вполне доступным устройством для большинства пользователей компьютеров. ИК-порт, которым оснащены многие модели телефонов, позволяет редактировать содержимое записной книжки аппарата через обыкновенный компьютер. Можно без особых проблем сменить логотип на дисплее или поставить мелодию вызова. Достаточно интересная функция, которая появляется у владельца мобильного аппарата, это сетевой мониторинг, который даст самую исчерпывающую информацию по сети. Нельзя не сказать о такой услуге практически всех сотовых операторов, как мобильный Интернет. В этом случае, вы можете выходить во Всемирную сеть через ваш мобильный телефон. Другими словами, вы становитесь пользователями Интернет в любой точке, где работает необходимый вам оператор. Это достаточно дорого, но альтернатив решения этой проблемы в некоторых случаях нет. Давайте поподробнее познакомиться с этим замечательным устройством.

Типы ИК-портов (по подключению):

1. | ИК-порт, подключающийся на IrDA-разъем материнской платы | на IrDA-разъем материнской платы,
2. | ИК-порт, подключающийся на стандартный 9-пинный разъем COM | на стандартный 9-пинный разъем COM
3. | ИК-порт, подключающийся на USB | и на USB.

Устройства второго и третьего типа являются универсальными. Другими словами, если вы купите такой ИК-приемопередатчик, то он без всяких осложнений встанет на ваш компьютер. Если же вам приглянулся ИК-порт, который подсоединяется к материнскому разъему IrDA, то могут возникнуть проблемы. Внимательно читайте инструкцию и консультируйтесь с продавцом. Например, ИК-порт компании ASUS работает только на материнской плате этого же производителя. Очень удобные ИК-порты делает одна из китайских компаний (на полиэтиленовом пакетике нет названия фирмы изготовителя). Коннектор для подключения к IrDA выполнен по принципу «собери меня сам». С одной стороны, ему явно не хватает механической прочности, и вставить его в разъем материнской платы очень сложно. Но с другой стороны, вы можете с легкостью, не прибегая к помощи паяльника и пинцета, собрать нужный коннектор, тем самым обеспечить необходимую «пинную» совместимость. Такая гибкость решения делает его очень привлекательным для покупки. Хотя качество китайских ИК-портов... Давайте не будем о плохом. В дальнейшем мы поговорим о характеристиках подобных устройств.

Рабочие условия

Устройства ИК-связи нельзя назвать очень капризными, но все же нужно немного рассказать об условиях их эксплуатации. Прежде всего, стоит знать, что длина волны работы ИК-портов лежит в диапазоне от 850 до 900 нм. Чаще всего это значение равно 880 нм. Так что организовать сильные помехи дело достаточно простое. Начнем с примеров:

  1. Окна квартиры, находящейся на пятом этаже, выходят на западную сторону. Ближе к вечеру ИК-приемник/передатчик перестал видеть сотовый телефон, оборудованный подобной системой. Эта связка находилась на столе и не была ничем прикрыта. Причина помех была найдена без особых проблем. Яркое весеннее солнышко стало виной всему. При работе с ИК-устройствами остерегайтесь прямых солнечных лучей.
  2. Вечером при включении лампы дневного света ситуация повторилась. Однако, стоит заметить, что связь все же была, но очень часто обрывалась. Лампа дневного света должна быть прикрыта или выключена во время работы ИК-устройств.
  3. Телевизор, который находится в непосредственной близости от рабочего стола, оборудован пультом дистанционного управления. При переключении каналов или любых других манипуляциях с «ленивчиком» рабочая программа исправно выдавала сообщение о том, что в прямой близости работает постороннее ИК-устройство и требовало выключить его. Мешало это передаче данных или нет — неизвестно, но пока не был убран пульт дистанционного управления (можно читать «был выключен»), не удалось ничего сделать с программой. При работе с ИК-устройством уберите все посторонние ИК-передатчики в зоне действия ИК-порта.

Исключите все источники ИК-волн диапазона 850–900 нм из зоны прямой видимости ИК-приемника. Отраженные волны могут принести проблемы, но в меньшей степени. Одним словом, всех помех не предусмотреть, но убрать их причину всегда можно. Рабочее расстояние между двумя ИК-устройствами не должно превышать одного метра. В противном случае система будет работать нестабильно. Диаграмма направленности работы ИК-порта, которая указана в инструкции к нему, мягко говоря, не выдерживает никакой критики. Старайтесь разместить устройства прямо друг напротив друга. Посторонние предметы, помещенные между ИК-портом и рабочим устройством, не будут способствовать лучшей работе. Были случаи, когда сотовый телефон в чехле пытались подключить через ИК-порт к компьютеру. Ничего не получалось, пока не снимали полупрозрачный чехол.

Подключение

Подключить ИК-порт к персональному компьютеру достаточно просто. Но в любом случае рекомендуется потратить десять минут на внимательное изучение инструкции к устройству. Даже если вы ничего нового не узнаете из нее, во время инсталляции будете чувствовать себя уверенно.

Аппаратная часть
Подключите ИК-порт к разъему COM-порта. Запомните номер COM-порта — это пригодиться вам в дальнейшем. При подключении ИК-порта к IrDA-разъему материнской платы раскрутите корпус вашего системного блока и, ознакомившись с описанием вашей материнской платы, вставьте в нужное гнездо коннектор (четырех-пинная линейка). Первый провод помечен на плате цифрой 1 или указан в описании материнской платы. Первый провод коннектора ИК-порта имеет цветовую метку. Выведите заднюю заглушку на свободное место и можете собирать корпус. Подсоедините коннектор гибкого провода с ИК-приемником/передатчиком к разъему на заглушке. Гнездо и коннектор очень похожи на PS/2-разъем.

Программная часть
Здесь приведено описание настройки программного обеспечения для операционной системы MS Windows 98. Для остальных операционных систем от Microsoft оно аналогичное. Подключать ИК-порт к компьютерам с другими операционными системами возможно, но в описании ИК-порта указано: «Предназначен для работы с операционными системами Windows 95 и выше». Поэкспериментируйте, может быть у вас все получиться.

При установке ИК-порта на COM вас ждет счастливое плавание. В комплекте к устройству идет CD-диск, установить драйвера с которого не составит никаких трудностей. Правильно установите номер порта, к которому подключен ИК-порт. Посмотрите, не занят ли COM-порт другим устройством, например, внутренним модемом. Также проверьте установки BIOS для параллельного порта — он должен быть установлен в режим ECP, а не в Normal или SPP (значение по умолчанию).

При установке внутреннего ИК-порта стоит сделать несколько больше манипуляций руками. Прежде всего, войдите в BIOS и включите второй COM-порт. Как правило, ниже находится опция по включению IrDA. Активизируйте ее. Далее установите полудуплексную связь. Если ваш BIOS содержит другие настройки, то поставьте их в режим «по умолчанию». Будут проблемы — читайте инструкцию и экспериментируйте с настройками. Вреда или физической порчи вашему компьютеру вы не сможете принести.

Загрузите операционную систему. Если вы сделали все правильно, то новое устройство само будет обнаружено системой. Далее вам предложат выбрать тип устройства. Для надежности сделайте это вручную. Выберите «ИК-УСТРОЙСТВА», а затем стандартный тип устройства. Установите виртуальный порт и запомните его номер. Он будет нужен вам для конфигурирования большинства программ. Меню «Свойства: Система» обретет еще один пункт — «Устройства ИК-связи».

Диалоговое окно Свойства: Система

Перегрузите машину.
После этого в правом нижнем углу появится значок в виде мигающей лампочки.
Открыв его, вы увидите свойства ИК-связи.

Диалоговое окно Свойства: ИК-связь: Режимы

Среди всех настроек стоит выделить только «Режимы». Здесь вы сможете включить ИК-связь и установить время, через которое ИК-порт будет искать ИК-устройства в прямой зоне видимости. Параметр «Ограничение скорости обмена до:» можно отключить.

Диалоговое окно Свойства: ИК-связь: Состояние

Теперь, если поместите в зону видимости вашего ИК-порта другое активизированное ИК-устройство, то услышите звук и увидите на экране подобное этому:

Диалоговое окно Свойства: ИК-связь: Состояние. Обнаружено внешнее устройство ИК-связи.

Все, ваш ИК-порт полностью настроен, теперь вы можете пользоваться им. Например, переслать картинку с телефона на компьютер. Дальше предлагаем вам посмотреть на самое модное и популярное применение устройства ИК-порт в связке с мобильным телефоном — Мобильный Интернет.

Диалоговое окно Свойства: ИК-связь: Состояние. Осуществляется обмен данными по ИК-связи.

Мобильный Интернет

Большинство операторов сотовой сети, работающих в стандарте GSM-900/1800, предлагают такую услугу как «Мобильный Интернет». Что это такое? При помощи сотового телефона, оборудованного ИК-приемником/передатчиком и модемом, вы можете входить во Всемирную паутину и пользоваться ей как при обыкновенном dial-up-соединении. Плюсы подобного входа в сеть очевидны. Прежде всего, вы отвязываете себя от надоевших телефонных проводов и становитесь мобильным (если вы используете ноутбук). Но сеть через мобильник имеет свои минусы. Рекомендуем заранее узнать, во сколько (в денежном эквиваленте) выльется вам такое развлечение. Второй минус заключается в скорости мобильного Интернета. Она составляет 9600 bps и не больше. С введением в эксплуатацию новых технологий эта цифра может скоро увеличиться. Настройка мобильного Интернета не занимает много времени. Вот порядок ваших действий. Убедитесь, что ваш сотовый телефон оборудован ИК-портом и модемом. Включите на мобильнике ИК-порт. После этого поместите его в зону действия подключенного к компьютеру ИК-порта (около 1 м).

Теперь надо настроить работу встроенного в телефон модема. Для это необходимо войти в меню «Настройка», далее «Модем» и вручную установить «стандартный модем 19200» (если у вас есть специальный драйвер для вашего сотового модема, то поставьте его). При инсталляции не забудьте указать правильный виртуальный порт, который был создан при подключении ИК-порта к вашему компьютеру. Все, настройка модема закончена. Перегрузите систему. Для установки соединения нужно создать «Новое соединение» (параметры для него вы можете узнать у вашего сотового оператора). Интернет через сотовый телефон в вашем распоряжении. Мобильный Интернет — это достаточно важное и интересное дополнение к вашему компьютеру.

Вместо заключения

ИК-связь компьютера с другими устройствами действует на сравнительно небольшом расстоянии. Однако ее возможности широко используются среди мобильной техники. Скорее всего, в ближайшем будущем связь на ИК-лучах уступит свое место более совершенным видам связи (например, Bluetooth — несколько десятков метров). Но пока никто из производителей материнских плат не отказался от IrDA, и вы можете со спокойной душой покупать ИК-порт. Хотя, прежде чем сделать покупку, убедитесь, что ваш телефон и компьютер могут передавать данные в инфракрасном диапазоне. Надеемся, что вы, ознакомившись с этой статьей, без особых проблем сможете выбрать и включить ИК-порт.

Частично использованы материалы www.iceinet.ru


Инфракрасный порт для компьютера(для подключения к материнке)

Берем один из специализированных ИК-трансиверов (приемопередатчиков) и распаиваем его в соответствии с типовой схемой включения, приведенной в спецификации. Подобные микросхемы производят многие известные зарубежные компании. Возможно, на своем рынке вы найдете другие ИК приемопередатчики - это не принципиально, главное - знать распайку. Вот список известных мне трансиверов:
MAX 3120 - MAXIM
HSDL3600 - Helwett Packard
TFDS6500E - Vishay Telefunken

Мне подвернулась HSDL 1001 - немного устаревший трансивер со скоростью передачи данных до 115 Кбит/с. Это немного - в ноутбуках, как правило, до 4 Мбит/с. Типовая схема включения. У меня она работает с резистором 11 Ом. Рекомендуется подпаивать конденсаторы как можно ближе к чипу. Для размещения деталей использовал кусочек стеклотекстолита, опять же переводными картинками нарисовал дорожки и вытравил плату. Импортный текстолит 1мм. Детали подпаял со стороны печати, предусмотрел контактные площадки для подпайки проводов. Всю разводку прекрасно видно сквозь текстолит. Справа - железный фиксатор из комплекта разъема для COM-порта.

Инфракрасный порт для компьютера на спецмикросхеме

Инфракрасный порт для компьютера на спецмикросхеме Инфракрасный порт для компьютера на спецмикросхеме

Использовал экранированный провод длиной около метра. Плату поместил в обрезанный копрус разъема для СОМ-порта. Справа - разьем для motherboard, это фрагмент обычного IDE разъема. Подключал схему к материнской плате ASUS P2B, предварительно включив в BIOS поддержку инфракрасного порта. (Chipset Features Setup->>UART2 Use Infrared ->> Enabled). Правда, пришлось свой внутренний модем перенести на COM3, иначе он конфликтовал с IrDA. Если все сделано правильно, то при загрузке Win9X сразу же найдет ИК-устройство и сама установит драйвера для него.

Инфракрасный порт для компьютера на спецмикросхеме

Win9X как правило ставят ИК-порт на СОМ4, что и следует указывать при настройке программ. WinME тоже ставит на СОМ4, но это не афиширует :-). Устанавливать IrDA на WinNT Win2K я пока не пробовал. Думаю, что подобную конструкцию можно заставить работать на многих материнских платах, нужно только узнать распиновку разъема на плате. Сделать это можно с помощью бумажной инструкции на MB, либо посмотреть на сайте производителя. Хоть все разъемы MB ASUS имеют одинаковую распайку, мне так и не удалось заставить работать этот ИК-порт на чипсете LX97 - самый мерзкий и глючный чипсет, с которыми мне пришлось работать. Причем Win9X находила порт, но при попытке работать через него возникала ошибка. На других платах все было отлично.

Подробно о работе в статье "Инфракрасный порт и работа с ним"

Дмитрий


Инфракрасный порт для компьютера(для подключения к материнке)

Связь на ик лучах

Всё предельно просто и понятно. Я применял для связи своего компьтера и ноутбука, чтобы не мучаться с проводами. Хотя также "выглядит" как нуль-модемная связь. Если подключить эту схему к разьёму на материнской плате вашего компьютера, то Windows9x без проблем её найдёт и установит.

Подробно о работе в статье "Инфракрасный порт и работа с ним"


Подключение к компьютеру пульта ДУ

Подключение к компьютеру пульта ДУ

Тенденции развития компьютеров предполагают их интеграцию с домашней аудио-видео техникой. При этом компьютер остается лишенным такого замечательного устройства ввода информации, каковым является пульт ДУ. Предлагаемый вариант решения этой проблемы подкупает своей гибкостью и дешевизной.

Подключение к компьютеру пульта ДУ

Диоды - 1N4148
резистор - 1.2 кОм
конденсатор - 10 мкФ
78L05 аналог КРЕН5A

IR-Receiver TK1833
IR-Receiver TK1833 выпуклостью к себе, слева-направо: DCD (сигнал), GND (общий), RTS (питание +)

Фотоприемник (ФП) представляет собой сборку: собственно ФП и усилитель. Бывают они 12 и 5 вольтовые. Вам нужен 5и вольтовый, 12 даже лучше, но тогда надо схемку переделать. У него три ноги, две - питание, одна сигнал. Не забудьте поинтересоваться какие где - спалить можно. Я купил его на "Караваевых дачах" в Киеве у ребят, торгующих импортными запчастями. Думаю, можно поспрашивать в ремонте аудио-видео и магазинах запчастей. Главный критерий - питание 5В. Новый стоит в зависимости от модели до доллара. Схемка подключается к COM порту. Еще вам понадобится пульт. Я не рекомендовал бы использовать ЭЛЕКТРОНовские. По слухам у них очень высокие частоты работы, хотя я не проверял. Самым удачным оказался SONY - короткие часто повторяющиеся пакеты. PHILIPS - хуже, хотя тоже работает. Единственный пульт, с которым мне не удалось разобраться, был от кондиционера TOSHIBA. Софт можно все написать самому, тут нет ничего сложного. Но зачем изобретать велосипед? Программка получившаяся у меня отлажена, проверена и готова к работе. Она позволяет производить практически любые манипуляции с приложениями: открывать, закрывать, эмулировать нажатия клавиш, щелчки мышки. Реализована возможность выполнения последовательности действий по нажатию одной кнопки пульта, при чем эта последовательность зависит от очередности нажатия. Кроме этого можно выключать компьютер, манипулировать громкостью. Все настройки вынесены в INI файл стандартного формата. Программка активно эксплуатируется с марта 2001 года. Программка написана на VC++ №6 и пользуется библиотеками MFC. Вы можете скачать полноценный Setup (950 kB) Настройки в INI файле для пульта от музыкального центра SONY. Если у вас другой пульт, то перед началом работы вам придется настроить программку.

Здесь можно выбрать прграммы


Последовательный асинхронный адаптер (COM порт)

Основные понятия и термины

Практически каждый компьютер оборудован хотя бы одним последовательным асинхронным адаптером. Обычно он представляет собой отдельную плату или же расположен прямо на материнской плате компьютера. Его называют еще асинхронным адаптером RS-232-C, или портом RS-232-C. Каждый асинхронный адаптер обычно содержит несколько портов RS-232-C, через которые к компьютеру можно подключать внешние устройства. Каждому такому порту соответствует несколько регистров, через которые программа получает к нему доступ, и определенная линия IRQ для сигнализирования компьютеру об изменении состояния порта. При выполнении BIOS процедуры начальной загрузки каждому порту RS-232-C присваивается логическое имя COM1 - COM4 (COM-порт номер 1 - 4).

Интерфейс RS-232-C разработан ассоциацией электронной промышленности (Electronic Industries Association - EIA) как стандарт для соединения компьютеров и различных последовательных периферийных устройств. Компьютер IBM PC поддерживает интерфейс RS-232-C не в полной мере скорее разъем, обозначенный на корпусе компьютера как порт последовательной передачи данных, содержит некоторые из сигналов, входящих в интерфейс RS-232-C и имеющих соответствующие этому стандарту уровни напряжения. В настоящее время порт последовательной передачи данных используется очень широко. Вот далеко не полный список применений:

  • подключение мыши;
  • подключение графопостроителей (плоттеров), сканеров, принтеров, дигитайзеров;
  • связь двух компьютеров через порты последовательной передачи данных;
  • подключение модемов для передачи данных по телефонным линиям;
  • подключение к сети персональных компьютеров.

Основные понятия и термины

Последовательная передача данных означает, что данные передаются по единственной линии. При этом биты байта данных передаются по очереди с использованием одного провода. Для синхронизации группе битов данных обычно предшествует специальный стартовый бит, после группы битов следуют бит проверки на четность и один или два стоповых бита. Иногда бит проверки на четность может отсутствовать. Сказанное иллюстрируется следующим рисунком:

Последовательный асинхронный адаптер - COM порт

Из рисунка видно, что исходное состояние линии последовательной передачи данных - уровень логической 1. Это состояние линии называют отмеченным - MARK. Когда начинается передача данных, уровень линии переходит в 0. Это состояние линии называют пустым - SPACE. Если линия находится в таком состоянии больше определенного времени, считается, что линия перешла в состояние разрыва связи - BREAK. Стартовый бит START сигнализирует о начале передачи данных. Далее передаются биты данных, вначале младшие, затем старшие.

Если используется бит четности P, то передается и он. Бит четности имеет такое значение, чтобы в пакете битов общее количество единиц (или нулей) было четно или нечетно, в зависимости от установки регистров порта. Этот бит служит для обнаружения ошибок, которые могут возникнуть при передаче данных из-за помех на линии. Приемное устройство заново вычисляет четность данных и сравнивает результат с принятым битом четности. Если четность не совпала, то считается, что данные переданы с ошибкой. Конечно, такой алгоритм не дает стопроцентной гарантии обнаружения ошибок. Так, если при передаче данных изменилось четное число битов, то четность сохраняется и ошибка не будет обнаружена. Поэтому на практике применяют более сложные методы обнаружения ошибок.

В самом конце передаются один или два стоповых бита STOP, завершающих передачу байта. Затем до прихода следующего стартового бита линия снова переходит в состояние MARK. Использование бита четности, стартовых и стоповых битов определяют формат передачи данных. Очевидно, что передатчик и приемник должны использовать один и тот же формат данных, иначе обмен будет невозможен. Другая важная характеристика - скорость передачи данных. Она также должна быть одинаковой для передатчика и приемника.

Скорость передачи данных обычно измеряется в бодах (по фамилии французского изобретателя телеграфного аппарата Emile Baudot - Э. Бодо). Боды определяют количество передаваемых битов в секунду. При этом учитываются и старт/стопные биты, а также бит четности. Иногда используется другой термин - биты в секунду (bps). Здесь имеется в виду эффективная скорость передачи данных, без учета служебных битов.

Аппаратная реализация

Компьютер может быть оснащен одним или двумя портами последовательной передачи данных. Эти порты расположены либо на материнской плате, либо на отдельной плате, вставляемой в слоты расширения материнской платы. Бывают также платы, содержащие четыре или восемь портов последовательной передачи данных. Их часто используют для подключения нескольких компьютеров или терминалов к одному, центральному компьютеру. Эти платы имеют название "мультипорт".

В основе последовательного порта передачи данных лежит микросхема Intel 8250 или ее современные аналоги - Intel 16450, 16550, 16550A. Эта микросхема является универсальным асинхронным приемопередатчиком (UART - Universal Asynchronous Receiver Transmitter). Микросхема содержит несколько внутренних регистров, доступных через команды ввода/вывода. Микросхема 8250 содержит регистры передатчика и приемника данных. При передаче байта он записывается в буферный регистр передатчика, откуда затем переписывается в сдвиговый регистр передатчика. Байт "выдвигается" из сдвигового регистра по битам. Аналогично имеются сдвиговый и буферный регистры приемника.

Программа имеет доступ только к буферным регистрам, копирование информации в сдвиговые регистры и процесс сдвига выполняется микросхемой UART автоматически. Регистры, управляющие асинхронным последовательным портом, будут описаны в следующей главе. К внешним устройствам асинхронный последовательный порт подключается через специальный разъем. Существует два стандарта на разъемы интерфейса RS-232-C, это DB25 и DB9. Первый разъем имеет 25, а второй 9 выводов. Приведем разводку разъема последовательной передачи данных DB25:

Номер контакта | Назначение контакта | Вход или выход компьютера
1 | Защитное заземление(Frame Ground, FG) | -
2 | Передаваемые данные(Transmitted Data, TD) | Выход
3 | Принимаемые данные(Received Data, RD) | Вход
4 | Запрос для передачи(Request to send, RTS) | Выход
5 | Сброс для передачи(Clear to Send, CTS) | Вход
6 | Готовность данных(Data Set Ready, DSR) | Вход
7 | Сигнальное заземление(Signal Ground, SG) | -
8 | Детектор принимаемого с линии сигнала(Data Carrier Detect, DCD) | Вход
9-19 | Не используются | -
20 | Готовность выходных данных(Data Terminal Ready, DTR) | Выход
21 | Не используется | -
22 | Индикатор вызова(Ring Indicator, RI) | Вход
23-25 | Не используются | -

Наряду с 25-контактным разъемом часто используется 9-контактный разъем:

Номер контакта | Назначение контакта | Вход или выход
1 | Детектор принимаемого с линии сигнала(Data Carrier Detect, DCD) | Вход
2 | Принимаемые данные(Received Data, RD) | Вход
3 | Передаваемые данные(Transmitted Data, TD) | Выход
4 | Готовность выходных данных(Data Terminal Ready, DTR) | Выход
5 | Сигнальное заземление(Signal Ground, SG) | -
6 | Готовность данных(Data Set Ready, DSR) | Вход
7 | Запрос для передачи(Request to send, RTS) | Выход
8 | Сброс для передачи(Clear to Send, CTS) | Вход
9 | Индикатор вызова(Ring Indicator, RI) | Вход

Только два вывода этих разъемов используются для передачи и приема данных. Остальные передают различные вспомогательные и управляющие сигналы. На практике для подсоединения того или иного устройства может понадобиться различное количество сигналов. Интерфейс RS-232-C определяет обмен между устройствами двух типов: DTE (Data Terminal Equipment - терминальное устройство) и DCE (Data Communication Equipment - устройство связи). В большинстве случаев, но не всегда, компьютер является терминальным устройством. Модемы, принтеры, графопостроители всегда являются устройствами связи. Рассмотрим теперь сигналы интерфейса RS-232-C более подробно.

Сигналы интерфейса RS-232-C

Здесь мы рассмотрим порядок взаимодействия компьютера и модема, а также двух компьютеров непосредственно соединенных друг с другом. Сначала посмотрим, как происходит соединение компьютера с модемом. Входы TD и RD используются устройствами DTE и DCE по-разному. Устройство DTE использует вход TD для передачи данных, а вход RD для приема данных. И наоборот, устройство DCE использует вход TD для приема, а вход RD для передачи данных. Поэтому для соединения терминального устройства и устройства связи выводы их разъемов необходимо соединить напрямую:

Последовательный асинхронный адаптер - COM порт

Остальные линии при соединении компьютера и модема также должны быть соединены следующим образом:

Последовательный асинхронный адаптер - COM порт

Рассмотрим процесс подтверждения связи между компьютером и модемом. В начале сеанса связи компьютер должен удостовериться, что модем может произвести вызов (находится в рабочем состоянии). Затем, после вызова абонента, модем должен сообщить компьютеру, что он произвел соединение с удаленной системой. Подробнее это происходит следующим образом. Компьютер подает сигнал по линии DTR, чтобы показать модему, что он готов к проведению сеанса связи. В ответ модем подает сигнал по линии DSR. Когда модем произвел соединение с другим, удаленным модемом, он подает сигнал по линии DCD, чтобы сообщить об этом компьютеру. Если напряжение на линии DTR падает, это сообщает модему, что компьютер не может далее продолжать сеанс связи, например из-за того что выключено питание компьютера. В этом случае модем прервет связь. Если напряжение на линии DCD падает, это сообщает компьютеру, что модем потерял связь и не может больше продолжать соединение. В обоих случаях эти сигналы дают ответ на наличие связи между модемом и компьютером.

Сейчас мы рассмотрели самый низкий уровень управлением связи - подтверждение связи. Существует более высокий уровень, который используется для управления скоростью обмена данными, но он также реализуется аппаратно. Практически управление скоростью обмена данными (управление потоком) необходимо, если производится передача больших объемов данных с высокой скоростью. Когда одна система пытается передать данные с большей скоростью, чем они могут быть обработаны принимающей сиситемой, результатом может стать потеря части передаваемых данных. Чтобы предотвратить передачу большего числа данных, чем то, которое может быть обработано, используют управление связью, называемое "управление потоком" (flow-controll handshake). Стандарт RS-232-C определяет возможность управления потоком только для полудуплексного соединения. Полудуплексным называется соединение, при котором в каждый момент времени данные могут передаваться только в одну сторону. Однако фактически этот механизм используется и для дуплексных соединений, когда данные передаются по линии связи одновременно в двух направлениях.

Управление потоком

В полудуплексных соединениях устройство DTE подает сигнал RTS, когда оно желает передать данные. DCE отвечает сигналом по линии CTS, когда оно готово, и DTE начинает передачу данных. До тех пор, пока оба сигнала RTS и CTS не примут активное состояние, только DCE может передавать данные. При дуплексных соединениях сигналы RTS/CTS имеют противоположные значения по сравнению с теми, которые они имели для полудуплексных соединений. Когда DTE может принять данные, он подает сигнал по линии RTS. Если при этом DCE готово для принятия данных, оно возвращает сигнал CTS. Если напряжение на линиях RTS или CTS падает, то это сообщает передающей системе, что получающая система не готова для приема данных. Ниже мы приводим отрывок диалога между компьютером и модемом, происходящий при обмене данными.

Последовательный асинхронный адаптер - COM порт

Конечно, все это хорошо звучит. На практике все не так просто. Соединить компьютер и модем не составляет труда, так как интерфейс RS-232-C как раз для этого и предназначен. Но если вы захотите связать вместе два компьютера при помощи такого же кабеля, который вы использовали для связи модема и компьютера, то у вас возникнут проблемы. Для соединения двух терминальных устройств - двух компьютеров - как минимум необходимо перекрестное соединение линий TR и RD:

Последовательный асинхронный адаптер - COM порт

Однако в большинстве случаев этого недостаточно, так как для устройств DTE и DCE функции, выполняемые линиями DSR, DTR, DCD, CTS и RTS, асимметричны. Устройство DTE подает сигнал DTR и ожидает получения сигналов DSR и DCD. В свою очередь, устройство DCE подает сигналы DSR, DCD и ожидает получения сигнала DTR. Таким образом, если вы соедините вместе два устройства DTE кабелем, который вы использавали для соединения устройств DTE и DCE, то они не смогут договориться друг с другом. Не выполнится процесс подтверждения связи.

Теперь перейдем к сигналам RTS и CTS, управления потоком данных. Иногда для соединения двух устройств DTE эти линии соединяют вместе на каждом конце кабеля. В результате получаем то, что другое устройство всегда готово для получения данных. Поэтому, если при большой скорости передачи принимающее устройство не успевает приинимать и обрабатывать данные, возможна потеря данных. Чтобы решить все эти проблемы для соединеия двух устройств типа DTE используется специальный кабель, в обиходе называемый нуль-модемом. Имея два разъема и кабель, вы легко можете спаять его самостоятельно, руководствуясь следующими схемами.

Последовательный асинхронный адаптер - COM порт

Для полноты картины рассмотрим еще один аспект, связанный с механическим соединением портов RS-232-C. Из-за наличия двух типов разъемов - DB25 и DB9 - часто бывают нужны переходники с одного типа разъемов на другой. Например, вы можете использовать такой переходник для соединения COM-порта компьютера и кабеля нуль-модема, если на компьютере установлен разъем DB25, а кабель оканчивается разъемами DB9. Схему такого переходника мы приводим на следующем рисунке:

Последовательный асинхронный адаптер - COM порт

Заметим, что многие устройства (такие, как терминалы и модемы) позволяют управлять состоянием отдельных линий RS-232-C посредством внутренних переключателей (DIP-switches). Эти переключатели могут менять свое значение на разных моделях модемов. Поэтому для их использования следует изучить документацию модема. Например, для hayes-совместимых модемов, если переключатель 1 находится в положении "выключен" (down), это означает, что модем не будет проверять наличие сигнала DTR. В результате модем может отвечать на приходящие звонки, даже если компьютер и не запрашивает у модема установление связи.

Технические параметры интерфейса RS-232-C

При передаче данных на большие расстояния без использования специальной аппаратуры из-за помех, наводимых электромагнитными полями, возможно возникновение ошибок. Вследствие этого накладываются ограничения на длину соединительного кабеля между устройствами DTR-DTR и DTR-DCE. Официальное ограничение по длине для соединительного кабеля по стандарту RS-232-C составляет 15,24 метра. Однако на практике это расстояние может быть значительно больше. Оно непосредственно зависит от скорости передачи данных. Согласно McNamara (Technical Aspects of Data Communications, Digital Press, 1982) определены следующие значения:

Скорость передачи, бодах | Максимальная длина для экранированного кабеля, м | Максимальная длина для неэкранированного кабеля, м
110 | 1524,0 | 914,4
300 | 1524,0 | 914,4
1200 | 914,4 | 914,4
2400 | 304,8 | 152,4
4800 | 304,8 | 76,2
9600 | 76,2 | 76,2

Уровни напряжения на линиях разъема составляют для логического нуля -15..-3 вольта, для логической единицы - +3..+15 вольт. Промежуток от -3 до +3 вольт соответствует неопределенному значению. Если вы подключаете внешние устройства к разъему интерфейса RS-232-C (а также при соединении двух компьютеров нуль-модемом), предварительно выключите его и компьютер, а также снимите статический заряд (подсоединив заземление). В противном случае можно вывести из строя асинхронный адаптер. Земля компьютера и земля внешнего устройства должны быть соединены вместе.


Стратегии развязки для PCB

Хорошие способы развязки позволяют сократить количество развязывающих конденсаторов.
Главным является правильный выбор конденсаторов и грамотная разводка.

1. ТОКИ ПЕРЕКЛЮЧЕНИЯ ЛОГИЧЕСКИХ КОМПОНЕНТОВ

Не секрет, что при смене логических состояний у большинства цифровых устройств возникает большой бросок тока, который следует сразу за фронтом тактового сигнала (рис. 1).

Например, схеме, работающей на частоте 100 МГц и потребляющей в среднем около 4 А, реально может потребоваться 20 А тока в течение первых нескольких наносекунд тактовой последовательности. (Причина возникновения больших токов при смене логических состояний рассмотрена в статье Б. Картера "Техника разводки печатных плат" - прим. переводчика.)

Очевидно, что питание этой схемы от 20-амперного источника увеличит размеры и стоимость изделия. Менее очевидно, что паразитные последовательные индуктивности соединительных проводов, проводников печатной платы и выводов компонентов могут сделать невозможным быструю ответную реакцию мощного источника питания на мгновенные изменения тока. С другой стороны, недостаточная нагрузочная способность источника будет приводить к возникновению нестабильных падений напряжений на шинах питания и земли. Это явление обычно проявляется как высокочастотный шум.

2. ПРИМЕНЕНИЕ КОНДЕНСАТОРОВ
В КАЧЕСТВЕ ЭЛЕМЕНТОВ РАЗВЯЗКИ ПИТАНИЯ

Применение развязывающих конденсаторов позволяет распределить рабочий ток между потребителями, используя низкоимпедансные (т.е. низкоиндуктивные для токов ВЧ) пути прохождения тока. Практически это означает, что развязывающие конденсаторы непосредственно обслуживают цифровые компоненты, в то время как источник питания занимается их перезарядом. Ключом к созданию работоспособной и удачной схемы развязки является правильный выбор применяемых конденсаторов и правильная разводка цепей их подключения.

Использование конденсаторов в качестве элементов развязки требует понимания основ их работы. На рисунке 2а показан идеальный конденсатор - емкость для накопления и хранения заряда и для освобождения от него. На рисунке 3 приведена частотная зависимость импеданса идеального конденсатора - монотонное уменьшение значения при увеличении частоты. Поскольку основной шум цифровых систем является высокочастотным шумом (>50 МГц), уменьшение импеданса на высоких частотах хорошо соответствует задаче развязки цепей питания.

К сожалению, поведение реального конденсатора не такое простое; его модель показана на рисунке 2б. Физическое устройство реального конденсатора включает в себя эквивалентное последовательное сопротивление (ESR) и эквивалентную последовательную индуктивность (ESL). К тому же, реальный конденсатор обладает сопротивлением утечки. Сумма этих паразитных эффектов приводит к изменению характера частотной зависимости импеданса (рис. 3).

Низшая точка импедансной зависимости известна как частота собственного резонанса. Разработчики часто пытаются подобрать конденсаторы с собственной резонансной частотой, находящейся близко от рабочей частоты системы. Однако, параметры реальных конденсаторов делают этот подбор нецелесообразным при тактовой частоте, превышающей 100 МГц. Важное правило, которое следует помнить: развязывающие конденсаторы допустимо использовать на частотах более низких, чем частота их собственного резонанса, до тех пор, пока их импеданс на этих частотах остается достаточно низким.

Падение напряжения на эквивалентном последовательном сопротивлении конденсатора пропорционально протекающему через него току. Поскольку важным является поддержание питающего напряжения стабильным, желательным является использование в цепях развязки конденсаторов с малым ESR (т.е. с меньшим, чем 200 мОм). Эквивалентная последовательная индуктивность определяет скорость реагирования конденсатора на изменения тока - конденсаторы с более низким значением ESL будут реагировать более быстро на изменения протекающего тока, что очень важно для цепей высокочастотной развязки. Несмотря на то, что, как параметр, ESR более широко описан и изучен, ESL, наверное, более важен. Все конденсаторы для поверхностного монтажа, приведенные в таблице 1, обладают достаточно низкими значениями ESL.

Типоразмер | ESL min (нГн) | ESL max (нГн)
0402 | 0,54 | 1,90
0603 | 0,54 | 1,95
0805 | 0,70 | 1,94
1206 | 1,37 | 2,26
1210 | 0,61 | 1,55
1812 | 0,91 | 2,25
с радиальными выводами | 6,0 | 15,0
с осевыми выводами | 12,0 | 20,0

Конденсаторы с материалом I типа в качестве диэлектрика не ухудшают свои характеристики от времени и воздействия температуры, но малое значение диэлектрической постоянной делает их использование в качестве компонентов развязки неэффективным. Конденсаторы с материалом II типа (т.е. X7R) являются более лучшим выбором из-за хорошей долговременной стабильности (10% потерь в течение 10 лет), температурных характеристик и высокого значения диэлектрической постоянной. Материал III типа обладает наивысшим значением диэлектрической постоянной и плохими температурными показателями (от 50 до 75% потерь при работе на предельных температурах) и плохой долговременной стабильностью (20% потерь в течение 10 лет). Среди популярных диэлектриков многослойная керамика и синтетика обладают небольшими эквивалентными последовательными индуктивностью и сопротивлением. Керамические конденсаторы более легко доставаемы. Танталовые конденсаторы часто используются как общие элементы развязки по низкой частоте, однако они не подходят для локальной развязки.

В таблице 1 показаны типичные значения ESL для различных типов корпусов конденсаторов. Типоразмер является определяющим элементом эквивалентной последовательной индуктивности - обычно конденсатор меньшего размера обладает меньшим значением ESL при таком же значении емкости. Конденсаторы с большими значениями ESL не годятся для использования в качестве элементов развязки.

В общем случае, правильной стратегией является поиск конденсатора с наибольшей емкостью при наименьших габаритных размерах (это верно лишь с точки зрения ESL, но не всегда правильно с точки зрения другого важнейшего параметра конденсаторов - диэлектрической абсорбции - прим. переводчика). Однако при таком выборе необходимо быть внимательным. Высота корпуса конденсатора в достаточно значительной мере оказывает влияние на ESL. Для перекрывающихся диапазонов ESL в таблице 1 возможен выбор корпуса с меньшим посадочным местом на печатной плате. Однако значение ESL может оказаться большим. Поэтому при выборе типа конденсатора необходимо руководствоваться параметрами производителя для определения лучшего компромиссного варианта.

3. ИНДУКТИВНОСТЬ ПРОВОДНИКА

При разводке компонентов и цепей основным препятствием хорошей развязки является индуктивность. С весьма грубыми приближениями можно считать, что индуктивность трассы с волновым сопротивлением 50 Ом на материале FR-4 будет составлять около 9 пГн на каждые 0,025 мм длины. Индуктивность одиночного переходного отверстия примерно равняется 500 пГн и зависит от геометрической конфигурации.

Индуктивность пропорциональна длине, поэтому важно минимизировать длину проводника между выводами компонента и развязывающего конденсатора. Индуктивность обратно пропорциональна ширине трассы, поэтому широкие проводники более предпочтительны, чем узкие.

Помните, что путь тока всегда представляет собой петлю, и эта петля должна быть минимизирована. Уменьшение расстояния между выводом питания компонента и выводом конденсатора может и не уменьшить общую индуктивность. Как правильно расположить конденсатор? Ближе к выводу питания компонента? Или ближе к выводу земли? Или посередине между этими выводами? Некоторые источники рекомендуют располагать конденсатор вблизи от вывода, наиболее удаленного от полигона питания или земли.

4. ВАРИАНТЫ РАЗВОДКИ КОНДЕНСАТОРОВ РАЗВЯЗКИ

Хорошая разводка чрезвычайно важна для эффективной работы цепей развязки. Как видно из таблицы 1, конденсаторы со значением эффективной последовательной индуктивности менее 1 нГн вполне доступны. Добавление всего лишь 2 нГн утроит значение ESL конденсатора. Рисунок 4 демонстрирует изменение частоты собственного резонанса и увеличение интегрального реактивного сопротивления при добавлении индуктивности проводника в 2 нГн к собственной индуктивности (0,8 нГн) конденсатора емкостью 4,7 нФ.

На рисунке 5 показано несколько методов размещения и подключения конденсатора развязки. Для упрощения на схемах показаны лишь выводы конденсатора и вывод питания активного компонента. Соединению между выводом конденсатора и общим выводом питания компонента также должно быть уделено значительное внимание.

На рисунке 5A показана наиболее часто встречающаяся конфигурация разводки. Вывод питания компонента подключен коротким проводником к шине питания во внутреннем слое через переходное отверстие. Конденсатор развязки, расположенный на другой стороне платы, подключен к этому же переходному отверстию. Несмотря на то, что такой подход часто обусловливается простотой разводки, он позволяет эффективно работать цепям развязки и экономит пространство разводки. Два одиночных отверстия добавят в цепь развязки около 1 нГн паразитной индуктивности.

Если конденсатор расположен на расстоянии 50 мил (1,27 мм) от вывода компонента, то добавляемая индуктивность в лучшем случае составит около 0,9 нГн. При более удаленном размещении конденсатора от активного компонента проводники будут более длинными, а паразитная индуктиность будет иметь большее значение.

Вариант B представляет собой значительное улучшение варианта A с размещением конденсатора развязки и активного компонента на одной стороне печатной платы. Конденсатор подключен после паразитной индуктивности переходного отверстия. При достаточно коротких проводниках схема развязки вносит дополнительно менее 1 нГн паразитной индуктивности.

Вариант D представляет собой развитие варианта A - для уменьшения собственной индуктивности и увеличения распределенной емкости проводники сделаны шире, что также улучшает характеристики цепи развязки.

Вариант E - модификация варианта B с более широкими проводниками и более хорошими характеристиками.

На первый взгляд кажется, что вариант C совершенно не подходит для разводки цепей развязки, поскольку нет проводников, напрямую подключающих активный компонент к конденсатору развязки; фактически они оба подключены через отверстия к полигонам питания и земли, которые расположены во внутренних слоях. При четырех отверстиях к цепям развязки добавится минимум 2 нГн паразитной индуктивности. Однако, очень широкие проводники питания и земли практически не будут добавлять индуктивности при не очень большой длине. Такой вариант разводки пригоден, когда конденсатор развязки не может быть размещен достаточно близко к активному компоненту.

Вариант F - улучшение варианта C добавлением дополнительных параллельных отверстий. Такое добавление приводит к уменьшению паразитной индуктивности переходных отверстий в два раза, позволяет улучшить качественные характеристики схемы и должно использоваться всякий раз, когда позволяет место.

5. ПРИМЕНЕНИЕ СОСТАВНЫХ КОНДЕНСАТОРОВ

Поскольку емкости при параллельном соединении суммируются, а результирующая индуктивность уменьшается, то параллельное соединение двух небольших конденсаторов с одинаковыми значениями емкости может привести к качественному выигрышу, по сравнению с применением одного большого конденсатора. Конечным результатом будет такая же емкость развязки и меньшая паразитная эквивалентная последовательная индуктивность.

На практике обычно избегают использования конденсаторов с разными значениями емкостей для создания локальной развязки. Составные конденсаторы с разными емкостями обладают частотной зависимостью импеданса, складывающейся из частотных зависимостей импедансов отдельных конденсаторов. Пример показан на рисунке 6.

Конденсатор емкостью 47 нФ используется для развязки низких частот, а конденсатор емкостью 150 пФ - для высоких. На первый взгляд, можно предположить, что параллельное соединение этих конденсаторов позволит улучшить импедансную характеристику.

К сожалению, это не так. Такое соединение может породить существенные проблемы на частотах, находящихся между собственными резонансными частотами конденсаторов. На рисунке 7 видно, что комбинация двух конденсаторов создает антирезонансный пик (а, следовательно, повышенное сопротивление) на суммарной частотной характеристике.

Источник данной проблемы легко определяется при рассмотрении эквивалентной схемы, показанной на рисунке 8. Результатом соединения паразитных компонентов конденсаторов является классический резонансный контур.

Тем не менее, составные конденсаторы, используемые в качестве элементов развязки, достаточно широко используются в прецизионных схемах. В этом случае, к выбору конденсаторов необходимо подходить с большой тщательностью, моделируя схемы, включающие все паразитные компоненты.


Техника разводки печатных плат

ОБЩИЕ СООБРАЖЕНИЯ

Из-за существенных отличий аналоговой схемотехники от цифровой, аналоговая часть схемы должна быть отделена от остальной части, а при ее разводке должны соблюдаться особые методы и правила. Эффекты, возникающие из-за неидеальности характеристик печатных плат, становятся особенно заметными в высокочастотных аналоговых схемах, но погрешости общего вида, описанные в этой статье, могут оказывать воздействие на качественные характеристики устройств, работающих даже в звуковом диапазоне частот.

Намерением этой статьи является обсуждение распространенных ошибок, совершаемых разработчиками печатных плат, описание воздействия этих ошибок на качественные показатели и рекомендации по разрешению возникших проблем.

Печатная плата - компонент схемы

Лишь в редких случаях печатная плата аналоговой схемы может быть разведена так, чтобы вносимые ею воздействия не оказывали никакого влияния на работу схемы. В то же время, любое такое воздействие может быть минимизировано так, чтобы характеристики аналоговой схемы устройства были такими же, как и характеристики модели и прототипа.

Макетирование

Разработчики цифровых схем могут скорректировать небольшие ошибки на изготовленной плате, дополняя ее перемычками или, наоборот, удаляя лишние проводники, внося изменения в работу программируемых микросхем и т.п., переходя очень скоро к следующей разработке. Для аналоговой схемы дело обстоит не так. Некоторые из распространенных ошибок, обсуждаемых в этой статье, не могут быть исправлены дополнением перемычек или удалением лишних проводников. Они могут и будут приводить в нерабочее состояние печатную плату целиком.

Очень важно для разработчика цифровых схем, использующего такие способы исправления, прочесть и понять материал, изложенный в этой статье, заблаговременно, до передачи проекта в производство. Немного внимания, уделенного при разработке, и обсуждение возможных вариантов помогут не только предотвратить превращение печатной платы в утильсырье, но и уменьшить стоимость из-за грубых ошибок в небольшой аналоговой части схемы. Поиск ошибок и их исправление может привести к потерям сотен часов. Макетирование может сократить это время до одного дня или менее. Макетируйте все свои аналоговые схемы.

Источники шума и помех

Шум и помехи являются основнымм элементами, ограничивающими качественные характеристики схем. Помехи могут как излучаться источниками, так и наводиться на элементы схемы. Аналоговая схема часто располагается на печатной плате вместе с быстродействующими цифровыми компонентами, включая цифровые сигнал-процессоры (DSP).

Высокочастотные логические сигналы создают значительные радиочастотные помехи (RFI). Количество источников излучения шума огромно: ключевые источники питания цифровых систем, мобильные телефоны, радио и телевидение, источники питания ламп дневного света, персональные компьютеры, грозовые разряды и т.д. Даже если аналоговая схема работает в звуковом частотном диапазоне, радиочастотные помехи могут создавать заметный шум в выходном сигнале.

КАТЕГОРИИ ПЕЧАТНЫХ ПЛАТ

Выбор конструкции печатной платы является важным фактором, определяющим механические характеристики при использовании устройства в целом. Для изготовления печатных плат используются материалы различного уровня качества. Наиболее подходящим и удобным для разработчика будет, если изготовитель печатных плат находится неподалеку. В этом случае легко осуществить контроль удельного сопротивления и диэлектрической постоянной - основных параметров материала печатной платы. К сожалению, этого бывает недостаточно и часто необходимо знание других параметров, таких как воспламеняемость, высокотемпературная стабильность и коэффициент гигроскопичности. Эти параметры может знать только производитель компонентов, используемых при производстве печатных плат.

Слоистые материалы обозначаются индексами FR (flame resistant, сопротивляемость к воспламенению) и G. Материал с индексом FR-1 обладает наибольшей горючестью, а FR-5 - наименьшей. Материалы с индексами G10 и G11 обладают особыми характеристиками. Материалы печатных плат приведены в табл. 1.

Не используйте печатную плату категории FR-1. Есть много примеров использования печатных плат FR-1, на которых имеются повреждения от теплового воздействия мощных компонентов. Печатные платы этой категории более похожи на картон.

FR-4 часто используется при изготовлении промышленного оборудования, в то время, как FR-2 используется в производстве бытовой техники. Эти две категории стандартизованы в промышленности, а печатные платы FR-2 и FR-4 часто подходят для большинства приложений. Но иногда неидеальность характеристик этих категорий заставляет использовать другие материалы. Например, для очень высокочастотных приложений в качестве материала печатных плат используются фторопласт и даже керамика. Однако, чем экзотичнее материал печатной платы, тем выше может быть цена.

При выборе материала печатной платы обращайте особое внимание на его гигроскопичность, поскольку этот параметр може оказать сильный негативный эффект на желаемые характеристики платы - поверхностное сопротивление, утечки, высоковольтные изоляционные свойства (пробои и искрения) и механическая прочность. Также обращайте внимание на рабочую температуру. Участки с высокой температурой могут встречаться в неожиданных местах, например, рядом с большими цифровыми интегральными схемами, переключения которых происходят на высокой частоте. Если такие участки расположены непосредственно под аналоговыми компонентами, повышение температуры может сказаться на изменении характеристик аналоговой схемы.

Таблица 1

Категория | Компоненты, комментарии
FR-1 | бумага, фенольная композиция: прессование и штамповка при комнатной температуре, высокий коэффициент гигроскопичности
FR-2 | бумага, фенольная композиция: применимый для односторонних печатных плат бытовой техники, невысокий коэффициент гигроскопичности
FR-3 | бумага, эпоксидная композиция: разработки с хорошими механическими и электрическими характеристиками
FR-4 | стеклоткань, эпоксидная композиция: прекрасные механические и электрические свойства
FR-5 | стеклоткань, эпоксидная композиция: высокая прочность при повышенных температурах, отсутствие воспламенения
G10 | стеклоткань, эпоксидная композиция: высокие изоляционные свойства, наиболее высокая прочность стеклоткани, низкий коэффициент гигроскопичности
G11 | стеклоткань, эпоксидная композиция: высокая прочность на изгиб при повышенных температурах, высокая сопротивляемость растворителям

После того, как материал печатной платы выбран, необходимо определить толщину фольги печатной платы. Этот параметр в первую очередь выбирается исходя из максимальной величины протекающего тока. По возможности, старайтесь избегать применения очень тонкой фольги.

КОЛИЧЕСТВО СЛОЕВ ПЕЧАТНОЙ ПЛАТЫ

В зависимости от общей сложности схемы и качественных требований разработчик должен определить количество слоев печатной платы.

Однослойные печатные платы

Очень простые электронные схемы выполняются на односторонних платах с использованием дешевых фольгированных материалов (FR-1 или FR-2) и часто имеют много перемычек, напоминая двухсторонние платы. Такой способ создания печатных плат рекомендуется только для низкочастотных схем. По причинам, которые будут описаны ниже, односторонние печатные платы в большой степени восприимчивы к наводкам. Хорошую одностороннюю печатную плату достаточно сложно разработать из-за многих причин. Тем не менее хорошие платы такого типа встречаются, но при их разработке требуется очень многое обдумывать заранее.

Двухслойные печатные платы

На следующем уровне стоят двухсторонние печатные платы, которые в большинстве случаев используют в качестве материала подложки FR-4, хотя иногда встречается и FR-2. Применение FR-4 более предпочтительнее, поскольку в печатных платах из этого материала отверстия получаются более лучшего качества. Схемы на двухсторонних печатных платах разводятся гораздо легче, т.к. в двух слоях проще осуществить разводку пересекающихся трасс. Однако для аналоговых схем пересечение трасс выполнять не рекомендуется. Где возможно, нижний слой (bottom) необходимо отводить под полигон земли, а остальные сигналы разводить в верхнем слое (top). Использование полигона в качестве земляной шины дает несколько преимуществ:

  • общий провод является наиболее часто подключаемым в схеме проводом; поэтому резонно иметь "много" общего провода для упрощения разводки.
  • увеличивается механическая прочность платы.
  • уменьшается сопротивление всех подключений к общему проводу, что, в свою очередь, уменьшает шум и наводки.
  • увеличивается распределенная емкость для каждой цепи схемы, помогая подавлять излучаемый шум.
  • полигон, являющийся экраном, подавляет наводки, излучаемые источниками, располагающимися со стороны полигона.

Двухсторонние печатные платы, несмотря на все свои преимущества, не являются лучшими, особенно для малосигнальных или высокоскоростных схем. В общем случае, толщина печатной платы, т.е. расстояние между слоями металлизации, равняется 1,5 мм, что слишком много для полной реализации некоторых преимуществ двухслойной печатной платы, приведенных выше. Распределенная емкость, например, слишком мала из-за такого большого интервала.

Многослойные печатные платы

Для ответственных схемотехнических разработок требуются многослойные печатные платы (МПП). Некоторые причины их применения очевидны:

  • такая же удобная, как и для шины общего провода, разводка шин питания; если в качестве шин питания используются полигоны на отдельном слое, то довольно просто с помощью переходных отверстий осуществить подводку питания к каждому элементу схемы;
  • сигнальные слои освобождаются от шин питания, что облегчает разводку сигнальных проводников;
  • между полигонами земли и питания появляется распределенная емкость, которая уменьшает высокочастотный шум.

Кроме этих причин применения многослойных печатных плат существуют другие, менее очевидные:

  • лучшее подавление электромагнитных (EMI) и радиочастотных (RFI) помех благодаря эффекту отражения (image plane effect), известному еще во времена Маркони. Когда проводник размещается близко к плоской проводящей поверхности, большая часть возвратных высокочастотных токов будет протекать по плоскости непосредственно под проводником. Направление этих токов будет противоположно направлению токов в проводнике. Таким образом, отражение проводника в плоскости создает линию передачи сигнала. Поскольку токи в проводнике и в плоскости равны по величине и противоположны по направлению, создается некоторое уменьшение излучаемых помех. Эффект отражения эффективно работает только при неразрывных сплошных полигонах (ими могут быть как полигоны земли, так и полигоны питания). Любое нарушение целостности будет приводить к уменьшению подавления помех.
  • снижение общей стоимости при мелкосерийном производстве. Несмотря на то, что изготовление многослойных печатных плат обходится дороже, их возможное излучение меньше, чем у одно- и двухслойных плат. Следовательно, в некоторых случаях применение лишь многослойных плат позволит выполнить требования по излучению, поставленные при разработке, и не проводить дополнительных испытаний и тестирований. Применение МПП может снизить уровень излучаемых помех на 20 дБ по сравнению с двухслойными платами.

Порядок следования слоев

У неопытных разработчиков часто возникает некоторое замешательство по поводу оптимального порядка следования слоев печатной платы. Возьмем для примера 4-слойную палату, содержащую два сигнальных слоя и два полигонных слоя - слой земли и слой питания. Какой порядок следования слоев лучший? Сигнальные слои между полигонами, которые будут служить экранами? Или же сделать полигонные слои внутренними, чтобы уменьшить взаимовлияние сигнальных слоев?

При решении этого вопроса важно помнить, что часто расположение слоев не имеет особого значения, поскольку все равно компоненты располагаются на внешних слоях, а шины, подводящие сигналы к их выводам, порой проходят через все слои. Поэтому любые экранные эффекты представляют собой лишь компромисс. В данном случае лучше позаботиться о создании большой распределенной емкости между полигонами питания и земли, расположив их во внутренних слоях.

Другим преимуществом расположения сигнальных слоев снаружи является доступность сигналов для тестирования, а также возможность модификации связей. Любой, кто хоть раз изменял соединения проводников, располагающихся во внутренних слоях, оценит эту возможность.

Для печатных плат с более, чем четырьмя слоями, существует общее правило располагать высокоскоростные сигнальные проводники между полигонами земли и питания, а низкочастотным отводить внешние слои.

ЗАЗЕМЛЕНИЕ

Хорошее заземление - общее требование насыщенной, многоуровневой системы. И оно должно планироваться с первого шага дизайнерской разработки.

Основное правило: разделение земли.

Разделение земли на аналоговую и цифровую части - один из простейших и наиболее эффективных методов подавления шума. Один или более слоев многослойной печатной платы обычно отводится под слой земляных полигонов. Если разработчик не очень опытен или невнимателен, то земля аналоговой части будет непосредственно соединена с этими полигонами, т.е. аналоговый возвратный ток будет использовать такую же цепь, что и цифровой возвратный ток. Авторазводчики работают примерно также и объединяют все земли вместе.

Если переработке подвергается ранее разработанная печатная плата с единым земляным полигоном, объединяющим аналоговую и цифровую земли, то необходимо сначала физически разделить земли на плате (после этой операции работа платы становится практически невозможной). После этого прозводятся все подключения к аналоговому земляному полигону компонентов аналоговой схемы (формируется аналоговая земля) и к цифровому земляному полигону компонентов цифровой схемы (формируется цифровая земля). И лишь после этого в источнике производится объединение цифровой и аналоговой земли.

Другие правила формирования земли:

  • Шины питания и земли должны находится под одним потенциалом по переменному току, что подразумевает использование конденсаторов развязки и распределенной емкости.
  • Не допускайте перекрытий аналоговых и цифровых полигонов (рис. 1). Располагайте шины и полигоны аналогового питания над полигоном аналоговой земли (аналогично для шин цифрового питания). Если в каком-либо месте существует перекрытие аналогового и цифрового полигона, распределенная емкость между перекрывающимися участками будет создавать связь по переменному току, и наводки от работы цифровых компонентов попадут в аналоговую схему. Такие перекрытия аннулируют изоляцию полигонов.
  • Разделение не означает электрической изоляции аналоговой от цифровой земли (рис. 2). Они должны соединяться вместе в каком-то, желательно одном, низкоимпедансном узле. Правильная, с точки зрения земли, система имеет только одну землю, которая является выводом заземления для систем с питанием от сетевого переменного напряжения или общим выводом для систем с питанием от постоянного напряжения (например, аккумулятора). Все сигнальные токи и токи питания в этой схеме должны возвращаться к этой земле в одну точку, которая будет служить системной землей. Такой точкой может быть вывод корпуса устройства. Важно понимать, что при подсоединении общего вывода схемы к нескольким точкам корпуса могут образовываться земляные контуры. Создание единственной общей точки объединения земель является одним из наиболее трудных аспектов системного дизайна.
  • По возможности разделяйте выводы разъемов, предназначенные для передачи возвратных токов - возвратные токи должны объединяться только в точке системной земли. Старение контактов разъемов, а также частая расстыковка их ответных частей приводит к увеличению сопротивления контактов, следовательно, для более надежной работы необходимо использование разъемов с некоторым количеством дополнительных выводов. Сложные цифровые печатные платы имеют много слоев и содержат сотни или тысячи проводников. Добавление еще одного проводника редко создает проблему в отличие от добавляемых дополнительных выводов разъемов. Если это не удается сделать, то необходимо создавать два проводника возвратного тока для каждой силовой цепи на плате, соблюдая особые меры предосторожности.
  • Важно отделять шины цифровых сигналов от мест на печатной плате, где расположены аналоговые компоненты схемы. Это предполагает изоляцию (экранирование) полигонами, создание коротких трасс аналоговых сигналов и внимательное размещение пассивных компонентов при наличии рядом расположенных шин высокоскоростных цифровых и ответственных аналоговых сигналов. Шины цифровых сигналов должны разводиться вокруг участков с аналоговыми компонентами и не перекрываться с шинами и полигонами аналоговой земли и аналогового питания. Если этого не делать, то разработка будет содержать новый непредусмотренный элемент - антенну, излучение которой будет воздействовать на высокоимпедансные аналоговые компоненты и проводники (рис. 3).

Почти все сигналы тактовых частот являются достаточно высокочастотными сигналами, поэтому даже небольшие емкости между трассами и полигонами могут создавать значительные связи. Необходимо помнить, что не только основная тактовая частота может вызывать проблему, но и ее высшие гармоники.

  • Хорошей концепцией является размещение аналоговой части схемы вблизи к входным/выходным соединениям платы. Разработчики цифровых печатных плат, использующие мощные интегральные схемы, часто склонны разводить шины шириной 1 мм и длиной несколько сантиметров для соединения аналогововых компонентов, полагая, что малое сопротивление трассы поможет избавиться от наводок. То, что при этом получается, представляет собой протяженный пленочный конденсатор, на который будут наводиться паразитные сигналы от цифровых компонентов, цифровой земли и цифрового питания, усугубляя проблему.

Пример хорошего размещения компонентов

На рисунке 4 показан возможный вариант размещения всех компонентов на плате, включая источник питания. Здесь используются три отделенных друг от друга и изолированных полигона земли/питания: один для источника, один для цифровой схемы и один для аналоговой. Цепи земли и питания аналоговой и цифровой частей объединяются только в источнике питания. Высокочастоный шум отфильтровывается в цепях питания дросселями. В этом примере высокочастотные сигналы аналоговой и цифровой частей отнесены друг от друга. Такой дизайн имеет очень высокую вероятность на благоприятный исход, поскольку обеспечено хорошее размещение компонентов и следование правилам разделения цепей.

Имеется лишь один случай, когда необходимо объединение аналоговых и цифровых сигналов над областью полигона аналоговой земли. Аналого-цифровые и цифро-аналоговые преобразователи размещаются в корпусах с выводами аналоговой и цифровой земли. Принимая во внимание предыдущие рассуждения, можно предположить, что вывод цифровой земли и вывод аналоговой земли должны быть подключенны к шинам цифровой и аналоговой земли соответственно. Однако в данном случае это не верно.

Названия выводов (аналоговый или цифровой) относятся лишь к внутренней структуре преобразователя, к его внутренним соединениям. В схеме эти выводы должны быть подключены к шине аналоговой земли. Соединение может быть выполнено и внутри интегральной схемы, однако получить низкое сопротивление такого соединения довольно сложно из-за топологических ограничений. Поэтому при использовании преобразователей предполагается внешнее соединение выводов аналоговой и цифровой земли. Если этого не сделать, то параметры микросхемы будут значительно хуже приведенных в спецификации.

Необходимо учитывать то, что цифровая элементы преобразователя могут ухудшать качественные характеристики схемы, привнося цифровые помехи в цепи аналоговой земли и аналогового питания. При разработке преобразователей учитывается это негативное воздействие так, чтобы цифровая часть потребляла как можно меньше мощности. При этом помехи от переключений логических элементов уменьшаются. Если цифровые выводы преобразователя не сильно нагружены, то внутренние переключения обычно не вызывают особых проблем. При разработке печатной платы, содержащей АЦП или ЦАП, необходимо должным образом отнестись к развязке цифрового питания преобразователя на аналоговую землю.

ЧАСТОТНЫЕ ХАРАКТЕРИСТИКИ ПАССИВНЫХ КОМПОНЕНТОВ

Для правильной работы аналоговых схем весьма важен правильный выбор пассивных компонентов. Начинайте дизайнерскую разработку с внимательного рассмотрения высокочастотных характеристик пассивных компонентов и предварительного размещения и компоновки их на эскизе платы.

Большое число разработчиков совершенно игнорируют частотные ограничения пассивных компонентов при использовании в аналоговой схемотехнике. Эти компоненты имеют ограниченные частотные диапазоны и их работа вне специфицированной частотной области может привести к непредсказуемым результатам. Кто-то может подумать, что это обсуждение касается только высокоскоростных аналоговых схем. Однако, это далеко не так - высокочастотные сигналы достаточно сильно воздействуют на пассивные компоненты низкочастотных схем посредством излучения или прямой связи по проводникам. Например, простой низкочастотный фильтр на операционном усилителе может легко превращаться в высокочастотный фильтр при воздействии на его вход высокой частоты.

Резисторы

Высокочастотные характеристики резисторов могут быть представлены эквивалентной схемой, приведенной на рисунке 5.

Обычно применяются резисторы трех типов: 1) проволочные, 2) углеродные композитные и 3) пленочные. Не надо иметь много воображения, чтобы понять, как проволочный резистор может превращаться в индуктивность, поскольку он представляет собой катушку с проводом из высокоомного металла. Большинство разработчиков электронных устройств не имеют понятия о внутренней структуре пленочных резисторов, которые также представляют собой катушку, правда, из металлической пленки. Поэтому пленочные резисторы также обладают индуктивностью, которая меньше, чем у проволочных резисторов. Пленочные резисторы с сопротивлением не более 2 кОм можно свободно использовать в высокочастотных схемах. Выводы резисторов параллельны друг другу, поэтому между ними существует заметная емкостная связь. Для резисторов с большим сопротивлением межвыводная емкость будет уменьшать полный импеданс на высоких частотах.

Конденсаторы

Высокочастотные характеристики конденсаторов могут быть представлены эквивалентной схемой, приведенной на рисунке 6.

Конденсаторы в аналоговых схемах используются в качестве элементов развязки и фильтрующих компонентов. Для идеального конденсатора реактивное сопротивление определяется по следующей формуле:

Следовательно, электролитический конденсатор емкостью 10 мкФ будет обладать сопротивлением 1,6 Ом на частоте 10 кГц и 160 мкОм на частоте 100 МГц. Так ли это?

В действительности, никто никогда не видел электролитического конденсатора с реактивным сопротивлением 160 мкОм. Обкладки пленочных и электролитических конденсаторов представляют собой свитые слои фольги, которые создают паразитную индуктивность. Эффект собственной индуктивности у керамических конденсаторов значительно меньше, что позволяет использовать их при работе на высоких частотах. Кроме этого, конденсаторы обладают током утечки между обкладками, который эквивалентен включенному параллельно их выводам резистору, добавляющему свое паразитное воздействие к воздействию последовательно включенного сопротивления выводов и обкладок. К тому же, электролит не является идеальным проводником. Все эти сопротивления складываясь создают эквивалентное последовательное сопротивление (ESR). Конденсаторы, используемые в качестве развязок должны обладать малым ESR, поскольку последовательное сопротивление ограничивает эффективность подавления пульсаций и помех. Повышение рабочей температуры довольно значительно увеличивает эквивалентное последовательное сопротивление и может привести к ухудшению характеристик конденсатора. Поэтому, если предполагается использование алюминиевого электролитического конденсатора при повышенной рабочей температуре, то необходимо использовать конденсаторы соответствующего типа (105°С).

Выводы конденсатора также вносят свой вклад в увеличение паразитной индуктивности. Для малых значений емкости важно оставлять длину выводов короткой. Сочетание паразитных индуктивности и емкости может создать резонансный контур. Полагая, что выводы имеют индуктивность порядка 8 нГн на один сантиметр длины, конденсатор емкостью 0,01 мкФ с выводами длиной по одному сантиметру будет иметь резонансную частоту около 12,5 МГц. Этот эффект известен инженерам, которые десятилетия назад разрабатывали электронные вакуумные приборы. Тот, кто восстанавливает антикварные радиоприемники и не знает об этом эффекте, сталкивается с множеством проблем.

При использовании электролитических конденсаторов необходимо следить за правильным подключением. Положительный вывод должен быть подключен к более положительному постоянному потенциалу. Неправильное подключение приводит к протеканию через электролитический конденсатор постоянного тока, что может вывести из строя не только сам конденсатор, но и часть схемы.

В редких случаях разность потенциалов по постоянному току между двумя точками в схеме может менять свой знак. Это требует применения неполярных электролитических конденсаторов, внутренняя структура которых эквивалентна двум полярным конденсаторам, соединенным последовательно.

Индуктивности

Высокочастотные характеристики индуктивностей могут быть представлены эквивалентной схемой, приведенной на рисунке 7.

Реактивное сопротивление индуктивности описывается следующей формулой:

Следовательно, индуктивность 10 мГн будет обладать реактивным сопротивлением 628 Ом на частоте 10 кГц, а на частоте 100 МГц - сопротивлением 6,28 МОм. Верно?

В действительности, не существует индуктивности с реактивным сопротивлением 6,28 МОм. Природу возникновения паразитного сопротивления легко понять - витки катушки выполнены из провода, обладающего некоторым сопротивлением на единицу длины. Паразитная емкость воспринимается труднее до тех пор, пока не принять во внимание то, что следующий виток катушки расположен вплотную к предыдущему, и между близко расположенными проводниками возникает емкостная связь. Паразитная емкость ограничивает верхнюю рабочую частоту. Небольшие проволочные индуктивности начинают становиться неэффективными в диапазоне 10...100 МГц.

Печатная плата

Сама печатная плата обладает характеристиками рассмотренных выше пассивных компонентов, правда, не столь очевидными.

Рисунок проводников на печатной плате может быть как источником, так и приемником помех. Хорошая разводка проводников уменьшает чувствительность аналоговой схемы к излучению источников.

Печатная плата восприимчива к излучению, поскольку проводники и выводы компонентов образовывают своеобразные антенны. Теория антенн представляет собой достаточно сложный предмет для изучения и не рассматривается в этой статье. Тем не менее, некоторые основы здесь приводятся.

Немного из теории антенн

Одним из основных типов антенн является штырь или прямой проводник. Такая антенна работает, потому что прямой проводник обладает паразитной индуктивностью и поэтому может концентрировать и улавливать излучение от внешних источников. Полный импеданс прямого проводника имеет резистивную (активную) и индуктивную (реактивную) составляющие:

На постоянном токе или низких частотах преобладает активная составляющая. При повышении частоты реактивная составляющая становится все более и более значимой. В диапазоне от 1 кГц до 10 кГц индуктивная составляющая начинает оказывать влияние, и проводник более не является низкоомным соединителем, а скорее выступает как катушка индуктивности.

Формула для расчета индуктивности проводника печатной платы выглядит следующим образом:

Обычно, трассы на печатной плате обладают значениями от 6 нГн до 12 нГн на сантиметр длины. Например, 10-сантиметровый проводник обладает сопротивлением 57 мОм и индуктивностью 8 нГн на см. На частоте 100 кГц реактивное сопротивление становится равным 50 мОм, а на более высоких частотах проводник будет представлять собой скорее индуктивность, чем активное сопротивление.

Правило штыревой антенны гласит, что она начинает ощутимо взаимодействовать с полем при своей длине около 1/20 от длины волны, а максимальное взаимодействие происходит при длине штыря, равной 1/4 от длины волны. Поэтому 10-сантиметровый проводник из примера в предыдущем параграфе начнет становиться довольно хорошей антенной на частотах выше 150 МГц. Необходимо помнить, что несмотря на то, что генератор тактовой частоты цифровой схемы может и не работать на частоте выше 150 МГц, в его сигнале всегда присутствуют высшие гармоники. Если на печатной плате присутствуют компоненты со штыревыми выводами значительной длины, то такие выводы также могут служить антеннами.

Другой основной тип антенн - петлевые антенны. Индуктивность прямого проводника сильно увеличивается, когда он изгибается и становится частью дуги. Увеличивающаяся индуктивность понижает частоту, на которой начинает происходить взаимодействие антенны с линиями поля.

Опытные дизайнеры печатных плат, достаточно хорошо разбирающиеся в теории петлевых антенн, знают, что нельзя создавать петли для критичных сигналов. Некоторые разработчики, однако, не задумываются об этом, и проводники возвратного и сигнального тока в их схемах представляют собой петли. Создание петлевых антенн легко показать на примере (рис. 8). Кроме того, здесь показано и создание щелевой антенны.

Рассмотрим три случая:

Вариант A - пример скверного дизайна. В нем вовсе не используется полигон аналоговой земли. Петлевой контур формируется земляным и сигнальным проводником. При прохождении тока возникают электрическое и перпендикулярное ему магнитное поля. Эти поля образовывают основу петлевой антенны. Правило петлевой антенны гласит, что для наибольшей эффективности длина каждого проводника должна быть равно половине длины волны принимаемого излучения. Однако, следует не забывать, что даже при 1/20 от длины волны петлевая антенна все еще остается достаточно эффективной.

Вариант Б лучше варианта A, но здесь присутствует разрыв в полигоне, вероятно, для создания определенного места для разводки сигнальных проводников. Пути сигнального и возвратного токов образуют щелевую антенну. Другие петли образуются в вырезах вокруг микросхем.

Вариант В - пример лучшего дизайна. Пути сигнального и возвратного тока совпадают, сводя на нет эффективность петлевой антенны. Заметьте, что в этом варианте также присутствуют вырезы вокруг микросхем, но они отделены от пути возвратного тока.

Теория отражения и согласования сигналов находится близко к теории антенн.

Когда проводник печатной платы поворачивает на угол 90° может возникнуть отражение сигнала. Это происходит, главным образом, из-за изменения ширины пути прохождения тока. В вершине угла ширина трассы увеличивается в 1.414 раза, что приводит к рассогласованию характеристик линии передачи, особенно распределенной емкости и собственной индуктивности трассы. Довольно часто необходимо повернуть на печатной плате трассу на 90°. Многие современные CAD-пакеты позволяют сглаживать углы проведенных трасс или проводить трассы в виде дуги. На рисунке 9 показаны два шага улучшения формы угла. Только последний пример поддерживает постоянной ширину трассы и минимизирует отражения.

Совет для опытных разводчиков печатных плат: оставляйте процедуру сглаживания на последний этап работ перед созданием каплеобразных выводов и заливкой полигонов. Иначе, CAD-пакет будет производить сглаживание дольше из-за более сложных вычислений.

ПАРАЗИТНЫЕ ЭФФЕКТЫ ПЕЧАТНОЙ ПЛАТЫ

Между проводниками печатной платы, находящимися на разных слоях, возникает емкостная связь, когда они пересекаются. Иногда это может создать проблему. Проводники, находящиеся друг над другом на смежных слоях, создают длинный пленочный конденсатор. Емкость такого конденсатора расчитывается по формуле, приведенной на рисунке 10.

Например, печатная плата может обладать следующими параметрами:
- 4 слоя; сигнальный и слой полигона земли - смежные,
- межслойный интервал - 0,2 мм,
- ширина проводника - 0,75 мм,
- длина проводника - 7,5 мм.

Типовое значение диэлектрической постоянной ER для FR-4 равняется 4.5.

Подставив все значения в формулу, получим значение емкости между этими двумя шинами, равное 1,1 пФ. Даже такая, казалось бы, небольшая емкость для некоторых приложений является недопустимой. Рисунок 11 иллюстрирует эффект от емкости в 1 пФ, возникающий при подключении ее к инвертирующему входу высокочастотного операционного усилителя.

Видно, что происходит удвоение амплитуды выходного сигнала на частотах, близких к верхнему пределу частотного диапазона ОУ. Это, в свою очередь, может привести к генерации, особенно на рабочих частотах антенны (выше 180 МГц).

Этот эффект порождает многочисленные проблемы, для решения которых, тем не менее, существует много способов. Самый очевидный из них - уменьшение длины проводников. Другой способ - уменьшение их ширины. Нет причины применения проводника такой ширины для подводки сигнала к инвертирующему входу, т.к. по этому проводнику протекает очень небольшой ток. Уменьшение длины трассы до 2,5 мм, а ширины до 0,2 мм приведет к уменьшению емкости до 0,1 пФ, а такая емкость уже не приведет к столь значительному подъему частотной характеристики. Еще один способ решения - удаление части полигона под инвертирующим входом и проводником, подходящим к нему.

Инвертирующий вход операционного усилителя, особенно, высокоскоростного, в большой степени склонен к генерации в схемах с высоким коэффициентом усиления. Это происходит из-за нежелательной емкости входного каскада ОУ. Поэтому, крайне важно уменьшить паразитную емкость и располагать компоненты обратной связи настолько близко к инвертирующему входу насколько это возможно. Если, несмотря на принятые меры, происходит возбуждение усилителя, то необходимо пропорционально уменьшить сопротивления резисторов обратной связи для изменения резонансной частоты цепи. Также может помочь и увеличение резисторов, правда, значительно реже, т.к. эффект возбуждения зависит и от импеданса схемы. При изменении резисторов обратной связи нельзя забывать и об изменении емкости корректирующего конденсатора. Также нельзя забывать и о том, что при уменьшении сопротивлении резисторов увеличивается потребляемая мощность схемы.

Ширину проводников печатной платы невозможно бесконечно уменьшить. Предельная ширина определяется как технологическим процессом, так и толщиной фольги. Если два проводника проходят близко друг к другу, то между ними образуется емкостная и индуктивная связь (рис. 12).

Зависимости, описывающие эти паразитные эффекты, достаточно сложны, чтобы их приводить в этой статье, но их можно найти в литературе, посвященной линиям передачи и полосковым линиям.

Сигнальные проводники не должны разводиться параллельно друг другу, исключая случаи разводки дифференциальных или микрополосковых линий. Зазор между проводниками должен быть минимум в три раза больше ширины проводников.

Емкость между трассами в аналоговых схемах может создать затруднения при больших сопротивлениях резисторов (несколько МОм). Относительно большая емкостная связь между инвертирующим и неинвертирующим входами операционного усилителя легко может привести к самовозбуждению схемы.

Всякий раз, когда при разводке печатной платы появляется необходимость в создании переходного отверстия, т.е. межслойного соединения (рис. 13), необходимо помнить, что при этом возникает также паразитная индуктивность. При диаметре отверстия после металлизации d и длине канала h индуктивность можно вычислить по следующей приближенной формуле:

Например, при d=0,4 мм и h=1,5 мм (достаточно распространенные величины) индуктивность отверстия равна 1,1 нГн.

Имейте в виду, что индуктивность отверстия вместе с такой же паразитной емкостью формируют резонансный контур, что может сказаться при работе на высоких частотах. Собственная индуктивность отверстия достаточно мала, и резонансная частота находится где-то в гигагерцовом диапазоне, но если сигнал в течение своего пути вынужден проходить через несколько переходных отверстий, то их индуктивности складываются (последовательное соединение), а резонансная частота понижается. Вывод: старайтесь избегать большого числа переходных отверстий при разводке ответственных высокочастотных проводников аналоговых схем. Другое негативное явление: при большом количестве переходных отверстий в полигоне земли могут создаваться петлевые участки. Наилучшая аналоговая разводка - все сигнальные проводники располагаются на одном слое печатной платы.

Кроме рассмотренных выше паразитных эффектов существуют еще такие, которые связаны с недостаточно чистой поверхностью платы.

Помните, что, если в схеме присутствуют большие сопротивления, то особое внимание следует уделить очистке платы. На заключительных операциях изготовления печатной платы должны удаляться остатки флюса и загрязнений. В последнее время при монтаже печатных плат достаточно часто применяются водорастворимые флюсы. Являясь менее вредными, они легко удаляются водой. Но при этом отмывка платы недостаточно чистой водой может привести к дополнительным загрязнениям, которые ухудшают диэлектрические характеристики. Следовательно, очень важно производить отмывку печатной платы с высокоимпедансной схемой свежей дистиллированой водой.

РАЗВЯЗКА СИГНАЛОВ

Как уже отмечалось, помехи могут проникать в аналоговую часть схемы через цепи питания. Для уменьшения таких помех применяются развязывающие (блокировочные) конденсаторы, уменьшающие локальный импеданс шин питания.

Если необходимо развести печатную плату, на которой имеются и аналоговая, и цифровая части, то необходимо иметь хотя бы небольшое представление об электрических характеристиках логических элементов.

Типовой выходной каскад логического элемента содержит два транзистора, последовательно соединенные между собой, а также между цепями питания и земли (рис. 14).

Эти транзисторы в идеальном случае работают строго в противофазе, т.е. когда один из них открыт, то в этот же момент времени второй закрыт, формируя на выходе либо сигнал логической единицы, либо логического нуля. В установившемся логическом состоянии потребляемая мощность логического элемента невелика.

Ситуация кардинально меняется, когда выходной каскад переключается из одного логического состояния в другое. В этом случае в течение короткого промежутка времени оба транзистора могут быть открыты одновременно, а ток питания выходного каскада сильно увеличивается, поскольку уменьшается сопротивление участка пути тока от шина питания до шины земли через два последовательно соединенных транзистора. Потребляемая мощность скачкообразно возрастает, а затем также убывает, что приводит к локальному изменению напряжения питания и возникновению резкого, кратковременного изменения тока. Такие изменения тока приводят к излучению радиочастотной энергии. Даже на сравнительно простой печатной плате может быть десятки или сотни рассмотренных выходных каскадов логических элементов, поэтому суммарный эффект от их одновременной работы может быть очень большим.

Невозможно точно предсказать диапазон частот, в котором будут находиться эти выбросы тока, поскольку частота их возникновения зависит от множества причин, в том числе и от задержки распространения переключений транзисторов логического элемента. Задержка, в свою очередь, также зависит от множества случайных причин, возникающих в процессе производства. Шум от переключений имеет широкополосное распределение гармонических составляющих во всем диапазоне. Для подавления цифрового шума существует несколько способов, применение которых зависит от спектрального распределения шума.

В таблице 2 представлены максимальные рабочие частоты для распространенных типов конденсаторов.

Таблица 2

Тип | Максимальная частота
алюминиевый электролитический | 100 кГц
танталовый электролитический | 1 МГц
слюдяной | 500 МГц
керамический | 1 ГГц

Из таблицы очевидно, что танталовые электролитические конденсаторы применяются для частот ниже 1 МГц, на более высоких частотах должны применяться керамические конденсаторы. Необходимо не забывать, что конденсаторы имеют собственный резонанс и их неправильный выбор может не только не помочь, но и усугубить проблему. На рисунке 15 показаны типовые собственные резонансы двух конденсаторов общего применения - 10 мкФ танталового электролитического и 0,01 мкФ керамического.

Реальные характеристики могут отличаться у различных производителей и даже от партии к партии у одного производителя. Важно понимать, что для эффективной работы конденсатора подавляемые им частоты должны находиться в более низком диапазоне, чем частота собственного резонанса. В противном случае характер реактивного сопротивления будет индуктивным, а конденсатор перестанет эффективно работать.

Не стоит заблуждаться относительно того, что один 0,1 мкФ конденсатор будет подавлять все частоты. Небольшие конденсаторы (10 нФ и менее) могут работать более эффективно на более высоких частотах.

Развязка питания ИС

Развязка питания интегральных схем с целью подавления высокочастотного шума состоит в применении одного или нескольких конденсаторов, подключенных между выводами питания и земли. Важно, чтобы проводники, соединяющие выводы с конденсаторами, были короткими. Если это не так, то собственная индуктивность проводников будет играть заметную роль и сводить на нет выгоды от применения развязывающих конденсаторов.

Развязывающий конденсатор должен быть подключен к каждому корпусу микросхемы, независимо от того, сколько операционных усилителей находится внутри корпуса - 1, 2 или 4. Если ОУ питается двухполярным питанием, то, само собой разумеется, что развязывающие конденсаторы должны располагаться у каждого вывода питания. Значение емкости должно быть тщательно выбрано в зависимости от типа шума и помех, присутствующих в схеме.

В особо сложных случаях может появиться необходимость добавления индуктивности, включенной последовательно с выводом питания. Индуктивность должна располагаться до, а не после конденсаторов.

Другим, более дешевым способом является замена индуктивности резистором с малым сопротивлением (10...100 Ом). При этом вместе с развязывающим конденсатором резистор образует низкочастотный фильтр. Этот способ уменьшает диапазон питания операционного усилителя, который к тому же становится более зависимым от потребляемой мощности.

Обычно для подавления низкочастотных помех в цепях питания бывает достаточно применить один или несколько алюминиевых или танталовых электролитических конденсаторов у входного разъема питания. Дополнительный керамический конденсатор будет подавлять высокочастотные помехи от других плат.

РАЗВЯЗКА ВХОДНЫХ И ВЫХОДНЫХ СИГНАЛОВ

Множество шумовых проблем является результатом непосредственного соединения входных и выходных выводов. В результате высокочастотных ограничений пассивных компонентов реакция схемы на воздействие высокочастотного шума может быть достаточно непредсказуемой.

В ситуациии, когда частотный диапазон наведенного шума в значительной степени отличается от частотного диапазона работы схемы, решение просто и очевидно - размещение пассивного RC-фильтра для подавления высокочастотных помех. Однако, при применении пассивного фильтра надо быть осторожным: его характеристики (из-за неидеальности частотных характеристик пассивных компонентов) утрачивают свои свойства на частотах, в 100...1000 раз превышающих частоту среза (f3db). При использовании последовательно соединенных фильтров, настроенных на разные частотные диапазоны, более высокочастотный фильтр должен быть ближайшим к источнику помех. Индуктивности на ферритовых кольцах также могут применяться для подавления шума; они сохраняют индуктивный характер сопротивления до некоторой определенной частоты, а выше их сопротивление становится активным.

Наводки на аналоговую схему могут быть настолько большими, что избавиться (или, по крайней мере, уменьшить) от них возможно только с помощью применения экранов. Для эффективной работы они должны быть тщательно спроектированы так, чтобы частоты, создающие наибольшие проблемы, не смогли попасть в схему. Это означает, что экран не должен иметь отверстия или вырезы с размерами, большими, чем 1/20 длины волны экранируемого излучения. Хорошая идея отводить достаточное место под предполагаемый экран с самого начала проектирования печатной платы. При использовании экрана можно дополнительно использовать ферритовые кольца (или бусинки) для всех подключений к схеме.

КОРПУСА ОПЕРАЦИОННЫХ УСИЛИТЕЛЕЙ

В одном корпусе обычно размещаются один, два или четыре операционных усилителя (рис. 16).

Одиночный ОУ часто также имеет дополнительные входы, например, для регулировки напряжения смещения. Сдвоенные и счетверенные ОУ имеют лишь инвертирующий и неинвертирующий входы и выход. Поэтому при необходимости иметь дополнительные регулировки надо применять одиночные операционные усилители. При использовании дополнительных выводов необходимо помнить, что по своей структуре они являются вспомогательными входами, поэтому управление ими должно осущуствляться аккуратно и в соответствии с рекомендациями производителя.

В одиночном ОУ выход располагается на противоположной стороне от входов. Это может создать затруднение при работе усилителя на высоких частотах из-за протяженных проводников обратной связи. Один из путей преодоления этого состоит в размещении усилителя и компонентов обратной связи на разных сторонах печатной платы. Это, однако, приводит к как минимум двум дополнительным отверстиям и вырезам в полигоне земли. Иногда стоит использовать сдвоенный ОУ для разрешения данной проблемы, даже если второй усилитель не используется (при этом его выводы должны быть подключены должным образом). Рисунок 17 иллюстрирует уменьшение длины проводников цепи обратной связи для инвертирующего включения.

Сдвоенные ОУ особенно часто используются в стереофонических усилителях, а счетверенные - в схемах многокаскадных фильтров. Однако, в этом есть довольно значительный минус. Несмотря на то, что современная технология обеспечивает приличную изоляцию между сигналами усилителей, расположенных на одном кремниевом кристалле, между ними все же существуют некоторые перекрестные помехи. Если необхомимо иметь очень малую величину таких помех, то необходимо использовать одиночные операционные усилители. Перекрестные помехи возникают не только при использовании сдвоенных или счетверенных усилителей. Их источником может служить очень близкое расположение пассивных компонентов разных каналов.

Сдвоенные и счетверенные ОУ, кроме вышесказанного, позволяют осуществить более плотный монтаж. Отдельные усилители как бы зеркально расположены друг относительно друга (рис. 18).

На рисунках 17 и 18 показаны не все подключения, требуемые для нормальной работы, например, формирователь среднего уровня при однополярном питании. На рисунке 19 приведена схема такого формирователя при использовании счетверенного усилителя.

На схеме показаны все необходимые подключения для реализации трех независимых инвертирующих каскадов. Необходимо обратить внимание на то, что проводники формирователя половины напряжения питания располагаются непосредственно под корпусом интегральной схемы, что позволяет уменьшить их длину. Этот пример иллюстрирует не то, как должно быть, а то, что должно быть сделано. Напряжение среднего уровня, например, могло бы быть единым для всех четырех усилителей. Пассивные компоненты могут быть соответствующего размера. Например, планарные компоненты типоразмера 0402 соответствуют расстоянию между выводами стандартного корпуса SO. Это позволяет сделать длину проводников очень короткой для высокочастотных приложений.

Типы корпусов операционных усилителей включают в себя, в основном, DIP (dual-in-line) и SO (small-outline). Вместе с уменьшением размера корпуса уменьшается и шаг выводов, что позволяет применять меньшие по размеру пассивные компоненты. Уменьшение размеров схемы в целом уменьшает паразитные индуктивности и позволяет работать на более высоких частотах. Однако это приводит также к возникновению более сильных перекрестных помех из-за увеличения емкостной связи между компонентами и проводниками.

ОБЪЕМНЫЙ И ПОВЕРХНОСТНЫЙ МОНТАЖ

При размещении операционных усилителей в корпусах типа DIP и пассивных компонентов с проволочными выводами требуется наличие на печатной плате переходных отверстий для их монтажа. Такие компоненты в настоящее время используются, когда нет особых требований к размерам печатной платы; обычно они стоят дешевле, но стоимость печатной платы в процессе изготовления возрастает из-за сверловки дополнительных отверстий под выводы компонентов.

Кроме того, при использовании навесных компонентов увеличиваются размеры платы и длины проводников, что не позволяет работать схеме на высоких частотах. Переходные отверстия обладают собственной индуктивностью, что также накладывает ограничения на динамические характеристики схемы. Поэтому навесные компоненты не рекомендуется применять для реализации высокочастотных схем или для аналоговых схем, размещенных поблизости с высокоскоростными логическими схемами.

Некоторые разработчики, пытаясь уменьшить длину проводников, размещают резисторы вертикально. С первого взгляда может показаться что, это сокращает длину трассы. Однако при этом увеличивается путь прохождения тока по резистору, а сам резистор представляет собой петлю (виток индуктивности). Излучающая и принимающая способность возрастает многократно.

При поверхностном монтаже не требуется размещения отверстия под каждый вывод компонента. Однако возникают проблемы при тестирования схемы, и приходится использовать переходные отверстия в качестве контрольных точек, особенно при применении компонентов малого типоразмера.

НЕИСПОЛЬЗУЕМЫЕ СЕКЦИИ ОУ

При использовании сдвоенных и счетверенных операционных усилителей в схеме некоторые их секции могут остаться незадействованными и должны быть в этом случае корректно подключены. Ошибочное подключение может привести к увеличению потребляемой мощности, большему нагреву и большему шуму используемых в этом же корпусе ОУ. Выводы неиспользумых операционных усилителей могут быть подключены так, как изображено на рис. 20а. Подключение выводов с дополнительными компонентами (рис. 20б) позволит легко использовать этот ОУ при наладке.

ЗАКЛЮЧЕНИЕ

Помните следующие основные моменты и постоянно соблюдайте их при проектировании и разводке аналоговых схем.

Общие:

  • думайте о печатной плате как о компоненте электрической схемы;
  • имейте представление и понимание об источниках шума и помех;
  • моделируйте и макетируйте схемы.

Печатная плата:

  • используйте печатные платы только из качественного материала (например, FR-4);
  • схемы, выполненные на многослойных печатных платах, на 20 дБ менее восприимчивее к внешним помехам, чем схемы, выполненные на двухслойных платах;
  • используйте разделенные, неперекрывающиеся полигоны для различных земель и питаний;
  • располагайте полигоны земли и питания на внутренних слоях печатной платы.

Компоненты:

  • осознавайте частотные ограничения, вносимые пассивными компонентами и проводниками платы;
  • старайтесь избегать вертикального размещения пассивных компонентов в высокоскоростных схемах;
  • для высокочастотных схем используйте компоненты, предназначенные для поверхностного монтажа;
  • проводники должны быть чем короче, тем лучше;
  • если требуется большая длина проводника, то уменьшайте его ширину;
  • неиспользуемые выводы активных компонентов должны быть правильно подключены.

Разводка:

  • размещайте аналоговую схему вблизи разъема питания;
  • никогда не разводите проводники, передающие логические сигналы, через аналоговую область платы, и наоборот;
  • проводники, подходящие к инвертирующему входу ОУ, делайте короткими;
  • удостоверьтесь, что проводники инвертирующего и неинвертирующего входов ОУ не располагаются параллельно друг другу на большом протяжении;
  • старайтесь избегать применения лишних переходных отверстий, т.к. их собственная индуктивность может привести к возникновению дополнительных проблем;
  • не разводите проводники под прямыми углами и сглаживайте вершины углов, если это возможно.

Развязка:

  • используйте правильные типы конденсаторов для подавления помех в цепях питания;
  • для подавления низкочастотных помех и шумов используйте танталовые конденсаторы у входного разъема питания;
  • для подавления высокочастотных помех и шумов используйте керамические конденсаторы у входного разъема питания;
  • используйте керамические конденсаторы у каждого вывода питания микросхемы; если необходимо, используйте несколько конденсаторов для разных частотных диапазонов;
  • если в схеме происходит возбуждение, то необходимо использовать конденсаторы с меньшим значением емкости, а не большим;
  • в трудных случаях в цепях питания используйте последовательно включенные резисторы малого сопротивления или индуктивности;
  • развязывающие конденсаторы аналогового питания должны подключаться только к аналоговой земле, а не к цифровой.


Настольный макет лазерной связи на 10Mbit

Настольный - значит на "проводочках" на столе, не оформлен в корпус. Дистанция между светодиодом и фотодиодом 5 см, но интенсивность света такая-же, как и с дистанции 250 метров с 5-ти милливаттной указки.

Макет очень "сырой" можете его не бомбить, я сам вижу всё его убожество, но он сделал главное - заработал. Через него я сидел в инете весь вечер, и отправлял письма.

В сущности, усилитель собран из двух одинаковых модулей, объединённых эмиттерным повторителем. Построение из двух разделённых по постоянной составляющей модулей, уменьшило воздействте постоянного тока со светодиода от солнечных засветок, и дало возможность не разделять конденсатором фотодиод и вход усилителя, иначе пришлось бы ставить нагрузку на фотодиод, а это бы его шунтировало, т.е. уменьшило бы его отдачу, сказалось бы на частотной характеристике и т.д.

В этом макете есть, по крайней мере, две изюминки:
1. Фотодиод низкочастотный, а работает на высокой частоте, у него большое окошко, что облегчит наведение его на излучатель, он стоит на момент написания этого текста 10 руб.
2. Все детали, как и обещано, нашенские, а транзисторы по 3 руб за штучку.

Из недостатков можно указать, что частотку валит он в два раза, т.е 5-ти мГц импульс он усиливает в два раза сильнее, чем 10-ти мГц. Видимо, с дистанции 250 метров он будет принимать сигнал (если будет) на ниточку - т.е. еле-еле. Не поставлены фильтры по питанию, а применены четыре источника питания, независимые и стабилизированные, но всё-едино он работает на грани возбуда.

Но всё-же, отправная точка есть, плох макет или хорош - его можно доработать, а общие навороты и их размеры теперь ясны. У меня на подходе очередная модификация, улучшенная.

Макет был включен в разрыв в витой паре, при этом, модулятор запускался сигналом от хаба, до него дистанция была 40 метров, приёмник работал через 10-ти метровый отрезок на приём в сетевой карте компа, а передача от компа на хаб шла по проводу. Так что связь получилась однобокой - на приём от хаба через свет, а на передачу через проволоку.

Конструктивно макет был выполнен в экранирующей коробочке от блока ДМВ телевизора, правда эта коробочка оказалась тесноватой для такого количества деталей, можно применить коробку от СКМ или от СКВ. В качестве стоек я применил конденсаторы 0.1мкФ одним концом я паял их к корпусу, а к другому подпаивал выводы элементов "холодных" узлов (где нет высокочастотной составляющей) тем самым, я решил две проблемы: фильтрацию и крепёж. На схеме я не обозначил эти "стойки", но чем их будет больше, тем лучше. Можно также в качестве стоек применить мегомные резисторы - схема со средними токами и мегомы на режимах не скажутся. Вообще, надо применить максимальные меры против самовозбуждения, а к выводам питания подвязать дроссели (хороший тон!!!). Иначе, при возникновении возбуда будет потрачено много времени и сил - это одно из самых противных паразитных явлений после периодичеких возникновений дефектов (периодика).

Вместо множества источников питания можно пробовать фильтры, но это уже отдельный разговор.

"Подводные камни" на которых белый парусник вашей надежды может разбиться:
1. транзисторы с низким бэтта.
2. плохая экранировка.
3. слишком размашистый монтаж, особенно в эмиттерных цепях транзисторов.
4. возбуд через выводы блоков питания (ставить дроссели)
5. низкокачественный фотодиод.
6. плохая оптика в указке.
7. и т.д. и т.п.

Автор: Father


Связь на IRDA(для подключения к материнке)

Связь на IRDA

Схема приемника на рис.1. Схема передатчика на рис. 2. Распайка разъема IR на рис. 3. Таблица скоростей на рис. 4..Теперь о конструкции: Пока я незаэкранировал эту микросхему, я думал она не работает. Hа двухстороннем текстолите прорезаем маленькие квадратики под ножки, паяем микросхему. Вырезаем из консервной банки экран и закрываем всю конструкцию, нижнюю часть текстолита соединяем с экраном. Можно для начала без экрана попробовать, снизив чувствительность добавлением R4, но это так плохо работает. Максимальная скорость передачи, которую мне удалось достич 38.4 кбод. Это соответствеут 4.88 мкс, (204,918 кГц ). Ограничение вносит К1056УП1. Возможно, для повышения частоты требуетс изменение С1, С2, С3, но мне это не удалось (хотя я просто коротил емкости, а не изменял их). Hа 19.2 кбод связь уверенная, на 57.6 кбод передача начинается, но за одну, две секунды из хорошей превращается в очень плохую вплоть до разрыва связи. Думаю просто эти импульсы микросхема детектирует как помехи и снижает чувствительность. И ещё не нужно светить лезером(или светодиодом) с расстояния 1 м прямо в фотодиод это вызывает его перенасыщение и скорость падает до 2400, если у вас маленькие расстояния поставьте перед фотодиодом лист плотной бумаги. Схема не боится засветок, 100 Вт лампа с расстояния 10 см, не повлияла на работу никак. Для индакации я ставил параллельно R3 светодиод с резистором 100 Ом, тогда видно приходящий сигная визуально. Прежде чем подключать к компьютеру подайте на схему 5V и посветите любым пультом дистанционого управления (от видака, телика, СД). Резистор R3 я ставил для лазера, чтоб он еле еле светился. Я думаю, это повысит быстродействие, и продлит срок службы лазера. Уровни TTL, в 7-ми конактном разъеме есть сигнал RXH я незнаю что это и поэтому не применял его.

Чтобы проще было разрабатывать под IR, спаяйте только один приемник и передатчик, а вместо второго канала пробросте провод RX-TX между разъемами. Объязательно соедените корпуса машин и выводы GND! Програмно: В win98 при включении IRDA оно найдется и поставится "Устройства ИК-связи", будут эмуляция LPT3 и СОМ4. Теперь можно через сом4 запустить "прямое соединение". Эти машины соеденяться в сеть. Hа win95 это я тоже делал, но там больше ручной работы.


ИК-порт для компьютера(для подключения к материнке)

ИК-порт для компьютера
ИК-порт для компьютера ИК-порт для компьютера

Протокол IrDA (Infra red Data Assotiation) позволяет соединяться с периферийным оборудованием без кабеля при помощи ИК-излучения. Порт IrDA позволяет устанавливать связь на небольшом расстоянии в режиме точка-точка. Интерфейс IrDA использует узкий ИК-диапазон (850-900 nm) с малой мощностью потребления, что позволяет создать недорогую аппаратуру и не требует сертификации FCC (Федеральной Комиссии по Связи). Порт IrDA основан на архитектуре коммуникационного СОМ-порта ПК, который использует универсальный асинхронный приемо-передатчик UART (Universal Asynchronous Receiver Transmitter) и работает со скоростью передачи данных 2400-115200 bps, обеспечивая устойчивую полудуплексную связь.

Подключается ИК-порт непосредственно к материнской плате, в большинстве случаев распиновка на плате соответствует схеме и описана в документации на плату, в случае не совпадения выводов их легко переставить. После установки необходимо включить в BIOS поддержку инфракрасного порта. ("Chipset Features Setup" -> "UART2 Use Infrared" -> "Enabled"). Если используется операционная система Windows 9X, то она сама установит необходимые для работы драйвера.


ИК-порт для компьютера(для подключения к материнке)

D1 | Любой инфракрасный
D2 | Любой, для индикации передачи
D3 | Любой, для индикации приема
T1 | 2N2222 (NPN)
T2 | 2N2222 (NPN)
T3 | OP485 (фототранзистор NPN) или фотодиод
T4 | 2N2222 (NPN)
T5 | 2N2222 (NPN)
T6 | 2N2222 (NPN)
IC1 | 74LS14


ИК-порт для компьютера(для COM порта)

Инфракрасный порт для компьютера

Это устройство позволяет установить связь на ИК лучах с любым бытовым устройством в вашей квартире имеющим ИК канал управления. Схема предназначена для компьютеров использующих все 25 контактов COM порта, а не 9. Можно найти соответствующие выводы и подключить к 9 контактному СОМ порту. Благодаря ему можно управлять с компьютера телевизором, видеомагнитофоном и т.д. Также позволяет вести обмен данными с другим компьютером, сотовым телефоном, лаптопом и др. Список необходимых радиодеталей:
R1 - 220 Om
R2 - 220 Om
X1 - n-p-n (3904 type)
IRX - фототранзистор
IRD1, IRD2 - ИК диод

А вот еще одна схема. Датали можно подобрать аналогичные, главное принцип работы.


Как получить 5 вольт от порта RS-232

Как получить 5 вольт от порта RS-232

В схеме используется LM78L05 или советский аналог на 5В. Диоды любые. Напряжение +5В получается из сигналов RTS и DTR в RS-232. Эта схема, даже из портативного компьютера, может выдавать ток 12mA. Единственый недостаток - то, что устройство транзисторно-транзисторной логики должно быть изолировано от корпуса компьютера, потому что интерфейс воспринимает корпус RS-232 как положительное напряжение.


Интерфейс RS-232C

Интерфейс RS-232C предназначен для подключения аппаратуры, передающей или принимающей данные (ООД — оконечное оборудование данных, или АПД — аппаратура передачи данных; DTE — Data Terminal Equipment), к оконечной аппаратуре каналов данных (АКД; DCE — Data Communication Equipment). В роли АПД может выступать компьютер, принтер, плоттер и другое периферийное оборудование. В роли АКД обычно выступает модем. Конечной целью подключения является соединение двух устройств АПД. Полная схема соединения приведена на рис. 1; интерфейс позволяет исключить канал удаленной связи вместе с парой устройств АКД, соединив устройства непосредственно с помощью нуль-модемного кабеля (рис. 2).

Полная схема соединения по RS-232C

Рис.1. Полная схема соединения по RS-232C

Соединение по RS-232C нуль-модемным кабелем

Рис. 2. Соединение по RS-232C нуль-модемным кабелем

Стандарт описывает управляющие сигналы интерфейса, пересылку данных, электрический интерфейс и типы разъемов. В стандарте предусмотрены асинхронный и синхронный режимы обмена, но COM-порты поддерживают только асинхронный режим. Функционально RS-232C эквивалентен стандарту МККТТ V.24/ V.28 и стыку С2, но они имеют различные названия сигналов.

Стандарт RS-232C описывает несимметричные передатчики и приемники — сигнал передается относительно общего провода — схемной земли (симметричные дифференциальные сигналы используются в других интерфейсах — например, RS-422). Интерфейс не обеспечивает гальванической развязки устройств. Логической единице (состояние MARK) на входе данных (сигнал RxD) соответствует диапазон напряжения от –12 до –3 В; логическому нулю — от +3 до +12 В (состояние SPACE). Для входов управляющих сигналов состоянию ON (“включено”) соответствует диапазон от +3 до +12 В, состоянию OFF (“выключено”) — от –12 до –3 В. Диапазон от –3 до +3 В — зона нечувствительности, обусловливающая гистерезис приемника: состояние линии будет считаться измененным только после пересечения порога (рис. 3). Уровни сигналов на выходах передатчиков должны быть в диапазонах от –12 до –5 В и от +5 до +12 В. Разность потенциалов между схемными землями (SG) соединяемых устройств должна быть менее 2 В, при более высокой разности потенциалов возможно неверное восприятие сигналов. Заметим, что сигналы уровней ТТЛ (на входах и выходах микросхем UART) передаются в прямом коде для линий TxD и RxD и в инверсном — для всех остальных.

Интерфейс предполагает наличие защитного заземления для соединяемых устройств, если они оба питаются от сети переменного тока и имеют сетевые фильтры.

ВНИМАНИЕ

Подключение и отключение интерфейсных кабелей устройств с автономным питанием должно производиться при отключенном питании. Иначе разность невыровненных потенциалов устройств в момент коммутации может оказаться приложенной выходным или входным (что опаснее) цепям интерфейса и вывести из строя микросхемы.

Стандарт RS-232C регламентирует типы применяемых разъемов.

На аппаратуре АПД (в том числе на COM-портах) принято устанавливать вилки DB-25P или более компактный вариант — DB-9P. Девятиштырьковые разъемы не имеют контактов для дополнительных сигналов, необходимых для синхронного режима (в большинстве 25-штырьковых разъемах эти контакты не используются).

На аппаратуре АКД (модемах) устанавливают розетки DB-25S или DB-9S.

Это правило предполагает, что разъемы АКД могут подключаться к разъемам АПД непосредственно или через переходные “прямые” кабели с розеткой и вилкой, у которых контакты соединены “один в один”. Переходные кабели могут являться и переходниками с 9 на 25-штырьковые разъемы (рис. 4).

Если аппаратура АПД соединяется без модемов, то разъемы устройств (вилки) соединяются между собой нуль-модемным кабелем (Zero-modem, или Z-modem), имеющим на обоих концах розетки, контакты которых соединяются перекрестно по одной из схем, приведенных на рис. 5.

Прием сигналов RS-232C

Рис. 3. Прием сигналов RS-232C

Кабели подключения модемов

Рис. 4. Кабели подключения модемов

Рис. 5. Нуль-модемный кабель: а — минимальный, б — полный

Если на каком-либо устройстве АПД установлена розетка — это почти 100 % того, что к другому устройству оно должно подключаться прямым кабелем, аналогичным кабелю подключения модема. Розетка устанавливается обычно на тех устройствах, у которых удаленное подключение через модем не предусмотрено.

В табл. 1 приведено назначение контактов разъемов COM-портов (и любой другой аппаратуры передачи данных АПД). Контакты разъема DB-25S определены стандартом EIA/TIA-232-E, разъем DB-9S описан стандартом EIA/TIA-574. У модемов (АКД) название цепей и контактов такое же, но роли сигналов (вход-выход) меняются на противоположные.

Таблица 1. Разъемы и сигналы интерфейса RS-232C

Обозначение цепи |  |  | Контакт разъема |  | № провода кабеля выносного разъема PC |  |  |  | Направление
COM- | RS- | V.24 | DB- | DB- | 11 | 22 | 33 | 44 | I/O
порт | 232 | Стык 2 | 25P | 9P |  |  |  |  |
PG | AA | 101 | 1 | 5 | (10) | (10) | (10) | 1 | –
SG | AB | 102 | 7 | 5 | 5 | 9 | 1 | 13 | –
TD | BA | 103 | 2 | 3 | 3 | 5 | 3 | 3 | O
RD | BB | 104 | 3 | 2 | 2 | 3 | 4 | 5 | I
RTS | CA | 105 | 4 | 7 | 7 | 4 | 8 | 7 | O
CTS | CB | 106 | 5 | 8 | 8 | 6 | 7 | 9 | I
DSR | CC | 107 | 6 | 6 | 6 | 2 | 9 | 11 | I
DTR | CD | 108/2 | 20 | 4 | 4 | 7 | 2 | 14 | O
DCD | CF | 109 | 8 | 1 | 1 | 1 | 5 | 15 | I
RI | CE | 125 | 22 | 9 | 9 | 8 | 6 | 18 | I

1 Ленточный кабель 8-битных мультикарт.

2 Ленточный кабель 16-битных мультикарт и портов на системных платах.

3 Вариант ленточного кабеля портов на системных платах.

4 Широкий ленточный кабель к 25-контактному разъему.

Подмножество сигналов RS-232C, относящихся к асинхронному режиму, рассмотрим с точки зрения COM-порта PC. Для удобства будем пользоваться мнемоникой названий, принятой в описаниях COM-портов и большинства устройств (она отличается от безликих обозначений RS-232 и V.24). Напомним, что активному состоянию управляющих сигналов (“включено”) и нулевому значению бита передаваемых данных соответствует положительный потенциал (выше +3 В) сигнала интерфейса, а состоянию “выключено” и единичному биту — отрицательный (ниже –3 В). Назначение сигналов интерфейса приведено в табл. 2. Нормальную последовательность управляющих сигналов для случая подключения модема к COM-порту иллюстрирует рис. 6.

Таблица 2. Назначение сигналов интерфейса RS-232C

Сигнал | Назначение
PG | Protected Ground — защитная земля, соединяется с корпусом устройства и экраном кабеля
SG | Signal Ground — сигнальная (схемная) земля, относительно которой действуют уровни сигналов
TD | Transmit Data — последовательные данные — выход передатчика
RD | Receive Data — последовательные данные — вход приемника
RTS | Request To Send — выход запроса передачи данных: состояние “включено” уведомляет модем о наличии у терминала данных для передачи. В полудуплексном режиме используется для управления направлением — состояние “включено” служит сигналом модему на переключение в режим передачи
CTS | Clear To Send — вход разрешения терминалу передавать данные. Состояние “выключено” запрещает передачу данных. Сигнал используется для аппаратного управления потоками данных
DSR | Data Set Ready — вход сигнала готовности от аппаратуры передачи данных (модем в рабочем режиме подключен к каналу и закончил действия по согласованию с аппаратурой на противоположном конце канала)
DTR | Data Terminal Ready — выход сигнала готовности терминала к обмену данными. Состояние “включено” поддерживает коммутируемый канал в состоянии соединения
DCD | Data Carrier Detected — вход сигнала обнаружения несущей удаленного модема
RI | Ring Indicator — вход индикатора вызова (звонка). В коммутируемом канале этим сигналом модем сигнализирует о принятии вызова

Последовательность управляющих сигналов интерфейса

Рис. 6. Последовательность управляющих сигналов интерфейса

  1. Установкой DTR компьютер указывает на желание использовать модем.

  2. Установкой DSR модем сигнализирует о своей готовности и установлении соединения.

  3. Сигналом RTS компьютер запрашивает разрешение на передачу и заявляет о своей готовности принимать данные от модема.

  4. Сигналом CTS модем уведомляет о своей готовности к приему данных от компьютера и передаче их в линию.

  5. Снятием CTS модем сигнализирует о невозможности дальнейшего приема (например, буфер заполнен) — компьютер должен приостановить передачу данных.

  6. Сигналом CTS модем разрешает компьютеру продолжить передачу (в буфере появилось место).

  7. Снятие RTS может означать как заполнение буфера компьютера (модем должен приостановить передачу данных в компьютер), так и отсутствие данных для передачи в модем. Обычно в этом случае модем прекращает пересылку данных в компьютер.

  8. Модем подтверждает снятие RTS сбросом CTS.

  9. Компьютер повторно устанавливает RTS для возобновления передачи.

  10. Модем подтверждает готовность к этим действиям.

  11. Компьютер указывает на завершение обмена.

  12. Модем отвечает подтверждением.

  13. Компьютер снимает DTR, что обычно является сигналом на разрыв соединения (“повесить трубку”).

  14. Модем сбросом DSR сигнализирует о разрыве соединения.

Из рассмотрения этой последовательности становятся понятными соединения DTR–DSR и RTS–CTS в нуль-модемных кабелях.

Асинхронный режим передачи

Асинхронный режим передачи является байт-ориентированным (символьно-ориентированным): минимальная пересылаемая единица информации — один байт (один символ). Формат посылки байта иллюстрирует рис. 7. Передача каждого байта начинается со старт-бита, сигнализирующего приемнику о начале посылки, за которым следуют биты данных и, возможно, бит четности (Parity). Завершает посылку стоп-бит, гарантирующий паузу между посылками. Старт-бит следующего байта посылается в любой момент после стоп-бита, то есть между передачами возможны паузы произвольной длительности. Старт-бит, имеющий всегда строго определенное значение (логический 0), обеспечивает простой механизм синхронизации приемника по сигналу от передатчика. Подразумевается, что приемник и передатчик работают на одной скорости обмена. Внутренний генератор синхронизации приемника использует счетчик-делитель опорной частоты, обнуляемый в момент приема начала старт-бита. Этот счетчик генерирует внутренние стробы, по которым приемник фиксирует последующие принимаемые биты. В идеале стробы располагаются в середине битовых интервалов, что позволяет принимать данные и при незначительном рассогласовании скоростей приемника и передатчика. Очевидно, что при передаче 8 бит данных, одного контрольного и одного стоп-бита предельно допустимое рассогласование скоростей, при котором данные будут распознаны верно, не может превышать 5 %. С учетом фазовых искажений и дискретности работы внутреннего счетчика синхронизации реально допустимо меньшее отклонение частот. Чем меньше коэффициент деления опорной частоты внутреннего генератора (чем выше частота передачи), тем больше погрешность привязки стробов к середине битового интервала, и требования к согласованности частот становятся более строгие. Чем выше частота передачи, тем больше влияние искажений фронтов на фазу принимаемого сигнала. Взаимодействие этих факторов приводит к повышению требований к согласованности частот приемника и передатчика с ростом частоты обмена.

Формат асинхронной передачи RS-232C

Рис. 7. Формат асинхронной передачи RS-232C

Формат асинхронной посылки позволяет выявлять возможные ошибки передачи.

Формат асинхронной посылки позволяет выявлять возможные ошибки передачи.

  • Если принят перепад, сигнализирующий о начале посылки, а по стробу старт-бита зафиксирован уровень логической единицы, старт-бит считается ложным и приемник снова переходит в состояние ожидания. Об этой ошибке приемник может не сообщать.

  • Если во время, отведенное под стоп-бит, обнаружен уровень логического нуля, фиксируется ошибка стоп-бита.

  • Если применяется контроль четности, то после посылки бит данных передается контрольный бит. Этот бит дополняет количество единичных бит данных до четного или нечетного в зависимости от принятого соглашения. Прием байта с неверным значением контрольного бита приводит к фиксации ошибки.

  • Контроль формата позволяет обнаруживать обрыв линии: как правило, при обрыве приемник “видит” логический нуль, который сначала трактуется как старт-бит и нулевые биты данных, но потом срабатывает контроль стоп-бита.

Для асинхронного режима принят ряд стандартных скоростей обмена: 50, 75, 110, 150, 300, 600, 1200, 2400, 4800, 9600, 19200, 38400, 57600 и 115200 бит/с. Иногда вместо единицы измерения “бит/с” используют “бод” (baud), но при рассмотрении двоичных передаваемых сигналов это некорректно. В бодах принято измерять частоту изменения состояния линии, а при недвоичном способе кодирования (широко применяемом в современных модемах) в канале связи скорости передачи бит (бит/с) и изменения сигнала (бод) могут отличаться в несколько раз.

Количество бит данных может составлять 5, 6, 7 или 8 (5- и 6-битные форматы распространены незначительно). Количество стоп-бит может быть 1, 1,5 или 2 (“полтора бита” означает только длительность стопового интервала).

Управление потоком данных

Для управления потоком данных (Flow Control) могут использоваться два варианта протокола — аппаратный и программный. Иногда управление потоком путают с квитированием. Квитирование (handshaking) подразумевает посылку уведомления о получении элемента, в то время как управление потоком предполагает посылку уведомления о возможности или невозможности последующего приема данных. Зачастую управление потоком основано на механизме квитирования.

Аппаратный протокол управления потоком RTS/CTS (hardware flow control) использует сигнал CTS, который позволяет остановить передачу данных, если приемник не готов к их приему (рис. 8). Передатчик “выпускает” очередной байт только при включенной линии CTS. Байт, который уже начал передаваться, задержать сигналом CTS невозможно (это гарантирует целостность посылки). Аппаратный протокол обеспечивает самую быструю реакцию передатчика на состояние приемника. Микросхемы асинхронных приемопередатчиков имеют не менее двух регистров в приемной части — сдвигающий, для приема очередной посылки, и хранящий, из которого считывается принятый байт. Это позволяет реализовать обмен по аппаратному протоколу без потери данных.

Аппаратное управление потоком

Рис. 8. Аппаратное управление потоком

Аппаратный протокол удобно использовать при подключении принтеров и плоттеров, если они его поддерживают. При непосредственном (без модемов) соединении двух компьютеров аппаратный протокол требует перекрестного соединения линий RTS — CTS.

При непосредственном соединении у передающего терминала должно быть обеспечено состояние “включено” на линии CTS (соединением собственных линий RTS — CTS), в противном случае передатчик будет “молчать”.

Применяемые в IBM PC приемопередатчики 8250/16450/16550 сигнал CTS аппаратно не отрабатывают, а только показывают его состояние в регистре MSR. Реализация протокола RTS/CTS возлагается на драйвер BIOS Int 14h, и называть его “аппаратным” не совсем корректно. Если же программа, пользующаяся COM-портом, взаимодействует с UART на уровне регистров (а не через BIOS), то обработкой сигнала CTS для поддержки данного протокола она занимается сама. Ряд коммуникационных программ позволяет игнорировать сигнал CTS (если не используется модем), и для них не требуется соединение входа CTS с выходом даже своего сигнала RTS. Однако существуют и иные приемопередатчики (например, 8251), в которых сигнал CTS отрабатывается аппаратно. Для них, а также для “честных” программ, использование сигнала CTS на разъемах (а то и на кабелях) обязательно.

Программный протокол управления потоком XON/XOFF предполагает наличие двунаправленного канала передачи данных. Работает протокол следующим образом: если устройство, принимающее данные, обнаруживает причины, по которым оно не может их дальше принимать, оно по обратному последовательному каналу посылает байт-символ XOFF (13h). Противоположное устройство, приняв этот символ, приостанавливает передачу. Когда принимающее устройство снова становится готовым к приему данных, оно посылает символ XON (11h), приняв который противоположное устройство возобновляет передачу. Время реакции передатчика на изменение состояния приемника по сравнению с аппаратным протоколом увеличивается, по крайней мере, на время передачи символа (XON или XOFF) плюс время реакции программы передатчика на прием символа (рис. 9). Из этого следует, что данные без потерь могут приниматься только приемником, имеющим дополнительный буфер принимаемых данных и сигнализирующим о неготовности заблаговременно (имея в буфере свободное место).

Программное управление потоком XON/XOFF

Рис. 9. Программное управление потоком XON/XOFF

Преимущество программного протокола заключается в отсутствии необходимости передачи управляющих сигналов интерфейса — минимальный кабель для двустороннего обмена может иметь только 3 провода (см. рис. 5, а). Недостатком, помимо обязательного наличия буфера и большего времени реакции (снижающего общую производительность канала из-за ожидания сигнала XON), является сложность реализации полнодуплексного режима обмена. В этом случае из потока принимаемых данных должны выделяться (и обрабатываться) символы управления потоком, что ограничивает набор передаваемых символов.

Кроме этих двух распространенных стандартных протоколов, поддерживаемых и ПУ, и ОС, существуют и другие.


Последовательный интерфейс RS-232

Широко используемый последовательный интерфейс синхронной и асинхронной передачи данных, определяемый стандартом EIA RS-232-C и рекомендациями V.24 CCITT. Изначально создавался для связи компьютера с терминалом. В настоящее время используется в самых различных применениях.

Интерфейс RS-232-C соединяет два устройства. Линия передачи первого устройства соединяется с линией приема второго и наоборот (полный дуплекс) Для управления соединенными устройствами используется программное подтверждение (введение в поток передаваемых данных соответствующих управляющих символов). Возможна организация аппаратного подтверждения путем организации дополнительных RS-232 линий для обеспечения функций определения статуса и управления.

Стандарт | EIA RS-232-C, CCITT V.24
Скорость передачи | 115 Кбит/с (максимум)
Расстояние передачи | 15 м (максимум)
Характер сигнала | несимметричный по напряжению
Количество драйверов | 1
Количество приемников | 1
Схема соединения | полный дуплекс, от точки к точке

Порядок обмена по интерфейсу RS-232C

Наименование | Направление | Описание | Контакт (25-контактный разъем) | Контакт (9-контактный разъем)
DCD | IN | Carrier Detect (Определение несущей) | 8 | 1
RXD | IN | Receive Data (Принимаемые данные) | 3 | 2
TXD | OUT | Transmit Data (Передаваемые данные) | 2 | 3
DTR | OUT | Data Terminal Ready (Готовность терминала) | 20 | 4
GND | - | System Ground (Корпус системы) | 7 | 5
DSR | IN | Data Set Ready (Готовность данных) | 6 | 6
RTS | OUT | Request to Send (Запрос на отправку) | 4 | 7
CTS | IN | Clear to Send (Готовность приема) | 5 | 8
RI | IN | Ring Indicator (Индикатор) | 22 | 9

Интерфейс RS-232C предназначен для подключения к компьютеру стандартных внешних устройств (принтера, сканера, модема, мыши и др.), а также для связи компьютеров между собой. Основными преимуществами использования RS-232C по сравнению с Centronics являются возможность передачи на значительно большие расстояния и гораздо более простой соединительный кабель. В то же время работать с ним несколько сложнее. Данные в RS-232C передаются в последовательном коде побайтно. Каждый байт обрамляется стартовым и стоповыми битами. Данные могут передаваться как в одну, так и в другую сторону (дуплексный режим).

Компьютер имеет 25-контактный (DB25P) или 9-контактный (DB9P) разъем для подключения RS-232C. Назначение контактов разъема приведено в таблице.

Назначение сигналов следующее:

FG - защитное заземление (экран).
TxD - данные, передаваемые компьютером в последовательном коде (логика отрицательная).
RxD - данные, принимаемые компьютером в последовательном коде (логика отрицательная).
RTS - сигнал запроса передачи. Активен во все время передачи.
CTS - сигнал сброса (очистки) для передачи. Активен во все время передачи. Говорит о готовности приемника.
DSR - готовность данных. Используется для задания режима модема.
SG - сигнальное заземление, нулевой провод.
DCD - обнаружение несущей данных (детектирование принимаемого сигнала).
DTR - готовность выходных данных.
RI - индикатор вызова. Говорит о приеме модемом сигнала вызова по телефонной сети.

Наиболее часто используются трех- или четырехпроводная связь (для двунапрвленной передачи). Схема соединения для четырехпроводной линии связи показана на рисунке 1.1.

Для двухпроводной линии связи в случае только передачи из компьютера во внешнее устройство используются сигналы SG и TxD. Все 10 сигналов интерфейса задействуются только при соединении компьютера с модемом.

Формат передаваемых данных показан на рисунке 1.2. Собственно данные (5, 6, 7 или 8 бит) соопровождаются стартовым битом, битом четности и одним или двумя стоповыми битами. Получив стартовый бит, приемник выбирает из линии биты данных через определннные интервалы времени. Очень важно, чтобы тактовые частоты приемника и передатчика были одинаковыми, допустимое расхождение - не более 10%). Скорость передачи по RS-232C может выбираться из ряда: 110, 150, 300, 600, 1200, 2400, 4800, 9600, 19200, 38400, 57600, 115200 бит/с.

Рис.1.1 Схема 4-проводной линии связи для RS-232C

Все сигналы RS-232C передаются специально выбранными уровнями, обеспечивающими высокую помехоустойчивость связи (рис.1.3.). Отметим, что данные передаются в инверсном коде (лоической единице соответствует низкий уровень, логическому нулю - высокий уровень).

Для подключения произвольного УС к компьютеру через RS-232C обычно используют трех- или четырехпроводную линию связи (см. рис. 1.1), но можно задействовать и другие сигналы интерфейса.

Рис.1.2 Формат данных RS-232C

Обмен по RS-232C осуществляется с помощью обращений по специально выделенным для этого портам COM1 (адреса 3F8h...3FFh, прерывание IRQ4), COM2 (адреса 2F8h...2FFh, прерывание IRQ3), COM3 (адреса 3F8h...3EFh, прерывание IRQ10), COM4 (адреса 2E8h...2EFh, прерывание IRQ11). Форматы обращений по этим адресам можно найти в многочисленных описаниях микросхем контроллеров последовательного обмена UART (Universal Asynchronous Receiver/Transmitter), например, i8250, КР580ВВ51.

Рис.1.3 Уровни сигналов RS-232C на передающем и принимающем концах линии связи.


Распиновка всех разьемов компьютера

Обычно блок питания компьютера имеет 6 или 5 коннекторов: 4 (4х пиновых) для питания приводов и 2 (6ти пиновых) (AT) или 1 (20ти пиновый) (ATX) - для материнской платы.

Разъемы питания материнской платы

AT разъемы питания материнской платы

P8

№ | Сигнал | Цвет
1 | Power Good | оранжевый
2 | +5В | красный
3 | +12В | желтый
4 | -12В | голубой
5 | корпус | черный
6 | корпус | черный

P9

№ | Сигнал | Цвет
1 | корпус | черный
2 | корпус | черный
3 | -5В | белый
4 | +5В | красный
5 | +5В | красный
6 | +5В | красный

ATX разъем питания материнской платы

№ | Сигнал | № | Сигнал
1* | +3,3 В | 11 | +3,3 В
2 | +3,3 В | 12 | -12 В
3 | Земля | 13* | Земля
4 | +5 В | 14* | Power Supply On
5 | Земля | 15 | Земля
6 | +5 В | 16 | Земля
7 | Земля | 17 | Земля
8 | Power Good | 18 | -5 В
9 | +5 В Standby | 19 | +5 В
10 | +12 В | 20 | +5 В

Разъем питания приводов

№ | Сигнал | Цвет
1 | +12В | желтый
2 | корпус | черный
3 | корпус | черный
4 | +5В | красный

Разъемы для подключения клавиатуры

Внимание! контакты нумеруются не по кругу, обращайте внимание на цифру, стоящую возле контакта.

DIN5

PS/2

№ | Сигнал | Назначение
1 | Тактовая частота | Выход
2 | Линия данных | Вход/Выход
3 | Сброс | -
4 | Корпус | Вход
5 | +5В | Вход

№ | Сигнал | Вход/Выход
1 | Линия данных | Вход/Выход
2 | Не подключен | Резерв
3 | Корпус | Вход
4 | +5В | Вход
5 | Тактовая частота | Выход
6 | Не подключен | Резерв

Разъем мыши для COM-порта. (DB-9)

№ | Сигнал
1 | MouseData
5 | GND
8 | +5V
9 | MouseClock

Разъем кабеля USB

№ | Сигнал | № | Сигнал
A1 | Vcc | B1 | Vcc
A2 | Port0 data+ | B2 | Port1 data+
A3 | Port0 data- | B3 | Port1 data-
A4 | GND | B4 | GND

Разъем инфракрасного модуля

№ | Сигнал
1 | IRTX
2 | GND
3 | IRRX
4 | N/C
5 | Vcc

Разъем RJ-45 (для соединения витой парой)

(кабель направлен от смотрящего)

При соединении компьютер - хаб используется раскладка "нормально". При каскадировании хабов или при подключении компьютер - компьютер (без хаба) используется раскладка "uplink" на одном конце кабеля, и "нормально" на другом.

№ | нормально | uplink
1 | коричневый | коричневый
2 | бело-коричневый | бело-коричневый
3 | зеленый | оранжевый
4 | бело-синий | бело-синий
5 | синий | синий
6 | бело-зеленый | бело-оранжевый
7 | оранжевый | зеленый
8 | бело-оранжевый | бело-зеленый

Кабель для подключения дисководов

Жилы с 10 по 16 перекручены - необходимо для идентификации дисковода.

Нечетные контакты - корпус.

№ | Вход/Выход | Сигнал | Значение
2 | Вход | High/normal density | Высокая/нормативная плотность записи
4 | Вход | Unused | Спецификация производителя
6 | Вход | Unused | Спецификация производителя
8 | Выход | Index | Идентификация индексного отверстия
10 | Вход | Motor Enable 0 | Двигатель дисковода A: включен
12 | Вход | Drive Select 1 | Активизация привода B:
14 | Вход | Drive Select 0 | Активизация привода A:
16 | Вход | Motor Enable 1 | Двигатель дисковода B: включен
18 | Вход | Direction Select | Указание направления для головки
20 | Вход | Step | Импульс для движения головки
22 | Вход | Write Data | Запись данных
24 | Вход | Write Gate | Сигнал для перезаписи данных
26 | Выход | Track 00 | Головка стоит на нулевой дорожке
28 | Выход | Write Protect | Наличие защиты диска от записи
30 | Выход | Read Data | Чтение данных
32 | Вход | Side Select | Доступ на первую или вторую сторону
34 | Выход | Drive Status | Готовность привода

Кабель для подключения IDE устройств

Контакт | Вход/Выход | Сигнал | Значение
1 | Выход | Reset | Сброс
2 | - | GND | Корпус
3 | Вход/Выход | HD7 | Линия данных 7
4 | Вход/Выход | HD8 | Линия данных 8
5 | Вход/Выход | HD6 | Линия данных 6
6 | Вход/Выход | HD9 | Линия данных 9
7 | Вход/Выход | HD5 | Линия данных 5
8 | Вход/Выход | HD10 | Линия данных 10
9 | Вход/Выход | HD4 | Линия данных 4
10 | Вход/Выход | HD11 | Линия данных 11
11 | Вход/Выход | HD3 | Линия данных 3
12 | Вход/Выход | HD12 | Линия данных 12
13 | Вход/Выход | HD2 | Линия данных 2
14 | Вход/Выход | HD13 | Линия данных 13
15 | Вход/Выход | HD1 | Линия данных 1
16 | Вход/Выход | HD14 | Линия данных 14
17 | Вход/Выход | HD0 | Линия данных 0
18 | Вход/Выход | HD15 | Линия данных 15
19 | - | GND | Корпус
20 | - | KEY | Ключ разъема (отсутствует)
21 | - | Reserved | Зарезервировано
22 | - | GND | Корпус
23 | Выход | IOW | Строб чтения
24 | - | GND | Корпус
25 | Выход | IOR | Строб записи
26 | - | GND | Корпус
27 | Вход | IOCHRDY | Готовность канала ввода/вывода
28 | Выход | ALE | Строб адреса
29 | - | Reserved | Зарезервировано
30 | - | GND | Корпус
31 | Вход | IRQ14 | Запрос на прерывание
32 | Вход | HIO16 | Признак обращения к 16-разрядному порту
33 | Выход | HA1 | Линия адреса 1
34 | Вход/Выход | Reserved | Зарезервировано
35 | Выход | HA0 | Линия адреса 0
36 | Выход | HA2 | Линия адреса 2
37 | Выход | CS0 | Выбор диска 1
38 | Выход | CS1 | Выбор диска 2
39 | Вход/Выход | ACTIV | Подтверждение выбора диска
40 | - | GND | Корпус

Параллельный интерфейс

Назначение контактов разъемов кабеля Centronics

25 pin | 36 pin | Сигнал | Вход/Выход | Значение
1 | 1 | STROBE | Выход | Готовность данных
2 | 2 | D0 | Выход | 1 бит данных
3 | 3 | D1 | Выход | 2 бит данных
4 | 4 | D2 | Выход | 3 бит данных
5 | 5 | D3 | Выход | 4 бит данных
6 | 6 | D4 | Выход | 5 бит данных
7 | 7 | D5 | Выход | 6 бит данных
8 | 8 | D6 | Выход | 7 бит данных
9 | 9 | D7 | Выход | 8 бит данных
10 | 10 | ACK | Вход | Контроль приема данных
11 | 11 | BUSY | Вход | Принтер не готов к приему (занят)
12 | 12 | PE | Вход | Конец бумаги
13 | 13 | SLCT | Вход | Контроль состояния принтера
14 | 14 | AF | Выход | Автоматический перевод строки (LF) после перевода каретки (CR)
15 | 32 | ERROR | Вход | Ошибка
16 | 31 | INIT | Выход | Инициализация принтера
17 | 36 | SLCT IN | Выход | Принтер в состоянии on-line
18 | 33 | GND | - | Корпус
19 | 19 | GND | - | Корпус
20 | 20 | GND | - | Корпус
21 | 21 | GND | - | Корпус
22 | 22 | GND | - | Корпус
23 | 23 | GND | - | Корпус
24 | 24 | GND | - | Корпус
25 | 25 | GND | - | Корпус
- | 15 | GND/NC | - | Корпус/свободный
- | 16 | GND/NC | - | Корпус/свободный
- | 17 | GND | - | Корпус для монтажной платы принтера
- | 18 | +5V DC | Вход | +5 В
- | 26 | GND | - | Корпус
- | 27 | GND | - | Корпус
- | 28 | GND | - | Корпус
- | 29 | GND | - | Корпус
- | 30 | GND | - | Корпус
- | 34 | NC | - | Свободный
- | 35 | +5V DC/NC | - | +5 В/свободный

Последовательная передача данных

Назначение контактов разъемов последовательного интерфейса (RS-232)

DB9 | DB25 | Сигнал | Вход/Выход | Значение
1 | 8 | DCD (Data Carrier Detect) | Вход | Обнаружение несущей данных
2 | 3 | RXD (Recive Data) | Вход | Принимаемые данные
3 | 2 | TXD (Transmit Data) | Выход | Передаваемые данные
4 | 20 | DTR (Data Terminal Ready) | Выход | Готовность терминала
5 | 7 | GND (Ground) | Корпус | Сигнальная земля
6 | 6 | DSR (Data Set Ready) | Вход | Готовность модема
7 | 4 | RTS (Request To Send) | Выход | Запрос передачи
8 | 5 | CTS (Clear To Send) | Вход | Сброс для передачи
9 | 22 | RI (Ring Indicator) | Вход | Индикатор звонка

Кабель Null-Modem

Переходник с PS/2 на 9ти контактный RS232

PS/2 | RS232
1 | 1
2 | Не занят
3 | 3, связан с контактом 5
4 | Связан с контактами 7 и 9
5 | 6
6 | Не занят

Назначение выводов 9ти контактного разъема для подключения цифрового (TTL) монитора

№ | Сигнал цветного монитора (EGA) | Сигнал монохромного монитора (MDA) | Сигнал цветного монитора (CGA)
1 | Корпус | Корпус | Корпус
2 | Контрольный красный | Корпус | Корпус
3 | Красный | Свободный | Красный
4 | Зеленый | Свободный | Зеленый
5 | Синий | Свободный | Синий
6 | Контрольный зеленый | Интенсивность | Интенсивность
7 | Контрольный синий | Видеосигнал | Видеосигнал
8 | Сигнал синхронизации по горизонтали | Сигнал синхронизации по горизонтали | Сигнал синхронизации по горизонтали
9 | Сигнал синхронизации по вертикали | Сигнал синхронизации по вертикали | Сигнал синхронизации по вертикали

Назначение выводов 15ти контактного разъема для
подключения аналогового монитора

№ | Назначение | Сигнал цветного монитора | Сигнал монохромного монитора
1 | Красный | Красный | Нет вывода
2 | Зеленый | Зеленый | Вход видеосигнала
3 | Синий | Синий | Нет вывода
4 | Свободный | Свободный | Нет вывода
5 | Корпус | Тестирование | Тестирование
6 | Контрольный красный (корпус) | Контрольный красный | Контрольный красный
7 | Контрольный зеленый (корпус) | Контрольный зеленый | Контроль видеосигнала
8 | Контрольный синий (корпус) | Контрольный синий | Нет вывода
9 | Управление | Нет вывода | Нет вывода
10 | Контроль синхроимпульсов (корпус) | Корпус | Корпус
11 | Сигнал ID монитора | Корпус | Нет вывода
12 | Сигнал ID монитора | Свободный | Корпус
13 | Синхронизация по горизонтали | Сигнал синхронизации по горизонтали | Сигнал синхронизации по горизонтали
14 | Синхронизация по вертикали | Сигнал синхронизации по вертикали | Сигнал синхронизации по вертикали
15 | Свободный | Нет вывода | Нет вывода

Переходник 9 на 15 контактов

Назначение вывода 9ти контактного разъема | № | № | Назначение вывода 15ти контактного разъема
Красный | 1 | 1 | Красный
Зеленый | 2 | 2 | Зеленый
Синий | 3 | 3 | Синий
Синхронизация по горизонтали | 4 | 13 | Синхронизация по горизонтали
Синхронизация по вертикали | 5 | 14 | Синхронизация по вертикали
Красный (корпус) | 6 | 6 | Контрольный красный
Зеленый (корпус) | 7 | 7 | Контрольный зеленый
Синий (корпус) | 8 | 8 | Контрольный синий
Синхросигнал (корпус) | 9 | 10 | Корпус (цифровой)
 |  | 5 | Корпус

Назначение выводов игрового порта

№ | Сигнал
1 | +5В
2 | Кнопка 4
3 | Позиция 0
4 | Корпус
5 | Корпус
6 | Позиция 1
7 | Кнопка 5
8 | +5В
9 | +5В
10 | Кнопка 6
11 | Позиция 2
12 | Корпус
13 | Позиция 3
14 | Кнопка 7
15 | +5В

Слоты расширения материнской платы

(не совсем про кабели, но пригодится)

8ми битный слот

Сторона монтажа |  |  | Сторона пайки
№ | Сигнал | Значение | № | Сигнал | Значение
A1 | I/O CH CK | Контроль канала ввода-вывода | B1 | GND | Земля
A2 | D7 | Линия данных 8 | B2 | RES DRV | Сигнал Reset
A3 | D6 | Линия данных 7 | B3 | +5V | +5В
A4 | D5 | Линия данных 6 | B4 | IRQ2 | Запрос прерывания 2
A5 | D4 | Линия данных 5 | B5 | -5V | -5В
A6 | D3 | Линия данных 4 | B6 | DRQ2 | Запрос DMA 2
A7 | D2 | Линия данных 3 | B7 | -12V | -12В
A8 | D1 | Линия данных 2 | B8 | RES | Зарезервировано
A9 | D0 | Линия данных 1 | B9 | +12V | +12В
A10 | I/O CN RDY | Контроль готовности канала ввода-вывода | B10 | GND | Земля
A11 | AEN | Adress Enable, контроль за шиной при CPU и DMA-контроллере | B11 | MEMW | Данные записываются в память
A12 | A19 | Адресная линия 20 | B12 | MEMR | Данные считываются из памяти
A13 | A18 | Адресная линия 19 | B13 | IOW | Данные записываются в I/O порт
A14 | A17 | Адресная линия 18 | B14 | IOR | Данные читаются из I/O порта
A15 | A16 | Адресная линия 17 | B15 | DACK3 | DMA-Acknowledge (подтверждение) 3
A16 | A15 | Адресная линия 16 | B16 | DRQ3 | Запрос DMA 3
A17 | A14 | Адресная линия 15 | B17 | DACK1 | DMA-Acknowledge (подтверждение) 1
A18 | A13 | Адресная линия 14 | B18 | IRQ1 | Запрос прерывания 1
A19 | A12 | Адресная линия 13 | B19 | REFRESH | Регенерация памяти
A20 | A11 | Адресная линия 12 | B20 | CLC | Системный такт 4,77 МГц
A21 | A10 | Адресная линия 11 | B21 | IRQ7 | Запрос прерывания 7
A22 | A9 | Адресная линия 10 | B22 | IRQ6 | Запрос прерывания 6
A23 | A8 | Адресная линия 9 | B23 | IRQ5 | Запрос прерывания 5
A24 | A7 | Адресная линия 8 | B24 | IRQ4 | Запрос прерывания 4
A25 | A6 | Адресная линия 7 | B25 | IRQ3 | Запрос прерывания 3
A26 | A5 | Адресная линия 6 | B26 | DACK2 | DMA-Acknowledge (подтверждение) 2
A27 | A4 | Адресная линия 5 | B27 | T/C | Terminal Count, сигнализирует конец DMA-трансформации
A28 | A3 | Адресная линия 4 | B28 | ALE | Adress Latch Enabled, расстыковка адрес/данные
A29 | A2 | Адресная линия 3 | B29 | +5V | +5В
A30 | A1 | Адресная линия 2 | B30 | OSC | Частота тактового генератора 14,31818 МГц
A31 | A0 | Адресная линия 1 | B31 | GND | Земля

16ти битный слот

Сторона монтажа |  |  | Сторона пайки
№ | Сигнал | Значение | № | Сигнал | Значение
A1 | I/O CH CK | Контроль канала ввода-вывода | B1 | GND | Земля
A2 | D7 | Линия данных 8 | B2 | RES DRV | Сигнал Reset
A3 | D6 | Линия данных 7 | B3 | +5V | +5В
A4 | D5 | Линия данных 6 | B4 | IRQ9 | Каскадирование второго контроллера прерываний
A5 | D4 | Линия данных 5 | B5 | -5V | -5В
A6 | D3 | Линия данных 4 | B6 | DRQ2 | Запрос DMA 2
A7 | D2 | Линия данных 3 | B7 | -12V | -12В
A8 | D1 | Линия данных 2 | B8 | RES | Коммуникация с памятью без времени ожидания
A9 | D0 | Линия данных 1 | B9 | +12V | +12В
A10 | I/O CN RDY | Контроль готовности канала ввода-вывода | B10 | GND | Земля
A11 | AEN | Adress Enable, контроль за шиной при CPU и DMA-контроллере | B11 | SMEMW | Данные записываются в память (до 1М байта)
A12 | A19 | Адресная линия 20 | B12 | SMEMR | Данные считываются из памяти (до 1 Мбайта)
A13 | A18 | Адресная линия 19 | B13 | IOW | Данные записываются в I/O порт
A14 | A17 | Адресная линия 18 | B14 | IOR | Данные читаются из I/O порта
A15 | A16 | Адресная линия 17 | B15 | DACK3 | DMA-Acknowledge (подтверждение) 3
A16 | A15 | Адресная линия 16 | B16 | DR Q3 | Запрос DMA 3
A17 | A14 | Адресная линия 15 | B17 | DACK1 | DMA-Acknowledge (подтверждение) 1
A18 | A13 | Адресная линия 14 | B18 | IRQ1 | Запрос IRQ 1
A19 | A12 | Адресная линия 13 | B19 | REFRESH | Регенерация памяти
A20 | A11 | Адресная линия 12 | B20 | CLC | Системный такт 4,77 МГц
A21 | A10 | Адресная линия 11 | B21 | IRQ7 | Запрос IRQ 7
A22 | A9 | Адресная линия 10 | B22 | IRQ6 | Запрос IRQ 6
A23 | A8 | Адресная линия 9 | B23 | IRQ5 | Запрос IRQ 5
A24 | A7 | Адресная линия 8 | B24 | IRQ4 | Запрос IRQ 4
A25 | A6 | Адресная линия 7 | B25 | IRQ3 | Запрос IRQ 3
A26 | A5 | Адресная линия 6 | B26 | DACK2 | DMA-Acknowledge (подтверждение) 2
A27 | A4 | Адресная линия 5 | B27 | T/C | Terminal Count, сигнализирует конец DMA-трансформации
A28 | A3 | Адресная линия 4 | B28 | ALE | Adress Latch Enabled, расстыковка адрес/данные
A29 | A2 | Адресная линия 3 | B29 | +5V | +5В
A30 | A1 | Адресная линия 2 | B30 | OSC | Такт осциллятора 14,31818 МГц
A31 | A0 | Адресная линия 1 | B31 | GND | Земля
C1 | SBHE | System Bus High Enabled, сигнал для 16-разрядных данных | D1 | MEM CS 16 | Memory Chip Select (выбор)
C2 | LA23 | Адресная линия 24 | D2 | I/O CS 16 | I/O карта с 8 бит/16 бит переносом
C3 | LA22 | Адресная линия 23 | D3 | IRQ10 | Запрос прерывания 10
C4 | LA21 | Адресная линия 22 | D4 | IRQ11 | Запрос прерывания 11
C5 | LA20 | Адресная линия 21 | D5 | IRQ12 | Запрос прерывания 12
C6 | LA19 | Адресная линия 20 | D6 | IRQ15 | Запрос прерывания 15
C7 | LA18 | Адресная линия 19 | D7 | IRQ14 | Запрос прерывания 14
C8 | LA17 | Адресная линия 18 | D8 | DACK0 | DMA-Acknowledge (подтверждение) 0
C9 | MEMR | Чтение данных из памяти | D9 | DRQ0 | Запрос DMA 0
C10 | MEMW | Запись данных в память | D10 | DACK5 | DMA-Acknowledge (подтверждение) 5
C11 | SD8 | Линия данных 9 | D11 | DRQ5 | Запрос DMA 5
C12 | SD9 | Линия данных 10 | D12 | DACK6 | DMA-Acknowledge (подтверждение) 6
C13 | SD10 | Линия данных 11 | D13 | DRQ6 | Запрос DMA 6
C14 | SD11 | Линия данных 12 | D14 | DACK7 | DMA-Acknowledge (подтверждение) 7
C15 | SD12 | Линия данных 13 | D15 | DRQ7 | Запрос DMA 7
C16 | SD13 | Линия данных 14 | D16 | +5V | +5В
C17 | SD14 | Линия данных 15 | D17 | MASTER | Сигнал Busmaster
C18 | SD15 | Линия данных 16 | D18 | GND | Земля

Назначение выводов слота PCI

№ | Сигнал (сторона пайки) | Сигнал (сторона монтажа) | № | Сигнал (сторона пайки) | Сигнал (сторона монтажа)
1 | TRST# | -12V | 48 | GND | AD10
2 | +12V | TCK | 49 | AD09 | GND
3 | TMS | GND | 50 | GND/5V | GND/5V
4 | TDI | TDO | 51 | GND/5V | GND/5V
5 | +5V | +5V | 52 | C/BE0 | AD08
6 | INTA# | +5V | 53 | +3,3V | AD07
7 | INTC# | INTB# | 54 | AD06 | +3,3V
8 | +5V | INTD# | 55 | AD04 | AD05
9 | Reserved | PRSNT1# | 56 | GND | AD03
10 | +5V | Reserved | 57 | AD02 | GND
11 | Reserved | PRSNT2 | 58 | AD00 | AD01
12 | GND/3,3V | GND/3,3V | 59 | +5V | +5V
13 | GND/3,3V | GND/3,3V | 60 | REQ64# | ACK64#
14 | Reserved | Reserved | 61 | +5V | +5V
15 | RST# | GND | 62 | +5V | +5V
16 | +5V | CLK | 63 | GND | Reserved
17 | GNT# | GND | 64 | C/BE7# | GND
18 | GND | REQ# | 65 | C/BE5# | C/BE6#
19 | Reserved | +5V | 66 | +5V | C/BE4#
20 | AD30 | AD31 | 67 | PAR64 | GND
21 | +3,3V | AD29 | 68 | AD62 | A63
22 | AD28 | GND | 69 | GND | A61
23 | AD26 | AD27 | 70 | AD60 | +5V
24 | GND | AD25 | 71 | AD58 | AD59
25 | AD24 | +3,3V | 72 | GND | AD57
26 | IDSEL | C/BE3# | 73 | AD56 | GND
27 | +3,3V | AD23 | 74 | AD54 | AD55
28 | AD22 | GND | 75 | +5V | AD53
29 | AD20 | AD21 | 76 | AD52 | GND
30 | GND | AD19 | 77 | AD50 | AD51
31 | AD18 | +3,3V | 78 | GND | AD49
32 | AD16 | AD17 | 79 | AD48 | GND
33 | 3,3V | C/BE2#80 | 80 | AD46 | AD47
34 | FRAME# | GND | 81 | GND | AD45
35 | GND | IRDY# | 82 | AD44 | GND
36 | TRDY# | 3,3V | 83 | AD42 | AD43
37 | GND | DEVSEL# | 84 | +5V | AD41
38 | STOP# | GND | 85 | AD40 | GND
39 | +3,3V | LOCK# | 86 | AD38 | AD39
40 | SDONE | PERR# | 87 | GND | AD37
41 | SBO# | +3,3V | 88 | AD36 | +5V
42 | GND | SERR# | 89 | AD34 | AD35
43 | PAR | +3,3V | 90 | GND | AD33
44 | AD15 | C/BE1 | 91 | AD32 | GND
45 | +3,3V | AD14 | 92 | Reserved | Reserved
46 | AD13 | GND | 93 | GND | Reserved
47 | AD11 | AD12 | 94 | Reserved | GND


Проектирование устройств обработки сигналов

С задачей разработки устройств обмена данными в той или иной мере сталкивался практически каждый разработчик. В случае выбора протокола для нового изделия всегда встает вопрос о компромиссе между сложностью аппаратных средств интерфейса («амуниции») и протоколом передачей данных («конституции»). Кроме того, присматриваясь к новомодному интерфейсу, не следует забывать, что очень часто в наших скромных задачах достаточно возможностей старого доброго RS232 или RS485, реализация которых к тому же исключительно дешева и многократно отработана.

Последние несколько лет помимо прочих прелестей принесли разработчику и целый букет новых интерфейсов, позволяющих без помех передавать большие объемы информации на значительное расстояние. Современные ПЛИС ведущих производителей [2, 3] имеют встроенную аппаратную реализацию таких интерфейсов, как GTL, LVDS. Однако практически вся современная элементная база устройств обработки сигналов рассчитана на работу от питающего напряжения не выше 3,3 В, что вызывает необходимость разработки способов сопряжения указанных интерфейсов с традиционными. В то же время на русском языке практически отсутствует литература по этому вопросу. Многие компании опубликовали руководства по применению ИС для реализации технических средств интерфейса [4], но, к сожалению, они не всегда доступны российскому читателю.

Области применения интерфейсов передачи данных

Рис. 1. Области применения интерфейсов передачи данных

На рис. 1 представлены области использования различных интерфейсов передачи данных в координатах расстояние — скорость передачи.

Как нетрудно заметить, если требуется передача информации на расстояние больше нескольких десятков сантиметров, стандартные логические уровни оказываются неудовлетворительными. На помощь приходят специализированные протоколы. Какой же из них выбрать для разрабатываемой системы? Какая элементная база позволит реализовать его аппаратно? Каковы особенности применения данного интерфейса? Дать ответ на эти вопросы предстоит в этом занятии школы.

При выборе протокола передачи данных следует обращать внимание на несколько основных параметров. Это скорость передачи данных, расстояние между источником и приемником данных, заранее заданные уровни сигналов, совместимость, вид интерфейса (параллельный или последовательный). В табл. 1 приведена краткая характеристика основных интерфейсов и данные об основных производителях ИС, их поддерживающих. Разумеется, последний столбец отражает лишь малую толику существующих решений — в тех случаях, когда производителей слишком много, в таблице скромно указано семейство ИС.

Таблица 1. Интерфейсы передачи данных

Тип интерфейса | Скорость передачи данных по одной линии, Мбит/с | Расстояние между источником и приемником данных, м | Стандарт | Производители элементной базы, поддерживающие интерфейс или семейства ИС
Последовательный | 25/50 | 1,5 | IEEE1394 - 1995 | Texas Instruments, Intel и др.
 | 100-400 | 4,5 | IEEE1394-1995/p1394.a | Texas Instruments, Intel и др.
 | 12 | 5 | USB2.0 | Texas Instruments, Intel и др.
 | 35 | 10 (1200) | TIA/EIA485(RS-485)(ISO8482) | Texas Instruments, Analog Devices, Maxim, Sipex и др.
 | 200 | 0,5 | LVDM (в разработке) | LVDM
 | 10 | 10 (1200) | TIA/EIA422(RS-422)(ITU-TV.11) | Texas Instruments, Analog Devices, Maxim, Sipex и др.
 | 200/100 | 0,5/10 | TIA/EIA644(LVDS)(в разработке) | LVDS
 | 512 Кбит/с | 20 | TIA/EIA232(RS-232)(ITU-TV.28) | Texas Instruments, Analog Devices, Maxim, Sipex и др.
Параллельно-последовательный, последовательно-параллельный | 455 | До 10 | TIA/EIA644 (LVDS) | Texas Instruments и др.
 | 1,25 Гбит/с | До 10 | IEEE P802.3z | Texas Instruments и др.
 | 2,5 Гбит/с | До 10 | IEEE P802.3z | Texas Instruments и др.
 | 35 | 10 (1200) | TIA/EIA485 (RS-485)(ISO8482) | Texas Instruments, Analog Devices, Maxim, Sipex и др.
 | 40/20 | 12/25 | SCSI | Многие производители
 | 40 | 12 | LVD-SCSI | Многие производители
 | 200/100 | 0,5/10 | LVDM (в разработке) | LVDM
 | 33/66 | 0,2 | Compact PCI | TI, PLX, разработчики прошивок для ПЛИС
 | 33/66 | 0,2 | PCI | TI, PLX, разработчики прошивок для ПЛИС
Параллельный | Тактовая частота до 4 МГц | 10 | IEEE Std1284-1994 | AC1284, LVC161284LV161284
 | Тактовая частота до 20 МГц | 0,5 | CMOS, JESD20, TTL, IEEE1014-1987 | AC, AHC, ABT, HC, HCT и др.
 | Тактовая частота до 33 МГц | 0,5 | LVTTL (JED8-A), IEEE1014-1987 | LVTH. ALVT
 | Тактовая частота до 40 МГц | 0,5 | VME64 StandardANSI/VITA1-1991 | ABTE
 | Тактовая частота до 60 МГц | 0,5 | IEEE Std1194.1-1991 | BTL/FB+
 | Тактовая частота до 60 МГц | 0,5 | JESD8-3 | GTL/GTL+
 | Тактовая частота до 100 МГц | 0,5 | JESD8-3 | GTLP
 | Тактовая частота до 200 МГц | 0,1 | EIA.JESD8-3,EIA/JESD8-9 | SSTL

По способу организации передачи данных различают однопроводные (single-ended) и дифференциальные (differential) интерфейсы. На рис. 2 приведена обобщенная схема однопроводного интерфейса При однопроводной передаче данных используется одна сигнальная линия, и ее логический уровень определяется относительно земли. Для простых медленных интерфейсов допускается использование общей земли. В более совершенных интерфейсах каждый сигнальный провод имеет свою землю, и оба провода, как правило, объединяются в витую пару. Преимуществом однопроводных систем является простота и дешевизна реализации. Поскольку каждая линия передачи данных требует только одного сигнального провода, они удобны для передачи параллельных данных на небольшое расстояние. Примером может служить привычный параллельный интерфейс принтера. Другой пример — последовательный интерфейс RS-232. Как видим, однопроводные интерфейсы часто применяются в тех случаях, когда решающим фактором является стоимость реализации.

Рис. 2. Однопроводный интерфейс

Основным недостатком однопроводных систем является их низкая помехоустойчивость. Из-за наводок на общий провод возможен сдвиг уровней сигналов, приводящий к ошибкам. При передаче на расстояния порядка нескольких метров начинает оказывать влияние индуктивность и емкость проводов.

Преодолеть указанные недостатки удается в дифференциальных системах. На рис. 3 приведена принципиальная схема реализации дифференциальной передачи данных.

Рис. 3. Дифференциальный интерфейс

Для балансной дифференциальной передачи данных используется пара проводов. На приемном конце линии вычисляется разность между сигналами. Заметим, что такой способ передачи данных пригоден не только для цифровых, но и для аналоговых линий. Ясно, что при дифференциальной передаче удается в значительной мере подавить синфазную помеху. Отсюда следует основное достоинство дифференциальных протоколов — высокая помехоустойчивость. Недаром один из самых распространенных протоколов в промышленных компьютерах — RS-485 построен по дифференциальной схеме.

Недостатком дифференциальных схем является их относительно высокая стоимость, а также сложности при выполнении парных согласованных каскадов передатчиков и приемников.

Рассмотрим физические параметры интерфейсов. В литературе принято следующее обозначение уровней.

  • VIH — входное напряжение высокого уровня (логической единицы);
  • VIL — входное напряжение низкого уровня (логического нуля);
  • VOH — выходное напряжение высокого уровня (логической единицы);
  • VOL — выходное напряжение низкого уровня (логического нуля).

На рис. 4 приведены логические уровни для однопроводных интерфейсов, а на рис. 5 — для дифференциальных.

Уровни сигналов в однопроводных интерфейсах

Рис. 4. Уровни сигналов в однопроводных интерфейсах

Далее мы рассмотрим несколько современных интерфейсов.

Интерфейс TIA/EIA — 644 (LVDS — Low voltage differential signaling), используется в скоростных системах передачи данных. Интерфейс LVDS использует дифференциальную передачу данных с довольно низкими уровнями сигналов. Разность сигналов составляет 300 мВ, линии нагружаются сопротивлением 100 Ом. Выходной ток передатчика составляет от 2,47 до 4,54 мА. Интерфейс TIA/EIA — 644 обладает лучшими характеристиками потребления по сравнению с TIA/EIA — 422 и может служить его заменой в новых разработках. Максимальная скорость передачи данных составляет 655 Мбит/с. Достоинство данного интерфейса — преемственность ИС приемопередатчиков по разводке с драйверами хорошо известных и применяемых интерфейсов RS-422 и RS-485. Данный подход позволяет использовать новые интерфейсы в уже разработанных платах [5], что облегчает переход на новую элементную базу.

Интерфейс LVDS поддерживают многие современные ПЛИС, такие как APEX фирмы ALTERA, Virtex фирмы Xilinx и ряд других. Типичными представителями драйверов этого интерфейса являются ИС SN65LVDS31/32, SN65LVDS179 фирмы Texas Instruments.

По электрическим свойствам к интерфейсу LVDS примыкает интерфейс LVDM. Этот протокол поддерживают ИС SN65LVDM176, SN65LVDM050.

Уровни сигналов в двухпроводных интерфейсах

Рис. 5. Уровни сигналов в двухпроводных интерфейсах

При проектировании однопроводных интерфейсов одной из центральных проблем является сопряжение различных устройств с объединительной или кросс-платой (backplane systems), особенно если требуется «горячая замена» узлов. Как правило, на объединительной плате приняты единые уровни сигналов, и задача разработчиков периферийных плат состоит в правильном выборе средств сопряжения. Следует заметить, что за долгую историю ТТЛ-уровни стали стандартом де-факто для объединительных плат и внутрифирменных (или внутриведомственных) интерфейсов. Поэтому при развитии существующих систем и применении новой элементной базы возникает необходимость в сопряжении новых плат с общей шиной. Для этих целей существует целый набор решений.

Как известно, классические ТТЛ и КМОП семейства ИС обеспечивают ток нагрузки до 24 мА при минимальном импедансе линии 50 Ом. С появлением БиКМОП технологии стало возможным достигнуть значения выходного тока –32/ 64 мА и работы на линию с импедансом 25 Ом. Для этих целей приспособлено семейство ИС SN74ABT25xxx. Данные микросхемы могут быть также использованы в системах так называемой «горячей замены» модулей, съемные модули могут подключаться или отключаться по ходу работы прибора.

При проектировании подключаемых модулей необходимо выполнить несколько требований, которые, во-первых, предупредят поломку модуля при подключении к работающей системе и, во-вторых, не приведут к сбоям в работе системы. Рассмотрим их.

Интерфейс между подключаемым и основным модулями состоит из шин питания, земли и сигнальных шин. Модель микросхемы, подключаемой к системе, показана на рис. 6.

Диоды на входе и выходе ИС

Рис. 6. Диоды на входе и выходе ИС

Защита входов и выходов микросхем осуществляется с использованием диодных ключей.

Диод D1 защищает микросхему от электростатических разрядов, ограничивая напряжение на входе микросхемы. Этого диода нет в микросхемах семейств ТТЛ, ЭСЛ и БиКМОП. Диод D2 — паразитный диод, появление которого предопределено структурой входа микросхем. В цифровых микросхемах дополнительно в этому диоду ставят еще один с меньшим сопротивлением для того, чтобы ограничивать пики напряжения, меньшие уровня логического нуля. Этот диод также защищает вход микросхемы от электростатического разряда. Очень часто для защиты входов цифровых схем применяют диодную сборку BAV99. Недавно в сети обнаружился забавный сайт, целиком посвященный сему объекту (bav99.narod.ru).

Для защиты выходов используются диоды Д3 и Д4. Диод D3 используется в микросхемах КМОП для защиты от электростатических разрядов. Диод D4 защищает от напряжения на выходе, меньшего уровня логического нуля.

При разработке подключаемых модулей лучше использовать микросхемы БиКМОП, поскольку они выгодно отличаются от прочих тем, что имеют схему (рис. 7), которая держит выход микросхемы в состоянии высокого импеданса в момент включения микросхемы. Эта цепь следит за напряжением питания и состоит из двух диодов D1 и D2 и транзистора Q1, на базу которого подается напряжение. При напряжении питания, которое меньше установленного (например, для серии ABT/BCT VCOFF~2,5 В, для LVT VCOFF~1,8 В), выход этой цепи переходит в состояние логической единицы. При этом он отключает сигнал на выходе микросхемы, независимо от входного. Это свойство микросхем БиКМОП гарантирует, что поведение схемы предсказуемо даже при очень низком напряжении питания.

Цепь, отключающая выход при пониженном напряжении питания в микросхемах БиКМОП

Рис. 7. Цепь, отключающая выход при пониженном напряжении питания в микросхемах БиКМОП

При горячем подключении модуля поведение системы будет предсказуемо, если соблюдаются по крайней мере два условия:

  • на разъеме есть один или несколько контактов земли, выдвинутых вперед относительно других контактов;
  • интерфейс состоит только из биполярных или БиКМОП микросхем с тристабильными выходами или с выходами с открытым коллектором.

Проблема конфликтов на шине стоит особенно остро, когда встречаются выходные сигналы разных уровней — низкого и высокого. На рис. 8 показан этот процесс. Ток, который возникает в результате конфликта, достигает 120 мА, и в этой борьбе выживает та микросхема, которая имеет на выходе низкий уровень. Микросхема с высоким уровнем на выходе работает в режиме короткого замыкания и сгорает.

Ток короткого замыкания при конфликтах на шине

Рис. 8. Ток короткого замыкания при конфликтах на шине

Для того чтобы избежать такого конфликта, нужна дополнительная схема, которая во время включения питания держала бы выходы в состоянии высокого импеданса.

Основным элементом этой схемы может быть ИС TLC7705. Такие микросхемы используются для генерации сигнала RESET при включении прибора. В нашем случае выводы этой микросхемы подключаются ко входам разрешения шинных формирователей. Во время инициализации или включения модуля сигнал RESET переводит выходы микросхем в третье состояние. При создании таких схем удобно использовать микросхемы, которые имеют два входа ENABLE (например, SN74ABT541). Это решение показано на рис. 9.

Мониторинг конфликтов на шине

Рис. 9. Мониторинг конфликтов на шине

Существуют шинные формирователи, которые уже содержат в себе все необходимые для защиты от шинных конфликтов компоненты — коммутаторы и резисторы. Эти микросхемы выпускаются в двух сериях: ETL (Enhanced Transceiver Logic, серия SN74ABTE) и BTL (Backplane Transceiver Logic, серия SN74FB).

Микросхемы серии ETL имеют дополнительный вывод для подключения напряжения зарядки выходной емкости микросхемы, обычно называемый VCCBIAS. Он питает схему, заряжающую конденсатор во время включения модуля.

На рис. 10 показана схема интерфейса с использованием микросхемы ETL. В момент включения модуля после подсоединения контактов VCC1 и GND на микросхеме U3 появляется напряжение VCCBIAS. Одновременно включаются микросхемы U2 и U1 и сигналом OE отключают выходы шинного формирователя от шины.

Схема интерфейса с использованием микросхем серии ETL

Рис. 10. Схема интерфейса с использованием микросхем серии ETL

Броски напряжения в цепях питания системы при подключении модуля появляются точно так же, как броски в сигнальных цепях. При этом величина заряжаемой емкости колеблется от десятков до сотен микрофарад и зависит от емкости блокирующих конденсаторов на подключаемой плате. Один из путей к ограничению скачка напряжения — включение в цепь питания коммутатора, который медленно включается. На рис. 11 предложена схема, в которой роль коммутатора играет P-МОП транзистор. RC-цепочка обеспечивает медленное изменение сигнала на базе транзистора. Диод D быстро разряжает конденсатор после того, как модуль был выключен.

Схема медленного включения модуля с использованием транзистора

Рис. 11. Схема медленного включения модуля с использованием транзистора

Предполагается, что транзистор имеет малое сопротивление во включенном состоянии. При работе рассеиваемая на транзисторе мощность невелика из-за небольшого падения напряжения. При необходимости можно параллельно включать несколько транзисторов.

В подключаемых модулях удобно использовать собственные источники питания.

На рис. 12 приведена схема источника питания, который получает из системы от десяти до сорока вольт и преобразует их импульсным способом в 5 В. Схема не дает броска напряжения при включении.

Децентрализованный источник питания

Рис. 12. Децентрализованный источник питания

Литература

  1. Стешенко В. Б. Школа схемотехнического проектирования устройств обработки сигналов. // Компоненты и технологии, № 3, 4, 2000 г.
  2. Стешенко В. Школа разработки аппаратуры цифровой обработки сигналов на ПЛИС Chip News,1999, № 8–10, 2000, №1, 3–5.
  3. Стешенко В. ПЛИС фирмы ALTERA: проектирование устройств обработки сигналов. М.: «Додека», 2000.
  4. Alicke F., Bartholdy F., Blozis S., Dehemelt F., Forstner P., Holland N., Huchzermier J. Comparing Bus Solutions, Application Report, Texas Instruments, SLLA067, March 2000.
  5. Стешенко В. ACCEL EDA: технология проектирования печатных плат. М.: «Нолидж», 2000, 512 с., ил.


Конвертер RS-232-TTL

При разработке различного рода электронных устройств с использованием микроконтроллеров очень часто оказывается полезной возможность подключения их к персональному компьютеру через последовательный порт. Однако напрямую это сделать невозможно, поскольку по стандарту RS-232, сигнал передается уровнями -3..-15 В (логическая <1>) и +3..+15В (логический <0>). Для преобразования уровней RS-232 в стандартные логические уровни TTL обычно используют специальные микросхемы преобразователей. Однако далеко не всегда имеет смысл закладывать преобразователь уровней в схему проектируемого устройства, поскольку часто бывает так, что связь с компьютером нужна только на этапе изготовления и отладки устройства, а для конечного изделия в ней нет никакой необходимости. Логичным выходом в данной ситуации может послужить изготовление отдельного конвертера уровней RS-232 в TTL, схема одного из возможных вариантов которого приведена на рисунке 1.

Рис. 1.

Основу предлагаемого конвертера составляет широко распространенная микросхема преобразователя уровней MAX232A фирмы Maxim (U1), которая имеет также множество аналогов других производителей (Analog Devices, LG и др.). Данная микросхема рассчитана на напряжение питания 5В и имеет встроенные удвоитель и инвертор напряжения на переключаемых конденсаторах для получения напряжений +10 В, необходимых для работы с сигналами стандарта RS-232. Для работы микросхемы требуется 4 внешних конденсатора (C1, C2, C3, C4) емкостью 0.1 мкФ, которые используются в преобразователе напряжения. Кроме того, с целью упрощения использования данного конвертера в нем предусмотрена схема питания прямо от последовательного порта, что избавляет от необходимости использования внешних источников питания. Напряжение питания 5 В создается маломощным линейным стабилизатором напряжения LM78L05 (U2), вход которого подключен к накопительному конденсатору C6. Конденсатор C6 заряжается через диод от сигнала Data Terminal Ready (DTR, четвертый контакт 9-pin разъема RS-232). Диод D1 может быть любого типа (автор использовал диод в корпусе для поверхностного монтажа, выпаянный со сгоревшей материнской платы). Для нормальной работы такого преобразователя питания требуется, чтобы большую часть времени сигнал DTR имел значение логического нуля. Это должно обеспечиваться используемой терминальной программой или программой пользователя.

Использование описанного выше конвертера оказывается удобным в тех случаях, когда в процессе эксплуатации устройства не требуется наличие возможности связи с компьютером, но она нужна на этапе отладки или изготовления устройства. Типичным примером этого может служить, например, устройство с flash или EEPROM памятью, требующей начальной инициализации. Кроме того, часто бывает очень удобно в процессе разработки выводить в последовательный порт различного рода отладочную информацию, что иногда позволяет обойтись без аппаратных эмуляторов.


Распиновки различных кабелей RS-232

ВНИМАНИЕ! Данная информация собрана из различных источников. Мы не в состоянии проверить работу всех схем и устройств приведенных ниже и не несем ответственности за вред который может быть нанесен аппаратуре в результате использования этих материалов. Однако, мы прилагаем максимум усилий, для того чтобы обеспечить достоверность представленой информации

Итак, здесь мы приводим стандартные и не очень распиновки кабелей...

Условные обозначения:
F - "мама";
M - "папа";
"-" - соединение;
"х" - нет соединения.
"+" - линии объединяются.

________________________________

DTE 9 F <--> DCE 9 M
 Применяется для соединения таких устройств как компьютер и модем.

Соединение прямое:
1 - 1
2 - 2
3 - 3
...
...
9 - 9

ПРИМЕЧАНИЕ: Экраны соединяются.

________________________________

DTE 9 F <--> DTE 9 F (Null-modem 9)
 Применяется для соединения таких устройств как компьютер и компьютер.

Соединение:
1+7- 8
2 - 3
3 - 2
4 - 6
5 - 5
6 - 4
7+1 - 8
8 - 1+7

ПРИМЕЧАНИЕ: 1 и 7 контакты на разъемах соеденены между собой.
9 не используется. Экраны соединяются.

________________________________

DTE 25 F <--> DCE 9 M
 Применяется для соединения таких устройств как компьютер (25-пиновый разъем) и 9-пиновая мышь (или модем).

Соединение:
2 - 3
3 - 2
4 - 7
5 - 8
6 - 6
7 - 5
8 - 1
20 - 4
22 - 9

ПРИМЕЧАНИЕ: Остальные не используются. Экраны соединяются.

________________________________

DTE 9 F <--> DCE 25 M
 Применяется для соединения таких устройств как компьютер (9-пиновый разъем) и 25-пиновая мышь (или модем).

Соединение:
1 - 8
2 - 3
3 - 2
4 - 20
5 - 7
6 - 6
7 - 4
8 - 5
9 - 22

ПРИМЕЧАНИЕ: Остальные не используются. Экраны соединяются.

________________________________

DTE 25 F <--> DCE 25 M
 Применяется для соединения таких устройств как компьютер (25-пиновый разъем) и 25-пиновая мышь (или модем).

Соединение прямое:
1 - 1
2 - 2
3 - 3
4 - 4
...
...
24 - 24
25 - 25

ПРИМЕЧАНИЕ: Экраны соединяются.

________________________________

DTE 25 F <--> DTE 25 F (Null-modem Универсальный 25)
 Применяется для соединения таких устройств как компьютер (25-пиновый разъем) и компьютер (25-пиновый разъем).

Соединение:
1 - 1
2 - 3
3 - 2
4 - 5
5 - 4
6+8 - 20
7 - 7
20 - 6+8

ПРИМЕЧАНИЕ: Остальные не используются. Экраны соединяются.

________________________________

Заглушка на COM-порт 9 pin F
Применяется для тестирования коммуникационных приложений.

Соединение:
2+3
1+6+4
7+8
ПРИМЕЧАНИЕ: Остальные не используются.

________________________________

Заглушка на COM-порт 25 pin F
Применяется для тестирования коммуникационных приложений.

Соединение:
2+3
4+5
6+8+20
ПРИМЕЧАНИЕ: Остальные не используются.


Интерфейс 1-wire

Что такое 1-Wire?

Однопроводной интерфейс 1-Wire , разработанный в конце 90-х годов фирмой Dallas Semiconductor Corp., регламентирован разработчиками для применения в трех основных сферах-приложениях:

    1-Wire - простая и недорогая технология автоматизации.
  • приборы в специальных корпусах MicroCAN для решения проблем идентификации, переноса или преобразования информации (технология iButton),
  • программирование встроенной памяти интегральных компонентов,
  • системы автоматизации (технология сетей 1-Wire-сетей).

Если первое применение широко известно на мировом рынке, и уже давно пользуется заслуженной популярностью, а второе с успехом обеспечивает возможность легкой перестройки функций полупроводниковых компонентов с малым количеством внешних выводов, производимых фирмой Dallas Semiconductor Corp., то системы автоматизации на базе 1-Wire-шины еще не получили должного признания. Ранее такая ситуация определялась, крайне ограниченным набором компонентов для организации применений в области автоматизации. Однако, в последнее время появляется все больше сообщений и конкретных примеров использования 1-Wire-интерфейса в самых различных областях, все больше разработчиков проявляют интерес к этой технологии, что связанно, прежде всего, со значительным расширением номенклатуры однопроводных компонентов.

Так в чем же особенность этого сетевого стандарта? Ведь в качестве среды для передачи информации по однопроводной линии чаще всего возможно использование обычного телефонного кабеля и, следовательно, скорость обмена в этом случае не велика. Однако, если внимательно проанализировать большинство объектов требующих автоматизации, то более чем для 60% из них предельная скорость обслуживания в 15,4Кбит/сек будет более чем удовлетворительной. А другие преимущества 1-Wire, такие как:

  • простое и оригинальное решение адресуемости абонентов,
  • несложный протокол,
  • простая структура линии связи,
  • малое потребление компонентов,
  • легкое изменение конфигурации сети,
  • значительная протяженность линий связи,
  • исключительная дешевизна всей технологии в целом,
говорит о необходимости обратить самое пристальное внимание на этот эффективный инструмент для решения задач комплексной автоматизации в самых различных областях деятельности.

Основные принципы

1-Wire-net представляет собой информационную сеть, использующую для осуществления цифровой связи одну линию данных и один возвратный (или земляной) провод. Таким образом, для реализации среды обмена этой сети могут быть применены доступные кабели, содержащие неэкранированную витую пару той или иной категории, и даже обычный телефонный провод. Такие кабели при их прокладке не требуют наличия какого-либо специального оборудования, а ограничение максимальной длины однопроводной линии регламентировано разработчиками на уровне 300м.

Основой архитектуры 1-Wire-сетей, является топология общей шины, когда каждое из устройств подключено непосредственно к единой магистрали, без каких-либо каскадных соединений или ветвлений. При этом в качестве базовой используется структура сети с одним ведущим или мастером и многочисленными ведомыми. Хотя существует ряд специфических приемов организации работы однопроводных систем в режиме мультимастера.

Конфигурация любой 1-Wire-сети может произвольно меняться в процессе ее работы, не создавая помех дальнейшей эксплуатации и работоспособности всей системы в целом, если при этих изменениях соблюдаются основные принципы организации однопроводной шины. Эта возможность достигается благодаря присутствию в протоколе 1-Wire-интерфейса специальной команды поиска ведомых устройств (Поиск ПЗУ), которая позволяет быстро определить новых участников информационного обмена. Стандартная скорость отработки такой команды составляет ~75 узлов сети в секунду.

Каждый однопроводных компонентов имеет уникальный номер (адрес), как и денежные знаки. Благодаря наличию в составе любого устройства, снабженного сетевой версией 1-Wire-интерфейса, уникального индивидуального адреса (отсутствие совпадения адресов для приборов, когда-либо выпускаемых Dallas Semiconductor Corp., гарантируется самой фирмой-производителем), такая сеть имеет практически неограниченное адресное пространство. При этом, каждый из однопроводных приборов сразу готов к использованию в составе 1-Wire-сети, без каких-либо дополнительных аппаратно-программных модификаций. Однопроводные компоненты являются самотактируемыми полупроводниковыми устройствами, в основе обмена информацией между которыми, лежит управление изменением длительности временных интервалов импульсных сигналов в однопроводной среде и их измерение. Передача сигналов, для 1-Wire-интерфейса, асинхронная и полудуплексная, а вся информация, циркулирующая в сети, воспринимается абонентами либо как команды, либо как данные. Команды сети генерируются мастером и обеспечивают различные варианты поиска и адресации ведомых устройств, определяют активность на линии даже без непосредственной адресации отдельных компонентов, управляют обменом данными в сети и т.д.

Схема порта 1-Wire-мастера. Стандартная скорость работы 1-Wire-сети, которая составляет 15,4Кбит/сек, была выбрана, во-первых, с учетом обеспечения максимальной надежности передачи данных на большие расстояния, и, во-вторых, с учетом быстродействия наиболее широко распространенных типов микроконтроллеров, которые в основном должны использоваться при реализации ведущих устройств однопроводной шины. Это значение скорости обмена может быть уменьшено до любого возможного значения благодаря введению принудительной задержки между передачей в линию отдельных битов данных (растягиванию временных слотов протокола). Или увеличено за счет перехода на специальный ускоренный режим обмена (скорость Overdrive - до 125Кбит/сек), который допускается для отдельных типов однопроводных компонентов на небольшой по расстоянию, качественной, не перегруженной другими приборами линии связи.

Схема порта ведомого 1-Wire-устройства При реализации однопроводного интерфейса используются стандартные КМОП/ТТЛ логические уровни сигналов, а питание большинства однопроводных компонентов может осуществляться от внешнего источника с рабочим напряжением в диапазоне от 2,8В до 6,0В. Альтернативой применению внешнего питания служит, так называемый, механизм "паразитного питания", действие которого заключается в использовании каждым из ведомых компонентов 1-Wire-линии электрической энергии импульсов, передаваемых по шине данных, которая аккумулируется специальной, встроенной в прибор емкостью. Кроме того, отдельные компоненты однопроводных сетей могут использовать режим питания по шине данных, когда энергия к приемнику поступает непосредственно от мастера по линии связи, при этом обмен информацией в сети принудительно прекращается.

Ориентировочный вид оболочки программы iButton TMEX-Viewer (для боле подробного просмотра щелкните левой кнопкой мыши). Пожалуй, особенно привлекательным качеством технологии 1-Wire является исключительная простота настройки, отладки и обслуживания сети практически любой конфигурации, построенной по этому стандарту. Действительно, для начала работы достаточно любого персонального компьютера, недорогого адаптера 1-Wire-линии, а также свободно распространяемой фирмой Dallas Semiconductor Corp. программы iButton Viewer. При наличии этого небольшого числа составляющих контроль и управление сетью практически любой сложности, построенной на базе стандартных однопроводных компонентов, организуется буквально в течение нескольких минут. Программа iButton Viewer, в этом случае, позволяет с максимальным комфортом для разработчика идентифицировать любое из ведомых однопроводных устройств на линии и проверить в полном объеме правильность его функционирования в составе конфигурируемой сети.

Организация ведущих

Отдельные виды адаптеров, которые позволяют наделить любой персональный компьютер возможностью обслуживать в качестве мастера 1-Wire-сеть, выпускаются самой фирмой Dallas Semiconductor Corp. К ним относятся адаптеры для параллельного порта типа DS1410E, для COM-порта типа DS9097E и DS9097U, для USB-порта типа DS9490R. Эти приборы имеют различные функциональные возможности и конструктивные особенности, что обеспечивает разработчику максимальную свободу выбора при конструировании. А наличие у пользователя небольших навыков в создании электронной аппаратуры, позволяет легко произвести самостоятельную сборку схемы простейшего адаптера 1-Wire-сети для компьютера из небольшого числа доступных электронных компонентов.

Для СОМ-портов персональных компьютеров выпускаются разнообразные адаптеры 1-Wire-линии, построенные на базе микросхем DS2480В. Часто в качестве ведущего однопроводной шины выступает не компьютер, а простейший универсальный микроконтроллер. Для организации его сопряжения с 1-Wire-сетью используются различные программно-аппаратные методы. От простейшего, когда управляющая программа контроллера полностью реализует протокол 1-Wire-интерфейса на одном из своих функциональных двунаправленных выводов, связанных с однопроводной линией, до вариантов, позволяющих высвободить значительные ресурсы контроллера, благодаря использованию специализированных микросхем сопряжения с 1-Wire-сетью. Такие микросхемы подключаются к процессору, играющему роль ведущего однопроводной шины, через периферийные узлы ввода/вывода, входящие в состав любого универсального микроконтроллера. Например, устройство DS1481 предназначено для подключения непосредственно к функциональным выводам параллельного обмена контроллера. Адаптеры 1-Wire-линии для USB-порта персонального компьютера. А для организации мастера однопроводной системы на базе микроконтроллеров с 3хвольтовым питанием поставляются пассивные микросхемы DS1482, выполняющие согласование с уровнями сигналов стандартной 1-Wire-магистрали. Если же мастер однопроводной линии должен быть организован на базе стандартного узла последовательного интерфейса UART микроконтроллера, используется микросхема DS2480В, а микросхема DS2490 адаптирует однопроводную линию для работы от встроенного узла UBS-интерфейса. Обе микросхемы реализуют так называемый программируемый механизм активной подтяжки шины данных 1-Wire-магистрали, обеспечивающий качественную передачу сигналов в длинных проблемных линиях и увеличение нагрузочной способности ведущего по количеству обслуживаемых им ведомых устройств. Кстати большинство выше упомянутых адаптеров для персональных компьютеров, также построены на базе подобных микросхем. Более того, учитывая особенности работы современных операционных сред Windows, использование именно этих компонентов, которые по своей сути являются управляемыми по последовательному интерфейсу цифровыми автоматами, обеспечивает полномасштабное обслуживание однопроводных линий в реальном масштабе времени.

При построении сложных законченных микропроцессорных систем, имеющих дефицит машинного времени для реализации 1-Wire-протокола, наиболее рациональной является идея о возложении отдельной задачи по обслуживанию однопроводной линии на специальный узел заказной или полузаказной СБИС, для последующего сопряжения такого цифрового автомата, через системную магистраль, непосредственно с основным процессорным узлом. Фирма Dallas Semiconductor Corp. даже разработала набор рекомендаций по организации подобного узла под названием DS1WM, который был реализован, в том числе, специалистами Xilinx Inc. в виде законченного практического примера для программируемых перестраиваемых матриц семейств Virtex и Spartan. Более того, и Dallas Semiconductor Corp., которая в том числе известна как поставщик высокоскоростных контроллеров клона MCS51, выпускает специализированный связной микроконтроллер DS80C400, который содержит встроенный в кристалл автомат поддержки 1-Wire-протокола с возможностью реализации механизма активной подтяжки.

Мастер сети, построенный на базе карманного компьютера. Достаточно перспективным представляется также направление, связанное с применением карманных компьютеров (или PDA (Personal Digital Assistant)) популярных платформ PalmOS, Handspring и WinCE/PocketPC для обслуживания однопроводных компонентов, в том числе работающих в составе 1-Wire-сетей. При этом, для подключения PDA к однопроводной шине применяют специализированные адаптеры последовательного порта, которые отличаются малым потреблением и построены на базе схемных решений, использующих выше перечисленные микросхемы сопряжения с 1-Wire-линией. Именно такой подход в настоящее время является наиболее рациональным при организации автономных и мобильных 1-Wire-систем.

Проблема подготовки программного обеспечения для управления мастером линии при обслуживании 1-Wire-сетей, также не представляется неразрешимой. Фирмой Dallas Semiconductor Corp. свободно распространяется профессиональный программный пакет разработчика iButton TMEX SDK, являющийся универсальным средством для профессиональных программистов, который значительно упрощает процесс создания программ для обслуживания однопроводных устройств, подключенных через стандартные типы адаптеров к персональным компьютерам, которые оснащены операционной системой Windows. Он содержит комплект отлаженных драйверов и утилит для реализации полномасштабного 1-Wire-протокола. В качестве среды взаимодействия с разработчиком пакет iButton TMEX SDK использует специальный стандартизованный программный API-интерфейс. Кроме того, с fttp-сервера кампании Dallas Semiconductor Corp. свободно доступен ряд примеров реализации 1-Wire-протокола для некоторых, наиболее популярных видов микропроцессоров, а также готовые библиотеки функциональных программных модулей однопроводного интерфейса для различных программных платформ.

Ведомые однопроводные компоненты

Кристалл 1-Wire в корпусе MicroCAN. Так выглядят кристаллы 1-Wire. Ведомые однопроводные компоненты, содержащие 1-Wire-интерфейс, выпускаются в двух различных видах. Либо в корпусах MicroCAN, похожих внешне на дисковый металлический аккумулятор, либо в обычных корпусах для монтажа на печатную плату. Футляр MicroCAN полый внутри. Он выполняет функцию защиты содержащегося в нем полупроводникового кристалла однопроводной микросхемы, который соединен с внешним миром лишь через две, изолированные друг от друга, половинки корпуса, являющиеся по существу контактными площадками для подключения однопроводной линии. В подобных "таблеточных" корпусах поставляются, как правило, приборы iButton. Компоненты, которые предназначены для использования в составе 1-Wire-сетей, упаковываются в пластиковые корпуса, используемые для изготовления транзисторов и интегральных схем. Такой подход объясняется тем, что в отличие от устройств iButton однопроводные приборы для 1-Wire-сетей часто имеют более двух выводов. Помимо выводов, которые требуются для обмена данными по однопроводной магистрали, они располагают дополнительными выводами необходимыми, для обеспечения их питания и организации внешних цепей, связывающих такие приборы с объектами автоматизации, например, датчиками или исполнительными устройствами.

К наиболее простым ведомым однопроводным компонентам относятся кремневый серийный номер DS2401 (или модифицированный вариант этого прибора с внешним питанием DS2411) и электронный ключ DS2405, управляемый по 1-Wire-интерфейсу. Первое из этих устройств часто используется в качестве электронной метки, которая позволяет идентифицировать состояние, например, механического переключателя, коммутирующего линию данных однопроводного интерфейса. С помощью DS2405 можно дистанционно осуществить простейшие функции переключения внешнего оборудования, изменяя состояние управляемого ключа относительно возвратного проводника 1-Wire-магистрали.

Термометры с 1-Wire-интерфейсом применяют во многих лабораториях мира. Однако, наиболее популярными ведомыми компонентами, на базе которых реализовано, пожалуй, наибольшее количество применений, безусловно, являются цифровые термометры типа DS18S20 (более известные под обозначением снятого с производства прибора DS1820, который уже не производится, но успел стать международным брендом). Преимущества этих цифровых термометров с точки зрения организации магистрали, по сравнению с любыми другими интегральными температурными сенсорами, а также неплохие метрологические характеристики и хорошая помехоустойчивость, выводят их на первое место при построении многоточечных систем температурного контроля в диапазоне от -55°С до +125°С. Внешний вид популярнейших цифровых термометров от Dallas Semiconductor Corp. Они позволяют не только осуществлять непосредственный мониторинг температуры в режиме реального времени, но и благодаря наличию встроенной энергонезависимой памяти температурных уставок, могут обеспечивать приоритетную сигнализацию в линию о факте выхода контролируемого параметра за пределы заданных значений. Также, поставляются более совершенные приборы DS18В20, скорость преобразования, в которых определяется разрядностью результата, которая программируется мастером линии непосредственно в ходе их обслуживания. Цифровой код, считываемый с такого термометра, является прямым результатом измеренного значения температуры и не нуждается в дополнительных преобразованиях. А их некалиброванная, но в тоже время более дешевая версия под обозначением DS1822, представляется оптимальным решением для разработчиков недорогих многоточечных систем контроля температурных процессов. Для потребителей, использующих только паразитный режим питания однопроводной линии, кампания Dallas Semiconductor Corp. выпускает экономичные двухвыводные приборы - DS18S20-PAR, DS18B20-PAR, DS1822-PAR. Российской фирмой Rainbow Technologies получен сертификат Госстандарта России об утверждении в качестве средств измерения в том числе однопроводных цифровых термометров DS1822, DS18B20, DS18S20, DS1920, производимых фирмой Maxim Integrated Products, Inc., в состав которой входит Dallas Semiconductor Corp. В подтверждение этого факта имеется документ о том, что данные типы приборов зарегистрированы в Государственном реестре средств измерений под №23169-02 и допущены к применению в Российской Федерации.

Многообразие однопроводных устройств для контроля сигналов. Четырехканальный однопроводной АЦП типа DS2450 и двухканальный однопроводной счетчик, совмещенный с буферной памятью, типа DS2423 позволяют решать задачи, связанные с оцифровкой аналоговых и импульсно-временных сигналов. Первое из этих устройств по существу разрешает проблему обслуживания источников аналоговой информации в составе 1-Wire-сетей, к которым относится большинство выпускаемых в настоящее время датчиков различных физических величин (давление, вес, напряжение, влажность, ток, освещенность, ускорение, та же температура, но в диапазонах недоступных для регистрации посредством использования цифровых термометров и т.д.). Второй прибор может с успехом обслуживать многие виды применяемых в технике импульсных сенсоров (различные оптические счетчики, сенсоры количества оборотов, выходной сигнал с расходомеров-вертушек, емкостные датчики влажности, включенные в задающие цепи управляемых генераторов импульсов, счетчики уровня радиации, интегрирующие преобразователи напряжения в частоту и т.д.).

Но все-таки наиболее незаменимыми "кирпичиками", лежащими в основе фундамента однопроводных сетей автоматизации, являются универсальные сдвоенные адресуемые транзисторные ключи типа DS2406P (современная версия широко известных приборов DS2407P). Многообразие однопроводных устройств для решения задач управления. На базе этих устройств может быть реализована масса применений, и, прежде всего, узлы контроля логических состояний (уровней) и схемы обслуживания датчиков "сухого контакта", а также разнообразные ключевые схемы. Таким образом, именно благодаря использованию этих компонентов осуществляется сбор дискретной информации с территориально рассредоточенных датчиков (мониторов дверей, контакторов положения арматуры, любых датчиков имеющих выход ДА/НЕТ, как-то датчики положения, прохода, присутствия, пожарной и охранной сигнализации и т.д.). Подобные же приборы обеспечивают управление переключением любых видов силового оборудования, которые имеют два рабочих состояния: включено/выключено (нагревателей, кондиционеров, моторов, вентиляторов, арматурных задвижек и т.д.). Кроме того, двунаправленные, индивидуально программируемые выводы DS2406P могут быть использованы для организации медленного последовательного интерфейса между локальным микроконтроллером и 1-Wire-сетью. Не смотря на невысокую скорость при реализации подобного способа обмена информацией по однопроводной сети, когда один бит данных передается за две стандартные посылки, такое решение является приемлемым и достаточно надежным для большого числа конкретных применений.

Тем не менее, самой фирмой Dallas Semiconductor Corp. в качестве стандартного "мостика" обмена между любыми схемами, построенными на микроконтроллерах различных типов, и 1-Wire-сетями рекомендуется применение специализированной двухпортовой статической памяти DS2404. Поскольку к массиву памяти этого прибора возможен доступ, как со стороны однопроводной шины, так и со стороны подчиненного последовательного интерфейса, управляемого микроконтроллером, обмен информацией между ведущим сети и подчиненным интеллектуальным устройством, решающим какую-либо локальную задачу, производится достаточно легко. Более того, благодаря наличию в составе микросхемы DS2404 дополнительного узла часов реального времени и календаря, возможно снабжение данных, сохраняемых процессором в общем массиве памяти, индивидуальными временными метками.

На базе узла часов реального времени кристалла DS2404 кампанией Dallas Semiconductor Corp. выпускается еще два компонента, весьма полезных для создания однопроводных систем автоматизации. Это устройства DS2415 и DS2417. Применяя любой из этих приборов можно организовать дешевые часы/календарь с однопроводным сетевым интерфейсом. Кроме того, второе устройство благодаря наличию в его составе отдельного вывода прерывания, может также дополнительно управлять по времени переключением внешнего оборудования или обеспечивать синхронизацию работы других устройств с процессами, происходящими на 1-Wire-линии.

Значительно расширяет возможности однопроводных сетей по аналоговому управлению рассредоточенным, в том числе силовым, оборудованием цифровой потенциометр DS2890 укомплектованный сетевым 1-Wire-интерфейсом. Используя этот прибор можно создавать самые разнообразные системы удаленного безударного управления, благодаря возможности плавного изменения аналогового регулирующего сигнала по 256 градациям.

Однопроводной универсальный двунаправленный регистр DS2408 значительно расширяет возможности 1-Wire-сетей. При всем многообразии однопроводных компонентов, очевидно, что наиболее универсальным из них является уникальный прибор DS2408. Это индивидуально двунаправленный восьмиразрядный свободно поразрядно программируемый по 1-Wire-шине порт ввода/вывода, который позволяет реализовать любой интерфейс между внешним устройством произвольной модификации и однопроводной линией. Этот прибор имеет двунаправленный вывод внешней синхронизации, обеспечивающий аппаратное тактирование передаваемых или принимаемых данных. Использование микросхемы DS2408 позволяет обеспечить управление посредством 1-Wire-шины: сосредоточенным двунаправленным вводом/выводом по 8 независимым каналам, приводом светодинамических, жидкокристаллических индикаторов и дисплеев различных видов, сканированием матричных клавиатур и дискретных датчиков самых различных типов, а так же позволяет реализовать действительно полномасштабный интерфейс с различными типами микроконтроллеров, как в последовательной, так и в параллельной моде.

Вспомогательные устройства 1-Wire. Некоторые компоненты 1-Wire-сетей содержат в своем составе массив постоянной (однократно заполняемой пользователем) или энергонезависимой памяти того или иного объема. Это позволяет хранить специальную служебную информацию, связанную с применением конкретного компонента и особенностями его использования (идентификатор, территориальное положение, калибровочные коэффициенты, размерность, значение уставок по умолчанию и т.д.), непосредственно в составе однопроводного прибора. Благодаря этому для организации работы каждой новой однопроводной сети не нужно готовить отдельное специальное программное обеспечение, достаточно иметь одну стандартную программу, которая переконфигурируется в зависимости от специфики конкретной системы (конечно, если память всех компонентов 1-Wire-системы заполнена в соответствии с определенными, заранее оговоренными правилами). Если же в процессе работы системы требуется хранить дополнительные объемы информации, в распоряжении разработчика имеются специальные однопроводные приборы, содержащие как постоянную (DS2502/ DS2505/ DS2506), так и энергонезависимую (DS2430A/ DS2432/ DS2433) память различных объемов.

На базе устройств IButton также возможно построение 1-Wire-сети. Целый ряд компонентов семейства iButton в корпусах MicroCAN также может быть использован в составе 1-Wire-сетей в качестве ведомых однопроводных устройств, которые решают специфические задачи идентификации, накопления, хранения и переноса информации. Например, для реализации процедуры идентификации в системах промышленной автоматизации обычно достаточно применения распространенных носимых электронных меток DS1990A. А многоточечный температурный мониторинг легко может быть выполнен сетью из нескольких приборов DS1921# или иначе устройств ТЕРМОХРОН, каждое из которых регистрирует температурные значения, измеренные через определённые, заранее заданные, промежутки времени и сохраняет полученную информацию в собственной энергонезависимой памяти, по существу, являясь программируемым "температурным магнитофоном". Для решения проблемы переноса данных, накопленных автономной 1-Wire-системой, к персональному компьютеру выпускаются разнообразные приборы iButton, которые в этом случае играют роль, так называемых, "транспортных таблеток". К подобным устройствам, прежде всего, относятся приборы энергонезависимой памяти, включающие в состав своей конструкции литиевый элемент питания. Это целый ряд "таблеток" начиная с DS1992 (1Кбит) до DS1996 (64Кбита), и среди них, конечно, модификация DS1994 (4Кбита), содержащая дополнительно узел часов реального времени, удобный для генерации временных меток сохраняемых данных или для организации автономных логгеров ресурса.

DS9490B - эффективный инструмент обмена данными между 'транспортными таблетками' с большим объемом памяти и персональным компьютером. Кроме того, для этих же целей могут быть использованы приборы с электрически стираемой памятью типа EEPROM модификаций DS1971(32байта), DS1973(512байт) и DS1977(32Кбайта). При перемещении больших массивов информации "транспортную таблетку" удобно использовать совместно с адаптером USB-порта типа DS9490B, который обеспечивает высокую скорость передачи при обмене данными между устройством iButton и персональным компьютером. Если же речь идет только о решении задачи накопления и хранения данных в 1-Wire-сети, любая из перечисленных выше "транспортных таблеток" может быть легко включена в состав подобной сети. При этом для подключения приборов в корпусах MicroCAN к проводникам однопроводной линии используют специальные защелки типа DS9100 или DS9098P, или же более простые зажимы типа DS9094.

С точки зрения схемотехнической реализации однопроводного интерфейса и устойчивости работы на проблемных линиях все ведомые однопроводные компоненты исторически отличаются друг от друга, делясь при этом на группы:
1. DS2401, DS2405 - первые приборы с 1-Wire-интерфейсом в пластиковых корпусах, полностью аналогичны по схемотехнике первым моделям приборов iButton, которые были ориентированные для работы на коротких шинах (до 1994 года),
2. DS1820, DS2407P, DS2450, DS2404, DS2415, DS2417, DS1920 и т.д. - вторая версия, специально ориентированная для работы на длинных линиях (до 2000 года сейчас эти компоненты в основном снимаются с производства),
3. DS18S20, DS18B20, DS1822, DS2438, DS2406P, DS2409, DS2890, DS1973 и т.д. - третий вариант, более устойчивый к коллизиям на 1-Wire-магистрали по сравнению с предыдущим (с 2000 года),
4. DS2411, DS2408, DS1921#, DS1977 и т.д. - последний вариант, наиболее удачной по надежности схемотехники 1-Wire-интерфейса (c 2003 года).

Линия связи и топология

Большую роль при построении 1-Wire-сетей играет исполнение однопроводной линии связи. Как правило, такие линии имеют структуру, состоящую из трех основных проводников: DATA - шина данных, RET - возвратный или земляной провод, EXT_POWER - внешнее питание не только обслуживаемых ведомых устройств, но и внешних относительно них цепей датчиков и органов управления. В зависимости от способа прокладки, сопряжения с ведомыми устройствами и используемых при прокладке материалов, в соответствии с ниже следующей Таблицей различают три основных варианта качества организации 1-Wire-сетей, каждый из которых подразумевает использование особой технологии и аксессуаров при реализации линии.

Классификация линии | Длина линии | Количество ведомых устройств | Тип используемого кабеля | Топология | Мастер линии
Короткие линии | До 30м | До 50шт. | 4-хпроводный телефонный | Свободная | Пассивная подтяжка (резистор)
Средние линии | До 100м | До 200шт. | Витая пара 5 категории | Общая шина | Активная подтяжка (DS2480, DS2490 или специальное схемное решение)
Длинные линии | До 300м | До 300шт. | IEEE1394 (Firewire) | Общая шина с единым стволом | Активная подтяжка с учетом тока в линии

Эффективный способ ветвления 1-Wire-линий с помощью коуплера DS2409 Часто при организации сложных однопроводных сетей, с целью удобства проводки линии связи, уменьшения ее протяженности или снижения электрической нагрузки на линии благодаря уменьшению одновременно работающих на ней устройств, необходимо обеспечить древовидную или лучевую структуру магистрали, значительно отличающуюся от структуры общей шины. Для этого используют ветвления 1-Wire-сетей одного или нескольких уровней. Основным элементом при построении таких ветвей является либо обычный адресуемый ключ типа DS2406, который обеспечивает ветвление благодаря коммутации возвратного провода однопроводной линии, либо специализированный ветвитель DS2409, коммутирующий непосредственно шину данных 1-Wire-линии. Последний вариант является более предпочтительным т.к. компоненты на отключенной ветви, ведомой ветвителем, остаются всегда в активном состоянии. Поочередное обслуживание мастером сети каждой из ветвей, при отключенных остальных ветвях, позволяет значительно увеличить общую длину линии и количество ведомых устройств на ней.

Если же организация 1-Wire-системы на базе персонального компьютера связанна с особыми трудностями, наиболее оптимально использование интеллектуального адаптера для COM-порта типа LINK. Он реализован на базе микропроцессора. При этом, устройство, полностью эмулируя со стороны последовательного порта работу популярного адаптера DS9097U, производства Dallas Semiconductor Corp., и таким образом поддерживая все разработанное ранее для персональных компьютеров программное обеспечение, благодаря встроенным собственным интеллектуальным ресурсам реализует льготный режим работы однопроводных приборов на проблемных 1-Wire-линиях в условиях сложной помеховой обстановки. LINK многократно улучшает механизм активной подтяжки на линии, что позволяет действительно получать идеальные сигналы обмена при длинах кабеля более 300 метров и числе сопровождаемых однопроводных компонентов большем 100шт, а использование процессором прибора алгоритмов цифровой фильтрации многократно улучшает устойчивость обслуживаемой однопроводной линии к электромагнитным помехам.

Применения

О признании однопроводной шины в качестве международного стандарта и серьезности отношения к этому интерфейсу со стороны маститых разработчиков и производителей электроники говорят многочисленные факты. Например, нет практически ни одного универсального микроконтроллера, в литературе по применению которого не обсуждались бы способы организации на его базе мастера однопроводной линии.

Многообразие продукции кампании Embedded Data Systems, LLC. Наиболее последовательно отстаивает линию на использование технологии 1-Wire-сетей в области автоматизации американская фирма Embedded Data Systems, LLC (приемница PointSix, Inc.). Можно сказать, что эта кампания сделала себе имя на внедрение и пропаганде достижений однопроводной шины в области автоматизации. И это, не смотря на то, что основной областью ее деятельности является не автоматизация оранжерей и не создание систем пожарной сигнализации, а разработка средств и систем для обслуживания высокотехнологичных отраслей машиностроения и химической промышленности, и даже создание уникального экспериментального и научного оборудования. Подтверждением этому служит широчайший спектр продукции, который выпускается фирмой (разнообразные зонды для измерения высоких и низких температур, датчики влажности, давления и кислотности с особыми функциями, специальные оптические сенсоры, платы сбора информации, устройства сопряжения с различным аналитическим оборудованием и многое другое), причем каждый из приборов содержит элементы однопроводной технологии.

AAG Electronica. LLC поставляет целый набор однопроводных OEM-приборов для самостоятельного построения 1-Wire-сетей. К перспективным примерам в области применения 1-Wire-технологии для автоматизации, несомненно, можно отнести деятельность таких известных мировых производителей как SYSTRONIX или AAG Electronica. LLC. Сетевые 1-Wire-решения от фирмы SYSTRONIX. Линейки законченных инструментальных средств, а также многочисленные примеры их использования, и высокий рейтинг продаж поставляемых изделий, позволяют говорить об успешности и востребованности концепции однопроводной шины применяемой этими фирмами для решения самых разнообразных проблем распределенной автоматизации.

Так выглядит электронное 'сердце' 1-Wire Weather Station. 1-Wire Weather Station - популярнейшее применение технологии 1-Wire. Другим примером, наглядно демонстрирующим на практике возможности технологии однопроводной шины, является проект построения полностью автоматических метеорологических станций (1-Wire Weather Station), который разрабатывался совместно фирмами PointSix, Inc., AAG Electronica LLC, Dallas Semiconductor Corp. и Texas Weather Instruments, Inc. Вначале (еще в середине 90-х годов) было создано несколько экспериментальных систем, построенных на базе ведущего персонального компьютера с адаптером DS9097U, который является сердцем комплекса, из трех термометров DS18S20, выполняющих контроль температуры, микросхемы DS2438 для обслуживания датчика влажности воздуха, компонента DS2423 для определения скорости ветра и 16-ти электронных меток DS2401 определяющих его направление. Эти первые метеосистемы были установлены и успешно испытаны в процессе длительной эксплуатации в штате Техас. Причем отдельные из них комплектовались дополнительными однопроводными решениями, которые обеспечивали контроль сигналов от датчиков: барометрического давления, разрядов молнии, количества осадков на поверхности, солнечной активности, влажности почвы и т.д. Данные со всех сенсоров, регистрируемые каждой из подобных систем, поступали в персональный компьютер и через Интернет транслировались в режиме реального времени на центральный операторский пульт, где выполнялся прием и архивация данных о погоде региона, получаемый благодаря анализу информации от нескольких территориально рассредоточенных станций. После успешного завершения проекта Texas Weather Instruments Inc. уже на протяжении нескольких лет успешно торгует готовыми полностью автоматическими метеостанциями, не требующими обслуживания человеком. Причем популярность подобных устройств настолько велика по всему миру, что фирма Dallas Semiconductor Corp. была вынуждена начать производство специализированного набора микросхем WS-1, который включает комплект однопроводных компонентов, минимально необходимый для построения подобной станции. А полную комплектацию подобных систем для многочисленных пользователей со всего мира, включая платы для самостоятельной сборки, сертифицированные механические и конструкционные элементы, выполняет фирма AAG Electronica LLC.

Довольно перспективной областью, в которой в полной мере используются преимущества технологии 1-Wire-сетей, и которой, особенно много внимания уделяет кампания Dallas Semiconductor Corp. является менеджмент автономных химических источников тока - аккумуляторных батарей. Под менеджментом здесь понимается, - прежде всего, строгая и полная идентификация источников энергии, сохранение в памяти каждого отдельного встроенного в батарею электронного устройства особенностей ее изготовления и индивидуальных технических характеристик, наиболее полный мониторинг их основных эксплуатационных параметров на протяжении всего срока службы, а также формирование корректного управляющего воздействия, связанного с DS2438 - универсальный 1-Wire-компонент для менеджмента батарей мобильных устройств. восстановлением заряда обслуживаемого автономного источника энергии. От правильного менеджмента и знания истории эксплуатации батареи во многом зависит выбор алгоритма ее повторного заряда, что непосредственно связанно с эффективностью использования и сроком службы многих типов аккумуляторов. Для этого каждая из батарей многоэлементных энергетических конструкций (особенно для мобильных устройств и средств бесперебойного питания) снабжается индивидуальным однопроводным компонентом, превращаясь по существу в интеллектуальный системный элемент автономного питания. Целый ряд микросхем, выпускаемых фирмой, связан с этим направлением. Dallas Semiconductor Corp. сегодня доминирует на рынке интеллектуальных систем обслуживания автономных источников питания, исповедуя при этом новый комплексный сетевой подход к проблеме менеджмента энергетических элементов. При этом, используются 1-Wire-решения, позволяющие организовать многоточечную шину обслуживания устройств менеджмента и управления зарядом, что дает возможность сопровождать не только отдельные источники энергии, но и целые батареи, составленные из множества отдельных подобных элементов. Более того, подобные устройства способны обеспечить не только идентификацию или простейший температурный контроль аккумуляторов, но и полномасштабный мониторинг их основных параметров (напряжение, ток, разряд, контроль "короткого замыкания" и т.д.) на протяжении всего времени эксплуатации. Результаты, накопленные такими приборами, сохраняются во встроенной энергонезависимой памяти либо в виде гистограммы (DS2436), либо в виде массива последовательных отсчетов "привязанных" к временным меткам (DS2438).

Одна из наиболее значимых разработок Dallas Semiconductor Corp.- микросхема менеджмента батарей портативной аппаратуры DS2770. В настоящее время кампания Dallas Semiconductor Corp. выпускает целый ряд прецизионный кристаллов для мониторинга, менеджмента, защиты и управления восстановлением заряда автономных источников питания самых различных типов и назначений (DS2720, DS2740, DS2751, DS2770 и т.д.). К ним, в том числе, относятся кристаллы семейства DS276#, которые в отличие от иных модификаций подобных устройств, требующих внешней обвязки с использованием прецизионных и стабильных пассивных компонентов, обеспечивают более высокую точность при контроле тока, расходуемого контролируемой батареей. Это достигается, в том числе, за счет встроенной калиброванной резистивной схемы (шунта), выполненной по специальной полупроводниковой технологии, а также благодаря наличию в составе подобных приборов специального аппаратно-программного механизма предварительной калибровки.

Ограничения и сопряжение с промышленными сетями

Безусловно, 1-Wire-сети имеют свою нишу для применения при построении систем автоматизации. Бессмысленно всерьез использовать их для передачи больших массивов информации, при построении, к примеру, систем видео-наблюдения или скоростного обмена, связанных с обслуживанием быстрых процессов, или же сравнивать возможности однопроводных сетей с такими мощными сетевыми промышленными интерфейсами, как ProfiBus, FeldBus, LonWorks, CAN, Industrial Internet и т.д. Можно даже сформулировать основные на сегодняшний день ограничения для применения систем на базе однопроводных 1-Wire-сетей в области автоматизации:

  • необходимость непрерывной временной синхронизации или синхронной работы отдельных устройств в сети (эта проблема может быть решена вводом в структуру шины сети дополнительной линии для передачи сигнала общей синхронизации),

  • низкая скорость обмена информацией, и как следствие невозможность высокой динамики при обслуживании быстрых процессов в режиме реального времени (если контролируемый быстрый процесс является относительно непродолжительным, локальный микроконтроллер в составе однопроводной шины может обслужить его, сохранив результирующие данные в буферной памяти, а затем уже осуществить их передачу непосредственно к мастеру),

  • сложность в реализации мультимастерного режима работы сети (специализированный ветвитель 1-Wire-сетей DS2409 разрешает проблему конфликтов между несколькими ведущими на одной однопроводной шине).

Tini board -эффективнейший механизм сопряжения 1-Wire с CAN и Internet. Как видно из замечаний приведенных в скобках, даже эти очевидные для 1-Wire-сетей, трудности не являются непреодолимыми. Более того, существуют подходы, позволяющие органично интегрировать медленные однопроводные территориально рассредоточенные структуры в состав таких производительных сетей как CAN и Industrial Internet. Это достижимо благодаря применению специальных аппаратно-программных решений, реализуемых на базе современных микроконтроллеров, а так же уникального инструмента кампании Dallas Semiconductor Corp. - устройства TINI (Tiny InterNet Interface).

TINI400 - это целая микросистема, основой которой является центральный процессор, реализованный на высокопроизводительном сетевом микроконтроллере DS80С400, который объединяет ресурсы целого ряда наиболее распространенных сетевых интерфейсов, как-то: RS232, 1-Wire, CAN 2.0B, Ethernet, не говоря о возможности использования параллельной шестнадцатиразрядной синхронной магистрали, а также автономных узлов для организации стандартных локальных последовательных интерфейсов I2C и SPI. Кроме того, плата TINI400 содержит 1Мбайт программной Flash-памяти, 1Мбайт статического ОЗУ, узел часов реального времени, литиевую батарею и кремниевый идентификационный номер. Работает TINI400 под управлением мощной операционной среды, которая включает в себя поддержку TCP/IP и виртуальной машины Java, которая тщательно отработана и испытана еще на модели TINI предыдущего поколения - плате TINI390. Последнее определяется тем фактом, что технология программной поддержки для TINI390 на протяжении нескольких лет развивалась специалистами Dallas Semiconductor Corp. совместно с сотрудниками компании Sun Microsystems, Inc., являясь при этом полностью открытым проектом. Такой подход позволил иметь максимально эффективную обратную связь с конечными пользователями, что помогло выявить и устранить большинство недостатков программного обеспечения. И сейчас на сайте Dallas Semiconductor Corp. можно найти всю необходимую документацию и средства разработки программного обеспечения, что значительно облегчает построение на базе устройства TINI локальных однопроводных систем удаленного контроля и управления, объединяющих достоинства быстрых и производительных, но дорогих, и медленных, но дешевых и эффективных интерфейсов.

В заключении необходимо еще раз отметить безусловную эффективность и рациональность использования технологии 1-Wire при построении систем автоматизации контроля и управления для разнообразного рассредоточенного оборудования, когда не требуется высокая скорость при обслуживании, но необходима существенная гибкость и наращиваемость при не высоких затратах на реализацию.


Организация 1-Wire-систем

Возможны следующие варианты организации однопроводных систем.

1. Компьютер и одно устройство ML##.
2. Компьютер и несколько устройств ML##.
3. Компьютер и множество территориально рассредоточенных устройств ML##.
4. Компьютер и проблемные линии на базе территориально рассредоточенных устройств ML##.
5. Компьютер и несколько однопроводных веток с устройствами ML##.
6. Строгая реализация общей шины для проблемных 1-Wire-систем на базе множества устройств ML##.
7. 1-Wire-системы, ведомые микроконтроллерными устройствами.
8. Комбинированные решения с использованием распределенных микроконтроллерных устройств.
9. Локальные 1-Wire-подсистемы в составе традиционных систем автоматизации.
10. 1-Wire-системы, реализуемые на базе TINI-board.
11. Программирование 1-Wire-систем.

1. Компьютер и одно устройство ML##.
Наиболее простой вариант построения однопроводной системы - это сопряжение персонального компьютера, который выступает в роли ведущего 1-Wire-линии, с одним функциональным устройством ML##. Персональный компьютер в этом случае комплектуется адаптером типа ML97#-## или типа ML94#. Адаптер ML97#-## подключается к PC через любой свободный последовательный COM-порт, а адаптер ML94# через USB-порт. Адаптер и устройство ML## связываются между собой с помощью обычного плоского четырехжильного телефонного кабеля, оформленного с обоих его концов стандартными телефонными вилками (джеками) типа RJ11 (6p4c). Такое соединение выполняется предельно просто благодаря наличию, в конструкциях и каждого из адаптеров, и однопроводного устройства ML## любого типа, приемных разъемов-гнезд RJ11 (6p4c). Прокладка подобной линии связи должна выполняться по возможности вдали от силовых проводов, электромагнитных полей и иметь преимущественно линейную топологию. Построение такой системы допустимо при условии, что используемое однопроводное устройство ML## может функционировать на паразитном питании или его потребление по шине внешнего питания EXT_POWER не превосходит 4мА. Протяженность однопроводной линии при этом может составлять ~50 80м. Пример: контроль температуры в одной точке с помощью любого из цифровых термометров семейства ML20#, или одновременный контроль температуры, относительной влажности и уровня освещенности благодаря сопряжению компьютера с микросистемой ML38H.

Сопряжение компьютера с одним устройством ML## через адаптер ML97#-##

Сопряжение компьютера с одним устройством ML## через адаптер ML94# 2. Компьютер и несколько устройств ML##.
Более сложным является вариант многоточечной 1-Wire-сети, допустимый при организации системы из небольшого числа функциональных устройств ML## (до 20шт). В качестве ведущего однопроводной системы здесь также выступает персональный компьютер, укомплектованный одним из адаптеров 1-Wire-линии типа ML97#-## или типа ML94#. Однако, в этом случае адаптер соединяется тем же телефонным кабелем сразу с несколькими ведомыми 1-Wire-компонентами, реализованными на базе функциональных устройств ML##, различных типов, которые могут работать или на паразитном питании, или с использованием шины внешнего питания EXT_POWER, если их общее потребление в любом режиме работы системы не превосходит 4мА. Точнее непосредственно адаптер ML97#-## (или ML94#) соединяется только с одним приемным гнездом ближайшего к нему однопроводного устройства ML## . Однако, наличие в составе конструкции любого функционального устройства ML## двух, параллельно включенных приемных разъемов-гнезд RJ11 (6p4c), размещенных на торце их корпуса, позволяет легко реализовать структуру однопроводной линии в виде общей шины. Это достижимо при соединении отдельных функциональных устройств ML## между собой отрезками плоского телефонного кабеля необходимой длины, оформленных с обоих концов стандартными телефонными вилками (джеками) типа RJ11 (6p4c). Общая протяженность 1-Wire-линии при этом может составлять ~50м, при количестве используемых устройств ML## до 20шт. Пример: многоточечный контроль температуры с помощью нескольких цифровых термометров семейства ML20#.

Сопряжение компьютера с несколькими устройствами ML## через адаптер ML97#-## при небольшой протяженности линии

Сопряжение компьютера с несколькими устройствами ML## через адаптер ML94# при небольшой протяженности линии

3. Компьютер и множество территориально рассредоточенных устройств ML##.
При построении поряженных однопроводных систем (60 100м), содержащих большое число устройств ML## (30 50шт) самого различного класса , на один из проводников 1-Wire-магистрали, который выделяется в качестве отдельной шины внешнего питания EXT_POWER, подается энергия от сетевого блока питания класса ML00#-xx-###. Уровень напряжения внешнего питания, поступающего в подобную сеть, выбирается значительно большим уровня, необходимого для питания любых компонентов, входящих в состав устройств ML##, что допустимо благодаря наличию в схеме этих приборов специальных узлов преобразования внешнего питания. Сопряжение 1-Wire-магистрали с блоком питания осуществляется либо благодаря специальным разветвителям телефонных розеток системы RJ11, либо через свободные приемные гнезда любого из устройств ML##, входящих в состав формируемой однопроводной системы. Наличие дополнительной энергии в 1-Wire-линии позволяет значительно улучшить ее общую помехоустойчивость, в том числе благодаря применению терминаторов, включенных на конце такой однопроводной магистрали. Для реализации функций терминатора может быть использована любая метка, содержащая встроенный узел пассивной подтяжки шины данных. В качестве терминаторов с пассивной подтяжкой рекомендуются приборы ML01 или ML02.

Сопряжение компьютера с большим количеством устройств ML## через адаптер ML97#-## с запиткой шины внешнего питания от отдельного источника

Сопряжение компьютера с большим количеством устройств ML## через адаптер ML94# с запиткой шины внешнего питания от отдельного источника

Пассивная подтяжка в конце линии улучшает характеристики обмена информацией на однопроводной линии с внешним питанием

4. Компьютер и проблемные линии на базе территориально рассредоточенных устройств ML##.
При реальной работе с 1-Wire-сетями часто встречаются ситуации, связанные с необходимостью обеспечения функционирования большого количества устройств ML## (до 100шт), на протяженных магистралях (до 300м), имеющих сложную геометрию, работающих в условиях сильных помех, проходящих рядом с силовым коммутационным оборудованием, проложенных некачественным кабелем, без жесткого соблюдения топологии общей шины. Подобные линии относят в технологии 1-Wire к проблемным, а для обеспечения их функционирования разрабатываются специальные аппаратно-программные методы.
Прежде всего, при возникновении проблем с передачей информации в подобных однопроводных структурах, следует использовать программные методы обслуживания однопроводных элементов, которые могут быть реализованы благодаря выбору оптимального в каждой конкретной ситуации рабочего режима микросхем DS2480B для COM-порта или DS2490 для USB-порта. Эти аппаратные драйвера, предназначены специально для обслуживания протяженных 1-Wire-линий, и являются неотъемлемой частью любого из адаптеров ML97#-## или ML94#, соответственно . С их помощью реализуется механизм управляемой активной подтяжки линии данных, а также обеспечивается возможность изменения временных соотношений и формы фронтов сигналов на ведомой 1-Wire-магистрали, что позволяет оптимизировать работу используемого адаптера при обслуживании однопроводных линий с индивидуальными параметрами.
Адаптер типа ML97G, основой которого тоже является микросхема DS2480B, также обеспечивает надежное гальваническое разделение между землей компьютера, обычно гальванически соединенной с нейтралью электросети, и возвратным проводом 1-Wire-магистрали, что значительно снижает вероятность неустойчивой работы проблемной однопроводной линии, построенной на базе устройств ML##. Кроме того, применение адаптера с гальваническим разделением ML97G страхует персональный компьютер от случайного попадания в его схему через 1-Wire-магистраль сетевого напряжения, что особенно актуально при работе с устройствами типа ML07S, ML90S или ML06IAA.

Использование метки ML02A для улучшения работы проблемной 1-Wire-линии

Использование в самом начале (непосредственно рядом с компьютером) линии, ведомой адаптером с программно-регулируемой активной подтяжкой, специализированной метки типа ML02a, содержащей специальную дополнительную согласующую RC-цепь, которая обеспечивает гашение отраженных сигналов в однопроводной магистрали, позволяет существенно стабилизировать работу проблемной 1-Wire-системы.

Значительного улучшения работы проблемной 1-Wire-линии можно добиться благодаря включению в ее состав меток ML02S или ML02M

Другим эффективным методом увеличения надежности работы проблемных 1-Wire-линий является применение специализированных схем восстановителей однопроводного сигнала, реализованных в составе приборов ML02S и ML02M. Использование подобных схемотехнических приемов возможно благодаря наличию в составе однопроводной магистрали отдельной шины внешнего питания EXT_POWER, которое используется встроенным в эти приборы узлом активной подтяжки для усиления затухающего сигнала проблемной линии. Подобное решение подразумевает поиск эмпирическим путем наиболее оптимальной точки подключения приборов ML02S и ML02M вдоль всей 1-Wire-линии. Место расположения этой точки зависит от большого числа факторов, и прежде всего, от геометрии и топологии, индивидуальных при реализации каждой конкретной однопроводной системы. Кроме того, в отдельных случаях возможно включение нескольких приборов-восстановителей, распределенных вдоль всей длины 1-Wire-линии.

Адаптер LINK - оптимальное решение для поддержки проблемных 1-Wire-линий

Однако, наиболее эффективным на сегодняшний день является применение для обслуживания проблемных 1-Wire-сетей уникального адаптера LINK) (или ML97L по классификации НТЛ ЭлИн). Это устройство, благодаря собственным встроенным интеллектуальным ресурсам реализует льготный режим работы приборов ML## на длинных перегруженных линиях в условиях сложной помеховой обстановки. Прибор многократно улучшает работу механизма активной подтяжки, что позволяет получать действительно идеальные сигналы обмена при длинах кабеля магистрали более 300м, через который поддерживается работа 100 и более устройств ML##. Использование алгоритмов цифровой фильтрации многократно улучшает устойчивость обслуживаемой однопроводной системы к электромагнитным помехам, а также отражениям и возмущениям, возникающим в проблемных 1-Wire-сетях.

5. Компьютер и несколько однопроводных веток с устройствами ML##.
Достаточно часто при реализации сложных 1-Wire-систем встречаются ситуации, когда топология линии такова, что при ее реализации в виде общей шины длина магистрали, значительно превосходит суммарную протяженность по сравнению с вариантом построения системы в виде отдельных лучей. В этом случае для организации системы удобно использовать специальные устройства ветвления 1-Wire-линии или коуплеры типа ML09, а также однопроводные коммутационные элементы типа ML07. Применяя подобный подход можно организовать такую перестраиваемую систему, когда в каждый отдельный момент времени к мастеру может быть подключен только один из сегментов обслуживаемой сети. Это значительно снижает в целом нагрузку на линии (количество подключенных абонентов, погонную емкость кабеля, общее сопротивление информационного канала и общую утечку изоляции) и в целом соответственно уменьшает вероятность возникновения неоднозначных ситуаций. При этом возможно два варианта реализации подобной структуры: с применением ветвителей ML09 для прерывания шины данных DATA, и с применением ключей ML07 для прерывания возвратной шины RETURN. Первый вариант представляется более предпочтительным, т.к. при его реализации все устройства ML##, входящие в состав любой локальной ветви, но отключенные от основного ствола, всегда имеют внешнее питание, и соответственно функциональны. Кроме того, при использовании коуплеров ML09 возможна реализация вложенных многоуровневых ветвлений, сигнализация мастеру об аварийном состоянии на отключенной от основного ствола ветви, а также организация внешнего питания всех однопроводных устройств ML## любой локальной ветви от отдельного источника питания.

Реализация лучевой топологии 1-Wire-линии благодаря коммутации локальных ветвей коуплерами ML09 Снижение нагрузочной способности 1-Wire-линии благодаря коммутации возвратной шины локальной ветви ключом ML07

Использование ветвителя ML09 для сопряжения с приемниками приборов iButton типа ML19S

Особенно важна возможность применения подобных конфигураций при использовании в составе однопроводных систем автоматизации приемных устройств ML19S, обеспечивающих взаимодействие мастера 1-Wire-магистрали с приборами семейства iButton, которые могут быть предназначены, например, для обеспечения функций аутентификации или съема информации, накопленной автономной 1-Wire-сетью. В случае подключения такого устройства с встроенным приемным зондом, через промежуточный коуплер ML09, отделяющий его от основного ствола однопроводной магистрали, разработчик устраняет опасность даже кратковременного замыкания линии данных основного ствола на возвратный провод, а, следовательно, увеличивает живучесть системы в целом.
Если протяженность и загруженность разветвленной 1-Wire-сети все-таки остается критичной, коммутацию локальных ветвей можно организовать таким образом, чтобы обеспечить полное отключение от основного ствола однопроводной магистрали всех устройств ML##, обслуживаемых каждой из них, используя при этом комбинированное включение ветвителей ML09 (коммутация шины данных) и ML07 (коммутация возвратной шины). Однако, более эффективно применение устройства ML09A, которое выполняет функции по отключению от основного ствола шины данных и возвратной шины, а также дополнительно обеспечивает возможность отключения от основного ствола шины внешнего питания EXT_POWER обслуживаемой 1-Wire-ветви. Последнее обстоятельство особенно важно для однопроводных систем, в которых от шины внешнего питания получают энергию внешние устройства (датчики, механизмы сигнализации, приводы замков и т.д.), обслуживаемые элементами ML##.

Пример варианта полного отключения локальных ветвей от единого ствола 1-Wire-магистрали
Система определения адреса приемного устройства, к которому поднесен прибор iButton

Кроме того, использование коуплеров ML09 позволяет организовать адресную реакцию системы, например, при предъявлении идентификационного устройства iButton. Действительно если программа компьютера-мастера 1-Wire-сети, составленной из приемных устройств ML19S, подключенных к общему стволу через индивидуальные ветвители ML09, сканирует линию на предмет наличия на ней "таблетки", открывая поочередно доступ к каждому из приемников, то возможна четкая фиксация адреса, а, следовательно, и территориального положения приемника, к которому поднесен идентификатор.

6. Строгая реализация общей шины для проблемных 1-Wire-систем на базе множества устройств ML##.
Еще одним вариантом увеличения надежности и помехоустойчивости работы для перегруженных однопроводных систем на базе множества устройств ML## (до 100шт), имеющих большую протяженность (до 200м) и сложную топологию, а так же проходящих через зоны сильных помех, является использование специальных методов реализации 1-Wire-шины, построенной со строгим соблюдением архитектуры общей линии. При этом выделяется общий непрерывный ствол сети, который прокладывается качественным кабелем типа UPT витая пара высокой категории (не ниже пятой), а лучше применять кабель IEEE1394 (Firewire). В случае высокой интенсивности электромагнитных помех рекомендуется использовать провод в заземленном экране. Всякое однопроводное устройство ML## подключается к подобному стволу через отдельную розетку класса RJ45 (например, KRONE (одиночная или двойная)), не прерывающую монотонную прокладку кабеля ствола для организации любого ответвления. При этом, каждый из проводников кабеля-ствола прокалывается (заделывается) внутри такой розетки с помощью специального ножевого разъема без разрыва жилы, отводя сигнал к выводам встроенного стандартного разъема-гнезда RJ45 (8p8c), к которому затем, уже с помощью отдельного патч-кабеля, длиной не более 0,5м, подключается однопроводное устройство ML##. Такой патч-кабель может быть оформлен с обеих сторон вилками системы RJ11 (они достаточно надежно фиксируются также в гнездах RJ45), или же заделан несимметрично - на одном конце вилка RJ45, на другом вилка RJ11. В качестве материала патч-кабеля может быть использован как плоский телефонный кабель, так и кабель UPT витая пара пятой категории.
Если используется экранированный кабель, то корд, удерживающий экранирующую фольгу, соединяется с экраном каждой розетки под винт, а также подключается к доступному выводу надежной физической земли, но только в одной единственной точке для всей 1-Wire-системы.

Реализация 1-Wire-системы со строгим соблюдением принципов общей шины

Особенно важно при организации подобной шины правильно выполнить подвод энергии внешнего питания к 1-Wire-линии с учетом того, что по стволу однопроводной магистрали может протекать значительный по величине суммарный ток, обеспечивающий питание внутренних узлов множества приборов ML##, а также обслуживаемых ими внешних устройств. Для этой цели обычно используют отдельную клеммную или распаечную коробку, которую размещают в начале линии, рядом с розеткой подключения ведущего. В такой коробке надежно, под винт или методом пайки соединяют полюса выходного кабеля блока питания с возвратной шиной и шиной внешнего питания формируемой 1-Wire-магистрали. При построении системы с использованием технологии проколки или запрессовки общего кабеля-ствола без разрыва каждой из его жил, по шине внешнего питания и возвратной шине могут циркулировать значительные по уровню суммарные токи, в то время, как к каждому из абонентов ответвляется лишь не значительная по уровню составляющая общего тока, которая, как правило, не требует сверхнизкого импеданса в районе сопряжения с общим стволом. С подобной структурой однопроводной линии могут органично сочетаться все приемы, перечисленные в п.2, п.3, п.4, п.5.

7. 1-Wire-системы, ведомые микроконтроллерными устройствами.
1-Wire-система, ведомая микроконтроллерным блоком При реализации на базе устройств ML## любого из вариантов 1-Wire-систем, перечисленных в п.1 п.6, в качестве ведущего сети может быть использован не только персональный компьютер, но и недорогой микроконтроллерный блок, что в целом значительно снижает общие затраты на подобную разработку. Если система построена на базе одного из микроконтроллерных блоков типа ML98#, то он может работать, получая энергию для собственного питания, а также питания устройств ML##, подключенных к обслуживаемой таким прибором 1-Wire-линии, от внешнего трансформаторного источника ML00#-xx-###. При этом, под управлением специально подготовленной программы, "прошитой" во внутренней памяти микроконтроллера, являющегося ядром блока ML98# любой модификации, и выполняющего роль мастера 1-Wire-сети, может отрабатываться, к примеру, поддержание температурных уставок, предварительно введенных пользователем с клавиатуры этого устройства, сразу по нескольким петлям регулирования. Эффективный узел активной подтяжки, встраиваемый в любой из блоков ML98#, и специальные методы программирования позволяют поддерживать надежную работу на достаточно протяженных (до 50м) и загруженных однопроводных линиях (до 50 устройств ML##).

Автономная 1-Wire-система многоточечного мониторинга на базе карманного компьютера

В качестве мастера автономной 1-Wire-сети могут быть с успехом использованы карманные компьютеры (иначе именуемые как Personal Digital Assistant (далее просто PDA)). НТЛ ЭлИн поставляет адаптеры ML97P-###, которые построены на базе микросхем DS2480B и предназначены для организации однопроводных систем на базе PDA платформы PalmOS. При этом, устройства ML##, ведомые карманным компьютером получают от него и энергию, что требует специальных приемов программирования, обеспечивающих экономный расход элементов питания. Но не всякая малопотребляющая однопроводная система может работать полностью автономно. Так если мини-сеть, построенная на базе карманного компьютера, например, накапливает информацию от нескольких цифровых термометров ML20# в энергонезависимой памяти PDA, возникает вопрос о переносе собранных таким образом данных. Процесс выборки информации, зарегистрированной подобной системой может быть реализован под управлением 1-Wire-ведущего карманного компьютера, и производиться периодически с помощью "транспортной таблетки" той или иной модификации, которая имеет встроенную энергонезависимую память большой емкости. К классу подобных устройств относятся, например, приборы iButton типа DS1996 или типа DS1977. Данные, полученные от всех "температурных таблеток", входящих в состав системы, могут быть легко перенесены затем из памяти "транспортной таблетки" в память персонального компьютера, например, с помощью стационарного комплекса поддержки приборов iButton. Таким же образом могут быть изменены внутренние установки (включая синхронизацию календаря и часов реального времени), и даже алгоритм работы PDA (или микропроцессорного блока) - мастера 1-Wire-сети.

1-Wire-система многоточечного мониторинга с возможностью съема накопленной информации с помощью 'транспортной таблетки'

Для обеспечения информационного контакта между "транспортной таблеткой" и однопроводной линией, ведомой микроконтроллерным блоком или карманным компьютером, система должна иметь в своем составе специальное приемное устройство ML19S, обеспечивающее информационный контакт с приборами iButton. Альтернативой этому устройству является универсальный узел системного ввода для приборов-мастеров, оснащенных приемными зондами обслуживания "таблеток" iButton типа ML19R. С помощь подобных устройств, интегрированных в состав однопроводных 1-Wire-сетей, можно решать задачи: по записи в систему или чтению из нее информации больших объемов, когда емкости "транспортных таблеток" семейства iButton не достаточно. Кроме того, таким образом можно обеспечить обслуживание 1-Wire-сети, составленной из нескольких однопроводных логгеров (например, устройств ТЕРМОХРОН (DS1921)) включая программирование их установок, перезапуск и съем накопленной ими информации. Причем подобная сеть не нуждается, в каком-либо отдельном мастере, его роль может быть выполнена автономным прибором, укомплектованным специальным приемным зондом, непосредственно в момент его контакта с 1-Wire-системой через устройство ML19R. Для сопряжения приборов DS1921, упакованных в корпуса MicroCAN, с 1-Wire-сетью удобно использовать устройства ML19F, внутри которых и могут быть расположены не только эти температурные логгеры, но и любые иные "таблетки" iButton.

Автономная 1-Wire-система с периодически подключаемым мастером, реализующим считывание накопленных данных и изменение установок автономных логгеров

8. Комбинированные решения с использованием распределенных микроконтроллерных устройств.
Наиболее рациональным подходом, при реализации однопроводных систем автоматизации, построенных на базе устройств ML##, представляется использование сетей с комбинированной структурой. Примерами, подобных реализаций могут являться системы, организованные на базе микроконтроллерных блоков ML98D или ML92. При таком подходе каждое из устройств ML98D или ML92 является с одной стороны мастером локальной 1-Wire-ветви, который обслуживает несколько функциональных устройств ML##, реализованных по любой из схем, описанных в п.1 6. С другой стороны каждый из модулей ML98D или ML92 может являться абонентом информационной сети более высокого уровня, организованной на принципах, например, стандарта CAN.
Таким образом, программа управления микроконтроллером для каждого блока ML98D или ML92 должна обеспечивать информационный обмен между "медленными" ведомыми локальными 1-Wire-ветвями, и более "быстрой" и надежной сетевой CAN-структурой верхнего уровня, которая в свою очередь сопрягается с персональным компьютером, выполняющим функции:

  • обеспечения человеко-машинного интерфейса,
  • формирования уставок управления,
  • архивирования собранной информации.
Комбинированная система, построенная на базе 1-Wire- ветвей, ведомых блоками ML98D, и системной магистрали CAN

Компьютер в этом случае комплектуется интеллектуальным адаптером системной CAN-шины типа CCA# и является равноправным участником подобной сети. При такой системной организации обеспечивается наиболее оптимальное сочетание между территориально сосредоточенными объектами обслуживания, которые характеризуются индивидуальным многообразием функциональных требований, реализуемым благодаря сопряжению с разнообразными "медленными" устройствами ML##, ведомыми локальными 1-Wire-ветвями, и широко территориально рассредоточенными абонентами более помехоустойчивой и "быстрой" сети, что обеспечивает наибольшую надежность обмена информацией при практических реализациях. Системная магистраль CAN может быть проложена при этом в соответствии с положениями, подробно изложенными в разделе "Интерфейсы".

Комбинированная система, построенная на базе 1-Wire- ветвей, ведомых блоками ML92, и системной магистрали CAN

9. Локальные 1-Wire-подсистемы в составе традиционных систем автоматизации.

При построении традиционных систем автоматизации, имеющих сосредоточенную структуру, связанную с особенностями размещения оборудования в стойках (шкафах) и крейтах (блоках) УСО, для решения отдельных локальных подзадач могут быть использованы однопроводные структуры, организованные на базе одного или нескольких устройств ML##. При этом, в состав традиционной по конструкции системы интегрируются одна или несколько интеллектуальных плат контроллеров-ведущих 1-Wire-ветвей, которые обеспечивают информационный интерфейс между ресурсами основной системы (обычно с использованием стандартных периферийных интерфейсов типа SPI или I2C) и локальной однопроводной линией, решающей какие-либо частные подзадачи. Пример: подсистема контроля расхода воды в системе водоохлаждения, реализованная с помощью двухканальных счетчиков ML23, которые выполняют функции расходомеров благодаря автоматическому подсчету числа срабатываний герконов водосчетчиков вихревого типа, или подсистема измерения температуры холодного спая термоэлектрических преобразователей, на базе цифровых термометров ML20#, размещаемых непосредственно в термопарных компенсационных коробках.

Однопроводная локальные под системы в составе крейта традиционной системы автоматизации

10. 1-Wire-системы, реализуемые на базе TINI-board.
Система, реализованная на базе локальной однопроводной ветви и TINI-board Наиболее современным на сегодняшний день решением по реализации удаленной однопроводной, сети построенной на базе устройств ML##, представляется 1-Wire-шина, организованная по одной из схем, описанных в п.1 п.6, и ведомая платой TINI (Tiny InterNet Interface). TINI или TINI-board - это уникальный инструмент, поставляемый кампанией Dallas Semiconductor Corp., и обеспечивающий возможность интегрировать 1-Wire-структуры, магистраль CAN и Интернет. Поскольку TINI-board содержит производительный микроконтроллер, к последовательному порту которого подключен аппаратный драйвер однопроводной магистрали, она может выступать в качестве мастера 1-Wire-сетей, в том числе требующих для своего обслуживания активной подтяжки шины данных.
Для обеспечения эксплуатации TINI-board должна быть установлена в специальный TINI SLOT типа ML-TS-###-###, который выполняет функции сопряжения с однопроводной линией, а также защиту от возможных коллизий на ней, обеспечивает подключение этой платы к персональному компьютеру, необходимое для загрузки в нее программы управления, снабжает ее энергией от внешнего блока питания.
Со стороны сети Интернет TINI-board может быть использована:
- либо в качестве web-сервера реального времени, отображающего информацию, фиксируемую устройствами ML## в момент запроса пользователя сети Интернет,
- либо в качестве шлюза между однопроводной системой и промежуточным web-сервером сети Интернет, который обеспечивает автоматическую визуализацию и архивацию информации, доступную для других пользователей Интернет,
- либо в качестве прибора-логгера, накапливающего данные в собственной памяти и затем пересылающего их по запросу легального компьютера, подключенного к сети Интернет.

11. Программирование 1-Wire-систем.
Важным вопросом при организации 1-Wire-сети любой конфигурации, в том числе построенной на базе устройств ML##, является решение задачи подготовки и реализации управляющей ею программы. Производитель однопроводных компонентов - фирма Dallas Semiconductor Corp. старается исповедовать в своей деятельности подход, при котором потребитель оплачивает только стоимость микросхем и готовых аппаратных решений, получая при этом доступ к бесплатным, свободно распространяемым средствам программной поддержки. Однако, следует учитывать, что подготовить инструменты разработки программ для всего спектра типов и моделей выпускаемых на сегодня в мире персональных компьютеров, PDA и микроконтроллеров нереально. Поэтому Dallas Semiconductor Corp. поставляет средства инструментальной поддержки для наиболее распространенных решений, архитектур, операционных сред и платформ, которые используют в своей деятельности большинство пользователей однопроводных компонентов.
Так практически для любой 1-Wire-системы, реализованной на базе персонального компьютера класса PС, оснащенного операционной системой Windows, и любого адаптера ML##, в качестве тестового отладочного средства можно применить свободно распространяемые Dallas Semiconductor Corp. программы-оболочки iButton Viewer или OneWireViewer, которые поддерживают работу и визуальный интерфейс для абсолютного большинства однопроводных компонентов и устройств ML##. Даже если проектируемая 1-Wire-система должна обслуживаться не персональным компьютером, использование программ iButton Viewer или OneWireViewer всегда позволит убедиться, что построенная однопроводная линия и все отдельные устройства на ней работают в соответствии с описаниями на них. Поскольку программы iButton Viewer или OneWireViewer не позволяют изменять параметры микросхем активной подтяжки, на базе которых работает большинство адаптеров ML OEM, совместно сними удобно использовать отдельные утилиты line32 или tmline, специально разработаные для этих целей.
Однако, наиболее оптимальным средством поддержки однопроводных систем, организованных на базе устройств ML##, является специализированный отладочный пакет MLex, который реализует поддержку и диагностику, а также визуальное сопровождение однопроводных элементов и приборов автоматизации, подключенных через один из последовательных портов к стандартному персональному компьютеру типа PC. Пакет MLex имеет множество преимуществ по сравнению со стандартными программами iButton Viewer или OneWireViewer от фирмы Dallas Semiconductor Corp., которые перегружены функциями сопровождения устройств iButton, в ущерб поддержке однопроводных компонентов, ориентированных на реализацию сетевых решений. Кроме того, пакет MLex позволяет осуществить все специфические функции конкретных устройств ML OEM, которые вообще не поддерживаются программами iButton Viewer или OneWireViewer.
При создании собственной программы для 1-Wire-систем на базе PC удобно использовать универсальный пакет iButton TMEX SDK, который является набором программных приложений поддержки однопроводных приборов под Windows. Вызов любого из этих приложений может быть выполнен через стандартный API интерфейс непосредственно из программы пользователя, написанной на любом современном языке программирования. Детальное описание функций пакета iButton TMEX SDK можно получить из подробной инструкции.
Если же, разработка программного обеспечения ведется не под Windows, и даже не для персонального компьютера PC, Dallas Semiconductor Corp. предлагает в рамках проекта 1-Wire Net Public Domain Kit набор библиотек компактного исходного кода поддержки 1-Wire-протокола. Код предназначен для работы на языке "С" и обеспечивает поддержку платформ, не покрываемых SDK TMEX, а именно: Linux, DOS, Win16, Win32, PalmOS, Handspring, WinCE/PocketPC, микроконтроллеры клона MCS-51. В случае, когда программа по обслуживанию 1-Wire-сети должна быть разработана для мастера, несвязанного ни с одной из перечисленных выше платформ и архитектур, следует, используя все возможности вычислительного средства, самостоятельно реализовать основные положения 1-Wire-протокола, в том числе пользуясь ресурсами библиотеки примеров программных кодов, собранных в разделе "Программная поддержка" этого сайта. Подобная самостоятельная работа по реализации программного обеспечения конкретной однопроводной системы имеет и ряд неоспоримых преимуществ. Например, в случае проблемной однопроводной линии благодаря программному затягиванию фронтов и отдельных фаз 1-Wire-протокола, а так же используя мажоритарные выборки, можно значительно увеличить надежность и устойчивость работы однопроводной сети без использования дополнительных аппаратных средств, а только за счет особенностей и приемов программного обслуживания. Другим характерным примером является составление программы для PDA, когда наряду с реализацией 1-Wire-протокола необходимо использовать специальные алгоритмические приемы, обеспечивающие сохранение энергии потребляемой однопроводным адаптером от элементов питания карманного компьютера, к которому он подключен. Программные продукты для 1-Wire-применений, реализованные на языке Java, разрабатываются совместно специалистами Dallas Semiconductor Corp. и Sun Microsystems Inc. Все они базируются на библиотеке API для JavaT, которая является основной платформой при разработке приложений для поддержки 1-Wire-устройств, использующих виртуальную Java-машину Java VM. В настоящее время, разработчикам доступны подобные продукты в рамках платформ: Win32, Linux, Solaris, Dallas Semiconductor's для TINI. Последнее обстоятельство является наиболее значимым, т.к. благодаря значительным вычислительным ресурсам устройство TINI-board работает под управлением специально разработанной операционной системы, которая включает в себя поддержку TCP/IP и Java VM. При этом на сегодняшний день уже имеется целый набор свободно-доступных процедур сопровождения однопроводных компонентов, а значит и устройств ML##, которые реализованы на их базе, что существенно упрощает организацию взаимодействия на обслуживаемой 1-Wire-магистрали ведомой TINI-board.
Все перечисленные выше программные продукты свободно доступны со страницы "Программная поддержка".


Система водяного охлаждения

В последнее время компоненты компьютера становятся всё горячее, для того чтобы их охладить приходится применять более эффективные системы охлаждения. Несмотря на надёжность, простоту, дешевизну традиционных воздушных систем охлаждения, воздух имеет низкую теплопроводность, а значит является не лучшим решением для охлаждения, не говоря уже о шуме который создаётся при большом потоке воздуха. Последние кулера издают просто изрядный рёв, при этом эффективность становится приемлемой, но не всегда достаточной. В последнее время всё большую популярность приобретает водяные системы охлаждения. Тем, кто с иронией смотрит на такую затею, скажу, что не даром в автомобилестроении используется именно такой способ, вспомните пресловутый запорожец с воздушным охлаждением, который, несмотря на слабый двигатель, так и не мог справиться с охлаждением. Вода намного лучше отводит тепло, чем воздух, именно поэтому водяные системы значительно более эффективны воздушных.

Меня на создание водяного охлаждения подвиг как раз шум компьютера. Во-первых, я работаю по ночам, а компьютер стоит рядом с кроватью, соответственно он мешает спать жене. Во-вторых длительное пребывание в шуме (а я сижу за компьютером >12часов в сутки) сказывается не лучшим образом на самочувствии. В третьих, разгон системы (а мне требуется для обработки видео производительная система) стандартными средствами охлаждения затруднён.

На сегодняшний день в интернете достаточно много материала по готовым системам от ведущих производителей, а также по самодельным системам охлаждения (самодельные системы как правило более эффективны). Не хочется повторятся и делать очередной обзор систем водяного охлаждения (приведу их в используемых ссылках), я на основе своего опыта, просто попробую красиво и детально описать свою конструкцию.

Основные компоненты водяной системы охлаждения рассмотрим на модели моей конструкции:

Водяная система охлаждения компьютера.

Вода подается по шлангу помпой (3) на ватерблоки (5,6,7), проходя по каналам ватерблоков, вода забирает тепло, и далее подаётся в радиатор (2), обдуваемый блоком вентиляторов (1). Таким образом, тепло принудительно выводится за пределы корпуса. Расширительный бачок (4) предотвращает наличие воздуха в системе, повышает объём теплоносителя (воды) в системе, тем самым увеличивает инертность системы, к тому же вода в бачке охлаждает помпу. Инертность системы в нашем случае - как раз большой плюс, ведь процессор работает, как правило, не постоянно на полную нагрузку. Пока он работает система плавно нагревается, а за время простоя процессора вода успевает охладиться. Замечу, что это правило работает не всегда, у меня, например, на 3200-м процессоре 1.5 часа видео кодируется в течении 7 часов, при этом процессор загружен на все 100%.

БЛОК ВЕНТИЛЯТОРОВ

Призван охлаждать радиатор. Глядя на блок из четырёх вентиляторов у народа сразу возникает сомнение на счёт тишины системы. Дело в том, что все вентиляторы включены через резисторы или можно включить их не на 12В, а на 5В (некоторые могут плохо стартовать), или на 7В. На минимальных оборотах их вообще не слышно. Во второй версии я поставил 3-х позиционный переключатель, первая позиция +12В (полные обороты), вторая через резистор 20Ом 2Вт, третья два по 25Ом 2Вт последовательно (4Вт). Это дало возможность включать на большие обороты вентиляторы при длительных нагрузках компьютера летом в жару. Сразу оговорюсь, каждый режим уменьшал/увеличивал температуру процессора на 1 градус, воды на 2 градуса. Разница мизерная, а вот шум в максимальном режиме достаточный, но когда очень жарко, на это можно пойти.

Угадайте, из чего сделан корпус блока вентиляторов. Из пластиковых линеек! Они дёшево стоили и классно клеились дихлорэтаном. Поскольку к блоку вентиляторов пришлось выводить 12В, туда же было встроено реле включения помпы (на фото).

РАДИАТОР

Охлаждает воду, передавая тепло воздуху. Моё мнение, место радиатору - наверху системного блока. Внутри он не может быть охлаждён и без того тёплым воздухом (а эффективность такой системы ОЧЕНЬ сильно зависит от температуры окружающей среды), снизу он плохо вентилируется, сбоку не создаётся самостоятельный поток воздуха, в отдельном ящике - очень громоздко. По материалу радиатора, медь хорошо проводит тепло, но плохо его отдаёт, посему, в этом плане, алюминий должен быть лучше, но я не проверял на практике, я сразу купил алюминиевый, к тому же он был дешевле. Радиатор печки от ВАЗ-2101 чудесным образом подошел по ширине корпуса InWin, кроме того, в пластмассовых креплениях отводящей/подводящей трубок очень быстро и классно нарезалась резьба под штуцеры. Я не стал ставить его в кожух, так лучше вентиляция, единственное я наклеил снизу полоски пористой резины, это подняло радиатор над корпусом и создало лучший поток воздуха. Эстетического вида он не портит, зато пыль очень удобно пылесосить :). Надо бы фильтр поставить, говорят хороший эффект дают обычные женские колготки - дёшево и сердито, как говорится.

ПОМПА

Сердцем всей системы охлаждения является водяная помпа, которая перекачивает воду. Погружная помпа RESUN SP-1200 Надёжность водяной системы охлаждения как раз зависит только от неё. Наиболее часто используют погружные аквариумные помпы средней производительности, они дёшевы и наиболее распространены. Их недостатками являются: питание от 220В, большая вибрация и ограничение температуры воды до 35 oC. Слухи о ненадёжности аквариумных помп является вымыслом, есть просто некачественные помпы от нерадивых изготовителей. Выбрать хорошую помпу проблема, фирменные дорогие и их оказалось не так просто достать. У нас, например, весь город завален дешевыми польскими AquaEL, о них как раз отзывы не очень лесные и характеристики у них странные. Лучшими помпами у народа считаются немецкие IHEIM, но они очень дороги.

Главные характеристики помпы - производительность (литров в час), и высота подъема воды (метры). Производительность сильно зависит от уровня, на который подымается вода(в характеристиках указывается производительность без учёта подъёма), например 700 л/ч на нулевом уровне превращается в 300 л/ч на уровне 30см, дальше ещё хуже. Для нормального охлаждения вполне хватит производительность 150л/ч в собранной системе (все компоненты в системе понижают производительность помпы). Для эксперимента я купил недорогую китайскую RESUN, модель SP-1200, производительность 700 л/ч, высота подъёма воды 0,8 м, мощность 12Вт, размеры 130x52x109. Проверив в ванной производительность помпы я убедился в правдивости слов китайцев :) Не стоит гнаться за мощными помпами, чем больше помпа, тем больше она будет нагревать воду в бачке. У меня для корпуса Inwin A500 высота подъёма уровня воды составила 35см.

РАСШИРИТЕЛЬНЫЙ БАЧОК

Я купил вот такую ёмкость для холодильника, объёмом 2.5 литра. Она просто шикарно стала в низ корпуса, даже не мешая винчестерам. Её размеры 175х175х125. Ёмкость для холодильника

Для начала нужно модифицировать крышку - встроить заливное отверстие и отверстие для шнура. Заливное отверстие я сделал из верхней части пластиковой бутылки от витаминов, а для шнура - резиновая пробка от бутылочки с лекарствами. Хорошо бы ещё и сливное отверстие. Далее, проделываем дырки под штуцеры в корпусе ёмкости, лучше сделать это нагрев инструмент на огне. Штуцеры крепятся гайками с внутренней стороны и с обеих сторон промазываем герметиком. Немного о герметике. Сантехнический прозрачный силиконовый герметик оказался не лучшим вариантом, лучше пользовать автомобильный герметик, белый, непрозрачный, он обладает гораздо лучшими прилипающими свойствами, более эластичный и крепкий. Помпу необходимо оградить от стенок толстым слоем поролона или подвесить, иначе вибрация от помпы сделает ваши "очучения непередаваемыми".
Расширительный бачок в сборе Крышка расширительного бачка

После первого эксперимента соединения помпы и штуцера толстой силиконовой трубкой, я был в замешательстве. Гул от работы помпы был жутким, вибрировала вся ёмкость, вибрация могла передаваться только через соединение со штуцером, который жёстко крепится к корпусу. Надо было искать решение мягкой сцепки помпа-штуцер. Второй эксперимент производился в клизмой в качестве интерфейса, из-за своего объёма она успевала гасить вибрацию потока воды выбрасываемого помпой, что создавало часть гула. Результат был гораздо лучшим, но я не смог толком закрепить эту конструкцию, к тому же она с трудом помещалась в ёмкость. Третий эксперимент был более удачным, в плане сочетания конструкции и тишины. Я взял белый пенный материал, тот что подкладывается под материнские платы в коробке, и из него в 1,5 слоя сделал трубку, склеив клеем Момент, а швы промазав герметиком. Но толщина материала давала таки немного жестковатую конструкцию. Тогда я взял такой же материал, только более тонкий (в них упаковывают различные устройства). Склеив его в 2 слоя, я получил очень мягкую и гибкую трубку. Шум при работе исчез, остался слабо заметный на слух гул. Это была победа! :) Но не долгая :( После 30 минут работы трубка слетела, поскольку в воде материал немного растянулся. Пришлось применить хомуты с двух сторон трубки, а поскольку они могли заржаветь в воде, я их полностью залил герметиком. Конструкция оказалась надёжной, уже скоро год и всё работает как часы.

Жидкость в бачке. Как правило заливают дистиллированную воду, если залить обычную - она быстро зацветёт, все компоненты в системе перестанут работать эффективно из за налёта покрывшего их, а помпа вообще выйдет из строя. Для надёжности в дистиллированную воду можно добавить водку, спирт или автомобильную охлаждающую жидкость (лучший вариант). Дело в том, что антифриз нейтрален к алюминию и меди, с такой жидкостью можно сочетать два этих метала в системе, а с обычной водой они образуют гальванопару. Народ утверждает, что лучшей пропорцией является 1:3, у меня получилось 1:4 - 2 литра воды и 0.5 литра импортного антифриза. За 7 месяцев работы система остаётся чистой, несмотря на то, что в ватерблоке процессора у меня применены и медь и алюминий. А в начале экспериментов, в системе была залита обычная вода, за неделю всё в системе покрылось склизким налётом. В случае добавления антифриза надо быть аккуратным с протечками. У меня после переборки процессорный ватерблок потёк через 5 часов 100%-ой нагрузки. После промывки и просушки видеокарта отказалась запускаться, не помогло даже промывка её в водке, пришлось купить новую. А через неделю она чудесным образом заработала. А..., всё равно хотел новую купить :)

ВАТЕРБЛОКИ

Ватерблоки - это рабочий инструмент системы. Пожалуй, наиболее трудная в изготовлении деталь в системе. Как правило изготавливается из наиболее теплопроводного материала, для того, чтобы наиболее быстро передать тепло от чипа теплоносителю (воде). Самым дешевым из наилучших по теплопроводности материалом является медь. Незначительно лучше его - серебро, в два раза хуже - алюминий. Найти медные болванки таких размеров для многих оказывается достаточно трудной задачей. Я тоже долго мучался в поисках материала, кстати это заняло наибольшее время. Но потом я нашёл место, где с избытком можно найти все компоненты к системе - это, как у нас называют, "поле чудес" или блошиные рынки, где народ продаёт, то что у них завалялось со старых времён.

Вариантов конструкций ватерблоков жуткое количество. В интернете ветки конференций по поводу наиболее эффективной конструкции зашкаливают за тысячу страниц. Вообще конструкция ватерблока не сильно влияет на температуру процессора, но иногда важно и пару градусов. Мне было интересно попробовать несколько вариантов в разных частях системы. Я не претендую на звание "лучший ватерблок", просто я выбрал наиболее понравившиеся мне конструкции. Вот эти красавцы в проекте :)

Процессорный ватерблок

Самый важный ватерблок в системе (центральный на фотографии). Процессор, как устройство наиболее горячее требует и лучшего охлаждения. Я выбрал для реализации конструкцию типа "спираль", холодная вода попадает в центральную часть блока, при ударе в основание возникают турбулентные потоки, которые увеличивают отбор тепла от металла. Конструкция требует заводского изготовления, мне делали её на станке с ЦПУ, но некоторые умельцы умудряются делать такие вещи на коленке при помощи дрели. Скажу сразу, не люблю конструкции на "соплях", поэтому я не сторонник такого изготовления.

Я приведу ещё один процессорный ватерблок, занимающий в импортных обзорах первое место, кроме того он мне нравится и по конструкции и чисто эстетически.

Под центральным штуцером есть так называемый акселератор(фото справа), который усиливает поток воды именно на центральную часть блока. В комплект входят 5 акселераторов с разной шириной щели, можно подобрать оптимальный для себя :) Классная штукенция, всё сделано грамотно, к тому же вот Вам и разветвитель потока, жаль что стоит он как вся система охлаждения :(

Ватерблок под чипсет

Чипсет - самый "холодный" чип в системе из всех. С пассивным радиатором он нагреется до 40-45 градусов, можно было бы на него вообще не ставить ватерблок, но если отводить тепло за пределы корпуса, то отводить, да и надёжность системы это должно увеличить. У меня для него получился самый простой ватерблок, он полностью (кроме штуцеров) изготавливается просто и быстро. Два квадратика оргстекла толщиной 10мм склеенных между собой представляют собой крышку. В одной части при помощи дрели и напильника делается сквозная дорожка типа "змейка", в другая представляет собой крышку с креплением для штуцеров. Крышка крепиться снизу по всему периметру винтами М3 с потайными головками. Я хотел изготовить такой блок для видео, но подумалось - оргстекло с температурами GPU... Как всегда, все щели лучше обильно залить герметиком.

Штуцера для ватерблоков

Их придётся точить, что тоже ограничивает скорость изготовления и увеличивает стоимость конструкции. Лучший материал - латунь, она менее подвергается окислению и коррозии, кроме того не будет конфликтовать с медным основанием ватерблока. У меня первые штуцера были сделаны из алюминия, хороши они тем, что очень легкие и проще достать материал для изготовления, в остальном их преимущества заканчиваются.

ТРУБКИ

Трубки силиконовые диаметром 10-12мм, в изобилии продаются на авторынках. Меньше - значительно увеличивается гидросопротивление, сильно нагружается помпа, падает её производительность. Больше, как правило, не позволяет свободное пространство, которое должно таки остаться после впихивания системы внутрь. Бывают армированные и нет. Армированные хороши тем что не заламываются на изгибах, плохи тем, что они толще примерно на 2мм. Трубки на штуцерах очень желательно зажать хомутами, пока вода холодная - трубки сидят плотно, но когда вода нагревается, может произойти и утечка воды, поэтому лучше перестраховаться.

Соединение ватерблоков может быть последовательное, параллельное и параллельно-последовательное. Опыт показывает, что параллельное включение не приносит какой либо ощутимой пользы, а вот недостатков у такой системы несколько. Первое, это необходимость дополнительных деталей - разветвителей. Второе - разветвленные контура могут иметь разное гидросопротивление и разный уровень, в этом случае, в контуре с меньшим сопротивлением вода пойдет бОльшим потоком, а в другом с меньшим. Нам это надо?

Медные трубки для конструкции можно найти на строительных рынках, где продают сантехническое оборудование. К сожалению, все сантехнические "причиндалы" имеют диаметр 14мм, для меня это много. Но, после долгих поисков, я смог таки найти 10мм трубку. С уголками под 10мм всё оказалось сложнее, я их до сих пор не нашёл, но они были, просто их перестали завозить(у нас, по крайней мере).

Т ЕСТЫ

Тестовая конфигурация:

Плата : EPOX 8RDA3+ rev 2.0 - nForce2
Процессор : AMD Burton 2500
Твоздуха = 24OC

Стандартная режим процессора 1820Мгц=2500+, Vcore=1,65 В

Простой + S2Clk:

 | Tcpu | Tводы
Cooler Low Speed | 31 | 31

Нагрузка CPUBurn:

 | Tcpu | Tводы
Cooler Low Speed | 39 | 34
Cooler Hight Speed | 37 | 31

Нагрузка Sandra "Burn-in Wizard" CPU Arithmetic & CPU Multimedia Test:

 | Tcpu | Tводы
Cooler Low Speed
0 мин | 27,5 | 27,0
10 мин | 34,5 | 29,0
15 мин | 35,5 | 30,0
20 мин | 35,5 | 31,0
25 мин | 36,0 | 31,5
30 мин | 36,5 | 32,0
35 мин | 36,5 | 32,5
40 мин | 37,0 | 33,0
50 мин | 37,5 | 33,5
80 мин | 38,0 | 34,0
Cooler Middle Speed
9 5 мин | 37,0 | 32,5
Cooler Hight Speed
110 мин | 35,0 | 29,5

Р ежим разгона процессора 2200Мгц=3200+, Vcore=1,8 В

Простой + S2Clk:

 | Tcpu | Tводы
Cooler Low Speed | 31 | 31

Нагрузка CPUBurn:

 | Tcpu | Tводы
Cooler Low Speed | 47 | 35,5
Cooler Hight Speed | 42 | 31,0

Нагрузка Sandra "Burn-in Wizard" CPU Arithmetic & CPU Multimedia Test:

 | Tcpu | Tводы
Cooler Low Speed
0 мин | 25,0 | 24,5
10 мин | 36,0 | 27,5
15 мин | 38,0 | 28,0
20 мин | 39,0 | 29,5
25 мин | 40,5 | 31,0
30 мин | 41,0 | 32,0
35 мин | 42,0 | 33,0
40 мин | 42,5 | 33,5
50 мин | 43,0 | 34,5
80 мин | 45,0 | 35,0
Cooler Middle Speed
9 5 мин | 43,5 | 34,5
Cooler Hight Speed
110 мин | 40,0 | 30,5

Максимальная температура достигнутая при работе в реальных приложениях (соответствует результатам нагрузки в Sandra) - 45OC. Минимальная, когда вентиляторы работали на максимальной скорости, при такой же нагрузке 40OC. Шум при максимальных оборотах вентиляторов примерно соответствует шуму одного Titan CU5TB, при нём температура процессора доходила до 55OC. Итого минус 15OC. Если брать работу при минимальном шуме, то разница составляет уже 20OC, но шум от CU5TB был всё равно несоизмеримо больше.


Шина USB и FireWire

USB (Universal Serial Bus — универсальная последовательная шина) является промышленным стандартом расширения архитектуры PC, ориентированным на интеграцию с телефонией и устройствами бытовой электроники. Версия 1.0 была опубликована в январе 1996 года. Архитектура USB определяется следующими критериями:

* Легко реализуемое расширение периферии PC.

* Дешевое решение, поддерживающее скорость передачи до 12 Мбит/с.

* Полная поддержка в реальном времени передачи аудио-и (сжатых) видеоданных.

* Гибкость протокола смешанной передачи изохронных данных и асинхронных сообщений.

* Интеграция с выпускаемыми устройствами. ^ Доступность в PC всех конфигураций и размеров.

* Обеспечение стандартного интерфейса, способного быстро завоевать рынок.

* Создание новых классов устройств, расширяющих PC.

С точки зрения конечного пользователя, привлекательны следующие черты USB:

* Простота кабельной системы и подключений.

* Скрытие подробностей электрического подключения от конечного пользователя.

*Самоидентифицирующиеся ПУ, автоматическая связь устройств с драйверами и конфигурирование.

* Возможность динамического подключения и конфигури- рования ПУ.

С середины 1996 года выпускаются PC со встроенным кон- троллером USB, реализуемым чипсетом. Ожидается появ- ление модемов, клавиатур, сканеров, динамиков и других устройств ввода/вывода с поддержкой USB, а также мони- торов с USB-адаптерами - они будут играть роль хабов для подключения других устройств.

1.1. Структура USB

USB обеспечивает одновременный обмен данными между хост-компьютером и множеством периферийных устройств (ПУ). Распределение пропускной способности шины между ПУ планируется хостом и реализуется им с помощью по- сылки маркеров. Шина позволяет подключать, конфигури- ровать, использовать и отключать устройства во время ра- боты хоста и самих устройств.

Ниже приводится авторский вариант перевода терминов из спецификации "Universal Serial Bus Specification. Revi- sion I.O.January 15, 1996", опубликованной Compaq, DEC, IBM, Intel, Microsoft, NEC и Northern Telecom. Более под- робную и оперативную информацию можно найти по ад- ресу: http://www.usb.org.

Устройства (Device) USB могут являться хабами, функция- ми или их комбинацией. Хаб (Hub) обеспечивает дополни- тельные точки подключения устройств к шине. Функции (Function) USB предоставляют системе дополнительные воз- можности, например подключение к ISDN, цифровой джой- стик, акустические колонки с цифровым интерфейсом и т. п. Устройство USB должно иметь интерфейс USB, обеспечи- вающий полную поддержку протокола USB, выполнение стандартных операций (конфигурирование и сброс) и пре- доставление информации, описывающей устройство. Многие устройства, подключаемые к USB, имеют в своем соста- ве и хаб, и функции. Работой всей системы USB управляет хост-контроллер (Host Controller), являющийся программно- аппаратной подсистемой хост-компьютера.

Физическое соединение устройств осуществляется по топо- логии многоярусной звезды. Центром каждой звезды явля- ется хаб, каждый кабельный сегмент соединяет две точки - хаб с другим хабом или с функцией. В системе имеется один (и только один) хост-контроллер, расположенный в верши- не пирамиды устройств и хабов. Хост-контроллер интегри- руется с корневым хабом (Root Hub), обеспечивающим одну или несколько точек подключения - портов. Контроллер USB, входящий в состав чипсетов, обычно имеет встроен- ный двухпортовый хаб. Логически устройство, подключен- ное к любому хабу USB и сконфигурированное (см. ниже), может рассматриваться как непосредственно подключенное к хост-контроллеру.

Функции представляют собой устройства, способные пере- давать или принимать данные или управляющую информа- цию по шине. Типично функции представляют собой отдель- ные ПУ с кабелем, подключаемым к порту хаба. Физически в одном корпусе может быть несколько функций со встро- енным хабом, обеспечивающим их подключение к одному порту. Эти комбинированные устройства для хоста являют- ся хабами с постоянно подключенными устройствами-функ- циями.

Каждая функция предоставляет конфигурационную инфор- мацию, описывающую возможности ПУ и требования к ре- сурсам. Перед использованием функция должна быть скон- фигурирована хостом - ей должна быть выделена полоса в канале и выбраны опции конфигурации.

Примерами функций являются:

^ Указатели - мышь, планшет, световое перо. ^ Устройства ввода - клавиатура или сканер.

^ Устройство вывода - принтер, звуковые колонки (цифровые).

т Телефонный адаптер ISDN.

Хаб - ключевой элемент системы РпР в архитектуре USB. Хаб является кабельным концентратором. Точки подключе- ния называются портами хаба. Каждый хаб преобразует одну точку подключения в их множество. Архитектура допускает соединение нескольких хабов.

У каждого хаба имеется один восходящий порт (Upstream Port}, предназначенный для подключения к хосту или хабу верхнего уровня. Остальные порты являются нисходящими (Downstream Ports), предназначенными для подключения функций или хабов нижнего уровня. Хаб может распознать подключение устройств к портам или отключение от них и управлять подачей питания на их сегменты. Каждый из портов может быть разрешен или запрещен и сконфигурирован на полную или ограниченную скорость обмена. Хаб обеспе- чивает изоляцию сегментов с низкой скоростью от высоко-скоростных.

Хабы могут управлять подачей питания на нисходящие пор- ты; предусматривается установка ограничения на ток, по- требляемый каждым портом.

Система USB разделяется на три уровня с определенными правилами взаимодействия. Устройство USB содержит ин- терфейсную часть, часть устройства и функциональную часть. Хост тоже делится на три части - интерфейсную, си- стемную и ПО устройства. Каждая часть отвечает только за определенный круг задач, логическое и реальное взаимодей- ствие между ними иллюстрирует рис. 7.1.

В рассматриваемую структуру входят следующие элементы:

^ Физическое устройство USB - устройство на шине, вы- полняющее функции, интересующие конечного пользо- вателя.

^ Client SW - ПО, соответствующее конкретному устрой- ству, исполняемое на хост-компьютере. Может являться составной частью ОС или специальным продуктом.

^ USB System SW - системная поддержка USB, независи- мая от конкретных устройств и клиентского ПО.

^ USB Host Controller - аппаратные и программные сред- ства для подключения устройств USB к хост-компьютеру.

Физический интерфейс

Стандарт USB определяет электрические и механические спе- цификации шины.

Информационные сигналы и питающее напряжение 5 В пе- редаются по четырехпроводному кабелю. Используется диф- ференциальный способ передачи сигналов D+ и D- по двум проводам. Уровни сигналов передатчиков в статическом режиме должны быть ниже 0,3 В (низкий уровень) или выше 2,8 В (высокий уровень). Приемники выдерживают входное напряжение в пределах - 0,5...+3,8 В. Передатчики должны уметь переходить в высокоимпедансное состояние для дву- направленной полудуплексной передачи по одной паре про- водов.

Передача по двум проводам в USB не ограничивается диф- ференциальными сигналами. Кроме дифференциального приемника каждое устройство имеет линейные приемники сигналов D+ и D-, а передатчики этих линий управляются индивидуально. Это позволяет различать более двух состояний линии, используемых для организации аппаратного ин- терфейса. Состояния DiffO и Diff1 определяются по разно- сти потенциалов на линиях D+ и D- более 200 мВ при условии, что на одной из них потенциал выше порога сраба- тывания VSE. Состояние, при котором на обоих входах D+ и D- присутствует низкий уровень, называется линейным ну- лем (SEO - Single-Ended Zero). Интерфейс определяет следу- ющие состояния:

йа DataJ State и Data К State - состояния передаваемого бита (или просто J и К), определяются через состояния DiffO и Diff1.

^ Idle State - пауза на шине.

^ Resume State - сигнал "пробуждения" для вывода устрой- ства из "спящего" режима.

^ Start of Packet (SOP) - начало пакета (переход из Idle State в К).

т End of Packet (EOP) - конец пакета.

^ Disconnect - устройство отключено от порта.

^ Connect - устройство подключено к порту.

^ Reset - сброс устройства.

Состояния определяются сочетаниями дифференциальных и линейных сигналов; для полной и низкой скоростей состояния DiffO и Diff1 имеют противоположное назначение. В декодировании состояний Disconnect, Connect и Reset учитывается время нахождения линий (более 2,5 мс) в определенных состояниях.

Шина имеет два режима передачи. Полная скорость передачи сигналов USB составляет 12 Мбит/с, низкая - 1,5 Мбит/с. Для полной скорости используется экранированная витая пара с импедансом 90 Ом и длиной сегмента до 5 м, для низкой -невитой неэкранированньгй кабель до 3 м. Низкоскоростные кабели и устройства дешевле высокоскоростных. Одна и та же система может одновременно использовать оба режима;

переключение для устройств осуществляется прозрачно. Низкая скорость предназначена для работы с небольшим количеством ПУ, не требующих высокой скорости.

Скорость, используемая устройством, подключенным к конкретному порту, определяется хабом по уровням сигналов на линиях D+ и D-, смещаемых нагрузочными резисторами R2 приемопередатчиков (см. рис. 7.2 и 7.3).

Сигналы синхронизации кодируются вместе с данными по методу NRZI (Non Return to Zero Invert), его работу иллюст- рирует рис. 7.4. Каждому пакету предшествует поле синх- ронизации SYNC, позволяющее приемнику настроиться на частоту передатчика.

Кабель также имеет линии VBus и GND для передачи питающего напряжения 5 В к устройствам. Сечение проводников выби- рается в соответствии с длиной сегмента для обеспечения гарантированного уровня сигнала и питающего напряжения.

Рис. 7.4. Кодирование данных по методу NRZI

Стандарт определяет два типа разъемов (см. табл. 7.1 и рис. 7.5).

Контакт | Цепь | Контакт | Цепь
1 | VBus | 3 | D+
2 | D- | 4 | GND

Разъемы типа "А" применяются для подключения к хабам (Upstream Connector). Вилки устанавливаются на кабелях, не отсоединяемых от устройств (например, клавиатура, мышь и т. п.). Гнезда устанавливаются на нисходящих портах (Downstream Port) хабов.

Разъемы типа "В" (Downstream Connector) устанавливаются на устройствах, от которых соединительный кабель может отсоединяться (принтеры и сканеры). Ответная часть (вилка) устанавливается на соединительном кабеле, противополож- ный конец которого имеет вилку типа "А".

Разъемы типов "А" и "В" различаются механически (рис. 7.5), что исключает недопустимые петлевые соедине- ния портов хабов. Четырехконтактные разъемы имеют ключи, исключающие неправильное присоединение. Конструкция разъемов обеспечивает позднее соединение и раннее отсоединение сигнальных цепей по сравнению с питающими. Для распознавания разъема USB на корпусе устройства ставится стандартное символическое обозначение.

Рис. 7.5. Гнезда USB: а - типа "А", б - типа "В", в - символическое обозначение

Питание устройств USB возможно от кабеля (Bus-Powered Devices) или от собственного блока питания (Self-Powered Devices). Хост обеспечивает питанием непосредственно подключенные к нему ПУ. Каждый хаб, в свою очередь, обеспе- чивает питание устройств, подключенных к его нисходящим портам. При некоторых ограничениях топологии допускается применение хабов, питающихся от шины. На рис. 7.6 приведен пример схемы соединения устройств USB. Здесь клавиатура, перо и мышь могут питаться от шины.

Модель передачи данных

Каждое устройство USB представляет собой набор независимых конечных точек (Endpoint), с которыми хост-контроллер обменивается информацией. Конечные точки описыва- ются следующими параметрами:

^ требуемой частотой доступа к шине и допустимыми задержками обслуживания;

^ требуемой полосой пропускания канала;

^ номером точки;

^ требованиями к обработке ошибок;

^ максимальными размерами передаваемых и принимаемых пакетов;

^ типом обмена;

^ направлением обмена (для сплошного и изохронного об- менов).

Каждое устройство обязательно имеет конечную точку с но- мером 0, используемую для инициализации, общего управ- ления и опроса его состояния. Эта точка всегда сконфи- гурирована при включении питания и подключении устройства к шине. Оно поддерживает передачи типа "управление" (см. далее).

Кроме нулевой точки, устройства-функции могут иметь дополнительные точки, реализующие полезный обмен данными. Низкоскоростные устройства могут иметь до двух до- полнительных точек, полноскоростные - до 16 точек ввода и 16 точек вывода (протокольное ограничение). Точки не могут быть использованы до их конфигурирования (уста- новления согласованного с ними канала).

Каналом {Pipe) в USB называется модель передачи данных между хост-контроллером и конечной точкой (Endpoint) ус- тройства. Имеются два типа каналов: потоки (Stream) и со- общения (Message). Поток доставляет данные от одного конца канала к другому, он всегда однонаправленный. Один и тот же номер конечной точки может использоваться для двух поточных каналов - ввода и вывода. Поток может реализо- вывать следующие типы обмена: сплошной, изохронный и прерывания. Доставка всегда идет в порядке "первым во- шел - первым вышел" (FIFO); с точки зрения USB, данные потока неструктурированы. Сообщения имеют формат, определенный спецификацией USB. Хост посылает запрос к ко- нечной точке, после которого передается (принимается) па- кет сообщения, за которым следует пакет с информацией состояния конечной точки. Последующее сообщение нор- мально не может быть послано до обработки предыдущего, но при отработке ошибок возможен сброс необслуженных сообщений. Двухсторонний обмен сообщениями адресуется к одной и той же конечной точке. Для доставки сообщений используется только обмен типа "управление".

С каналами связаны характеристики, соответствующие конечной точке (полоса пропускания, тип сервиса, размер буфера и т. п.). Каналы организуются при конфигурировании устройств USB. Для каждого включенного устройства существует канал сообщений (Control Pipe 0), по которому передается информация конфигурирования, управления и состояния.

Типы передачи данных

USB поддерживает как однонаправленные, так и двунаправленные режимы связи. Передача данных производится между ПО хоста и конечной точкой устройства. Устройство может иметь несколько конечных точек, связь с каждой из них (канал) устанавливается независимо.

Архитектура USB допускает четыре базовых типа передачи данных:

^ Управляющие посылки (Control Transfers), используемые для конфигурирования во время подключения и в процессе работы для управления устройствами. Протокол обеспе- чивает гарантированную доставку данных. Длина поля данных управляющей посылки не превышает 64 байт на полной скорости и 8 байт на низкой.

^ Сплошные передачи (Bulk Data Transfers) сравнительно больших пакетов без жестких требований ко времени до- ставки. Передачи занимают всю свободную полосу про- пускания шины. Пакеты имеют поле данных разме- ром 8, 16, 32 или 64 байт. Приоритет этих передач самый низкий, они могут приостанавливаться при большой за- грузке шины. Допускаются только на полной скорости передачи.

^ Прерывания (Interrupt) - короткие (до 64 байт на полной скорости, до 8 байт на низкой) передачи типа вводимых символов или координат. Прерывания имеют спонтанный характер и должны обслуживаться не медленнее, чем того требует устройство. Предел времени обслуживания уста- навливается в диапазоне 1-255 мс для полной скорости и 10-255 мс - для низкой.

^ Изохронные передачи (Isochronous Transfers) - непрерывные передачи в реальном времени, занимающие предварительно согласованную часть пропускной способности шины и имеющие заданную задержку доставки. В случае обнаружения ошибки изохронные данные передаются без повтора - недействительные пакеты игнорируются. При- мер - цифровая передача голоса. Пропускная способность определяется требованиями к качеству передачи, а задержка доставки может быть критичной, например, при реа- лизации телеконференций.

Полоса пропускания шины делится между всеми установленными каналами. Выделенная полоса закрепляется за каналом, и если установление нового канала требует такой полосы, которая не вписывается в уже существующее распределение, запрос на выделение канала отвергается.

Архитектура US В предусматривает внутреннюю буферизацию всех устройств, причем чем большей полосы пропуска- ния требует устройство, тем больше должен быть его буфер. USB должна обеспечивать обмен с такой скоростью, чтобы задержка данных в устройстве, вызванная буферизацией, не превышала нескольких миллисекунд.

Изохронные передачи классифицируются по способу синхронизации конечных точек - источников или получателей данных - с системой: различают асинхронньш, синхронный и адаптивный классы устройств, каждому из которых соот- ветствует свой тип канала USB.

Протокол

Все обмены (транзакции) по USB состоят из трех пакетов. Каждая транзакция планируется и начинается по инициати- ве контроллера, который посылает пакет-маркер {Token Packet). Он описывает тип и направление передачи, адрес устройства USB и номер конечной точки. В каждой транзакции возможен обмен только между адресуемым устройством (его конечной точкой) и хостом. Адресуемое маркером устройство распознает свой адрес и готовится к обмену. Источник данных (определенный маркером) передает пакет данных (или уведомление об отсутствии данных, предназначенных для передачи). После успешного приема пакета приемник данных посылает пакет подтверждения (Handshake Packet).

Планирование транзакций обеспечивает управление поточ- ными каналами. На аппаратном уровне использование отказа от транзакции (NAck) при недопустимой интенсивнос- ти передачи предохраняет буферы от переполнения сверху и снизу. Маркеры отвергнутых транзакций повторно пере- даются в свободное для шины время. Управление потоками позволяет гибко планировать обслуживание одновременных разнородных потоков данных.

Устойчивость к ошибкам обеспечивают следующие свойства USB:

^ Высокое качество сигналов, достигаемое благодаря диф- ференциальным приемникам/передатчикам и экраниро- ванным кабелям.

^ Защита полей управления и данных CRC-кодами.

^ Обнаружение подключения и отключения устройств и конфигурирование ресурсов на системном уровне.

^ Самовосстановление протокола с тайм-аутом при потере пакетов.

^ Управление потоком для обеспечения изохронности и управления аппаратными буферами.

^ Независимость функций от неудачных обменов с други- ми функциями.

Для обнаружения ошибок передачи каждый пакет имеет контрольные поля CRC-кодов, позволяющие обнаруживать все одиночные и двойные битовые ошибки. Аппаратные сред- ства обнаруживают ошибки передачи, а контроллер автоматически производит трехкратную попытку передачи. Если повторы безуспешны, сообщение об ошибке передается кли- ентскому ПО.

Форматы пакетов

Байты передаются по шине последовательно, начиная с млад- шего бита. Все посылки организованы в пакеты. Каждый пакет начинается с поля синхронизации Sync, которое пред- ставляется последовательностью состояний KJKJKJKK (коди- рованную по NRZI), следующую после состояния Idle. По- следние два бита (КК) являются маркером начала пакета SOP, используемым для идентификации первого бита идентифи- катора пакета PID. Идентификатор пакета является 4-бит-ным полем PID[3:0], идентифицирующим тип пакета (табл. 7.2), за которым в качестве контрольных следуют те же 4 бита, но инвертированные.

Тип PID | Имя PID | PID[3:0] | Содержимое и назначение
Token | OUT | 0001 | Адрес функции и номер конечной точки - маркер транзакции функ- ции
Token | IN | 1001 | Адрес функции и номер конечной точки - маркер транзакции хоста
Token | SOF | 0101 | Маркер начала кадра
Token | SETUP | 1101 | Адрес функции и номер конечной точки - маркер транзакции с управ- ляющей точкой
Data | DataO Datal | 0011 1011 | Пакеты данных с четным и нечетным PID чередуются для точной идентификации под- тверждений
Handshake | Ack | 0010 | Подтверждение безошибочного приема пакета
Handshake | NAK | 1010 | Приемник не сумел принять или передатчик не сумел передать данные. Может использоваться для управления потоком данных (неготовность). В транзакциях пре- рываний является признаком отсутствия необслуженных преры- ваний
Handshake | STALL | 1110 | Конечная точка требует вмеша- тельства хоста
Special | PRE | 1100 | Преамбула передачи на низкой скорости

В пакетах-маркерах IN, SETUP и OUT следующими являются адресные поля: 7-битный адрес функции и 4-битный адрес конечной точки. Они позволяют адресовать до 127 функций USB (нулевой адрес используется для конфигурирования) и по 16 конечных точек в каждой функции.

В пакете SOF имеется 11-битное поле номера кадра (Frame Number Field), последовательно (циклически) увеличиваемое для очередного кадра.

Поле данных может иметь размер от 0 до 1023 целых байт. Размер поля зависит от типа передачи и согласуется при установлении канала.

Поле СКС-кола присутствует во всех маркерах и пакетах дан- ных, оно защищает все поля пакета, исключая PID. CRC для маркеров (5 бит) и данных (11 бит) подсчитываются по раз- ным формулам.

Каждая транзакция инициируется хост-контроллером посыл- кой маркера и завершается пакетом квитирования. После- довательность пакетов в транзакциях иллюстрирует рис. 7.7.

Хост-контроллер организует обмены с устройствами согласно своему плану распределения ресурсов. Контроллер цикли- чески (с периодом 1 мс) формирует кадры (Frames), в кото- рые укладываются все запланированные транзакции. Каж- дый кадр начинается с посылки маркера SOF (Start Of Frame), который является синхронизирующим сигналом для всех устройств, включая хабы. В конце каждого кадра выделяет- ся интервал времени EOF (End Of Frame), на время которого хабы запрещают передачу по направлению к контроллеру. Каждый кадр имеет свой номер. Хост-контроллер опериру- ет 32-битным счетчиком, но в маркере SOF передает только младшие 11 бит. Номер кадра увеличивается (циклически) во время EOF. Хост планирует загрузку кадров так, чтобы в них всегда находилось место для транзакций управления и прерывания. Свободное время кадров может заполняться сплошными передачами (Bulk Transfers).

Рис. 7.8. Поток кадров USB

Для изохронной передачи важна синхронизация устройств и контроллера. Есть три варианта:

^ синхронизация внутреннего генератора устройства с мар- керами SOF;

^ подстройка частоты кадров под частоту устройства;

^ согласование скорости передачи (приема) устройства с частотой кадров.

Подстройка частоты кадров контроллера возможна, есте- ственно, под частоту внутренней синхронизации только од- ного устройства. Подстройка осуществляется через механизм обратной связи, который позволяет изменять период кадра в пределах ±1 битового интервала.

1.2. Системное конфигурирование

USB поддерживает динамическое подключение и отключе- ние устройств. Нумерация устройств шины является посто- янным процессом, отслеживающим изменения физической топологии.

Все устройства подключаются через порты хабов. Хабы определяют подключение и отключение устройств к своим портам и сообщают состояние портов при запросе от кон- троллера. Хост разрешает работу порта и адресуется к уст- ройству через канал управления, используя нулевой адрес - USB Default Address. При начальном подключении или пос- ле сброса все устройства адресуются именно так.

Хост определяет, является новое подключенное устройство хабом или функцией, и назначает ему уникальный адрес USB. Хост создает канал управления (Control Pipe) с этим устрой- ством, используя назначенный адрес и нулевой номер точки назначения.

Если новое устройство является хабом, хост определяет под- ключенные к нему устройства, назначает им адреса и уста-

навливает каналы. Если новое устройство является функ- цией, уведомление о подключении передается диспетчером USB заинтересованному ПО.

Когда устройство отключается, хаб автоматически запреща- ет соответствующий порт и сообщает об отключении кон- троллеру, который удаляет сведения о данном устройстве из всех структур данных. Если отключается хаб, процесс уда- ления выполняется для всех подключенных к нему устройств. Если отключается функция, уведомление посылается заин- тересованному ПО.

Нумерация устройств, подключенных к шине (Bus Enumeration), осуществляется динамически по мере их под- ключения (или включения их питания) без какого-либо вме- шательства пользователя или клиентского ПО. Процедура нумерации выполняется следующим образом:

1. Хаб, к которому подключилось устройство, информиру- ет хост о смене состояния своего порта ответом на опрос состояния. С этого момента устройство переходит в со- стояние Attached (подключено), а порт, к которому оно подключилось, в состояние Disabled.

2. Хост уточняет состояние порта.

3. Узнав порт, к которому подключилось новое устройство, хост дает команду сброса и разрешения порта.

4. Хаб формирует сигнал Reset для данного порта (10 мс) и переводит его в состояние Enabled. Подключенное устройство может потреблять от шины ток питания до 100 мА. Устройство переходит в состояние Powered (пи- тание подано), все его регистры переводятся в исходное состояние, и оно отзывается на обращение по нулевому адресу.

5. Пока устройство не получит уникальный адрес, оно до- ступно по дежурному каналу, по которому хост-контрол- лер определяет максимально допустимый размер поля данных пакета.

6. Хост сообщает устройству его уникальный адрес, и оно переводится в состояние Addressed (адресовано).

7. Хост считывает конфигурацию устройства, включая за- явленный потребляемый ток от шины. Считывание мо- жет затянуться на несколько кадров.

8. Исходя из полученной информации, хост конфигуриру- ет все имеющиеся конечные точки данного устройства, которое переводится в состояние Configured (сконфигу- рировано). Теперь хаб позволяет устройству потреблять от шины полный ток, заявленный в конфигурации. Уст- ройство готово.

Когда устройство отключается от шины, хаб уведомляет об этом хост и работа порта запрещается, а хост обновляет свою текущую топологическую информацию.

1.3. Устройства USB - функции и хабы

Возможности шины USB позволяют использовать ее для подключения разнообразных устройств. Не касаясь "полез- ных" свойств ПУ, остановимся на их интерфейсной части, связанной с шиной USB. Все устройства должны поддержи- вать набор общих операций, перечисленных ниже.

Динамическое подключение и отключение. Эти события от- слеживаются хабом, который сообщает о них хост-контрол- леру и выполняет сброс подключенного устройства. Устрой- ство после сигнала сброса должно отзываться на нулевой адрес, при этом оно не сконфигурировано и не приостанов- лено. После назначения адреса, за которое отвечает хост-кон- троллер, устройство должно отзываться только на свой уни- кальный адрес.

Конфигурирование устройств, выполняемое хостом, являет- ся необходимым для их использования. Для конфигуриро- вания обычно используется информация, считанная из самого устройства. Устройство может иметь множество ин- терфейсов, каждому из которых соответствует собственная конечная точка, представляющая хосту функцию устройства. Интерфейс в конфигурации может иметь альтернативные наборы характеристик; смена наборов поддерживается про- токолом. Для поддержки адаптивных драйверов дескрипто- ры устройств и интерфейсов имеют поля класса, подкласса и протокола.

Передача данных возможна посредством одного из четырех типов передач (см. выше). Для конечных точек, допускаю- щих разные типы передач, после конфигурирования досту- пен только один из них.

Управление энергопотреблением является весьма развитой функцией USB. Для устройств, питающихся от шины, мощ- ность ограничена. Любое устройство при подключении не должно потреблять от шины ток, превышающий 100 мА. Рабочий ток (не более 500 мА) заявляется в конфигурации, и если хаб не сможет обеспечить устройству заявленный ток, оно не конфигурируется и, следовательно, не может быть использовано.

Устройство USB должно поддерживать приостановку (Suspended Mode), в котором его потребляемый ток не пре- вышает 500 мкА. Устройство должно автоматически приос- танавливаться при прекращении активности шины.

Возможность удаленного пробуждения (Remote Wakeup) по- зволяет приостановленному устройству подать сигнал хост- компьютеру, который тоже может находиться в приостанов- ленном состоянии. Возможность удаленного пробуждения описывается в конфигурации устройства. При конфигури- ровании эта функция может быть запрещена.

Хаб в USB выполняет коммутацию сигналов и выдачу пи- тающего напряжения, а также отслеживает состояние под- ключенных к нему устройств, уведомляя хост об изменени- ях. Хаб состоит из двух частей - контроллера (Hub Controller) и повторителя (Hub Repeater). Повторитель представляет собой управляемый ключ, соединяющий выходной порт со входным. Он имеет средства поддержки сброса и приоста- новки передачи сигналов. Контроллер содержит регистры для взаимодействия с хостом. Доступ к регистрам осуществля- ется по специфическим командам обращения к хабу. Коман- ды позволяют конфигурировать хаб, управлять нисходящи- ми портами и наблюдать их состояние.

Нисходящие (Downstream) порты хабов могут находиться в следующих состояниях:

^ Powered (^(питание отключено) - на порт не подается питание (возможно только для хабов, коммутирующих

питание). Выходные буферы переводятся в высокоимпе- дансное состояние, входные сигналы игнорируются.

^ Disconnected (отсоединен) - порт не передает сигналы ни в одном направлении, но способен обнаружить подключе- ние устройства (по отсутствию состояния SEO в течение 2,5 мкс). Тогда порт переходит в состояние Disabled, а по уровням входных сигналов {DiffO или Diff1 в состоянии Idle) он определяет скорость подключенного устройства.

s^ Disabled (запрещен) - порт передает только сигнал сбро- са (по команде от контроллера), сигналы от порта (кро- ме обнаружения отключения) не воспринимаются. По обнаружении отключения (2,5 мкс состояния SEO) порт переходит в состояние Disconnect, а если отключение об- наружено "спящим" хабом, контроллеру будет послан сигнал Resume.

ш Enabled (разрешен) - порт передает сигналы в обоих на- правлениях. По команде контроллера или по обнаруже- нии ошибки кадра порт переходит в состояние Disabled, а по обнаружении отключения - в состояние Disconnect.

^ Suspended (приостановлен) - порт передает сигнал пере- вода в состояние останова ("спящий" режим). Если хаб находится в активном состоянии, сигналы через порт не пропускаются ни в одном направлении. Однако "спящий" хаб воспринимает сигналы смены состояния незапрещен- ных портов, подавая "пробуждающие" сигналы от акти- визировавшегося устройства даже через цепочку "спя- щих" хабов.

Состояние каждого порта идентифицируется контроллером хаба с помощью отдельных регистров. Имеется общий ре- гистр, биты которого отражают факт изменения состояния каждого порта (фиксируемый во время EOF). Это позволяет хост-контроллеру быстро узнать состояние хаба, а в случае обнаружения изменений специальными транзакциями уточ- нить состояние.

1.4. Хост-контроллер

Хост-компьютер общается с устройствами через контроллер. Хост имеет следующие обязанности:

^ обнаружение подключения и отсоединения устройств USB;

^ манипулирование потоком управления между устройства- ми и хостом;

^ управление потоками данных;

^ сбор статистики;

^ обеспечение энергосбережения подключенными ПУ.

Системное ПО контроллера управляет взаимодействием меж- ду устройствами и их ПО, функционирующим на хост-ком- пьютере, для согласования:

^ нумерации и конфигурации устройств;

^ изохронных передач данных;

^ асинхронных передач данных;

^ управления энергопотреблением;

^ информации об управлении устройствами и шиной.

По возможности ПО USB использует существующее систем- ное ПО хост-компьютера - например, Advanced Power Management для управления энергопотреблением.

2. Шина IEEE 1394-FireWire

Стандарт для высокопроизводительной последовательной шины (High Performance Serial Bus), получивший офици- альное название IEEE 1394, был принят в 1995 году. Целью являлось создание шины, не уступающей современным стан- дартным параллельным шинам, при существенном удешев- лении и повышении удобства подключения (за счет перехо- да на последовательный интерфейс). Стандарт основан на шине FireWire, используемой Apple Computer в качестве де- шевой альтернативы SCSI в компьютерах Macintosh и PowerMac. Название FireWire ("огненный провод") теперь применяется и к реализациям IEEE 1394, оно сосуществует с кратким обозначением 1394.

Преимущества FireWire перед другими последовательными шинами:

s? Многофункциональность: шина обеспечивает цифровую связь до 63 устройств без применения дополнительной аппаратуры (хабов). Устройства - цифровые камкодеры, сканеры, принтеры, камеры для видеоконференций, дис- ковые накопители - могут обмениваться данными не только с PC, но и между собой. FireWire по инициативе VESA позиционируется и для "домашних сетей".

^ Высокая скорость обмена и изохронные передачи позво- ляют даже на начальном уровне (100 Мбит/с) передавать одновременно два канала видео (30 кадров в секунду) широковещательного качества и стереоаудиосигнал с ка- чеством CD.

s§ Низкая цена компонентов и кабеля.

si Легкость установки и использования. FireWire расши- ряет систему РпР. Устройства автоматически распозна- ются и конфигурируются при включении/отключении. Питание от шины (ток до 1,5 А) позволяет ПУ общать- ся с системой даже при отключении их питания. Управ- лять шиной и другими устройствами могут не только PC, но и другие "интеллектуальные" устройства, напри- мер VCR.

2.1. Структура и взаимодействие устройств шины

Стандарт 1394 определяет две категории шин: кабельные шины и кросс-шины (Backplane). Под кросс-шинами обычно подразумеваются параллельные интерфейсы, объединяющие внутренние подсистемы устройства, подключенного к кабелю 1394.

В отличие от USB, управляемой одним хост-контроллером, стандарт 1394 допускает соединение равноправных устройств в сеть. Сеть может состоять из множества шин, соединенных мостами. В пределах одной шины устройства объединяются соединительными кабелями без применения дополнительных устройств. Мосты представляют собой специальные интел- лектуальные устройства. Интерфейсная карта шины FireWire для PC представляет собой мост PCI - 1394. Мостами яв- ляются также соединения кабельной шины 1394 с кросс- шинами устройств, 16-битная адресация узлов сети допус-

кает до 63 устройств в каждой шине, адресуемых 6-битным полем идентификатора узла. 10-битное поле идентификато- ра шины допускает использование в системе до 1023 мос- тов, соединяющих шины разного типа.

Кабельная шина представляет собой сеть, состоящую из уз- лов и кабельных мостов. Гибкая топология позволяет стро- ить сети, сочетающие древовидную и цепочечную ар- хитектуры (рис. 7.9). Каждый узел обычно имеет три равноправных соединительных разъема. Допускается мно- жество вариантов подключения устройств со следующими ограничениями:

ssi между любой парой узлов может быть не более 16 ка- бельных сегментов;

^ длина сегмента стандартного кабеля не должна превы- шать 4,5 м;

2Й суммарная длина кабеля не должна превышать 72 м (при- менение более качественного кабеля позволяет ослабить это ограничение).

Некоторые устройства могут иметь только один разъем, что ограничивает возможные варианты их местоположения. Стандарт допускает до 27 разъемов на одном устройстве.

Рис. 7.9. Соединение устройств на шине FireWire

Рис. 7.10. Разъем FireWire

Стандарт предусматривает связь узлов с помощью 6-провод- ного кабеля, заключенного в общий экран. Две витые пары используются для передачи сигналов (раздельные для при- емника и передатчика), два провода задействованы для пи- тания устройств (8-40 В, до 1,5 А). Для гальванической развязки интерфейса используются трансформаторы (напря- жение изоляции развязки до 500 В) или конденсаторы (в дешевых устройствах с напряжением развязки до 60 В от- носительно общего провода). Представление о разъемах дает рис. 7.10. Некоторые устройства (камкодеры Sony DCR- VX700 и DCR-VX1000, а также DHR-1000 DVCR) имеют только один 4-контактный разъем меньшего размера, у ко- торого реализованы только сигнальные цепи. Эти устрой- ства подключаются к шине через специальный переходной кабель только как оконечные (хотя возможно применение специальных адаптеров-разветвителей).

Стандарт 1394 определяет три возможные частоты переда- чи сигналов по кабелям: 98,304, 196,608 и 393,216 Мбит/с, которые округляют до 100, 200 и 400 Мбит/с. Частоты в стандарте обозначаются как S100, S200 и S400 соответствен- но. Бытовые устройства обычно поддерживают S100, боль- шинство адаптеров допускают S200. К одной шине могут подключаться устройства, рассчитанные на разные скорос- ти. Обмен будет происходить на минимальной для всех ак- тивных узлов скорости. Однако, если хост-контроллер реа- лизует карту топологии и скоростей (Topology_Мар и Speed_Map), возможно использование нескольких частот в одной шине, в соответствии с возможностями конкретной пары, участвующей в обмене.

Система допускает динамическое (горячее) подключение и отключение устройств. Идентификаторы подключаемым

устройствам назначаются автоматически, без участия пользо- вателя. Изменения топологии (состава подключенных уст- ройств) автоматически отслеживаются шиной и передаются управляющему ПО.

Протокол IEEE 1394

Протокол 1394 реализуется на трех уровнях (рис. 7.11).

^ Уровень транзакций (Transaction Layer) преобразует па- кеты в данные, предоставляемые приложениям, и наобо- рот. Он реализует протокол запросов-ответов, соответству- ющий стандарту ISO/IEC 13213:1994 (ANSI/IEEE 1212, редакции 1994 г.), архитектуры регистров управления и состояния CSR (Control and Status Register) для микро- компьютерных шин (чтение, запись, блокировка). Это облегчает связь шины 1394 со стандартными параллель- ными шинами.

^ Уровень связи (Link Layer) из данных физического уров- ня формирует пакеты и выполняет обратные преобразо- вания. Он обеспечивает обмен узлов датаграммами с под- тверждениями. Уровень отвечает за передачу пакетов и управление изохронными передачами.

^ Физический уровень (Physical Layer) вырабатывает и при- нимает сигналы шины. Он обеспечивает инициализацию и арбитраж, предполагая, что в любой момент времени работает только один передатчик. Уровень передает по- токи данных и уровни сигналов последовательной шины вышестоящему уровню. Между этими уровнями возмож- на гальваническая развязка, при которой микросхемы физического уровня питаются от шины. Гальваническая развязка необходима для предотвращения паразитных контуров общего провода, которые могут появиться че- рез провода защитного заземления блоков питания.

Аппаратная часть FireWire обычно состоит из двух специ- ализированных микросхем - трансиверов физического уровня PHY Transceiver и моста связи с шиной LINK Chip. Связь между ними возможна, например, по интерфейсу IBM-Apple LINK-PHY. Микросхемы уровня связи выпол- няют все функции своего уровня и часть функций уровня

транзакций, остальная часть уровня транзакций выполня- ется программно.

Коннекторы

Рис. 7.11. Трехуровневая структура FireWire

Управление шиной

Протокол 1394 имеет гибкий механизм управления связью между различными устройствами. Для этого не обязательно присутствие на шине PC или иного контроллера шины. Управление включает три сервиса:

^ Мастер циклов, посылающий широковещательные паке- ты начала циклов (требуемые для изохронных обменов).

^ Диспетчер изохронных ресурсов, если какой-либо узел поддерживает изохронный обмен (для цифрового видео и аудио).

^ Необязательный контроллер шины (Bus Master) - им мо- жет являться PC или редактирующий DVCR.

По сбросу производится определение структуры шины, каж- дому узлу назначаются физические адреса и производится арбитраж мастера циклов, диспетчера изохронных ресурсов и контроллера шины. Через секунду после сброса все ресур- сы становятся доступными для последующего использования.

Принципиальным преимуществом шины является отсутствие необходимости в контроллере. Любое передающее устрой- ство может получить полосу изохронного трафика и начи- нать передачу по сигналу автономного или дистанционного управления - приемник "услышит" эту информацию. При наличии контроллера (PC) соответствующее ПО может управлять работой устройств, реализуя, например, цифро- вую студию нелинейного видеомонтажа.

Изохронная транспортировка данных

Изохронная транспортировка шины 1394 обеспечивает гаран- тированную пропускную способность и ограниченную задерж- ку при высокоскоростной передаче по множеству каналов. Диспетчер изохронных ресурсов содержит регистр BANDWIDTH^AVAILABLE, который определяет доступность оставшейся части полосы пропускания для узлов с изохрон- ной передачей. По сбросу вновь появившийся узел с изо- хронной передачей запрашивает выделение полосы. Для циф- рового видео, например, требуется полоса 30 Мбит/с (25 Мбит/с на видеоданные и 3-4 Мбит/с на аудио, син- хронизацию и заголовки пакетов). Полоса измеряется в спе- циальных единицах распределения, число которых в 125-мил- лисекундном цикле составляет 6144. Единица занимает около 20 нс, что соответствует времени, требуемому для передачи одного квадлета (Quadlet) на частоте 1600 Мбит/с. Квадлет (32-битное слово) является единицей передачи данных по шине. 25 мс цикла резервируется под асинхронный трафик, поэтому начальное значение регистра после сброса состав- ляет 4915 единиц. В S100 устройства цифрового видео за- прашивают около 1800 единиц, в S200 - около 900. Если со- ответствующая полоса недоступна, запрашивающее ее устройство будет периодически повторять запрос.

Диспетчер изохронных ресурсов каждому изохронному узлу назначает номер канала (0-63) из числа доступных (регистр

CHANNELS_AVAILABLE). Он является идентификатором изо- хронного пакета. Когда изохронный обмен становится не- нужным узлу, он должен освободить свою полосу и номер канала. Обмен управляющей информацией производится по асинхронному каналу.

2.2. Синонимы и дополнения стандарта IEEE 1394

Шина IEEE 1394 имеет множество псевдонимов:

^ IEEE 1394-1995 Standard for a High Performance Serial Bus - полное название документа, описывающего стан- дарт, действующий в настоящее время.

т FireWire - торговая марка реализации IEEE-1394 фир- мой Apple Computer, Inc.

^ Р1394 - название предварительной версии IEEE-1394 (до принятия в декабре 1995 г.).

^ DigitalLink - торговая марка Sony Corporation, исполь- зуемая применительно к реализации IEEE-1394 в циф- ровых камерах.

ш MultiMedia Connection - имя, используемое в логоти- пе 1394 High Performance Serial Bus Trade Association (1394TA).

Поскольку фирма Apple разрабатывала концепцию FireWire еще с 1986 года, имя FireWire является самым распростра- ненным синонимом IEEE 1394.

Кроме основного стандарта IEEE 1394-1995, имеется несколь- ко его модификаций:

^ 1394а рассматривается как чистовой документ, заполня- ющий некоторые пробелы исходного стандарта и имею- щий небольшие изменения (например, ускоренную опе- рацию сброса на шине). Продуктам 1394а обеспечена обратная совместимость с устройствами, выпущенными до принятия основного стандарта. Версия вводилась для повышения скорости до 800 Мбит/с и выше, высокоско- ростные версии входят и в 1394Ь.

^ 1394.1 определяет 4-проводньш соединитель и устанав- ливает стандарт на шинные мосты.

^ 1394.2 предполагается как стандарт на соединение клас- тера станций со скоростью обмена 1 Гбит/с и выше, не- совместимый с 1394. Этот стандарт проистекает из IEEE 1596 SCI (Scalable Coherent Interface - масштаби- руемый когерентный интерфейс) для суперкомпьютеров и иногда называется Serial Express или SCILite. Сигналь- ный интерфейс 1394.2 похож на FCAL и допускает коль- цевую топологию, запрещаемую стандартом 1394.

2.3. Сравнение FireWire и USB

Последовательные интерфейсы FireWire и USB, имея общие черты, являются существенно различными технологиями. Обе шины обеспечивают простое подключение большого числа ПУ (127 для USB и 63 для FireWire), допуская ком- мутации и включение/выключение устройств при работаю- щей системе. Топология обеих шин достаточно близка. Хабы USB входят в состав ЦУ; для пользователя их присутствие незаметно. Обе шины имеют линии питания устройств, но допустимая мощность для FireWire значительно выше. Обе шины поддерживают систему РпР (автоматическое конфи- гурирование при включении/выключении) и снимают про- блему дефицита адресов, каналов DMA и прерываний. Раз- личаются пропускная способность и управление шиной.

USB ориентирована на ПУ, подключаемые к PC. Ее изо- хронные передачи позволяют передавать только цифровые аудиосигналы. Все передачи управляются централизованно, и PC является необходимым управляющим узлом, находя- щимся в корне древовидной структуры шины. Соединение нескольких PC этой шиной не предусматривается.

FireWire ориентирована на интенсивный обмен между лю- быми подключенными к ней устройствами. Изохронньш тра- фик позволяет передавать "живое" видео. Шина не требует централизованного управления со стороны PC. Возможно использование шины для объединения нескольких PC и ПУ в локальную сеть.

Новые устройства цифрового видео и аудио имеют встроен- ные адаптеры 1394. Подключение к шине FireWire традици- онных аналоговых и цифровых устройств (плейеров, камер,

мониторов) возможно через адаптеры-преобразователи ин- терфейсов и сигналов. Стандартные однотипные кабели и разъемы FireWire заменяют множество разнородных соеди- нений устройств бытовой электроники с PC. Разнотипные цифровые сигналы мультиплексируются в одну шину. В от- личие от сетей Ethernet, высокоскоростные передачи пото- ков данных по FireWire в реальном времени не требуют до- полнительных протоколов. Кроме того, имеются средства арбитража, гарантирующие доступ к шине за заданное вре- мя. Применение мостов в сетях FireWire позволяет изоли- ровать трафик групп узлов друг от друга.

7.3. Шина ACCESS.Bus и интерфейс PC

Последовательная шина ACCESS.Bus (Accessory Bus), разра- ботанная фирмой DEC, является шиной взаимодействия компьютера с его аксессуарами - например, монитором (ка- нал VESA DDC), интеллектуальными источниками питания (Smart Battery) и т. п. Шина позволяет по двум сигналь- ным и двум питающим (12 В, 500 мА) проводам подклю- чить до 14 устройств ввода/вывода, длина шины может до- стигать 8 м. Аппаратной основой является интерфейс PC, характеризуемый простотой реализации, но, даже по срав- нению с USB, низкой производительностью. Над аппарат- ным протоколом PC для шины ACCESS.Bus имеется базо- вый программный протокол, с которым взаимодействуют протоколы конкретных подключенных устройств. Протоко- лы обеспечивают подключение/отключение устройств без пе- резагрузки ОС. Назначение сигналов разъема ACCESS.Bus, предложенное VESA, приведено в табл. 7.3.

Контакт | Назначение
1 | GND
2 | Ключ
3 | SDA
4 | +5 В (питание устройств)
5 | SCL

Интерфейс К, разработанный фирмой Philips, в PC появил- ся недавно и используется как внутренняя вспомогательная шина системной платы для общения с энергонезависимой памятью идентификации установленных компонентов (мо- дулей памяти DIMM). Шина отличается предельной про- стотой реализации - две сигнальные линии, с которыми ра- ботают программно. По прямому назначению эту шину применяет пока только BIOS при определении аппаратных средств, но использование перезаписываемой памяти конфи- гурирования открывает новые возможности для привязки ПО к конкретной системе (точнее, установленному модулю) и... для вирусов. Способ программного доступа к шине пока не стандартизован, но при желании его можно "вычислить", изучив документацию на чипсет.

Рис. 7.12. Протокол передачи данных PC

Последовательный интерфейс УС обеспечивает двунаправ- ленную передачу данных между парой устройств, исполь- зуя два сигнала: данные SDA (Serial Data) и синхронизацию SCL (Serial Clock). В обмене участвуют два устройства - ве- дущее (Master) и ведомое (Slave). Каждое из них может вы- ступать в роли передатчика, помещающего на линию SDA информационные биты, или приемника. Протокол обмена иллюстрирует рис. 7.12. Синхронизацию задает ведущее ус- тройство - контроллер. Линия данных - двунаправленная с выходом типа "открытый коллектор" - управляется обоими устройствами поочередно. Частота обмена (не обязательно постоянная) ограничена сверху величиной 100 кГц для стан- дартного режима и 400 кГц для скоростного, что позволяет организовать программно-управляемую реализацию контрол- лера интерфейса.

Начало любой операции - условие Start - инициируется переводом сигнала SDA из высокого в низкий при высоком уровне SCL. Завершается операция переводом сигнала SDA

из низкого уровня в высокий при высоком уровне SCL - условие Stop. При передаче данных состояние линии SDA может изменяться только при низком уровне SCL, биты дан- ных стробируются положительным перепадом SCL Каждая посылка состоит из 8 бит данных, формируемых передатчи- ком (старший бит - MSB - передается первым), после чего передатчик на один такт освобождает линию данных для получения подтверждения. Приемник во время девятого так- та формирует нулевой бит подтверждения Ack. После пере- дачи бита подтверждения приемник может задержать сле- дующую посылку, удерживая линию SCL на низком уровне. Приемник также может замедлить передачу по шине на уров- не приема каждого бита, удерживая SCL на низком уровне после его спада, сформированного передатчиком.

Каждое ведомое устройство имеет свой адрес, разрядность ко- торого по умолчанию составляет 7 бит. Адрес А[6:0] передается ведущим устройством в битах [7:1] первого байта, бит 0 содер- жит признак операции Я1У(Я1/У=1 - чтение, RW=Q -запись). 7-битный адрес содержит две части: старшие 4 бита А[6:3] не- сут информацию о типе устройства (например, для EEPROM - 1010), а младшие 3 бита А[0:2] определяют номер устройства данного типа. Многие микросхемы с интерфей- сом PC имеют три адресных входа, коммутацией которых на логические уровни 1 и 0 задается требуемый адрес. Некото- рые значения полного адреса зарезервированы (табл. 7.4).

Общий вызов позволяет включившемуся устройству заявить о себе широковещательным способом. Байт Start предназна- чен для привлечения внимания процессора к интерфейсу, если в устройстве он организован программным (не аппаратным) способом. До получения этого байта микроконтроллер уст- ройства не опрашивает состояние и не следит за сигналами интерфейса. При использовании 10-битной адресации биты [2:1] содержат старшую часть адреса, а младшие 8 бит будут переданы в следующем байте, если признак RW=0.

Адрес ведомого устройства и тип обращения задается кон- троллером при инициировании обмена. Обмен с памятью иллюстрирует рис. 7.13. Здесь SA[0:2] - адрес устройства, DA[0:7] - адрес данных, D[0:7] - данные, W - признак за- писи (0), R - признак чтения (1).

Биты [7:1] | BKTO(RW) | Назначение
0000 000 | 0 | General call address - адрес общего вызова
0000 000 | 1 | Start. - начало активного обмена
0000 001 | X | Адрес устройства шины CBUS (для сов- местимости)
0000 010 | X | Адрес для устройств иных шин
0000 011 | X | Зарезервировано
0000 1ХХ | X | Зарезервировано
1111 1ХХ | X | Зарезервировано
1111 ОХХ | X | Признак 10-битной адресации

Рис. 7.13. Обмен с памятью по интерфейсу PC: a - запись, б - чтение с текущего адреса, в - чтение с произвольного адреса

Выполнив условие Start, контроллер передает байт, содер- жащий адрес устройства и признак операции RW, и ожидает подтверждения. При операции записи следующей посылкой от контроллера будет 8-битный адрес записываемой ячейки, а за ней - байт данных (для микросхем объемом памяти бо- лее 256 байт адрес ячейки посылается двумя байтами). По- лучив подтверждения, контроллер завершает цикл услови- ем Stop, а адресованное устройство может начать свой внутренний цикл записи, во время которого не реагирует на сигналы интерфейса. Контроллер проверяет готовность уст- ройства посылкой команды записи (байт адреса устройства)

и анализом бита подтверждения, формируя затем условие Stop. Если устройство откликнулось битом подтверждения, значит, оно завершило внутренний цикл и готово к следую- щей операции.

Операция считывания инициируется так же, как и запись, но с признаком RW=\. Возможно чтение по заданному адре- су, по текущему адресу или последовательное. Текущий ад- рес хранится во внутреннем счетчике ведомого устройства, он содержит увеличенный на единицу адрес ячейки, участво- вавшей в последней операции.

Получив команду чтения, устройство дает бит подтвержде- ния и посылает байт данных, соответствующий текущему адресу. Контроллер может ответить подтверждением, тогда устройство пошлет следующий байт (последовательное чте- ние). Если на принятый байт данных контроллер ответит условием Stop, операция чтения завершается (случай чтения по текущему адресу). Начальный адрес для считывания кон- троллер задает фиктивной операцией записи, в которой пе- редается байт адреса устройства и байт адреса ячейки, а после подтверждения приема байта адреса снова формируется ус- ловие Start и передается адрес устройства, но уже с указа- нием на операцию чтения. Так реализуется считывание про- извольной ячейки (или последовательности ячеек).

Интерфейс позволяет контроллеру с помощью пары сигна- лов обращаться к любому из 8 однотипных устройств, под- ключенных к данной шине и имеющих уникальный адрес (рис. 7.14). При необходимости увеличения количества уст- ройств возможно подключение групп. При этом допустимо как использование общего сигнала SCL и раздельных сигна- лов SDA (двунаправленных), так и общего сигнала SDA и раздельных однонаправленных сигналов SCL. Для обраще- ния к одной из нескольких микросхем (или устройств), не имеющих выводов для задания собственного адреса, также применяют разделение линий SCL (или SDA).

Протокол PC позволяет нескольким контроллерам исполь- зовать одну шину, определяя коллизии и выполняя арбит- раж. Эти функции реализуются достаточно просто: если два передатчика пытаются установить на линии SDA различные

логические уровни сигналов, то "победит" тот, который ус- тановит низкий уровень. Передатчик следит за уровнями управляемых им сигналов и при обнаружении несоответствия (передает высокий уровень, а "видит" низкий) отказывает- ся от дальнейшей передачи. Устройство может иницииро- вать обмен только при пассивном состоянии сигналов. Кол- лизия может возникнуть лишь при одновременной попытке начала обмена - как только конфликт обнаружен, "проиг- равший" передатчик отключится, а "победивший" продол- жит работу.

Рис.7.14. Подключение устройств к контроллеру ^С

Приложение А. Системотехника IBM PC-совместимых компьютеров

Здесь рассмотрено взаимодействие программ с интерфейс- ными адаптерами. Приведены краткие сведения по архитек- туре PC. Описаны организация пространств памяти и вво- да/вывода, система прерываний и прямой доступ к памяти. Более подробные сведения можно найти в книге "Аппарат- ные средства IBM PC. Энциклопедия" ("Питер", 1998).

А.1. Пространство памяти

Логическая структура памяти PC обусловлена системой ад- ресации процессоров семейства х86. Процессоры 8086/88, применявшиеся в первых моделях IBM PC, имели адресное пространство 1 Мбайт (20 бит шины адреса). Начиная с про- цессора 80286 шина адреса была расширена до 24 бит, затем (386DX, 486, Pentium) до 32 и, наконец, до 36 бит (Pentium Pro, Pentium II). В реальном режиме процессора, используемом в DOS, формально доступен лишь 1 Мбайт памяти. Однако из-за ошибки эмуляции процессора 8086 в реальном режиме процессоры 80286 и выше имеют макси- мально доступный адрес lOFFEFh, что на (64К-16) байт больше. Область lOOOOOh-lOFFEFh называется высокой па- мятью - High Memory Area (HMA). В нее помещают часть ОС реального режима и небольшие резидентные програм- мы. Для полной совместимости с процессором 8086/88 име- ется вентиль линии А20 шины адреса - GateA20, который либо пропускает сигнал от процессора, либо принудительно обнуляет линию А20 системной шины адреса.


Дистанционное управление (ДУ) на инфракрасных (ИК) лучах

Информация взята с сайта Sly Control

Это дополнительная информация к плагинам DCD и sndRemote

Три вида модуляции
Bi-phase coding
Длина импульсов и промежутки между ними по 0.9мс или 1.8 мс.
Логические 0 и 1 определяются, как показано на рисунке:

Pulse-distance modulation

Длина импульсов постоянна.
Промежутки большей длительности - лог. 1 , меньшей - лог. 0.

Pulse-length code

Длина промежутков постоянна.
Импульсы большей длительности - лог. 1 , меньшей - лог. 0.

Сразу нужно сделать оговорку по поводу "импульсов". На самом деле каждый
такой "серый" импульс - это 20-30 очень коротких импульсов идущих с большой
постоянной частотой (от 30 до 56 кГц) или даже вообще инфракрасный фон
с частотой 400 кГц. При оцифровке звуковой картой (44100Гц) этот "фон" сливается
в импульсы по форме близкие к прямоугольным. Этого достаточно для точного
декодирования.

Стандарты кодировок
RC-5

Модуляция Bi-phase. Сначала идут старшие биты, потом младшие.

Если нажать кнопку на дистанционке и держать, будут слаться посылки (DataWord)
с одинаковым значением Toggle bit. Если отпустить кнопку и нажать снова,
пойдут те же посылки, но уже с инверсным значением Toggle bit.

Этот стандарт использует PHILIPS и SAMSUNG без каких-либо отклонений.

NEC
Модуляция Pulse-distance. Сначала идут младшие биты, потом старшие.

При нажатии кнопки на дистанционке выдается одна полная посылка,
а затем через промежутки идут одиночные импульсы, говорящие о том,
что кнопка еще нажата. Перед посылкой (первой полной и одиночными импульсами)
идет один длинный импульс синхронизации.

В посылке адрес и команда идут два раза - сначала просто, затем с инверсией
(что-то не совпало - команда не принята). Кроме того, основная посылка идет
только один раз при нажатии на кнопку. Вероятность того, что она пройдет
правильно с первого раза, не очень высока.

Data word:

Пример: адрес "00110111" и команда "00011010"
кодируются как "00110111'11001000'00011010'11100101".

Этот стандарт используют HITACHI, NOKIA, AIWA, AKAI, AverMedia.

Creative RM-900 (от SoundBlaster Live Platinum) повторяет первую посылку 2 раза,
кроме того первый байт адреса равен C1h, а второй 44h, то есть между первым и
вторым байтом нет ничего общего. Для совместимости первые 2 байта адреса не
сравниваются и используются оба.

RECS 80 / RC-4

Модуляция Pulse-distance. Сначала идут старшие биты, потом младшие.
На 100% этому стандарту не соответствует ничего. Например в дистанционках
JVC использован этот стандарт с сильными отклонениями (расхождения по
длительностям, Toggle bits никогда не меняются, адресных битов 6,
а командных 8 вместо 4 и 6 соответственно).

Используется JVC.

SONY / Panasonic

Модуляция Pulse-length. Сначала идут младшие биты, потом старшие.
В начале посылки есть длинный стартовый импульс. До 20 бит данных.

В плагинах DCD и sndRemote при декодировании сигнала получается 28-битный идентификатор
вида 0FAAAACC, где F - флаг определяющий модуляцию, A - адрес, C - команда.
Исключение составляет SONY, где 24 младших бита определяют просто код команды.


Почему IrDA не годится для приема команд ИК дистанционного управления

Ну вообще-то можно конечно использовать IrDA для приема команд с обычных ИК пультов, но с очень большими ограничениями. Работает далеко не со всеми пультами. Стабильность распознавания команд очень низкая. Если использовать IrDA встроенный в материнскую плату, то нужно колдовать с драйверами, если внешний, то нужно удалять драйвера или периодически перетыкать приемник в другой СОМ порт. USB IrDA вообще использовать невозможно, так как к нему нельзя обратиться напрямую как к СОМ порту (не путайте с виртуальным СОМ портом).

По многочисленным просьбам был написан плагин для СОМ IrDA, подробнее о всех ограничениях и сложностях использования см. здесь.

А теперь подробнее

Через IrDA данные передаются также как и через COM порт с небольшими отличиями. Наличие импульса - это логический 0, длительность имульса составляет 3/16 bit time. Обычно используется режим 8 бит, без контроля четности и 1 стоповый бит. Первый импульс рассматривается как стартовый, далее в зависимости от выбранной скорости передачи (обычно 115200) наличие или отсутствие импульса в заданный момент времени определяет значение очередного бита (0 или 1). Байт считается успешно принятым, если правильно принят стоповый бит, т.е. если в нужный момент не будет никакого импульса. На картинке показан сигнал при передаче данных через COM порт (UART) и через IrDA.

Получить доступ к IrDA как к обычному COM порту можно только если устройство подключается в COM порт или в IrDA разъем на материнской плате. Во втором случае придется править руками INF файлы, чтобы Windows не догадался что это ИК порт. Использовать например USB IrDA устройство для работы с дистанционкой вообще не получится.

О методах кодирования команд дистанционного управления на ИК (инфра-красных) лучах можно посмотреть здесь. Самое главное - каждый информационный импульс, посланный с дистанционки, на самом деле - это ИК фон заданной длительности с частотой от 30 до 56 кГц.

Теория

Допустим что со стоповым битом все в порядке, тогда все будет как нарисунке ( А ). Появился ИК фон, через 86.8 мкс (при скорости 115200) принялся первый байт, сгенерировано событие RX CHAR EVENT. Дождавшись окончания приема пакета, подсчитываем количество байтов и количество единичных младших битов в последнем байте, таким образом узнаем длительность импульса (T2) с точностью до 9 мкс. Дождавшись очередного RX CHAR EVENT и замерев между ними время узнаем T1. Отняв T2 от T1 узнаем длительность паузы. Казалось бы имеется достаточно информации для декодирования команды (известны длительности импульсов и пауз между ними), но...

Практика

Если в момент считывания стопового бита в ИК фоне попадется импульс, байт не примется. См. рисунок (B). Таким образом в случае неправильного приема одного или нескольких байтов RX CHAR EVENT может возникнуть в точке (1), (2) или (3). Мало того RX CHAR EVENT может возникнуть несколько раз в течение одного информационного импульса с дистанционки, например в точках (1) и (3). Наиболее вероятен безошибочный прием байта, перекрывающего окончание информационного импульса с дистанционки (на стоповый бит не попадет никакого импульса).

Все это относится к случаю, когда для анализа команды с дистанционки используется плагин DCD или IR210 (принцип работы аналогичен WinLIRC). Плагин UIR вообще не имеет понятия о кодировках различных пультов, от тупо анализирует последовательность принятых байтов. Вероятность того что для одной и той же команды пульта IrDA будет давать одинаковые байты очень маленькая. Результат, например, может меняться от расстояния между IrDA приемником и пультом. И наоборот для разных команд пульта могут быть получены одинаковые байты.

Вывод: при определенной частоте ИК фона (т.е. при определенной модели дистанционки) с большой натяжкой IrDA можно использовать для приема команд ДУ с pulse-distance модуляцией и при относительно коротких импульсах, ориентируясь при этом по времени между RX CHAR EVENT (плагин DCD). IrDA невозможно использовать для приема ИК команд от дистанционок с другим типом модуляции, а так же если в командах присутствует длинный первый информационный импульс, что встречается довольно часто.

Генерирование ИК команд ДУ через IrDA.

Здесь ситуация чуть лучше. Если знать точный формат команды для данной дистанционки, можно сформировать несколько пакетов и послать их через IrDA через заданное время. При этом нужно использовать скорость передачи 38400 (наиболее близкая к частоте большинства дистанционок). Получится очень близкий к оригиналу сигнал, однако он не будет идеальным. Через каждые 9 импульсов будет провал (стоповый бит). Кроме того скважность импульсов будет составлять примерно 19% (должно быть 50%). Принимающая аппаратура может воспринимать стоповый бит как короткую паузу между информационными импульсами и неправильно декодировать команды.


Сам себе монтер (Инструкция по монтажу локальных сетей)

in english
по-русски
Поиск электронных компонентов на складах
Bad Credit Loan Realty One Corresponcence courses Spanish Translator Hotels in Paris

Сам себе монтер

Монтаж и приемы работы с различными средами передачи данных, на мой взгляд, являются одной из наиболее интересных тем для многих пользователей: ведь именно умение работать со средой передачи данных “с нуля” отличает опытного “сетевика” от начинающего.

Этот материал, собственно говоря, не предназначен для специалистов по монтажу локальных сетей, поскольку в нем пойдет речь о вещах, хорошо им знакомых и известных, — об азах монтажных работ. Цель ее, скорее, в том, чтобы разъяснить основные понятия и дать необходимые рекомендации тем, кто, не будучи специалистом в этой области, тем не менее вынужден этим заниматься, — например, устанавливая локальную сеть у себя дома. Установка кабельной системы — не такое простое дело, как может показаться на первый взгляд. Правильный монтаж разъема на кабель очень важен, особенно если речь идет о кабеле на основе витой пары и оптоволоконном кабеле.

Локальная компьютерная сеть — это прежде всего среда передачи сигналов. Без среды передачи сети не может быть просто по определению, как не может быть дыхания без воздуха. Среду передачи можно условно разделить на ограниченную и неограниченную. Ограниченная среда — это, попросту говоря, кабель. Как пример неограниченной среды можно взять открытый эфир, по которому передает сигналы RadioEthernet.

В качестве среды передачи сигналов в локальных сетях, как правило, используются:

• коаксиальный кабель;

• кабель на основе витой пары;

• оптоволоконный кабель.

Коаксиальные кабели

В начале развития локальных сетей коаксиальный кабель как среда передачи был наиболее распространен. Он использовался и используется преимущественно в сетях Ethernet и отчасти ARCnet. Различают “толстый” и “тонкий” кабели.

“Толстый Ethernet”, как правило, используется следующим образом. Он прокладывается по периметру помещения или здания, и на его концах устанавливаются 50-омные терминаторы. Из-за своей толщины и жесткости кабель не может подключаться непосредственно к сетевой плате. Поэтому на кабель в нужных местах устанавливаются “вампиры” — специальные устройства, прокалывающие оболочку кабеля и подсоединяющиеся к его оплетке и центральной жиле. “Вампир” настолько прочно сидит на кабеле, что после установки его невозможно снять без специального инструмента. К “вампиру”, в свою очередь, подключается трансивер — устройство, согласовывающее сетевую плату и кабель. И, наконец, к трансиверу подключается гибкий кабель с 15-контактными разъемами на обоих концах — вторым концом он подсоединяется к разъему AUI (attachment unit interface) на сетевой плате.

Все эти сложности были оправданы только одним — допустимая максимальная длина “толстого” коаксиального кабеля составляет 500 метров. Соответственно одним таким кабелем можно обслужить гораздо большую площадь, чем “тонким” кабелем, максимально допустимая длина которого составляет, как известно, 185 метров. При наличии некоторого воображения можно представить себе, что “толстый” коаксиальный кабель — это распределенный в пространстве Ethernet-концентратор, только полностью пассивный и не требующий питания. Других преимуществ у него нет, недостатков же хоть отбавляй — прежде всего высокая стоимость самого кабеля (порядка 2,5 долл. за метр), необходимость использования специальных устройств для монтажа (25-30 долл. за штуку), неудобство прокладки и т.п. Это постепенно привело к тому, что “толстый Ethernet” медленно, но верно сошел со сцены, и в настоящее время мало где применяется.

“Тонкий Ethernet” распространен значительно шире, чем его “толстый” собрат. Принцип использования у него тот же, но благодаря гибкости кабеля он может присоединяться непосредственно к сетевой плате. Для подключения кабеля используются разъемы BNC (bayonet nut connector), устанавливаемые собственно на кабель, и T-коннекторы, служащие для отвода сигнала от кабеля в сетевую плату. Разъемы типа BNC бывают обжимные и разборные (пример разборного разъема — отечественный разъем СР-50-74Ф).

Т-коннектор

Для монтажа разъема на кабель вам потребуется либо специальный инструмент для обжимки, либо паяльник и плоскогубцы.

Кабель необходимо подготовить следующим образом:

1. Аккуратно отрежьте так, чтобы его торец был ровным. Наденьте на кабель металлическую муфту (отрезок трубки), который поставляется в комплекте с BNC-разъемом.

2. Снимите с кабеля внешнюю пластиковую оболочку на длину примерно 20 мм. Будьте аккуратны, чтобы не повредить по возможности ни один проводник оплетки.

3. Оплетку аккуратно расплетите и разведите в стороны. Снимите изоляцию с центрального проводника на длину примерно 5 мм.

4. Установите центральный проводник в штырек, который также поставляется в комплекте с разъемом BNC. Используя специальный инструмент, надежно обожмите штырек, фиксируя в нем проводник, либо впаяйте проводник в штырек. При пайке будьте особенно аккуратны и внимательны — плохая пайка через некоторое время станет причиной отказов в работе сети, причем локализовать это место будет достаточно трудно.

5. Вставьте центральный проводник с установленным на него штырьком в тело разъема до щелчка. Щелчок означает, что штырек сел на свое место в разъеме и зафиксировался там.

6. Равномерно распределите проводники оплетки по поверхности разъема, если необходимо, обрежьте их до нужной длины. Надвиньте на разъем металлическую муфту.

7. Специальным инструментом (или плоскогубцами) аккуратно обожмите муфту до обеспечения надежного контакта оплетки с разъемом. Не обжимайте слишком сильно — можно повредить разъем или пережать изоляцию центрального проводника. Последнее может привести к неустойчивой работе всей сети. Но и обжимать слишком слабо тоже нельзя — плохой контакт оплетки кабеля с разъемом также приведет к отказам в работе.

Отмечу, что отечественный разъем СР-50 монтируется примерно так же, за исключением того, что оплетка в нем заделывается в специальную разрезную втулку и закрепляется гайкой. В некоторых случаях это может оказаться даже удобнее.

Кабели на основе витой пары

Витая пара (UTP/STP, unshielded/shielded twisted pair) в настоящее время является наиболее распространенной средой передачи сигналов в локальных сетях. Кабели UTP/STP используются в сетях Ethernet, Token Ring и ARCnet. Они различаются по категориям (в зависимости от полосы пропускания) и типу проводников (гибкие или одножильные). В кабеле 5-й категории, как правило, находится восемь проводников, перевитых попарно (то есть четыре пары).

Кабель UTP

Структурированная кабельная система, построенная на основе витой пары 5-й категории, имеет очень большую гибкость в использовании. Ее идея заключается в следующем.

На каждое рабочее место устанавливается не менее двух (рекомендуется три) четырехпарных розеток RJ-45. Каждая из них отдельным кабелем 5-й категории соединяется с кроссом или патч-панелью, установленной в специальном помещении, — серверной. В это помещение заводятся кабели со всех рабочих мест, а также городские телефонные вводы, выделенные линии для подключения к глобальным сетям и т.п. В помещении, естественно, монтируются серверы, а также офисная АТС, системы сигнализации и прочее коммуникационное оборудование.

Благодаря тому что кабели со всех рабочих мест сведены на общую панель, любую розетку можно использовать как для подключения рабочего места к ЛВС, так и для телефонии или вообще чего угодно. Допустим, две розетки на рабочем месте были подключены к компьютеру и принтеру, а третья — к телефонной станции. В процессе работы появилась необходимость убрать принтер с рабочего места и установить вместо него второй телефон. Нет ничего проще — патч-корд соответствующей розетки отключается от концентратора и переключается на телефонный кросс, что займет у администратора сети никак не больше нескольких минут.

Розетка на 2 порта

Патч-панель, или панель соединений, представляет собой группу розеток RJ-45, смонтированных на пластине шириной 19 дюймов. Это стандартный размер для универсальных коммуникационных шкафов — рэков (rack), в которых устанавливается оборудование (концентраторы, серверы, источники бесперебойного питания и т.п.). На обратной стороне панели смонтированы соединители, в которые монтируются кабели.

Кросс в отличие от патч-панели розеток не имеет. Вместо них он несет на себе специальные соединительные модули. В данном случае его преимущество перед патч-панелью в том, что при его использовании в телефонии вводы можно соединять между собой не специальными патч-кордами, а обычными проводами. Кроме того, кросс можно монтировать прямо на стену — наличия коммуникационного шкафа он не требует. В самом деле, нет смысла приобретать дорогостоящий коммуникационный шкаф, если вся ваша сеть состоит из одного-двух десятков компьютеров и сервера.

Кабели с многожильными гибкими проводниками используются в качестве патч-кордов, то есть соединительных кабелей между розеткой и сетевой платой, либо между розетками на панели соединений или кроссе. Кабели с одножильными проводниками — для прокладки собственно кабельной системы. Монтаж разъемов и розеток на эти кабели совершенно идентичен, но обычно кабели с одножильными проводниками монтируются на розетки рабочих мест пользователей, панели соединений и кроссы, а разъемы устанавливают на гибкие соединительные кабели.

Патч-панель

Как правило, применяются следующие виды разъемов:

• S110 — общее название разъемов для подключения кабеля к универсальному кроссу “110” или коммутации между вводами на кроссе;

• RJ-11 и RJ-12 — разъемы с шестью контактами. Первые обычно применяются в телефонии общего назначения — вы можете встретить такой разъем на шнурах импортных телефонных аппаратов. Второй обычно используется в телефонных аппаратах, предназначенных для работы с офисными мини-АТС, а также для подключения кабеля к сетевым платам ARCnet;

• RJ-45 — восьмиконтактный разъем, использующийся обычно для подключения кабеля к сетевым платам Ethernet либо для коммутации на панели соединений.

Разъем RJ-45

В зависимости от того, что с чем нужно коммутировать, применяются различные патч-корды: “45-45” (с каждой стороны по разъему RJ-45), “110-45” (с одной стороны S110, с другой — RJ-45) или “110-110”.

Для монтажа разъемов RJ-11, RJ-12 и RJ-45 используются специальные обжимочные приспособления, различающиеся между собой количеством ножей (6 или 8) и размерами гнезда для фиксации разъема. В качестве примера рассмотрим монтаж кабеля 5-й категории на разъем RJ-45.

1. Аккуратно обрежьте конец кабеля. Торец кабеля должен быть ровным.

2. Используя специальный инструмент, снимите с кабеля внешнюю изоляцию на длину примерно 30 мм и обрежьте нить, вмонтированную в кабель (нить предназначена для удобства снятия изоляции с кабеля на большую длину). Любые повреждения (надрезы) изоляции проводников абсолютно недопустимы — именно поэтому желательно использовать специальный инструмент, лезвие резака которого выступает ровно на толщину внешней изоляции.

    1. Аккуратно разведите, расплетите и выровняйте проводники. Выровняйте их в один ряд, при этом соблюдая цветовую маркировку. Существует два наиболее распространенных стандарта по разводке цветов по парам: T568A (рекомендуемый компанией Siemon) и T568B (рекомендуемый компанией AT&T и фактически наиболее часто применяемый).

На разъеме RJ-45 цвета проводников располагаются так:

Проводники должны располагаться строго в один ряд, без нахлестов друг на друга. Удерживая их одной рукой, другой ровно обрежьте проводники так, чтобы они выступали над внешней обмоткой на 8-10 мм.

4. Держа разъем защелкой вниз, вставьте в него кабель. Каждый проводник должен попасть на свое место в разъеме и упереться в ограничитель. Прежде чем обжимать разъем, убедитесь, что вы не ошиблись в разводке проводников. При неправильной разводке помимо отсутствия соответствия номерам контактов на концах кабеля, легко выявляемого с помощью простейшего тестера, возможна более неприятная вещь — появление “разбитых пар” (splitted pairs).

Для выявления этого брака обычного тестера недостаточно, так как электрический контакт между соответствующими контактами на концах кабеля обеспечивается и с виду все как будто бы нормально. Но такой кабель никогда не сможет обеспечить нормальное качество соединения даже в 10-мегабитной сети на расстояние более 40-50 метров. Поэтому нужно быть внимательным и не торопиться, особенно если у вас нет достаточного опыта.

5. Вставьте разъем в гнездо на обжимочном приспособлении и обожмите его до упора-ограничителя на приспособлении. В результате фиксатор на разъеме встанет на свое место, удерживая кабель в разъеме неподвижным. Контактные ножи разъема врежутся каждый в свой проводник, обеспечивая надежный контакт.

Аналогичным образом можно осуществить монтаж разъемов RJ-11 и RJ-12, используя соответствующий инструмент.

Для монтажа разъема S110 специального обжимочного инструмента не требуется. Сам разъем поставляется в разобранном виде. Кстати, в отличие от “одноразовых” разъемов типа RJ разъем S110 допускает многократную разборку и сборку, что очень удобно. Последовательность действий при монтаже следующая:

1. Снимите внешнюю изоляцию кабеля на длину примерно 40 мм, разведите в стороны пары проводников, не расплетая их.

2. Закрепите кабель (в той половинке разъема, на которой нет контактной группы) с помощью пластмассовой стяжки и отрежьте получившийся “хвост”.

3. Аккуратно уложите каждый проводник в органайзер на разъеме. Не расплетайте пару на большую, чем требуется, длину — это ухудшит характеристики всего кабельного соединения. Последовательность укладки пар обычная — синяя-оранжевая-зеленая-коричневая; при этом светлый провод каждой пары укладывается первым.

4. Острым инструментом (бокорезами или ножом) обрежьте каждый проводник по краю разъема.

5. Установите на место вторую половинку разъема и руками обожмите ее до защелкивания всех фиксаторов. При этом ножи контактной группы врежутся в проводники, обеспечивая контакт.

Оптоволоконный кабель

Оптоволоконные кабели — наиболее перспективная и обеспечивающая наибольшее быстродействие среда распространения сигналов для локальных сетей и телефонии. В локальных сетях оптоволоконные кабели используются для работы по протоколам ATM и FDDI.

Устройство для обжима кабеля

Приспособление для снятия изоляции и обжимки разъема

Оптоволокно, как понятно из его названия, передает сигналы при помощи импульсов светового излучения. В качестве источников света используются полупроводниковые лазеры, а также светодиоды. Оптоволокно подразделяется на одно- и многомодовое.

Одномодовое волокно очень тонкое, его диаметр составляет порядка 10 микрон. Благодаря этому световой импульс, проходя по волокну, реже отражается от его внутренней поверхности, что обеспечивает меньшее затухание. Соответственно одномодовое волокно обеспечивает большую дальность без применения повторителей. Теоретическая пропускная способность одномодового волокна составляет 10 Гбит/с. Его основные недостатки — высокая стоимость и высокая сложность монтажа. Одномодовое волокно применяется в основном в телефонии.

Многомодовое волокно имеет больший диаметр — 50 или 62,5 микрона. Этот тип оптоволокна чаще всего применяется в компьютерных сетях. Большее затухание во многомодовом волокне объясняется более высокой дисперсией света в нем, из-за которой его пропускная способность существенно ниже — теоретически она составляет 2,5 Гбит/с.

Для соединения оптического кабеля с активным оборудованием применяются специальные разъемы. Наиболее распространены разъемы типа SC и ST.

Монтаж соединителей на оптоволоконный кабель — очень ответственная операция, требующая опыта и специального обучения, поэтому не стоит заниматься этим в домашних условиях, не будучи специалистом. Если уж вам “приспичило” строить сеть с использованием оптоволокна, легче приобрести кабели с соединителями. Впрочем, учитывая стоимость кабеля, соединителей, а также активного оборудования для оптики, можно предположить, что в домашних и небольших ЛВС это оборудование будет использоваться еще нескоро.


Обзор неординарных систем охлаждения и оригинальной компьютерной периферии, доступной в России

in english
по-русски
Поиск электронных компонентов на складах
Mortgage Real estate directory Cincinnati Houses Menorca MPAA

И холодно и жарко

Обзор неординарных систем охлаждения и оригинальной компьютерной периферии, доступной в России

Владимир Богданов

Закройте форточки, сквозит!

Несмотря на все нововведения производителей компьютеров, ситуация с охлаждением компонентов внутри корпуса остается напряженной. Не принесло ожидаемых результатов даже повсеместное распространение форм-фактора ATX, призванного, в частности, повысить эффективность воздухообмена внутри системного блока. Да разве угонишься за производителями комплектующих? Один только жесткий диск Seagate Cheetah (10 тысяч оборотов в минуту) способен нагреть воздух вокруг себя до 60 градусов Цельсия. Не меньшими “отопительными” способностями отличаются процессоры трехмерных акселераторов и других устройств. Не случайно на основном чипе многих современных графических карт можно встретить элементы пассивного охлаждения (радиаторы). Но и это не всегда спасает положение. Превышение допустимой температуры внутри корпуса чревато нестабильным поведением системы, “зависаниями”, вызванными, в частности, изменением основных свойств полупроводников, что весьма критично для серверов начального уровня, рабочих и графических станций. Программные системы контроля за температурой процессора уже поддерживаются многими современными материнскими платами на уровне BIOS (например, технология TOP (Thermal Overheat Protection) на системных платах MicroStar). В рассматриваемых случаях вполне оправданным может стать использование активных аппаратных систем температурного мониторинга и управления.

Съемный модуль для винчестеров Ultra Wide SCSI с системой температурного контроля
Съемный модуль для винчестеров Ultra Wide SCSI с системой температурного контроля

Съемный винчестерный модуль (mobile rack) SSI Computer Corporation содержит активную систему охлаждения и предназначен для работы с жесткими дисками с интерфейсом Ultra Wide SCSI. На модуле SI-145 интегрирован микроконтроллер, позволяющий определять рабочую температуру жесткого диска и в случае превышения допустимых параметров включать дополнительный вентилятор (модель SI-146 содержит уже два вентилятора). На расширенном жидкокристаллическом табло отображается напряжение питания, подаваемое на винчестер, номер SCSI ID, температура устройства, статус вентилятора, текущее время и общее время работы устройства.

Слотовый вентилятор с регулируемой зоной охвата представляет собой конструкцию из двух вентиляторов небольшого диаметра, которая устанавливается поверх свободного разъема для плат расширения и позволяет направить воздушный поток в нескольких направлениях. Кроме того, каждый из вентиляторов выдвигается из своей станины на нужное расстояние (как второе колено из пластикового спиннинга), что позволяет регулировать зону направленного охлаждения. Слабым местом этой модели является невысокая надежность самих вентиляторов, обусловленная их малым диаметром и, как следствие, высокой скоростью вращения.

Cлотовый вентилятор с регулируемой зоной охвата
Cлотовый вентилятор с регулируемой зоной охвата

Семейство недорогих вентиляторов JustCooler отличается почти полным отсутствием “интеллекта”. Они работают в принудительном режиме, невзирая на жару и холод, и представляют собой достаточно мощные вентиляционные системы со скоростью вращения чуть менее 3000 оборотов в минуту. По информации производителей, время наработки на отказ некоторых из рассмотренных устройств составляет 20 000 часов. Последнее в полной мере относится к модели FC-100, предназначенной для установки вместо заглушки задней панели корпуса при наличии свободного слота расширения. Подобные вентиляторы рекомендуется использовать для охлаждения 3D-акселераторов, изрядно нагревающих воздух вокруг себя. 12-вольтовый вентилятор FC-100 вращается со скоростью 2800 об/мин и имеет уровень шума не более 26 дБ. Размах его лопастей составляет около 12 см. По информации производителя, через 20 мин после начала использования FC-100 температура устройства снижается с 75 до 40 градусов.

Слотовый вентилятор FC-100
Слотовый вентилятор FC-100
Вентилятор дисковода, устанавливаемый<br> в 3,5-дюймовый отсек
Вентилятор дисковода, устанавливаемый
в 3,5-дюймовый отсек

Другой вентилятор серии JustCooler оптимизирован для охлаждения винчестеров и других “жарких” накопителей. Он устанавливается в свободный 3,5-дюймовый отсек системного блока непосредственно под охлаждаемым устройством. Примечательно, что поток воздуха, направляемый вентилятором, идет в сторону передней панели системного блока вопреки “концепции пылесоса” основного вентилятора системного блока, компьютера. Выброс воздуха осуществляется через нижнюю часть кожуха, выступающего за линию фронтальной части корпуса компьютера (на фотографии вентиляторный блок изображен наполовину вынутым из корпуса, а после установки виден только его передний “козырек”).

Модель многопозиционного вентилятора тайваньского производства привлекла мое внимание в первую очередь своей оригинальной конструкцией. Вентилятор установлен внутри подвижной рамы, угол которой только в горизонтальной плоскости можно менять на 270 градусов, не говоря уже о возможности вертикального перемещения. Таким образом, пользователь может прикрепить винтами это устройство, скажем, к корзине 3,5-дюймового отсека или в другом доступном месте системного блока и точно направить поток воздуха на заданное охлаждаемое устройство.

Многопозиционный вентилятор
Многопозиционный вентилятор
Комплексная сенсорная система охлаждения
Комплексная сенсорная система охлаждения

Конечно, люди, организующие дополнительное охлаждение внутри своих компьютеров, не должны забывать о том, что каждый работающий вентилятор — это лишний источник шума, а ПК и так не радуют нас тишиной. Отчасти решить эту проблему помогают интеллектуальные системы термоконтроля, которые осуществляют не принудительное общее, а “точечное” охлаждение устройств, подверженных перегреву, и только в те моменты времени, когда это действительно нужно.

Аппаратный набор TS Thermal@Control (на базе SSI CS003) представляет собой комплексную систему температурного контроля и управления. С помощью нескольких сенсоров эта система позволяет отслеживать температурные параметры целого ряда выбираемых пользователем устройств и при необходимости включать дополнительные вентиляторы. Каждый из семи сенсорных элементов располагается на концах соответствующих 60-сантиметровых шнуров и прикрепляется к любому критичному устройству при помощи теплопроводной липкой ленты (по виду напоминающей обычный скотч). Система поддерживает подключение до четырех вентиляторов. На основной ЖК-дисплей выводится информация о состоянии вентиляторов, температурных показаниях сенсоров, текущем времени; также на экране высвечивается сигнал тревоги.

Оповещение может производиться и с помощью звукового сигнала. Сообщение об ошибке поступает в случаях превышения допустимого порога температуры (который может задаваться отдельно для каждого устройства), а также в случаях, когда скорость вращения вентилятора падает на 50% или он вообще останавливается.

Рассмотренная мониторинговая система позволяет отслеживать изменение температуры устройств в диапазоне от 0 до 100 градусов Цельсия. Размеры основного блока составляют 151x101,5x25,4 мм при весе 140 г. Он потребляет стандартное напряжение 5 или 12 В. Кроме того, в системе может использоваться широкий набор вентиляторов с диаметром 3, 4, 6 и 8 см.

“Убей его, Шилов!”

Закрывать глаза на то, что в мире существует огромное количество “виртуальных экстремистов”, которых хлебом не корми — дай пострелять, бессмысленно. Главное — найти способ направить эту энергию в конструктивное мирное русло, создав комфорт стрелкам-любителям: ведь вести огонь из пистолета при помощи клавиатуры или даже кнопки джойстика несколько противоестественно. Кроме того, целевой аудиторией для компьютерного игрового “оружия” можно считать и вполне миролюбивых людей — вряд ли в компьютерной среде найдется человек, которому хотя бы раз в жизни не хотелось выстрелить в монитор.

Игровой комплект PcGun
Игровой комплект PcGun

В комплект стрелка PcGun производства тайваньской фирмы A4 Tech входит один пистолет (всегда можно подключить второй), интерфейсная карта, несколько кабелей и компакт-диск с набором игр и программ-утилит. Интерфейсная карта устанавливается в свободный ISA-слот и с помощью прилагаемого шлейфа подсоединяется к 26-контактному feature-коннектору обычной видеокарты (как для локальной шины PCI, так и для VESA). На самой интерфейсной плате расположены две “телефонные” розетки RJ-45, к которым подключаются шнуры одного или двух пистолетов. Длина шнуров достаточна для того, чтобы вести огонь по монитору, уютно устроившись на диване. На самом пластмассовом пистолете расположены только две кнопки: функциональная стартовая и курок, так что пытаться провернуть барабан или передернуть затворную раму (это зависит от типа оружия) не имеет смысла. Первая кнопка может служить для навигации по меню и выбору функций, а также служит для запуска ракет в отдельных играх. Оптический принцип работы устройства накладывает некоторые ограничения: не рекомендуется пользоваться устройством при сильной освещенности, потребуется также убрать экранный фильтр. Настоящее умиление вызывает забота производителей PcGun о нерадивых стрелках: в инструкции по эксплуатации содержится настоятельная просьба не перекрашивать пистолет в другой цвет, дабы не перепутать его с настоящим (речь идет о почти невесомой оранжевой игрушке с торчащим из рукоятки кабелем). Устройство и прилагаемый программный пакет поддерживает возможность сетевой игры через IPX-соединение. Конечно, первая же игра на CD-ROM предлагает побороться с мировым терроризмом (как известно, именно для этого и приобретается оружие) в составе неназванной международной организации. Перед игрой придется пройти процедуру пристрелки (калибровки) пистолета. Кроме того, несмотря на явно револьверный внешний вид, его можно использовать в качестве пулемета, помпового ружья, штурмовой винтовки M-16 или базуки (опции с автоматом Калашникова для русскоязычных пользователей не предусмотрено). Для нормальной работы игрового комплекта потребуется компьютер с Windows 95 (или DOS 5.0 и выше) класса Pentium с 16 Мбайт оперативной памяти, 20 Мбайт свободного дискового пространства и привод СD-ROM. Конечно, понадобится и звуковая карта, причем PcGun поддерживает все разновидности Sound Blaster, Windows Sound System и другие стандарты, включая даже Turtle Beach Multi Sound. Автор не имел достаточного самостоятельного опыта общения с этим устройством, поэтому воздержится от его общей оценки. Очевидно, что любой игровой манипулятор не является предметом первой необходимости, и всякие решения в его пользу зависят от конкретных предпочтений игрока. Недостатком рассмотренной игровой системы является возможность играть лишь в игры, специально написанные для нее. И несмотря на то что внушительный набор таких игр прилагается на компакт-дисках, Дюк Ньюкем может жить спокойно.

Трехмерный сканер

Сканер, поставляемый под торговой маркой TS Scanner 3D@E-LUX, привлек мое внимание, главным образом, благодаря присутствию 3D в его названии. Оказалось, что благодаря большой глубине резкости (8 см) этому устройству по силам производить сканирование объемных объектов, например букета цветов или яблока (как показано на фотографии).

Трехмерный сканер
Трехмерный сканер
Трехмерный сканер

Устройство подсоединяется к принтерному порту компьютера (рекомендуется выбрать в BIOS установку режима EPP/SPP/ECP) и это является его главным узким местом, так как скорость работы будет невысока. С другой стороны, это оборачивается преимуществом, так как не требуется дорогой SCSI-адаптер. Рассматриваемый однопроходный планшетный сканер поддерживает внутреннее представление цвета глубиной 36 бит (68,7 миллиарда цветов), а также 10 бит (1024 оттенков серого). Согласно информации производителя оптическое разрешение этой модели составляет 600x1200 точек на дюйм, а интерполяционное программное — 9600 точек на дюйм. Устройство позволяет сканировать изображения размером не более 216x297 мм (то есть и листы формата A4). Среди других особенностей этого устройства можно отметить его компактность и, можно сказать, подозрительную легкость.

Оно неплохо подходит для домашнего использования, и если вас не смутит необходимость перевернуть сканер вверх дном, то с его помощью можно получить даже любительскую цифровую фотографию предметов, лежащих на столе, или сделать незатейливый снимок самого себя (правда, ложиться на стол для этого совсем не обязательно).

Встраиваемые звуковые колонки

Свободные 3,5- и 5,25-дюймовые отсеки системных блоков компьютеров никак не дают покоя производителям компьютерной периферии: каждый норовит их чем-нибудь заполнить.

Внутренняя акустическая система
Внутренняя акустическая система

КомпьютерПресс уже рассказывал о встраиваемом источнике бесперебойного питания; определенное распространение получили графические эквалайзеры, устанавливаемые в трехдюймовый отсек; теперь появилась и встраиваемая акустическая система: в 5,25-дюймовый отсек устанавливается блок, включающий в себя два внешних динамика и один (низкочастотный) внутренний. Получается этакий псевдо-Dolby, если и не Surround, то Inside (басовый динамик расположен внутри компьютерного корпуса). Передняя панель с динамиками может поворачиваться в нужном направлении. Вряд ли уместно говорить об акустических достоинствах этой системы — она ориентирована исключительно на нетребовательных к качеству звука пользователей (что очевидно даже по диаметру динамиков). С другой стороны, подобная система существенно экономит место на рабочем столе и придает системному блоку оригинальный вид благодаря наличию полосных светодиодных индикаторов громкости.


Запуск компьютера с ПДУ

Выключить компьютер с ПДУ ТВ-тюнера не сложно. Это одна особенность всех без исключения ТВ-тюнеров. Но включить компьютер, нажав ту же заветную клавишу, увы, не получится. Чтобы решить проблему, придется взять в руки паяльник.

Итак, нам потребуется доработать ИК-приемник, входящий в комплект любого тюнера.

ИК приемник от ТВ-тюнера

Этот датчик содержит три контакта. В зависимости от конкретной модели расположение контактов может меняться. Но это не важно, так как по этим контактам передается одно и то же. К двум контактам подводиться питающее напряжение(+5 В и GND). Третий контакт - сигнальный. Нам нужно подключиться ко всем трем контактам, для этого снимаем изоляцию и припаиваем три провода, попутно определяя с помощью мультиметра назначение контактов.
Далее нам понадобяться один переменный резистор и маломощный транзистор p-n-p. Изменяя сопротивление резистора, можно подстроить точность срабатывания схемы. Все эти элементы нужно соединить с разъемом материнской платы Wake-On-Lan.

Схема включения компьютера с пульта управления

Когда все будет припаяно, включите в BIOS поддержку Wake-On-Lan и, изменяя сопротивление резистора, добейтесь четкого срабатывания схемы по нажатию клавиши на ПДУ. Найдя требуемое значение (мы рекомендуем отталкиваться от значений 100 Ом и выше), останеться лишь заизолировать все соединения и аккуратно убрать приемник в корпус ПК.


Правильная сборка компьютера

В статье подробно рассматривается вопрос правильной сборки компьютера из различных комплектующих.

Зa последние несколько лет у так называемых «продвинутых» пользователей сложился стереотип, что современный ПК - это конструктор LEGO, и собрать его из отдельных комплектующих не составляет труда. Для опытных сборщиков - это так и есть, но «теоретики» могут столкнуться с серьезными проблемами, особенно если учесть, что в последнее время появилось внушительное количество новых CPU с поддержкой новых фирменных технологий и сокетов под них с различными типами питания, несколько разновидностей RAM, новые чипсеты со своими особенностями, получил большое распространение стандарт SATA.

При сборке компьютера самостоятельно тебя могут подстерегать определенные опасности: покупка несовместимых комплектующих, порча оборудования (сколотые ядра и оторванные ноги у CPU, горелая память, отломанные SATA-разъемы - обычное дело), проблемы выявления причин неработоспособности собранной системы и т.д. Грамотно подобрать оборудование, наиболее рационально собрать и настроить ПК поможет тебе данная статья.

Установка CPU и кулера

Процессор. Первым и одним из самых ответственных шагов в деле сборки компьютера является правильная установка центрального процессора в сокет. Естественно, CPU должен поддерживаться материнской платой, о чем необходимо помнить при покупке, точнее, выбранная модель процессора определяет платформу. Особенно это хорошо заметно у AMD: Low-End CPU - SocketA, Middle-End CPU - Socket734, High-End CPU - Socket939, Ultra High-End CPU -Socket940. Для корректной установки CPU на материнскую плату существует специальный ключ, который показывает, как должен быть сориентирован процессор при установке на место. Сам ключ сделан в виде скошенного уголка, как на сокете, так и на основании процессора (или же это может быть маленький треугольник). То есть одинаково обозначенные углы (и на проце, и на сокете) должны совпасть друг с другом.
Также нужно ознакомиться с тем, как происходит открытие/закрытие самого разъема для CPU, о чем можно узнать в документации к материнской плате. Особое внимание надо обратить на CPU, предназначенные для установки в LGA775, поскольку очень тонкие площадки и контактные разъемы (до которых вообще не стоит дотрагиваться) в силу своих малых размеров могут испортиться, и тогда восстановить первозданное состояние будет практически невозможно. В процессе закрепления CPU нужно обратить внимание на тот факт, что сам процессор должен входить в сокет очень свободно (как бы сам), при этом все углы подложки должны быть на одинаковом уровне относительно сокета. Надо быть осмотрительным с ножками, которые имеют обыкновение гнуться или даже отламываться по углам при неосторожном обращении. Если это случилось (погнуты один или несколько контактов), выгибать обратно их стоит крайне плавно и аккуратно, но даже при «летальном» исходе для лапки ее можно заменить кусочком тонкой проволоки, вставленным в соответствующее отверстие сокета (были такие случаи и в нашей тестовой лаборатории), но уже на свой страх и риск.

Кулер. Выбор кулера также зависит от платформы. Для SocketA и Socket478 существует множество различных моделей кулеров, причем можно найти универсальные устройства, которые поддерживают установку на оба типа разъемов. К процессорам на базе AMD Athlon 64 (Socket 939/940) подходит один и тот же вид охлаждения, а вот с LGA775 могут возникнуть определенные проблемы, поскольку для этой платформы весьма сложно найти охлаждающее устройство (жидкостные системы тоже подходят не все). Единственным универсальным кулером, подходящим под все вышеописанные платформы, является Thermaltake Silent Tower (на момент написания статьи), который без труда будет поддерживать комфортный тепловой режим любой системы. Закрепление кулера Перед фиксацией радиатора с вентилятором на CPU сначала рекомендуется проделать пробную операцию без процессора, с пустым сокетом, дабы оценить жесткость пружины и понять, как и с какой стороны удобнее держать охлаждающее устройство, какую силу прикладывать при защелкивании застежек (особенно это актуально для CPU с открытым ядром). Перед установкой кулера на процессор следует намазать его термопастой (например, АЛСИЛ-3 или КПТ-8), причем перед этим лучше всего будет протереть спиртом обе контактирующие площадки (для обезжиривания и, следовательно, улучшения теплоотдачи). Термопаста наносится тонким слоем (чем тоньше, тем лучше), цель - заполнить микроцарапины. Хорошо зарекомендовал себя такой способ: несколько маленьких капель наносятся на поверхность ядра или металлическую пластину, его прикрывающую (CPU уже в сокете!), после чего кулером нужно очень аккуратно поводить по процессору. Если все сделано правильно, то оба узла притянутся друг к другу. Далее радиатор плотно прижимается к CPU одной рукой, а другой рукой защелкивается зажим. При этом действии очень важно не перекосить кулер на какой-либо бок, чтобы не повредить сам процессор (неважно, открыто ядро или нет!). Бывает, что производители материнских плат не задумываются о величине теплообменника, и располагают около сокета множество мешающих установке элементов (как правило, катушки стабилизации и конденсаторы), в такой ситуации не стоит бояться аккуратно отогнуть выпирающие детали. Иногда возникает потребность в обратном действии, то есть снятии кулера и процессора. Главное здесь - постараться не погнуть ножки, а для этого нужно, чтобы CPU выходил равномерно со всех сторон и двигался вертикально вверх относительно материнской платы.
При демонтаже радиатора с Athlon 64 зачастую бывает, что кулер снимается вместе с процессором. В этом случае после извлечения системы из сокета обе части (радиатор и проц) нужно медленно покрутить вокруг своей оси и тогда все без проблем разлепится. С повторными подсоединениями стоит быть особенно аккуратным на платформе LGA775, поскольку, по некоторым сведениям, примерно через 20 раз площадки изнашиваются.

Подключение вентилятора

Очень важно банально не забыть запитать вентилятор кулера! Если присоединение к электрической цепи происходит посредством разъема Molex 8981-04Р (белая четырехконтактная колодка), в BlOS'e не будет отображаться информация о скорости вращения лопастей, но иногда присутствует дополнительный желтый провод, который является выводом тахометра и подсоединяется к разъему CPU_FAN на материнской плате. При правильном включении будет показываться частота, с которой крутится вентилятор. Некоторые же системы охлаждения можно подключать через реобас, регулятор, термодатчик или сопротивление, снижающее обороты (и, соответственно, издаваемый шум) - при таком раскладе rpm показываться не будет (однако это бывает не всегда, и существуют аппаратные индикаторы вращения). Настройка BIOS Еще перед тем как процессор намазан термопастой и окончательно установлен в сокет вместе с кулером, очень важно выяснить рабочие параметры процессора, то есть тактовую частоту и напряжение питания, частоту шины и максимальную рабочую температуру. Все это узнается через маркировку на корпусе CPU.
Подробную информацию о продукции AMD можно найти по ссылке: http://www.amd.com/ru-ru (откуда скачивается документ Processor_Recognition_Rev05_RUS.pdf) про Intel же читай тут: http://processorfinder.intel.com - онлайновая страничка, где, указав маркировку, можно выяснить характеристики. В дальнейшем выясненные значения должны быть выставлены в BIOS (меню «Frequency/Voltage Control»), поскольку автоматическое определение не всегда работает корректно, и часто бывает так, что мощный процессор работает вполовину своих возможностей. Также обязательно зайди в меню «PC Health» и посмотри на температуру CPU. Если кулер был установлен плохо (перекошен или имеет плохой контакт с ядром), это будет сразу видно: температура будет слишком высокой для данной модели процессора, что через некоторое время повлечет за собой его выход из строя. Следует помнить, что в случае процессоров AMD необходимо ориентироваться на реальную частоту, а не на рейтинг. В разных BlOS'ax частота шины может выставляться, как в виде номинальной (реальной) частоты, так и в виде эффективной. Тактовая частота процессора должна получиться умножением множителя на частоту системной шины.
Приобретенный процессор может оказаться бракованным (такое случается даже в крупных солидных магазинах) или уже сгоревшим (при покупке «с рук»), и тогда на посткодере (который встраивается в современные материнские платы) при включении все время будет гореть «00».

Вставляем память

Оперативная память, которая сейчас имеется в продаже, бывает четырех основных типов: DDR, DDR II, Registered DDR, Dual Channel DDR. Выбор типа памяти и способ ее установки также зависят от платформы. Socket478 поддерживает работу памяти в двухканальном режиме. Как правило, CPU с частотой FSB 800 МГц требуют обязательной работы RAM именно в Dual DDR mode (LGA775). Организовать такую связку на высокой частоте (двухканальная память - процессор) способен чипсет NVIDIA nForce2, который нормально поддерживает Dual DDR. Обычно, чтобы задействовать дуальный режим, установка модулей памяти происходит через слот (например, в первый и третий), причем большинство производителей материнских плат специально окрашивают парные слоты в одинаковый цвет, а за более точной информацией стоит обратиться к руководству пользователя. В общем случае (при условии поддержки материнской платой) Dual DDR можно организовать на платформах Socket478, SocketA, Socket939 - для остальных требуется специальная память или же работа RAM только в обычном режиме.
Так, например, контроллер памяти у AMD Athlon 64 (подключающийся к Socket754) не имеет возможности работы в двойном режиме (поскольку на процессоре физически «не хватает» количества лапок), тогда как под Socket940 необходима специальная Registered DDR (с технической точки зрения на русский язык это правильно переводить как «буферизированная», а не «регистровая» память). Из-за внешнего сходства различных модулей пользователи иногда вставляют в слот неподходящую память. Также бывает, что пользователи вставляют планку не той стороной (необходимо убедиться, что память вошла в слот всеми контактами, а не только первыми -ключ мешает вставить модуль неправильно). Некоторые умудряются засунуть модуль кверху ногами. Такие ошибки могут привести к сгоранию или поломке модуля и платы. Чтобы этого избежать, перед приобретением нужно прочитать в User's Guide материнской платы, какая память подходит для данной модели платы и как правильно производить установку.

Настройка памяти в BIOS

Это важная операция, поскольку от настроек памяти напрямую зависит производительность системы (в целом можно выиграть около 5% по сравнению с заниженными значениями «по умолчанию»). К сожалению, единого названия всех нужных нам опций нет, и каждый производитель материнских плат сам выбирает, в каком меню они находятся, можно лишь привести некоторые наиболее распространенные заголовки. При покупке модуля памяти обычно пишется некая последовательность чисел (иначе ее называют формулой), которые обозначают временные промежутки в работе чипов. Формула памяти состоит из трех цифр, например, 5-2-2, и обозначает, соответственно, RAS-RAS_to_CAS-CAS время доступа к адресным ячейкам. Выставлять данные значения следует напротив соответствующих названий параметров (например, часто употребляется «DRAM RAS# Latency», «Tras», «Row Address Strobe» для обозначения первой цифры). Также из-за неправильной настройки частоты шины или временных параметров возможны проблемы при включении компьютера (происходит начальная инициализация, после чего сбой в виде перезагрузки, выключения или зависания). В такой ситуации необходимо увеличить одно или все значения таймингов или понизить частоту шины. В любом случае нужно стремиться к оптимальному их значению - чем меньше время доступа, тем быстрее обрабатываются данные.

Видеокарта

Видеоплаты и особенности их подключения также довольно разнообразны, поэтому здесь следует быть не менее аккуратным, чтобы не ошибиться при выборе и установке. Существует два слота для подключения графических карт - это AGP и PCI Express 16x. Первый - более старый, работает на меньшей скорости и поддерживает всего одно устройство такого типа (кроме спецификации за номером 3.0, где их может быть два). Стандарт AGP 3.0 описывает четыре скорости работы (от 1х - 266 Мб/сек до 8х -2 Гб/сек). Существует его расширение -AGP Pro (увеличенная длина слота для подачи дополнительного питания, однако на деле плат под этот разъем очень мало). Платы AGP совместимы с разъемом AGP Pro. Главное отличие второй шины (PCI Express 16x) в том, что она является последовательной и поддерживает скорость передачи данных до 8 Гб/сек. Также возросла электрическая мощность, которая может подаваться по этой шине, так что новые видеокарты вполне могут обойтись без дополнительного питания. При установке современного графического ускорителя не стоит забывать о требующемся дополнительном питании и подключить разъем (Molex) от БП. Симптомы, сигнализирующие о его отсутствии, выражаются в виде сообщения на экране перед загрузкой компьютера, попискиваниями из PC Speaker'a, отсутствия изображения (способ извещения пользователя различается у разных производителей).

Установки AGP в BIOS

В BlOS'e желательно изменить некоторые параметры, касающиеся слота AGP, которые, однако, не имеют критического влияния на производительность. Если в системе одновременно установлены PCI-адаптер и AGP-адаптер, в опции «Init Display First» можно выбрать, какой из них будет инициализироваться первым (на него будут выводиться системные сообщения до загрузки ОС). «AGP Aperture Size» (размер апертуры AGP) лучше задать в 64-128 Мб, хотя для новых моделей это ни на что не влияет, поскольку эта функция остается незадействованной. По некоторым данным при меньшем значении возможны проблемы в современных играх. «AGP Speed» - при наличии поддержки высокой скорости передачи данных значение 8х будет оптимальным, чтобы не занижать производительность графической подсистемы.

Подключаем питание

Для подачи напряжения на материнскую плату предназначен разъем АТХ (широкая 20-контактная колодка), однако этим многие системы не ограничиваются. Для SocketA, чаще всего, ничего больше не нужно, и компьютер включится без проблем, а вот Socket478 может отказаться работать без подсоединения колодки ATX12V (четыре контакта, расположенные квадратом). Процессоры же, имеющие 754/939/940 ног, заработают только с 12-вольтовым разъемом питания, так как потребляют повышенную мощность. С LGA775 вообще отдельная история, и здесь уже возможны два способа: первый - это когда на материнской плате имеется целых три колодки, а именно: стандартный ATX, ATX12V, Molex, и все их требуется подключить к блоку питания.
Второй случай - удлиненная на 4 контакта колодка АТХ, правда, такие блоки питания еще мало распространены, но в продаже уже можно встретить переходники (в обе стороны), которые позволяют использовать и стандартный разъем (тогда не нужно подключать Molex). Иногда у блока питания может иметься дополнительный провод желтого цвета с разъемом FAN (трехконтактный), предназначенный для индикации скорости вращения вентилятора в самом БП, и тогда, присоединив его к соответствующему разъему материнской платы, можно будет отслеживать этот показатель. Зачастую блоки питания, предназначенные для поставки в разные страны, имеют переключатель напряжения сети (на задней панели), который встречается и в неправильном 110-вольтовом положении, и если прозевать этот момент и оставить все как есть, можно поплатиться сгоревшим предохранителем (такие случаи были у нас в тестовой лаборатории). Если же перемычка отсутствует, значит стоит обратить внимание на стикеры на корпусе, где указаны рабочие режимы блока (чтобы убедиться в пригодности устройства). Стоит напомнить, что при переподключении любых устройств обязательно отключать БП от сети, поскольку даже в выключенном состоянии (режим сна) он подает дежурное напряжение на материнскую плату.

Первое включение

После подключения CPU, кулера, памяти, видеоадаптера и питания еще вне системного блока для оценки работоспособности железа необходимо осуществить контрольный запуск системы. Материнскую плату при этом следует положить на антистатический пакет (тот самый, в котором она продавалась). Если все в порядке, из динамика (ты же не забыл его подключить?) должен раздаться короткий одиночный сигнал, а на экране появится приглашение нажать для входа в BIOS какую-нибудь клавишу, где необходимо произвести описанные выше настройки CPU, памяти и AGP.

Сборка в корпус

Убедившись в корректном функционировании базовых узлов компьютера, приступим к установке всего в системный блок. Делать это следует, не снимая память, процессор и кулер с материнской платы, поскольку в системном блоке подключать их будет неудобно. Главное в процессе не применять силы, а крепежные винты сильно не затягивать, дабы избежать деформации платы.

Винчестеры

Подключение HDD может быть различно в зависимости от имеющегося оборудования - на данный момент в домашних условиях наиболее распространены IDE и SATA варианты.

IDE Для определения места подключения этих устройств стоит заглянуть в руководство к материнской плате, поскольку у многих современных матплат имеется встроенный RAID-контроллер, из-за чего добавляется еще несколько IDE-разъемов. При подключении двух устройств на один IDE-канал обязательно нужно определить одно из них как Master, а другое как Slave. Делается это с помощью перемычек на корпусе устройства. Подсоединять жесткие диски следует 80-жильным шлейфом, для CD/DVD достаточно 40-жильного. Определить первую ножку на плате и на устройстве можно по маркировке, а на шлейфе первый провод обозначается красным или синим цветом. На разъемах обычно есть ключ - выпуклость и отсутствие отверстия для одной ножки на кабеле, вырез и отсутствие ножки на плате или устройстве.

SATA Здесь все проще, поскольку отсутствует проблема определения главного-подчиненного (к одному разъему может быть подключено лишь одно устройство), но определенные проблемы возникают с подсоединением питающего провода. Часть SATA-дисков имеет старый разъем, типа стандартного Molex'a, и тогда никаких трудностей нет, но стандарт предполагает другой вид разъема, и может возникнуть ситуация, когда потребуется специальный переходник. Провод с нужным разъемом может оказаться в комплекте с материнской платой или же продаваться совместно с HDD, однако нередко бывает, что необходимый кабель вообще отсутствует, в такой ситуации потребуется дополнительно его приобрести. Винчестеры в BIOSe Для задействования SATA-винчестеров в BlOS'e нужно включить SATA-контроллер, поскольку в противном случае диски SATA не будут определяться системой, причем в списке IDE-устройств они также не появятся. Кроме того, неплохо вручную задать параметры дисков (в разделе «Standart CMOS Features»), чтобы при загрузке компьютера автоматическое определение каждый раз не отнимало дополнительное время. Если имеется лишь один HDD или отсутствует потребность в создании RAID-массива, встроенные контроллеры, обеспечивающие эти функции, отключаются. В противном случае при включении компьютера каждый раз будет запускаться микропрограмма, пытающаяся инициализировать дополнительные диски, что, опять же, отнимает время.

Вcтроенные устройства

В BlOS'e имеется меню «Integrated Peripherals», которое позволяет управлять устройствами, встроенными в материнскую плату. Бывает так, что имеется, допустим, внешняя звуковая карта, и надобность во встроенной отпадает. Тогда напротив «Onboard Audio» стоит выставить «Disabled», чтобы избавиться от проблем с определением устройства в Windows и установкой дополнительных драйверов. Такую операцию стоит проделать со всеми встроенными устройствами, не требующимися в работе.

Подключение корпуса

На системном блоке имеется индикационная панель, которая содержит несколько светодиодов, отображающих режимы работы компьютера и обращения к жесткому диску, а также кнопки управления питанием. Для того чтобы их задействовать, предназначен ряд контактов на материнской плате (расположены рядом и объединены одним названием, обычно это «F_PANEL», «PANEL», «PANEL1», «JFP1/2») и несколько проводков, подключенных к передней панели системного блока. На разных материнских платах контакты в гребенке располагаются различно, однако всегда соблюдается количество и положение колодок, а для того чтобы определить, что к чему относится, имеется специальная маркировка, как на плате, так и на разъемах. Также провода различаются и по цветам, причем на землю всегда идет черный провод (маркировка «GND», «-», «Pull-Down», «Cathode», «Negative»), сигнальный же контакт может быть разных цветов, но как правило, это красный (обозначается, как «VCC», «Anode», «+», «Pull-Up», «Positive»). Полярность важно соблюдать у световых индикаторов, так как они являются диодами и при неправильном включении просто не будут функционировать. Для кнопок и динамика ориентация коннектора роли не играет. Обозначение элементов передней панели создается из сокращения до нескольких букв названия и добавки в виде указания полярности, например PW_SW_GND обозначает «земля» кнопки включения компьютера (расшифровывается, как Power Switch Ground) или HDD_LED_ANODE (положительный провод индикатора винчестера). В общем случае стоит посмотреть на схему расположения контактов, которую можно найти в руководстве к материнской плате.

Заключительный этап

При правильном подключении устройств и настройках BIOS после включения компьютер должен подать одиночный звуковой сигнал из внутреннего динамика и продолжить загрузку. В случае каких-либо проблем необходимо по сообщениям BIOS на экране или POST-кодам определить участок, на котором они возникают, и проверить подключение соответствующих устройств и настройки в BlOS'e. Стоит еще раз проверить характеристики железа, корректность подключения и исправность шлейфов. Если компьютер перестал включаться после изменения параметров BlOS'a, сбросить настройки можно специальной перемычкой (которая находится около батарейки на материнской плате, точно можно посмотреть в руководстве пользователя). В итоге, после установки операционной системы обязательно нужно поставить все драйвера, которые можно найти на дисках, прилагающихся вместе с оборудованием, поскольку стандартные (включенные в ОС) не всегда обеспечивают реализацию всех аппаратных возможностей. Также сразу необходимо провести проверку системы комплексными пакетами типа SiSoftware Sandra, и проверить ее на стабильность при помощи бенчмарков. При этом необходимо установить фирменную утилиту мониторинга состояния материнской платы и настроить ее на отключение ПК при достижении определенных порогов температур (если температура превысила 80 градусов Цельсия, в CPU могут начаться необратимые изменения). Мониторинг системы следует производить еще в течение месяца, чтобы выявить проблемы, которые могут возникнуть не сразу.


Зависимость работы ADSL от различных параметров

В статье подробно рассматривается влияние различных параметров на скорость и другие характеристики работы ADSL-оборудования.

Аббревиатура ADSL (Asymmetric Digital Subscriber Line) расшифровывается как "Асимметричная цифровая абонентская линия", что подчеркивает изначально заложенное в этой технологии различие скоростей обмена в направлениях к абоненту и обратно.

Асимметричность ADSL, по своей сути, подразумевает передачу больших объемов информации к абоненту (видео, массивы данных, программы) и небольших объемов от абонента (в основном команды и запросы).

Оборудование ADSL, размещенное на АТС, и абонентский ADSL-модем, подключаемые к обоим концам телефонной линии, образуют три канала:

  • высокоскоростной канал передачи данных из сети в компьютер (скорость - от 32Кбит/с до 8Мб/с);
  • скоростной канал передачи данных из компьютера в сеть (скорость - от 32Кбит/с до 1,5Мб/с);
  • простой канал телефонной связи, по которому передаются обычные телефонные разговоры.

Величина скорости передачи данных при этом зависит от длины и качества телефонной линии. Асимметричный характер скорости передачи данных вводится специально, т. к. удалённый пользователь Интернет обычно загружает данные из сети в свой компьютер, а в обратном направлении идут либо команды, либо поток данных существенно меньшей скорости. Для получения асимметрии скорости полоса пропускания абонентского окончания делится между каналами также асимметрично.

Со стороны АТС на линии пользователя должен располагаться так называемый мультиплексор доступа ADSL - DSLAM. Этот мультиплексор выделяет подканалы из общего канала и отправляет голосовой подканал на АТС, а высокоскоростные каналы данных направляет на маршрутизатор, подключенный к DSLAM.

Одно из главных преимуществ технологии ADSL по сравнению с аналоговыми модемами и протоколами ISDN и HDSL - то, что поддержка голоса никак не отражается на параллельной передаче данных по двум быстрым каналам. Причина подобного эффекта состоит в том, что ADSL основана на принципах разделения частот, благодаря чему голосовой канал надежно отделяется от двух других каналов передачи данных.

Влияние параметров кабеля на работу ADSL оборудования

Первичные параметры линии: (реальные)

Сопротивление шлейфа(пары), | R [Ом] | от 10 до 1200
Сопротивление изоляции, | R [МОм] | более 40
Индуктивность шлейфа, | L [мГн] | как правило не измеряют.
Емкость шлейфа, | С [нФ] | от 10 до 300
Емкостная асимметрия, | C [нФ] | от 0 до 10, относительно земли.

примечание:

на поврежденном кабеле измерить цифровым мультиметром сопротивление изоляции и емкость невозможно! это первый признак намокания кабеля, "разбитость", асимметрия...

Вторичные параметры линии: (основные)

Затухане сигнала.

от 5dB до 20dB - линия отличная.
от 20dB до 30dB - линия хорошая.
от 30dB до 40dB - линия плохая.
от 50dB и выше линия отстойная.
(на Upstream и Downstream затухание свое)

Уровень шума: RMS Noise Energy [dBm]

от -65dBm до -50dBm - линия отличная.
от -50dBm до -35dBm - линия хорошая.
от -35dBm до -20dBm - линия плохая. (высокая вероятность повреждения линии)
от -20dBm и выше работа оборудования невозможна.

Частотная характеристика линии. (примеры ниже)

примечание:

при уровне шума в линии от -65dBm до -55dBm нормальное оборудование может работать на запредельных расстояниях. (до 6км и более при диаметре жилы 0.5мм) несмотря на высокое затухание сигнала (до 50dB) хотя бы и на минимальных параметрах.

Измерительное оборудование:

Рефлектомер “CableSHARK” фирмы ”Consultronics”. Рефлектомер “990DSL CopperPro” фирмы ”FLUKE Networks”. Мультиметры APPA 101 и UNI-T UT70D
Рефлектомер CableSHARK фирмы Consultronics Рефлектомер 990DSL CopperPro фирмы FLUKE Networks Мультиметры APPA 101 и UNI-T UT70D

Для начала глянем как выглядит с точки зрения ADSL модема идеальная линия.

Витая пара. 5Cat. 720м. (собрано на скрутках из кусочков)

Сопротивление шлейфа 160 Ом. (24AWG)
Средний уровень шума в диапазоне 4кГц-2000кГц:
RMS noise -65 dBm (или меньше)
Емкость шлейфа 0,040 мкФ

Рис.1. Проверка расстояния

На Рис.2 показаны результаты тестирования полученой линии.
Синим обозначена частотнаяя характеристика.
Зеленым - уровень шума в линии.
красным обозначено DMT.

примечание:

DMT (Discrete Multi-Tone), информационный поток разбивается на несколько каналов, каждый из которых передается на своей несущей частоте с использованием QAM. Обычно DMT разбивает полосу от 4 кГц до 1,1 Мгц на 256 каналов, каждый шириной по 4 кГц. Данный метод по определению решает проблему разделения полосы между голосом и данными (голосовую часть он просто не использует), но более сложен в реализации, чем CAP. DMT утвержден в стандарте ANSI T1.413, а также рекомендован как основа спецификации Universal ADSL.

Результаты тестирования линии

Рис.2. Результаты тестирования линии

примечание:

Чем больше расстояние, тем больше сопротивление линии, хуже частоная характеристика и выше затухание сигнала. В основном это сказывается на Downstream (середина и конец графика) т.е. скорость соединения ADSL модема в сторону абонента.

Реальная линия:
Сопротивление шлейфа 420 Ом
Расстояние примерно 2,5км.
Рабочая емкость линии 0,12 мкФ.
Средний уровень шума в диапазоне 4кГц-2000кГц: RMS Noise -38dBm

DSLAM и модем фирмы SIEMENS.
Теоретическая скорость:
7Mбит/с Downstream
800кбит/с Upstream

Реальная скорость соединения:
1Mбит/с Downstream
512кбит/с Upstream

Соединение стабильное.

На линии имеется небольшое повреждение:
замокание кабеля, один из проводников коротит на землю. Как следствие - НЧ шум в влинии при выключеном ADSL оборудовании. плюс при включении ADSL оборудования, из-за асимметрии параметров линии, появляется слышимый ВЧ шум. замена сплиттера бесполезна.

С помощью рефлектомера можно "увидеть" повреждение. (предположительно на расстоянии 42,9м намокание.) чуть ближе выброс вверх - это скорее всего окислившаяся скрутка.

Линия с повреждением

Рис.3. Линия с повреждением

Шум в линии

Рис.4. Шум в линии, в основном от радиостанции Маяк(549КГц) и т.п.

Шум в линии

Рис.5. Шум в линии, (рис.4 подробнее)

Прямой провод:
(медная пара без телефонии, ее любят называть выделенной линией.:)
Cопротивление шлейфа 1067 Ом
Рабочая емкость линии 0,18 мкФ.
Средний уровень шума в диапазоне 4кГц-2000кГц: RMS Noise -55,71dBm

DSLAM и модем фирмы SIEMENS.

Реальная скорость соединения:
64Кбит/с Downstream
32кбит/с Upstream
(иногда потеря синхронизации)

Заводской кросс, лапша, скрутки... очень большое расстояние до АТС.
Стабильная работа ADSL оборудования на такой линии невозможна.

Рис.6.

Внешние факторы влияющие на работу ADSL оборудования

Очень сильно мешают работе всевозможные лини АВУ, ВЧ уплонения, УВО сигнализации, прочее DSL, проходящие в том же самом кабеле, в соседних парах. Особенно если имеют место быть всевозможные дефекты кабеля, "распаренности/битости" , намокание кабеля, отводы. Все эти устройства создают сильный шум в диапазоне частот от 0 Гц до 100-200КГц.(в основном) При этом происходит снижение сигнала исходящего потока ADSL (Upstream) вплоть до его полного отсутсвия и, как следсвие, потерей ADSL модемом синхронизации.

При совместной работе DSL и ВЧ уплотнений в одном кабеле на разных парах могут возникать перекрестные помехи, мешающие работе аналоговой телефонии. (шум в диапазоне от 1КГц и выше)

В заводских и промышленных зонах очень сильно влияет всевозможное силовое оборудование. Непосредстенная близость железной дороги.

Помехи от линий АВУ, ВЧ уплонений Peterstar, УВО сигнализаций

Рис.7. Помехи от линий АВУ, ВЧ уплонений Peterstar, УВО сигнализаций

Как видно на графике практически весь основной шум приходящийся на диапазон Upstream.(начало графика) Шум от линий АВУ и ВЧ уплотнений постоянный, т.е. от времени суток не зависит. Сигнализацию обычно включают с 19:00 до 09:00 и в выходные дни круглосуточно. Соответственно в это время ADSL работает с перебоями или не работает совсем.

Работа силового электрооборудования

Рис.8. Работа силового электрооборудования

Очень плохая частотная характеристика кабеля. Высокий уровень шума, забивающий практически весь сигнал. Станционная часть. DSLAM

Повреждения соединительного многопарного кабеля от DSLAM до кроссплинтов:
Повреждения кабеля, плинтов, некачественная "заделка кабеля". На старых кроссах: холодная пайка или непропаянная накрутка. Как следствие - дребезг контактов. Результат - бессистемная потеря модемом синхры.
"Разбитость пар" - можно отследить только тон-генератором + тестовая трубка с высокоомным входом. Неправильная разделка/монтаж кабеля. Некачественная/неправильная распайка соединительных разъемов. (Самые трудноотслеживаемые глюки. Решаются, как правило, на стадии монтажа)

Нарушение технологии монтажа кроссировочного кабеля.

Например:

когда через кроссовое ушко, в котором уже есть много других кроссировок, пропускают очередную пару проводов. И делают это с таким усилием, что протаскиваемая пара сдирает/сжигает изоляцию на соседних кроссировках. Как следствие: замыкание проводников различных пар между собой или на землю.

Неправильное подключение сплиттерной/модемной карты в DSLAM. Неправильное подключение порта сплиттера в линию/станцию. Подключение абонентской линии на другой порт DSLAM. Иногда просто забывают сделать кроссировки. :) Перегрев оборудования.
Глючность софта/прошивки, отказ работы DSLAM с некоторым типом абонентского оборудования при некоторых параметрах линии.

Выводы

Сопротивление линии напрямую зависит от расстояния. Следовательно, зная сопротивление, можно достаточно точно вычислить расстояние между абонентом и АТС. Зная справочные данные ADSL модема, можно прикинуть на какой скорости соединится модем. К сожалению это все. чтобы узнать вторичные параметры линии требуется сложное дорогостоящие оборудование. Ещё есть возможность посмотреть среднее затухание сигнала на Upstream и Downstream потоке в некоторых ADSL модемах: ZyXEL 650, Cisco 800 series, в USB ADSL модемах и другие.

Например:

при сечении кабеля 0,5мм.кв. (0,085 Ом/м) и сопротивлении шлейфа линии 1000 Ом длина линии L = (1000/0,085)/2 = 5882 м. Также нужно учитывать, что на некоторых участках сечение кабеля может быть 0,4мм.кв (0,133 Ом/м) Т.о. для модема ZyXEL 645R теоретическая скорость - 64кбит/с

ещё пример:

Расстояние 5,5км
Диаметр жилы магистрального кабеля от АТС: 0.7мм
[до ближайшего десятипарного ответвления от магистрального кабеля идущего в здание абонента] Т.е. большая часть кабеля от АТС до абонента имеет диаметр медной жилы 0.7мм
Сопротивление шлейфа: 570 Ом !!!
Емкость шлейфа: 0,3мкФ
Максимальная возможная скорость: 5М/640Кбит
Реальная рабочая скорость: 640Кбит/360Кбит (если выставить больше - срыв синхры)
Оборудование: Cisco 800 серия. работает две VoIP линии и доступ в инет.

При сопротивлении шлейфа линии 800 - 1000 Ом вероятность сбоев/нестабильностей очень высока. (во всяком случае гарантировать 100% надежность нельзя) Тут уж как повезёт с магистральным кабелем. Есть случаи когда ZyXEL 645R работает с незначительными сбоями на линии с сопротивлением 1200 - 1400 Ом.

Запросто можно угробить линк и при сопротивлении много меньше 800 Ом. Как правило это так любимая всеми "лапша под гвоздик" на стороне абонента. Предельная рабочая частота 180кГц и при желании через хлорку (две пары) можно замутить 10BaseT... но на каком расстоянии?

Старые совковые телефонные розетки. Этакий шЫт с конденсатором 1мкФ х 160В внутри. Новые, кстати, тоже не блещут качеством. Из розеток "Зроблено у белорусии" вилка RJ11 сделаная в Китае просто вываливается. Вилок RJ11 сделаных в Белорусии не встречал, поэтому такие розетки сразу в помойку.

В квартирах и офисах с повышеной влажностью (старый фонд), сопротивление окислившихся контактов может достигать нескольких сотен Ом.

Иногда недалёкие "телефонисты" могут сделать телефонный ввод в офис/квартиру через забытый радиоввод. Распределительная коробка оставшаяся от радиоточки. (на каждый провод впаяно сопротивлеие 300 Ом)

Ещё можно поискать на лестничной площадке в щитке диодные блокираторы (если когда-то давно линия была спарена) Получаем забавный эффект: ADSL модем работает только при снятой трубке на телефоне. Или забытый ВЧ фильтр от сигнализации вневедомственной охраны.

Если линия проходит через кросс старого завода/предприятия, то вы получаете дополнительные бонусы в виде:

  1. Четыре "термички" на линию. каждая имеет сопротивление 25-50 Ом + индуктивность.
  2. Параллельные отводы линии в другие цеха, промежуточные кроссы, муфты или т.п.
  3. Система "Гранит", против прослушивания. Через неё работа Dial-UP оборудования затруднительна, а про ADSL можно вообще забыть.

Особо клинические случаи:
Повреждение изоляции магистрального кабеля :(
Размокшие муфты, "разбитости" и т.п.
Разбитость пары - это когда провода для линии берут из разных пар кабеля.

Ну и самое простое:
Неправильное подключение сплиттера или микрофильтров.
Летом... Перегрев модема.
Или после очередной грозы - сгоревший модем. :)

При сопротивлении шлейфа линии более 1000 Ом работа ADSL модема практически невозможна.

Параметры линии по постоянному току для подключения аппаратуры ADSL
Параметры | Для телефонии | Для установки ADSL | Для установки VoIP
Сопротивление шлейфа, (ориентировочно) | 1200 Ом | До 1000 Ом | До 600 Ом
Емкость между жилами | Не определено | Не более 0,25мкФ | Не боле 0,15мкФ
Сопротивление изоляции, (А-З,Б-З) | Не менее 1000 МОм/км | Не менее 1000 МОм/км | Не менее 1000 МОм/км
Сопротивление изоляции между жилами | Не менее 1000 МОм/км | Не менее 1000 МОм/км | Не менее 1000 МОм/км
Емкостная асимметрия относительно земли, (А-З, Б-З) | Не определено | Не более 5% | Не более 5%

Источник:www.library.espec.ws


Блок питания компьютера для круглосуточной работы

Полное описание БП от компьтеров и режимы работы.

В данной статье использовались только факты, проверенные и испытанные временем. Автор статьи не ставит своей целью убеждать читателя в чём-либо. И уж тем более не несёт никакой ответственности за ваши эксперименты с вашим же оборудованием. Информация справедлива для блоков питания стоимостью много меньше 40$. Ну так вот. Вернёмся к нашим… ээ.. файл серверам и маршрутизаторам. Как правило в домашних сетях такая вещь не принадлежит конкретному человеку, а собирается из общих комплектующих или на общие деньги. Стараются чтоб было надёжно и подешевле (CPU – Intel, Память – не больше не меньше, Сетевухи – NE2000 ISA 10Base2/T). Для полной надёжности и скорости на всё это железо ставят Unix. Ах да!!! совсем забыл. Сюда ещё нужен UPS.

Без стоимости UPS скромная системка потянет на 50..70$ + стоимость HDD для файл сервера. Естественно, что блок питания в такой системе не может стоить 40$

Кто-то возразит: “А у нас старый корпус от брендовой i486.” Угу. А сколько лет этому БП? И сколько лет он ещё должен будет проработать? Будет ли всё это работать долго и безглючно? И так:

Типовая схема блока питания АТ 200W.

Главный недостаток всех дешевых БП

Вот так выглядит осциллограмма напряжений +5В дешевого БП.

Рис1. Статическая нагрузка 30%

В общем-то всё в пределах нормы. Заметны короткие выбросы напряжения. С увеличением нагрузки – увеличиваются выбросы.Следствие – глюки памяти и других цифровых элементов PC.Отметим, что нагрузка 30% - это большинство PC не обременённых более чем одним HDD. Имеющим простенькую видеокарту и CPU потребляющий не более 15W.

Второй недостаток

В теории сказано, что ИБП очень критичны к нестабильности тока нагрузки.В нашем случае этот недостаток проявляется во всей красе.Так выглядит осциллограмма напряжения +12В при динамической нагрузке.

Рис2. Комбинированная нагрузка 50% (2 и более HDD)

На Рис.2 участок №1 – статическая нагрузка.Участок №2 – HDD в режиме чтение/запись. Характерны провалы напряжения питания +12В. Величина и длительность провала зависит от параметров фильтра блока питания и мощности HDD.Следствие: Из-за нестабильности шины питания +12В жесткий диск начинаетхлопать головами по “блинам”. Появляются бэды.Глюки утройств питающихся от шины +12В (ISA карты, COM порты)

Как с этим бороться

Рассмотрим фильтр блока питания.

Рис3. Фильтр (какой он есть)

В большинстве АТ блоках фильтр для шины питания +5В состоит из двух электролитических конденсаторов 1000мкФх10В.Для шины питания +12В одного конденсатора 1000мкФх16В.Для импульсных блоков питания емкость фильтрующих конденсаторов берётся из расчета500..1000мкФ на 1А тока нагрузки.В нашем случае получаем для шины +5В максимальныйток нагрузки составит 4А.Для шины питания +12В максимальный ток нагрузки составит 2А.В большинстве случаев аварийная ситуация не возникает.Но вот при использовании даже одного HDD типа IBM DPTA 7200RPM (или с аналогичным энергопотреблением) наблюдались вышеуказанные глюки.

Рис4. Фильтр. (какой он должен быть)

Для этой схемы (Рис4.) справедливы следующие параметры:Шина +5В – максимальный динамический ток нагрузки 20А.Шина +12В – максимальный динамический ток нагрузки 8А.Электролитические конденсаторы устраняют нестабильность по току.Керамические (2.2мкФ 3..6шт.) устраняют импульсные выбросы напряжения.Рекомендуется серия с низким сопротивлением для импульсных токов(кажись так называется)Каждая фирма маркирует их посвоему. Из того, что можно достать вПитере - например Hitano, Серия EXR, рабочая температура до 105 цельсия.Для +5В - две штучки 2200мкФ или 3300мкФ 6,3 или 10В (нужно смотретьгабариты, производители БП очень сильно ужимают место)С керамикой ничего посоветовать не могу.Из того что видел отличаются только ТКЕ и точностью ( например +80 -50% ).Думаю в фильтрах такого рода это не принципиально. Тут чем больше емкость, темлучше. Наверное лучше брать SMD (бескорпусную) и паять с обратной стороны платы прямо на проводники.По поводу катушек в выходных фильтрах:Если нет опыта намотки - лучше не эксперементировать. Если есть возможность купить, то можно попробовать. Или выпаять из мертвого БП.С катушками на выходе - нужно быть очень осторожным. Блок проверять тольконагружая на резисторы.После модернизации фильтра смотрим осциллограмму.

Рис5. Статическая нагрузка 30% (шина +5В)

Так выглядит под нагрузкой “поверхность” напряжения брендового блока питания.Присутствуют выбросы напряжения, но они незначительны (много меньше допустимой нормы) и с увеличением нагрузки практически не увеличиваются.Суммарная емкость (мой вариант) электролитических конденсаторов 6800мкФ. Керамических конденсаторов 1.5мкФ. (всё что было под рукой).Для интереса был протестирован блок питания АТХ фирмы PowerMan из корпуса InWin A500 – осциллограмма похожая, но выбросы напряжения отсутствуют.

Рис6. Комбинированная нагрузка 50% (2 и более HDD)

На Рис.6 участок 2 соответствует динамической нагрузке.

Емкость фильтра – один конденсатор 4700мкФх25В( HDD в режиме чтение/запись). Максимальная помеха не более 100мВ.Блок питания АТХ фирмы PowerMan показал примерно тотже результат.

Безопасность/надёжность высоковольтной части БП

Рис7. Осциллограмма сетевого напряжения. Идеальная.

…Опять кто-то выключил свет.

Рис8. Осциллограмма сетевого напряжения. Работа нескольких РС без фильтра.

Кто-то скажет: “ну а нам пофигу гадит наш РС в сеть или нет. Ну сэкономили ушлые китайцы на сетевом фильтре, ну и что.”Возможно вас убедит следующая осциллограмма.

Рис9. Работа в сети (220В) некоторых мощных потребителей.

На Рис9. Участок №1 – работа мощного перфоратора.Участок №2 – включение мощного индуктивного потребителя.(например холодильник или пылесос)Включение индуктивной нагрузки всегда сопровождается мощным всплеском напряжения. Напряжение импульсной помехи рассчитывается по следующей формуле. Где: - сопротивление контактов в момент размыкания. - сопротивление контура цепи 220В. -напряжение сети. (220В)

Нетрудно догадаться, что числитель всегда больше чем знаменатель.

На осциллограмме (Рис.9) участок 2 - присутствует “провал” сетевого напряжения длительностью 20..500мсек.(Харктерно для включения в сеть потребителей с реактивным характером сопротивления)От коротких провалов напряжения спасает UPS.(минимальное время включения бесперебойника 4мсек)Это хорошо если он есть.Возможно понадобится увеличить емкость высоковольтного фильтра постоянного тока. (на Рис.10 – электролиты 680х250V).Обычно установлены 220х200VПри потребляемой мощности 100Ватт запаса емкости (220х200V) хватаетна 70..100мсек.Если увеличивать емкость до 680..1000мкФх200В, то не забудьте заменитьдиодную сборку RS205 (2A 500V) на RS507 (5A 700V).!!!Обязательно наличае терморезистора. 4,7 ... 10 Ом на 10АНа терморезисторах обычно экономят. Ставят обычное сопротивление 1 Ом 1Ватт

Рис.10. Сетевой фильтр + выпрямитель. Какими они должны быть.

Из всех элементов в схеме фильтра обычного БП присутствует только терморезистор PS405L и предохранитель. (самое необходимое)Иногда ставят симметричный трансформатор (на схеме – 5mH). Само собой - выпрямитель RS205 и высоковольтный фильтр постоянного тока (2 электролита 220х200В)

Увеличение КПД

1 Замена мощных ключевых транзисторов.

Менять будем импортные биполярные KSE13007 (или NT405F, 2SC3306) на наш советский полевик КП948А.

Рис.11 Типовая схема включения полевого транзистора.

Такой вариант годится для АТХ блоков питания, т.к. запуск блока происходитот отдельного маломощного источника питания.Для АТ блоков такая схема не годится.Поэтому я оставил обвязку транзистора как есть, добавив 15В стабилитрон.(как показано на схеме Рис.11)Стабилитроны ставить необзятельно, т.к. прямое напряжение на затворе не превышает 1в (прямой диод),а напряжение его обратного пробоя не более 10в,Конденсаторы 1*50v(Рис12.) стоит ставить керамические (если ставится задача повышения надёжности), высыхание этих электролитов(особенно рядом с горячим радиатором) является основнойпричиной выхода блока питания из строя, так какнедостаточно резко запираются силовые транзисторы.

Рис.12 Рекомендуемая схема включения КП948А для блока АТ.

Не знаю почему –но у меня работает.Падение мощности на транзисторах уменьшается на 3..5Ватт.Хотя стабилитроны я всётаки оставил.Как следствие – перестает греться.

<

2 Выпрямительные диоды.

Мощные выпрямительные диоды ставим на нормальные радиаторы.Подойдёт радиатор от CPU - пилим поплам. Одна половинка на +5В выпрямитель. Вторая - для +12В выпрямителя.Рекомендуют также силовые диодные сборки заменить на наши советские диоды КД2998АРадиаторы - увеличить.Всё!Теперь вентилятор из БП можно выкинуть.При этом нарушается нормальный теплообмен внутри корпуса.Но если это БП для маршрутизатора – то греться внутри корпуса особо нечему.Если это файл сервер – тогда на свой страх и риск.Хотя Manowar Manowar'ыч утверждает, что у него переделанный АТХ блок питания нагружен на 2HDD 7200RPM + УНЧ и всё это хозяйство работает без вентилятора.


Сверхвысокочастотный усилитель мощности с переключателем

Специфика применения некоторых зарубежных средств связи в российских условиях состоит в необходимости дополнения функциональности этих средств разнообразными приставками отечественного производства. Так, например, беспроводные системы связи стандарта IEEE802.11 [1], выполненные в конструктиве PCMCIA карт, применяются за рубежом для подключения портативных компьютеров к сетям общедоступного и корпоративного пользования в магазинах, университетах, аэропортах, складах и т.п. Так как они предназначены для работы с портативным компьютером, их схема минимизирована по потреблению энергии, с чем связана невысокая мощность передатчика (30-100 мВт). Вследствие же относительно невысокой цены такие устройства в России применяются повсеместно для любых применений беспроводной связи. И часто их невысокая выходная мощность – это единственное, что не удовлетворяет конечного заказчика. В этом случае на сцене появляются отечественные усилители мощности, предназначенные для совместного использования с миниатюрными устройствами IEEE802.11 и позволяющие значительно поднять их выходную мощность. О проектировании и испытании одного из таких усилителей и пойдет речь в этой статье.

Обычно устройства IEEE802.11 имеют один СВЧ разъем, используемый для подключения антенны, переключение прием-передача происходит внутри устройства, так как эта система – с временным разделением. Поэтому первая проблема, которую предстояло решить при разработке усилителя мощности – это разделения каналов приема и передачи с целью усиления последнего и по возможности минимального ослабления первого. Для описанного разделения можно использовать пассивные устройства – циркуляторы. О проектировании усилителей мощности с циркулятором было подробно рассказано в [2], поэтому в настоящей статье речь пойдет о другом способе – использовании активного переключателя.

Рис. 1: Структурная схема усилителя мощности с переключателем.

Особенность использования СВЧ переключатели состоит в необходимости формирования сигнала управления для переключения режимов прием-передача. Конечно, такой сигнал можно брать с самого устройства IEEE802.11, но в этом случае теряется удобство пользования усилителем, так как кроме СВЧ кабелей необходимо подключение еще одного управляющего кабеля. Кроме того, в явном виде сигнал переключения прием-передача на разъем PCMCIA не выведен. Для получения сигнала управления переключателем в разработанном усилителе применен СВЧ детектор, реализованный на диоде Шоттки типа HSMS-2850 фирмы Agilent. Диод Шоттки HSMS-2850, предназначенный для детектирования, модуляции, смешивания и деления частоты в диапазоне от 915 МГц до 5.8 ГГц на частоте 2.45 ГГц (средней рабочей частоте разработанного усилителя) обладает чувствительностью 35 мВ/мкВатт. Более подробно о технических параметрах этого компонента можно прочитать в [3] или в Интернете на сайте www.agilent.ru. Для согласования диода Шоттки на частоте 2.45 ГГц применена резонансная цепь, состоящая из двух полосков. Ее расчет приведен в [4], кроме того, для ее расчета можно использовать бесплатно распространяемый компанией Agilent микроволновый калькулятор AppCad.

Рис. 2: Внешний вид устройства.

Структурная схема разработанного усилителя показана на рис. 1, внешний вид – на фотографии, рис.2. В качестве активного элемента усилителя использован полевой транзистор SHF-0289 на арсениде галлия фирмы Stanford Microdevices. Этот перспективный компонент обеспечивает выходную мощность не менее 30 дБм на частоте 2.45 ГГц при входной мощности 20 дБм. Некоторым недостатком его применения можно назвать необходимость напряжения питания 8 Вольт, но как показали эксперименты, он удовлетворительно работает и при напряжении 5 Вольт, если не требовать от него полной мощности на выходе. Схема включения транзистора, приведенная в документации по применению [5], достаточно сложна, при этом значениями некоторых компонентов при настройке необходимо варьировать для получения приемлемых параметров, но такова судьба всех полевых транзисторов.

С выхода транзисторного усилителя усиленный сигнал передатчика поступает на СВЧ переключатель SW-438 фирмы MA-COM. Этот недорогой арсенид-галлиевый переключатель, размещенный в пластмассовом корпусе SOT-363 для поверхностного монтажа, обеспечивает малое затухание при прямом прохождении сигнала (не более 0.7 дБ на 2.4 ГГц), высокую изоляцию (не менее 25 дБ) и практически не потребляет энергии (менее 10 мкА на 3 Вольт). Обычно полевые СВЧ переключатели управляются отрицательным напряжением, поэтому еще одним из его достоинств можно назвать возможность управления как отрицательным, так и положительным напряжением – при проектировании своего драйвера это очень удобно. Подробную техническую документацию [6] на этот компонент можно найти на сайте фирмы-производителя: www.macom.com.

Рис. 3: Принципиальная схема.

СВЧ переключателем управляет драйвер, в роли которого в данной схеме выступает быстродействующий мультиплексор аналоговых сигналов фирмы Analog Devices ADG774ABRQ. В его функции входит одновременное переключение сигналов 0 и +2.5 Вольта на управляющих входах переключателя SW-438 по сигналу обнаружения мощности на входе СВЧ детектора, передающегося через исполнительный элемент – транзистор КТ-3130. Уровень + 2.5 Вольта формируется резистивным делителем R7/R8 – смотрите принципиальную схему на рис. 3. ADG774ABRQ обладает низким сопротивлением в открытом состоянии – 2.2 Ом, может функционировать при напряжении как 5, так и 3 Вольта, по управляющим входам совместим ТТЛ/КМОП. Основное достоинство, отличающее ADG774ABRQ от своей первой реализации - ADG774BRQ, состоит в удвоенной полосе пропускания аналогового сигнала – 400 МГц и малого времени переключения – 3 нс, что позволяет использовать такой мультиплексор в любых современных телекоммуникациях, подробнее о нем в [7].

Рис. 4: Результаты испытаний.

Результаты испытаний разработанного устройства показаны на графике, рис 4. Коэффициент усиления устройства в децибелах и выходная мощность в децибелах к милливатту показаны на графике в зависимости от рабочей частоты. В заключение хотелось бы отметить, что использование фольгированного фторопласта толщиной 1 мм вместо фольгированного стеклотекстолита толщиной 1.5 мм в качестве материала подложки усилителя позволило бы существенно улучшить полученные результаты.

Список использованной литературы

  1. Шахнович И. “Беспроводные локальные сети. Анатомия стандартов IEEE802.11”. – Электроника: Наука, Технология, Бизнес. - № 1, 2003. – С. 38-48.
  2. Малыгин И.В. “Разработка и исследование усилителей мощности СВЧ радиомодемов стандарта IEEE802.11” - Компоненты и технологии. - № 9, 2002. – С. 24 – 25.
  3. Surface Mount Microwave Schottky Detector Diodes HSMS-2850 Series. Technical Data. Communications Components Designer’s Catalog. Hewlett Packard. 5966-0895E (9/97).
  4. 2.45 GHz Detector Demonstration Board. Assembly and Operating Instructions. HSMS-2850. Semiconductor Products Designer’s Catalog. Agilent Technologies. CD. 5968-7805E (11/99).
  5. SHF-0289. DC – 3 GHz, 1.0 Watt, CaAs HFET. Product Description. Stanford Microdevices, http://www.stanfordmicro.com. EDS-101241 Rev A.
  6. GaAs SPDT Switch DC-3.0 GHz SW-438. Ver. 2.00, MA-COM, Tyco/Electronics.
  7. Low Voltage 400 VHz Quad 2:1 Mux with 3 ns Switching Time ADG774A. REV.0. Analog Devices Inc., 2001, www.analog.com.

Малыгин И.В.

Источник:www.library.espec.ws


Шина управления I2C

I2C – двухпроводной интерфейс, разработанный корпорацией Philips. В первоначальном техническом требовании к интерфейсу максимальная скорость передачи данных составляла 100 Кбит/с. Однако со временем появились стандарты на более скоростные режимы работы I2C. К одной шине I2C могут быть подключены устройства с различными скоростями доступа, так как скорость передачи данных определяется тактовым сигналом.

Протокол передачи данных разработан таким образом, чтобы гарантировать надежный прием передаваемых данных.

При передаче данных одно устройство является «Master», которое инициирует передачу данных и формирует сигналы синхронизации. Другое устройство «Slave» - начинает передачу только по команде, пришедшей от «Master».

В микроконтроллерах PIC16CXXX аппаратно реализован режим «Slave» устройства в модуле SSP. Режим «Master» реализуется программно.

Основные термины, используемые при описании работы с шиной I2C:

Передатчик – устройство, передающее данные по шине

Приемник – устройство, получающее данные с шины

«Master» - устройство, которое инициирует передачу и формирует тактовый сигнал

«Slave» - устройство, к которому обращается «Master»

Multi-«Master» - режим работы шины I2C с более чем одним «Master»

Арбитраж – процедура, гарантирующая, что только один «Master» управляет шиной

Синхронизация – процедура синхронизации тактового сигнала от двух или более устройств

Выходные каскады формирователей сигналов синхронизации (SCL) и данных (SDA) должны быть выполнены по схемам с открытым коллектором (стоком) для объединения нескольких выходов и через внешний резистор подключены к плюсу питания для того, чтобы на шине был уровень «1», когда ни одно устройство не формирует сигнал «0». Максимальная емкостная нагрузка ограничена емкостью 400 пФ.

Инициализация и завершение передачи данных

В то время, когда передача данных на шине отсутствует, сигналы SCL и SDA имеют высокий уровень за счет внешнего резистора.

Сигналы START и STOP формируются «Master» для определения начала и окончания передачи данных соответственно.

Сигнал START формируется переходом сигнала SDA из высокого уровня в низкий при высоком уровне сигнала SCL. Сигнал STOP определяется как переход SDA из низкого уровня в высокий при высоком уровне SCL. Таким образом, при передаче данных сигнал SDA может изменяться только при низком уровне сигнала SCL.

Адресация устройств на шине I2C

Для адресации устройств используется два формата адреса:

Простой 7-разрядный формат с битом чтения/записи R/W;

и 10-разрядный формат – в первом байте передается два старших бита адреса и бит записи/чтения, во втором байте передается младшая часть адреса.

Подтверждение приема

При передаче данных после каждого переданного байта приемник должен подтвердить получение байта сигналом ACK.

Если «Slave» не подтверждает получение байта адреса или данных, «Master» должен прервать передачу, сформировав сигнал STOP.

При передаче данных от «Slave» к «Master», «Master» формирует сигналы подтверждения приема данных ACK. Если «Master» не подтвердит приема байта, «Slave» прекращает передачу данных, «отпуская» линию SDA. После этого «Master» может сформировать сигнал STOP.

Для задержки передачи данных «Slave» может установить логический нуль, указывая «Master» о необходимости ожидания. После «отпускания» линии SCL передача данных продолжается.

Передача данных от «Master» к «Slave»

Чтение данных из «Slave»

Использование сигнала повторного START для обращения к «Slave»

Режим Multi-«Master»

Протокол передачи данных I2C позволяет иметь более одного «Master» на шине. Для разрешения конфликтов на шине при инициализации передачи используются функции арбитража и синхронизации.

Арбитраж

Арбитраж выполняется на линии SDA при высоком уровне линии SCL. Устройство, которое формирует на линии SDA высокий уровень когда другое передает низкий, теряет право брать «Master» и должно перейти в режим «Slave». «Master», потерявший инициативу на шине, может формировать тактовые импульсы до конца байта, в котором потерял свойства ведущего.

Синхронизация

Синхронизация на шине происходит после выполнения арбитража по отношению к сигналу SCL. При переходе сигнала SCL с высокого уровня в низкий, все заинтересованные устройства начинают отсчитывать длительность низкого уровня. Затем устройства начинают переводить уровень SCL из низкого в высокий согласно требуемой скорости передачи данных. После перехода уровня из низкого в высокое состояние, заинтересованные устройства отсчитывают длительность высокого уровня. Первое устройство, которое переведет сигнал SCL в низкий уровень, определяет параметры тактового сигнала.


Фильтр для модема

Простой, но весьма эффективный фильтр для телефонной линии. Был весьма эффективен до того времени, как оцифровали АТС. Никаких проблем с ним не было. Так же хороший фильтр: на разрыв линии поставить сопротивления на каждый провод по 300 Ом. Рекомендую, поставить 3х ступенчатый переключатель. Одно положение - сигнал проходит через данный фильт. Другое - через сопротивления. И третье - соединение без каких-либо фильтров.

Схема фильтра для модема


Фильтр для модема

in english
по-русски
Поиск электронных компонентов на складах
Plumbers eHarmony V7ndotcom Elursrebmem Movers & Shakers Dish Network Pasadena Yellow Pages

Фильтр для модема-2

Фильтр для модема

Главная цель этого устройства - снижение уровня разнообразных шумов в телефонной линии, с чем оно отлично справляется. Tpaнcфopмaтop T1 пpeднaзнaчeн для выcoкoэффeктивнoй фильтpaции выcoкoчacтoтныx пoмex. Этo пoзвoляeт ycпeшнo пpoтивocтoять вoзникнoвeнию пoмexи вcлeдcтвиe paбoты элeктpoбытoвыx пpибopoв и тaкoгo нeпpиятнoгo явлeния, кaк нaвoдкa пapaзитнoй пoмexи paдиoтpaнcляциoннoй ceтью. Учacтoк cxeмы, coбpaннoй нa пaccивныx элeмeнтax R1, C1 - R2,C2, пpeднaзнaчeн для чacтoтнoй кoppeкции вxoднoгo cигнaлa. Tpaнcфоpмaтop T2 выпoлняeт фyнкцию пaccивнoгo ycилитeля пoлeзнoгo cигнaлa.

Tpaнcфopмaтop T1 coдepжит 2 нeзaвиcимыe oбмoтки пo 7 виткoв кaждaя, нaмoтaнныx нa фeppитoвoe кoльцo cтpoгo cиммeтpичнo, т.e. oбe oбмoтки нaмoтaны гpyбo гoвopя пo чacoвoй cтpeлкe. Пpoвoд - лaкиpoвaный, 0,4 - 0.5мм в диaмeтpe. Coпpoтивлeния R1,R2 - 10..50 Oм, чтo oпpeдeляeтcя опытным путем и зaвиcит oт пpoтяжeннocти линии oт ATC дo Baшeй тeлeфoннoй poзeтки, в кoтopyю включeн мoдeм. Koндeнcaтopы C1, C2 - 0.1 мкФ. Tpaнcфopмaтop T2 coдepжит 2 нeзaвиcимыe oбмoтки пo 30-60 виткoв кaждaя, нaмoтaнныx нa фeppитoвoe кoльцo cтpoгo accиммeтpичнo, т.e. oбмoтки нaмoтaны в paзныe cтopoны. Пpoвoд - лaкиpoвaный, пpиблизитeльнo 0,4 - 0.5мм в диaмeтpe. Пocтapaйтecь pacпoлoжить тpaнcфopмaтopы T1 и T2 пoдaльшe дpyг oт дpyгa - этo yлyчшит oбщиe xapaктepиcтики пpибopa. Ферритовые кольца трансформаторов любового размера и проницаемости. Все детали фильтра распологаются на печатной плате размерами 82x19 мм, в качестве входа и выхода используються современные телефонные гнезда, которые тоже расположены на плате.


Компютерная электроника

in english
по-русски
Поиск электронных компонентов на складах
Website Design Loans Kansas City Chiefs News Self Help CDs Cigars by Camino Viejo

Электроника и компьютер

В данном разделе находяться схемы различных устройств к компьютерам и различные статьи на тему Hardware: регуляторы скорости вращения вентиляторов, большой подраздел по интерфейсам (RS232, USB, IEE1394 и др.), раздел по инфракрасным портам и устройствам, Software-раздел по программам САПР (CAD), моддинг компьютера и др. Если у вас возникли какие-либо вопросы по теме компьютерной электроники, то добро пожаловать в форум по Hardware, где на ваши вопросы постараются ответить грамотные специалисты и участники форума.

Устройства для компьютера:

  1. Делаем руль и педали к компьютеру
  2. Руль для компьютера
  3. Джойстик своими руками
  4. Тестер для витой пары
  5. Регулятор скорости вентилятора (Вариант 1)
  6. Регулятор скорости вентилятора (Вариант 2)
  7. Регулятор скорости вентилятора (Вариант 3)
  8. Регулятор скорости вентилятора (Вариант 4)
  9. Регулятор скорости вращения вентилятора (Вариант 5)
  10. Сигнализатор неисправности кулера
  11. Промежуточный усилитель звуковой карты для устранения недостатков
  12. Устройства чтения СИМ карт (3 варианта)

Интерфейсы:

  1. Интерфейс RS-232C
  2. Последовательный интерфейс RS-232
  3. Последовательный асинхронный адаптер(COM порт)(Основные понятия и термины)
  4. Удлинитель COM порта на 200 метров
  5. Соединение компьтеров через COM порты по двум проводам
  6. Передатчик ТТЛ сигнала
  7. Как получить 5 вольт от порта RS-232
  8. Конвертер RS-232-TTL
  9. Распиновки различных кабелей RS-232
  10. Коммутатор двух устройств для LPT порта
  11. Сопряжение звуковой карты с музыкальным инструментом
  12. Универсальный паралельный адаптер
  13. Настольный макет лазерной связи на 10Mbit
  14. Cоединение 2-х компьютеров на лазерных указках
  15. Система связи двух компьютеров на лазеpных указках
  16. Распиновка всех разьемов компьютера
  17. Проектирование устройств обработки сигналов
  18. Интерфейс 1-wire
  19. Организация 1-Wire-систем
  20. Шина USB и FireWire
  21. Шина управления I2C
  22. Спецификация по USB 1.1 (PDF-формат)
  23. Спецификация по USB 1.1 на русском языке(Word-формат)
  24. Описание USB на английском (PDF-формат)

ИК-порты:

  1. Инфракрасный порт и работа с ним
  2. Инфракрасный порт для компьютера (для материнки)-1
  3. Инфракрасный порт для компьютера (для материнки)-2
  4. Инфракрасный порт для компьютера (для материнки)-3
  5. ИК-порт для компьютера(для COM порта)
  6. Связь на IRDA(для подключения к материнке)
  7. ИК-порт для компьютера(для подключения к материнке)
  8. Подключение к компьютеру пульта ДУ
  9. Дистанционное управление (ДУ) на инфракрасных (ИК) лучах
  10. Почему IrDA не годится для приема команд ИК дистанционного управления
  11. Запуск компьютера с ПДУ

Работа с CAD-программами:

  1. Стратегии развязки для PCB
  2. Техника разводки печатных плат

Модинг:

  1. Подсветка клавиатуры
  2. Модинг флопи диска, CD-привода

Разное:

  1. Востановление читаемости CD
  2. CD-ROM в роли проигрывателя Audio-CD
  3. Метод очистки оптики в CD проигрывателях
  4. Ремонт и обслуживание приводов CD-ROM
  5. Как сделать из монитора телевизор
  6. Применение компьютерных блоков питания
  7. Переделка старых блоков питания компьютера АТ в АТХ
  8. Разводка разъемов питания AT и ATX
  9. БП для трансивера из компьютерного БП AT/ATX
  10. БП для трансивера из компьютерного источника питания AT/ATX
  11. Ремонтируем блока питания компьютера
  12. Блок питания компьютера для круглосуточной работы
  13. Печатаем струйным принтером на CD и DVD
  14. Система водяного охлаждения
  15. Обзор неординарных систем охлаждения и оригинальной компьютерной периферии, доступной в России
  16. Сам себе монтер
  17. Правильная сборка компьютера
  18. Зависимость работы ADSL от различных параметров
  19. СВЧ усилитель мощности с переключателем
  20. Фильтр для модема
  21. Фильтр для модема-2

Интерфейс RS232. Связь между компьютером и микроконтроллером Кузьминов А.Ю. Интерфейс RS232. Связь между компьютером и микроконтроллером Цена: 146.00 руб.
Купить
Изложены принципы обмена информацией между компьютерами и 51-совместимыми микроконтроллерами по интерфейсу RS232.
Представлены многочисленные примеры аппаратных средств на современной элементной базе и программного обеспечения обмена по RS232. Наряду со справочными данными, касающимися инициализации интерфейса и команд ввода/вывода, приведен предложенный автором алгоритм (протокол) обмена, позволяющий передавать и принимать информацию компьютером и микроконтроллером со скоростью 115200 бод с высокой надежностью. Программы для компьютера написаны на ассемблере, Бейсике и Кларионе, а для микроконтроллеров - на ассемблере и СИ. Рассмотрены схемные решения и программное обеспечение программирования современных микроконтроллеров - систем на кристалле (ADUC8XX и MSC1210YX и др.), обладающих возможностью программирования в системе, по интерфейсу RS232. Описаны примеры использования RS232 в системах сбора и обработки информации с датчиков, а также в программаторах микроконтроллеров.
Для опытных разработчиков компьютерных и автономных систем сбора и обработки информации, в составе которых используются микроконтроллеры, а также для начинающих специалистов в этой области; может быть полезна студентам вузов соответствующих специальностей.